Subject: [sunset4] CGN document for consideration

From: Reinaldo Penno <[email-masked]>
Date: Tue, 01 May 2012 15:01:10 -0700

Hi,

I would like to submit this document to the WG for consideration.

http://tools.ietf.org/html/draft-penno-behave-rfc4787-5382-5508-bis-02

I'm assuming that port allocation method drafts should be submitted to
this WG.

Thanks,

Reinaldo

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 1 May 2012 18:44:27 -0400

the current charter milestones are:
1) Review current Carrier-Grade NAT (CGN) documents … determine if CGN is 
a suitable sunsetting technology to become a work item...
2) Gap analysis of IPv4 features to facilitate IPv4 sunsetting

Your document says: " This document focuses solely on NAPT44…"

How do you see your document fulfilling milestone 1 or 2 ?

Marc.

Le 2012-05-01 à 18:01, Reinaldo Penno a écrit :

> _______________________________________________
> sunset4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sunset4

---

From: Reinaldo Penno <[email-masked]>
Date: Tue, 01 May 2012 16:27:02 -0700

Hi Marc,

A CGN is a NAPT44 which shares IP address across subscribers. It is
fundamentally NAPT44.

Thanks,

Reinaldo

From:  Marc Blanchet <[email-masked]>
Date:  Tue, 1 May 2012 18:44:27 -0400
To:  Reinaldo Penno <[email-masked]>
Cc:  <[email-masked]>
Subject:  Re: [sunset4] CGN document for consideration

> 1) Review current Carrier-Grade NAT (CGN) documents Š determine if CGN is
> Your document says: " This document focuses solely on NAPT44Š"
>

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 1 May 2012 20:19:29 -0400

Le 2012-05-01 à 19:27, Reinaldo Penno a écrit :

> Hi Marc,
> 
> A CGN is a NAPT44 which shares IP address across subscribers. It is fundamentally NAPT44. 

yes, I know what it is … ;-) , but:

as the charter says, we need to demonstrate/convince that CGN is an IPv4 sunsetting technology, based on the following criteria:

<charter_extract>
before the working  group adopts any technology, it must: 

1) describe the problem to be solved and show that there is widespread 
demand for a solution 
2) demonstrate that the problem can not be solved with existing 
technologies 
3) provide a description of the proposed solution along with the 
impact on current IPv4-only use and its ability to promote the 
deployment of IPv6 
</charter_extract>

This is what the charter says.

So before adopting CGN documents, we need to demonstrate that CGN is a sunset4 technology. When demonstrated, then we can work on CGN/NAPT44 topics.  Right now, based on charter, we can't yet work on CGN/NAPT44.

Marc.