Subject: [sunset4] I-D Action: draft-ietf-sunset4-gapanalysis-08.txt

From: [email-masked]
Date: Mon, 26 Jun 2017 10:07:26 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Sunsetting IPv4 of the IETF.

        Title           : Gap Analysis for IPv4 Sunset
        Authors         : Will(Shucheng) Liu
                          Weiping Xu
                          Cathy Zhou
                          Tina Tsou
                          Simon Perreault
                          China Mobile
	Filename        : draft-ietf-sunset4-gapanalysis-08.txt
	Pages           : 11
	Date            : 2017-06-26

Abstract:
   Sunsetting IPv4 refers to the process of turning off IPv4
   definitively.  It can be seen as the final phase of the migration to
   IPv6.  This memo enumerates difficulties arising when sunsetting
   IPv4, and identifies the gaps requiring additional work.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sunset4-gapanalysis/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-sunset4-gapanalysis-08
https://datatracker.ietf.org/doc/html/draft-ietf-sunset4-gapanalysis-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-sunset4-gapanalysis-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 26 Jun 2017 20:05:14 +0200

Hi,

In general I agree with the document. I’ve just a couple of comments.

If we are talking about phases, we should not use migration, but transition. In many languages, when you translate migration, it means “dropping IPv4 and using only-IPv6”, which is not the case, and is not the spirit of the transition mechanism (IETF hasn’t defined migration mechanisms, right?). It seems a minor comment, but it confuses a lot non-english (and also English speakers, in my opinion). So please, replace all the occurrences of migration with transition.

Regarding the different issues that are indicated because Happy Eyeballs, a possible solution is to increase the timers, so even if IPv6 is “slower” than IPv4, is not just a matter of 50 milliseconds (for example), but several seconds, so then IPv6 will get preference anyway. I’ve described this in a recent email related to the HE-update document (so you could use some of the text that I mention in that email):

https://www.ietf.org/mail-archive/web/v6ops/current/msg26731.html

Regards,
Jordi

-----Mensaje original-----
De: sunset4 <[email-masked]> en nombre de <[email-masked]>
Responder a: <[email-masked]>
Fecha: lunes, 26 de junio de 2017, 19:07
Para: <[email-masked]>
CC: <[email-masked]>
Asunto: [sunset4] I-D Action: draft-ietf-sunset4-gapanalysis-08.txt

    
    Abstract:

    

    
    _______________________________________________
    sunset4 mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/sunset4

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Leo Gaspard <[email-masked]>
Date: Tue, 27 Jun 2017 00:42:43 +0200

> Regarding the different issues that are indicated because Happy Eyeballs, a possible solution is to increase the timers, so even if IPv6 is “slower” than IPv4, is not just a matter of 50 millisecon…

Please be careful about this (for problem 6): I've already seen people
advising to "just disable IPv6 to get a speed boost." If the timeout is
going to slow down to several seconds, this may make more people switch
to using IPv4 only, which would be the complete opposite of the objective.

Sure, you also consider making this setting a knob, but people may go
the easiest already known way, because "well, who cares about IPv6 anyway?"

Then, all this depends on the proportion of the internet that is already
quickly IPv6-reachable, but if there is a problem to solve, it can only
be solved by making IPv4 slower when IPv6 is enabled... which sounds
like a bad idea to me so long as IPv4's sunset (or IPv6's rise?) isn't
complete yet (at which point this solution is no longer needed anyway).

Best regards,
Leo

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 27 Jun 2017 09:17:45 +0200

I’m suggesting the other way around, making sure that IPv6 always get the preference by making HE to allow IPv6 even if is much slower than IPv4 … because IPv4 is going to be turned down.

Regards,
Jordi

-----Mensaje original-----
De: sunset4 <[email-masked]> en nombre de Leo Gaspard <[email-masked]>
Responder a: <[email-masked]>
Fecha: martes, 27 de junio de 2017, 0:42
Para: <[email-masked]>
Asunto: Re: [sunset4] I-D Action: draft-ietf-sunset4-gapanalysis-08.txt

    

    Best regards,
    Leo