Subject: Re: [sunset4] I-D Action: draft-ietf-sunset4-gapanalysis-08.txt

From: Jacques Latour <[email-masked]>
Date: Tue, 4 Jul 2017 14:47:24 +0000

> The final phase of the migration to IPv6 is the sunset of IPv4, that
> is turning off IPv4 definitively on the attached networks and on the
> upstream networks.

The problem statements for sunsetting IPv4 on "attached networks" are different than the one from "upstream networks".  I think the focus should be on " turning off IPv4 definitively" on "upstream networks".  The Internet itself, not the intranets, and doing a gap analysis focused on what is required at a minimum for "attached networks" to work in this environment, and what is required for the "upstream network" to work exclusively in IPv6.

> -----Original Message-----
> From: sunset4 [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Monday, June 26, 2017 1:07 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [sunset4] I-D Action: draft-ietf-sunset4-gapanalysis-08.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Sunsetting IPv4 of the IETF.
> 
>         Title           : Gap Analysis for IPv4 Sunset
>         Authors         : Will(Shucheng) Liu
>                           Weiping Xu
>                           Cathy Zhou
>                           Tina Tsou
>                           Simon Perreault
>                           China Mobile
> 	Filename        : draft-ietf-sunset4-gapanalysis-08.txt
> 	Pages           : 11
> 	Date            : 2017-06-26
> 
> Abstract:
>    Sunsetting IPv4 refers to the process of turning off IPv4
>    definitively.  It can be seen as the final phase of the migration to
>    IPv6.  This memo enumerates difficulties arising when sunsetting
>    IPv4, and identifies the gaps requiring additional work.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-sunset4-gapanalysis/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-sunset4-gapanalysis-08
> https://datatracker.ietf.org/doc/html/draft-ietf-sunset4-gapanalysis-08
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-sunset4-gapanalysis-08
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> sunset4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sunset4

---

From: "Liushucheng (Will Liu)" <[email-masked]>
Date: Wed, 19 Jul 2017 09:09:54 +0000

Hi Jordi and all,

Please note that I fully agree with your first comment. Actually I've done the same (s/ migration/transition) for another document in ETSI ISG IP6. I will submit a new version soon to fix this.

For the second comment, a little bit tricky as anyway the goal of this wg is to "point out specific areas of concern, provide recommendations, and standardize protocols that facilitate the graceful 'sunsetting' of the IPv4 Internet in areas where IPv6 has been deployed". So have the group get a rough consensus on how to put this into the draft?

Regards,
Will (Shucheng LIU)

> From: sunset4 [mailto:[email-masked]] On Behalf Of JORDI PALET
> MARTINEZ
> Sent: Monday, June 26, 2017 8:05 PM
> To: [email-masked]
> Subject: Re: [sunset4] I-D Action: draft-ietf-sunset4-gapanalysis-08.txt
> 
> Hi,
> 
> In general I agree with the document. I’ve just a couple of comments.
> 
> If we are talking about phases, we should not use migration, but transition.
> In many languages, when you translate migration, it means “dropping IPv4
> and using only-IPv6”, which is not the case, and is not the spirit of the
> transition mechanism (IETF hasn’t defined migration mechanisms, right?). It
> seems a minor comment, but it confuses a lot non-english (and also English
> speakers, in my opinion). So please, replace all the occurrences of migration
> with transition.
> 
> Regarding the different issues that are indicated because Happy Eyeballs, a
> possible solution is to increase the timers, so even if IPv6 is “slower” than
> IPv4, is not just a matter of 50 milliseconds (for example), but several
> seconds, so then IPv6 will get preference anyway. I’ve described this in a
> recent email related to the HE-update document (so you could use some of
> the text that I mention in that email):
> 
> https://www.ietf.org/mail-archive/web/v6ops/current/msg26731.html
> 
> Regards,
> Jordi
> 
> 
> -----Mensaje original-----
> De: sunset4 <[email-masked]> en nombre de <internet-
> [email-masked]> Responder a: <[email-masked]>
> Fecha: lunes, 26 de junio de 2017, 19:07
> Para: <[email-masked]>
> CC: <[email-masked]>
> Asunto: [sunset4] I-D Action: draft-ietf-sunset4-gapanalysis-08.txt
> 
> 
> **********************************************
> IPv4 is over
> Are you ready for the new Internet ?
> http://www.consulintel.es
> The IPv6 Company
> 
> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the use of the individual(s)
> named above. If you are not the intended recipient be aware that any
> disclosure, copying, distribution or use of the contents of this information,
> including attached files, is prohibited.
> 
> 
>