Subject: RE: [Syslog] #2, max message size - Need to resolve this

From: "Anton Okmianski \(aokmians\)" <[email-masked]>
Date: Wed, 30 Nov 2005 15:14:57 -0500

I vote for a different idea... As in latest syslog-protocol, define only the minimum message size the receivers is required to accept. I vote for defining it in both.  Syslog-protocol defines the least common agreed upon denominator.  Transport defines the minimum that is appropriate for the transport, which can be higher if needed.  Thus, if a receiver implements a syslog protocol and a given transport, it has to meet both requirements. 

Anton.  

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Chris 
> Lonvick (clonvick)
> Sent: Wednesday, November 30, 2005 2:08 PM
> To: [email-masked]
> Subject: [Syslog] #2, max message size - Need to resolve this
> 
> Hi Folks,
> 
> We need to resolve this one.  I've heard from Rainer and a 
> very few others.  I'd like to hear from more people on this.  
> Choose one:
> 
> __  The maximum message length needs to be defined in syslog-protocol.
> 
> 
> __  The maximum message length should be defined in the transport
>      documents.
> 
> 
> __  I have a different idea....
> 
> 
> Please VOTE NOW!
> 
> Thanks,
> Chris
> 
> _______________________________________________
> Syslog mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/syslog
> 

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: "Steve Chang \(schang99\)" <[email-masked]>
Date: Wed, 30 Nov 2005 12:46:02 -0800

I agree with Anton's wording and view.

Instead of capping the size maximally that a syslog receiver is to
support,
it should be the minimum size that it should support.

Steve

> From: [email-masked]
[mailto:[email-masked]]
> On Behalf Of Anton Okmianski (aokmians)
> Sent: Wednesday, November 30, 2005 12:15 PM
> To: Chris Lonvick (clonvick); [email-masked]
> Subject: RE: [Syslog] #2, max message size - Need to resolve this
> 
> I vote for a different idea... As in latest syslog-protocol, define
only
> the minimum message size the receivers is required to accept. I vote
for
> defining it in both.  Syslog-protocol defines the least common agreed
upon
> denominator.  Transport defines the minimum that is appropriate for
the
> transport, which can be higher if needed.  Thus, if a receiver
implements
> a syslog protocol and a given transport, it has to meet both
requirements.

---

From: "Rainer Gerhards" <[email-masked]>
Date: Wed, 30 Nov 2005 21:51:25 +0100

For obvious reasons, I agree with Steve and Anton.

Rainer

> [mailto:[email-masked]] On Behalf Of Steve 
> Chang (schang99)
> Sent: Wednesday, November 30, 2005 9:46 PM
> To: Anton Okmianski (aokmians); Chris Lonvick (clonvick); 
> [email-masked]
> Instead of capping the size maximally that a syslog receiver 
> is to support, it should be the minimum size that it should support.
> 
> Steve
> 
> > > [mailto:[email-masked]] On Behalf Of Chris Lonvick 
> > > (clonvick)
> > > We need to resolve this one.  I've heard from Rainer and 
> a very few 
> > > others.  I'd like to hear from more people on this. Choose one:
> > >
> > [email-masked] https://www1.ietf.org/mailman/listinfo/syslog
> 
> [email-masked] https://www1.ietf.org/mailman/listinfo/syslog
>