Subject: RE: [Syslog] #2, max message size

From: "Anton Okmianski \(aokmians\)" <[email-masked]>
Date: Wed, 30 Nov 2005 15:05:31 -0500

Darren:

> If you really want to get back to basics, I'd not accept any 
> maximum message size that was bigger than 490 bytes 
> (576-14-64-8) as this is the largest frame size that IPv4 is 
> *required* to reassemble.  Either you remove the maximum 
> message size from syslog-protocol or drop it to 490 but leave 
> it open to refining by transport definitions.  Yes, I'm well 
> aware of 490 being "too small" for some practical purposes 
> but you're not thinking clearly if you want any sort of 
> maximum size in syslog-protocol and this needs to be reinforced.

Before saying that somebody is not thinking clearly you should read what they sent you (if not the draft that is being discussed).  

There is NO maximum message size defined in syslog-protocol draft! Rainer sent you a copy of relevant text as part of this thread too.  It only defined a minimum size receivers must be able to process. That's all.  

A lot of your remarks come across very inflammatory, especially when they reflect that you are have not read the drafts.  Could you calm down the rhetoric maybe and do some home work?  Every email from you seems to scream that we are bunch of morons who don't know what they are doing, and you have come to save us from our misery.  I don't think it is the most productive way to get your arguments across.  There are a lot of knowledgeable people in this WG. 

And thanks for the re-education about the minimum MTU.  If you paid any attention to what this WG has done over the last two years or cared to read the archives (which even Rainer has done when discussing issues with you), you would have known that all these issues have been discussed at length here.  How about read the syslog-protocol-udp draft (sec 3.2)?

Anton. 

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: Darren Reed <[email-masked]>
Date: Thu, 1 Dec 2005 15:49:47 +1100 (EST)

Anton,

Please look into getting your email program to do word wrapping
before 80 columns.  Everyone else on the list seems to be able
to do this.  Replying to an email where you have to manually
reformat every line of quoted text is no fun.  Thanks.

> There is NO maximum message size defined in syslog-protocol draft!
..

Then why has there been any discussion, at all, on a maximum message
size ?  Seems like a waste of time and effort on everyone's behalf,
including Rainer's for listing it in the first place.

Cheers,
Darren