Subject: RE: [Syslog] Comments on syslog udp transport 05

From: "Anton Okmianski \(aokmians\)" <[email-masked]>
Date: Tue, 8 Nov 2005 21:03:38 -0500

Sam:

> Hi.  Here are my AD review comments on version 05 of the 
> syslog udp transport document.  These comments need to be 
> addressed before the document can be published.
> 
> 
> I noticed that you use the term bytes in this document .  
> Please use octet instead.

Section 2 on Terms has this:

"The words 'byte' and 'octet' are used interchangeably in this document.".  

I can change it to:

"The words 'byte' and 'octet' are used interchangeably in this document to refer to an octet.".

Is this sufficient?

I'd prefer to stick to byte (after properly defining it as octet) since this is what most engineers use and how most product documentation is written. If you insist, I can switch. 

> Section 4:
> 
>      bytes in size.  This limit stems from the maximum supported UDP
>         payload of 65536 kilobytes specified in the RFC 768 [1].
> 
> Is it 65536 or 65535?  Also it's octets not kb.

Ah, good catch - sloppy error. Fixed both. 

> Please either remove section 13 or  indicate that it should 
> be stripped on RFC publication.

Removed. 

Once I hear on octet vs. byte from you, I will send another draft to the editor.

Thanks,
Anton.

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: Sam Hartman <[email-masked]>
Date: Tue, 08 Nov 2005 21:11:22 -0500

>>>>> "Anton" == Anton Okmianski (aokmians) <[email-masked]> writes:

    Anton> Section 2 on Terms has this:

    Anton> "The words 'byte' and 'octet' are used interchangeably in
    Anton> this document.".

I did see that.

    Anton> I can change it to:

    Anton> "The words 'byte' and 'octet' are used interchangeably in
    Anton> this document to refer to an octet.".

    Anton> Is this sufficient?

No, I'm not really happy with that.  The IETf tends to use octet in
specs we publish.

    Anton> I'd prefer to stick to byte (after properly defining it as
    Anton> octet) since this is what most engineers use and how most
    Anton> product documentation is written. If you insist, I can
    Anton> switch.

I'm not sure I quite insist, but I'd strongly request at least.