Subject: RE: [Syslog] #7 field order

From: "Rainer Gerhards" <[email-masked]>
Date: Thu, 1 Dec 2005 16:45:28 +0100

Tom,

well-spotted. Indeed, PRI is NOT optional. The only one, as far as I am
concerned.

Rainer 

> -----Original Message-----
> From: Tom Petch [mailto:[email-masked]] 
> Sent: Thursday, December 01, 2005 12:35 PM
> To: Rainer Gerhards; [email-masked]
> Subject: Re: [Syslog] #7 field order
> 
> I was thinking that <PRI> is also not optional.
> 
> Tom Petch
> 
> ----- Original Message ----- 
> From: "Rainer Gerhards" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, November 30, 2005 10:06 AM
> Subject: RE: [Syslog] #7 field order
> 
> 
> I just got private mail if a missing field is denoted by "-". This is
> the case. Optional fields should be all but VERSION.
> 
> Rainer
> 
> > -----Original Message-----
> > From: [email-masked] 
> > [mailto:[email-masked]] On Behalf Of Rainer Gerhards
> > Sent: Wednesday, November 30, 2005 9:37 AM
> > To: [email-masked]
> > Subject: [Syslog] #7 field order
> > 
> > WG,
> > 
> > there has not been much discussion about the header fields and their
> > order recently. I think this is a sign the issue has been 
> settled. To
> > make sure I got the right understanding of the resulting 
> consensus, I
> > propose that we use the following format:
> > 
> > <PRI>VERSION SP TIMESTAMP SP HOSTNAME SP APP-NAME SP PROCID 
> > SP MSGID SP
> > [SD-ID]s SP MSG
> > 
> > That is the format that also proven to be quite useful during my
> > proof-of-concept implementation.
> > 
> > If somebody objects, please do that now.
> > 
> > Thanks,
> > Rainer
> > 
> 

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: "Rainer Gerhards" <[email-masked]>
Date: Thu, 1 Dec 2005 18:50:41 +0100

David,

> Can you please ask those who are sending you private messages to make
> their points on the mailing list, as is appropriate for IETF WG
> discussions?

That's what I typically do. But what if they are not willing to do that
and the point is important?

Rainer

---

From: "Anton Okmianski \(aokmians\)" <[email-masked]>
Date: Thu, 1 Dec 2005 13:11:05 -0500

Rainer, a better way to phrase this is may be that none of the fields are optional (except for maybe SD, depending on how you define the separators).  Some fields just have special values which are allowed to designate an "undefined value". So, the fields are always there.

Anton.  

> Sent: Thursday, December 01, 2005 10:45 AM
> To: Tom Petch; [email-masked]
> well-spotted. Indeed, PRI is NOT optional. The only one, as 
> far as I am concerned.
> 
> Rainer 
> 
> > > <PRI>VERSION SP TIMESTAMP SP HOSTNAME SP APP-NAME SP 
> PROCID SP MSGID 
> > > SP [SD-ID]s SP MSG
> > >

---

From: "Rainer Gerhards" <[email-masked]>
Date: Thu, 1 Dec 2005 20:57:37 +0100

Anton,

Thanks for the clarification. Your wording is correct. SD-ID will also
have "-" to indicate that it is "undefined", which in this case actually
means there is none.

Rainer 

> From: Anton Okmianski (aokmians) [mailto:[email-masked]] 
> Sent: Thursday, December 01, 2005 7:11 PM
> To: Rainer Gerhards; Tom Petch; [email-masked]
> Rainer, a better way to phrase this is may be that none of 
> the fields are optional (except for maybe SD, depending on 
> how you define the separators).  Some fields just have 
> special values which are allowed to designate an "undefined 
> value". So, the fields are always there.
> 
> Anton.  
>