Subject: Re: [Syslog] #5 - character encoding (was: Consensus?)

From: "Tom Petch" <[email-masked]>
Date: Thu, 1 Dec 2005 10:04:42 +0100

----- Original Message -----
From: "Chris Lonvick" <[email-masked]>
To: "Rainer Gerhards" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Wednesday, November 30, 2005 2:18 PM
Subject: RE: [Syslog] #5 - character encoding (was: Consensus?)

> Hi Rainer,
>
> Let's use this email as an example.  :)  There is no indication that I'm
> using US-ASCII encoding or that I'm writing in English.

Actually, Chris, there is; when I receive this e-mail, the header contains

Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed

so implicitly or explicitly you are telling me it is US-ASCII

By contrast, e-mails from Rainer, contain

Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

This reply is in charset="iso-8859-1" but by default, my Windows MUA replies in
the charset the message came in, so that
replying to you I could not then spell Müller properly which I could do to
Rainer.  On the
other hand, when replying to you, Windows inserts > to denote the incoming text
which it suppresses when I reply to Rainer.  And some e-mails I receive are not
in US-ASCII but lack the charset= in which case the display on screen is
somewhat or totally corrupted.

So MIME does an ok job but can be fooled by the rest of the system; if we can do
that well with syslog, we should be proud of ourselves.

Tom Petch

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: "David B Harrington" <[email-masked]>
Date: Thu, 1 Dec 2005 12:51:58 -0500

I suggest including wording to the effect

"if no SD-ID encoding element is specified, then the encoding of the
content is implementation specific and it is RECOMMENDED that no
assumption be made about the encoding of the content." 

dbh

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Rainer Gerhards
> Sent: Wednesday, November 30, 2005 6:24 AM
> To: [email-masked]; Chris Lonvick
> Cc: [email-masked]
> Andrew,
> > >Why don't we look at it from the other direction?  We could 
> > state that any 
> > >encoding is acceptable - for ease-of-use/migration with 
> > existing syslog 
> > >implementations.  It is RECOMMENDED that UTF-8 be used.  
> When it is 
> > >used, an SD-ID element will be REQUIRED.  e.g. - 
> > [enc="utf-8" lang="en"]
> > 
> > I like that idea too.
> > 
> > So, if no SD-ID encoding element is specified, then we must 
> > assume US-ASCII
> > and deal with it accordingly??
> 
> I think not. If it is not present, we known that we do not know it.
If
> it is US-ASCII, I would expect something like
> 
> [enc="us-ascii" lang="en"]
> 
> Of course, we could also say if it is non-present, we can assume
> US-ASCII. But then we would need to introduce
> 
> [enc="unknown"]
> 
> for the (common) case where we simply do not know it (again: think
> POSIX). I find this somehwat confusing.
> 
> Rainer
>