Subject: [Syslog] RE: nailing down characters in syslog-protocol

From: "Rainer Gerhards" <[email-masked]>
Date: Mon, 19 Dec 2005 08:57:33 +0100

Tom,

I see your point. I will check the text to see where this needs to be
fixed. Another approach might be to define all these characters with
specific ABNF names, and then refer to them (if they are not too many).
I'll see...

Rainer 

> -----Original Message-----
> From: Tom Petch [mailto:[email-masked]] 
> Sent: Saturday, December 17, 2005 4:59 PM
> To: Rainer Gerhards
> Cc: [email-masked]; Chris Lonvick
> Subject: nailing down characters in syslog-protocol
> 
> I would like to see a stricter definition of characters in 
> syslog-protocol.
> With US-ASCII, references to space or period or hyphen are 
> unambiguous; with
> UTF-8, they are not and so I think we should be more specific with our
> terminology.  Other documents specify characters in a variety 
> of ways, by
> names - SPACE or <NUL> or hyphen-minus - or by code - U+0020 
> or 0x00 or %2D.  We
> use
> %dnn
> in the ABNF so could use this notation elsewhere (although it 
> is not my
> favourite) with a
> paragraph in Section 2 to explain this, something like
> 
> Characters will be specified either by a decimal value
>    (e.g., the value %d65 for uppercase A and %d97 for 
> lowercase A) or by
>    a case-insensitive literal value enclosed in quotation marks (e.g.,
>    "A" for either uppercase or lowercase A).
> 
> or whatever is appropriate.  I know of no RFC that handles 
> this well but some
> are not bad, eg RFC2822 (from which the above comes) or RFC3987.
> 
> An example of a place in the I-D where I would make such a 
> change is in
>  6.2.8.  PROCID
> where we have
>  The dash ("-") is ...
> replacing it with something like
> %d45 ( - ) ...
> Not so pretty but more likely to interoperate.
> 
> This comment may not attract much "me too" on this list but 
> is intended to
> forestall objections that may well arise from the IESG or 
> during IETF last call.
> 
> Tom Petch
> 
> 

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: "Tom Petch" <[email-masked]>
Date: Tue, 20 Dec 2005 21:16:57 +0100

Rainer

I am flexible about what form the specification takes but would like it to be
one of the eight or so that already exist.  Looking at existing RFC,  I find the
ABNF format the least used (outside the strict ABNF itself), suspect that
Unicode's U+0020 is the future and so is what I would use, but that some form of
named characters would have the most appeal.  If we put names in the ABNF, then
I think the names should be from a standard, eg ISO 10636.

Tom

----- Original Message -----
From: "Rainer Gerhards" <[email-masked]>
To: <[email-masked]>
Sent: Monday, December 19, 2005 8:57 AM
Subject: [Syslog] RE: nailing down characters in syslog-protocol

Tom,

Rainer