Subject: RE: [Syslog] #5 - character encoding (was: Consensus?)

From: "Rainer Gerhards" <[email-masked]>
Date: Thu, 1 Dec 2005 14:25:08 +0100

Well... let me rephrase it slightly ;) After -protocol is finished, we could actually do something like syslog-mime, which could then describe this as an optional feature. Might even not be as crazy as it sounds - at least if I look what has been suggested so far. syslog-mime might be a solution for some of these needs....

Rainer 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Rainer Gerhards
> Sent: Thursday, December 01, 2005 12:45 PM
> To: Tom Petch; Chris Lonvick
> Cc: [email-masked]
> Subject: RE: [Syslog] #5 - character encoding (was: Consensus?)
> 
> Tom, WG
> 
> I am *not* kidding. If we go for an encoding header, why not 
> use MIME? 
> 
> Rainer 
> 
> > -----Original Message-----
> > From: [email-masked] 
> > [mailto:[email-masked]] On Behalf Of Tom Petch
> > Sent: Thursday, December 01, 2005 10:05 AM
> > To: Chris Lonvick
> > Cc: [email-masked]
> > Subject: Re: [Syslog] #5 - character encoding (was: Consensus?)
> > 
> > ----- Original Message -----
> > From: "Chris Lonvick" <[email-masked]>
> > To: "Rainer Gerhards" <[email-masked]>
> > Cc: <[email-masked]>; <[email-masked]>
> > Sent: Wednesday, November 30, 2005 2:18 PM
> > Subject: RE: [Syslog] #5 - character encoding (was: Consensus?)
> > 
> > > Hi Rainer,
> > >
> > > Let's use this email as an example.  :)  There is no 
> > indication that I'm
> > > using US-ASCII encoding or that I'm writing in English.
> > 
> > Actually, Chris, there is; when I receive this e-mail, the 
> > header contains
> > 
> > Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed
> > 
> > so implicitly or explicitly you are telling me it is US-ASCII
> > 
> > By contrast, e-mails from Rainer, contain
> > 
> > Content-Type: text/plain; charset="iso-8859-1"
> > Content-Transfer-Encoding: quoted-printable
> > 
> > This reply is in charset="iso-8859-1" but by default, my 
> > Windows MUA replies in
> > the charset the message came in, so that
> > replying to you I could not then spell Müller properly which 
> > I could do to
> > Rainer.  On the
> > other hand, when replying to you, Windows inserts > to denote 
> > the incoming text
> > which it suppresses when I reply to Rainer.  And some e-mails 
> > I receive are not
> > in US-ASCII but lack the charset= in which case the display 
> > on screen is
> > somewhat or totally corrupted.
> > 
> > So MIME does an ok job but can be fooled by the rest of the 
> > system; if we can do
> > that well with syslog, we should be proud of ourselves.
> > 
> > Tom Petch
> > 
> > 
> > _______________________________________________
> > Syslog mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/syslog
> > 
> 
> _______________________________________________
> Syslog mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/syslog
> 

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: "Tom Petch" <[email-masked]>
Date: Thu, 1 Dec 2005 19:18:27 +0100

Not sure which bits of MIME you have in mind but I like the term
Content-Transfer-Encoding, I like the list of such encodings, I like the list of
charsets and I like the way that the user/application gets to choose a suitable
delimiter for the various parts rather than have the protocol designer impose an
unsuitable one.  What don't I like? the term charset, but I think that is too
well embedded to avoid.

Oh and I love the way that the protocol proper is ASCII encoded, so easy to read
and display unlike markup languages, binary encodings etc etc

And I think its guidance about what to do when fields are absent or corrupt is
good, leading to a good chance of interoperability.

Tom Petch
----- Original Message -----
From: "Rainer Gerhards" <[email-masked]>
To: "Tom Petch" <[email-masked]>; "Chris Lonvick"
<[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, December 01, 2005 2:25 PM
Subject: RE: [Syslog] #5 - character encoding (was: Consensus?)

Well... let me rephrase it slightly ;) After -protocol is finished, we could
actually do something like syslog-mime, which could then describe this as an
optional feature. Might even not be as crazy as it sounds - at least if I look
what has been suggested so far. syslog-mime might be a solution for some of
these needs....

Rainer

---

From: "Tom Petch" <[email-masked]>
Date: Sat, 17 Dec 2005 16:58:57 +0100

I would like to see a stricter definition of characters in syslog-protocol.
With US-ASCII, references to space or period or hyphen are unambiguous; with
UTF-8, they are not and so I think we should be more specific with our
terminology.  Other documents specify characters in a variety of ways, by
names - SPACE or <NUL> or hyphen-minus - or by code - U+0020 or 0x00 or %2D.  We
use
%dnn
in the ABNF so could use this notation elsewhere (although it is not my
favourite) with a
paragraph in Section 2 to explain this, something like

Characters will be specified either by a decimal value
   (e.g., the value %d65 for uppercase A and %d97 for lowercase A) or by
   a case-insensitive literal value enclosed in quotation marks (e.g.,
   "A" for either uppercase or lowercase A).

or whatever is appropriate.  I know of no RFC that handles this well but some
are not bad, eg RFC2822 (from which the above comes) or RFC3987.

An example of a place in the I-D where I would make such a change is in
 6.2.8.  PROCID
where we have
 The dash ("-") is ...
replacing it with something like
%d45 ( - ) ...
Not so pretty but more likely to interoperate.

This comment may not attract much "me too" on this list but is intended to
forestall objections that may well arise from the IESG or during IETF last call.

Tom Petch