Subject: RE: [Syslog] #2, max message size - Need to resolve this

From: "Rainer Gerhards" <[email-masked]>
Date: Thu, 1 Dec 2005 20:52:14 +0100

Chris,

Wouldn't David's text be suitable? I think it is very clear and precise.
With it, probably the whole issue hadn't started. I know this WG likes
it very brief, but isn't it worth the extra lines?

Rainer 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Chris Lonvick
> Sent: Thursday, December 01, 2005 8:36 PM
> To: David B Harrington
> Cc: [email-masked]
> Subject: RE: [Syslog] #2, max message size - Need to resolve this
> 
> Hi David,
> 
> On Thu, 1 Dec 2005, David B Harrington wrote:
> 
> > Hi Chris,
> >
> > You have framed the question incorrectly.
> 
> That became evident when people started responding.  :)
> 
> It appears that we have consensus that:
> 
> - Rainer will place a recommendation of lengths into 
> syslog-protocol so
>    that recievers will have some expectations and,
> 
> - transport documents will contain a not-to-exceed length requirement.
> 
> Thanks,
> Chris
> 
> 
> >
> > This discussion is about the "minimum maximum message 
> length", not the
> > "maximum message length". This is about "at least this big" and not
> > about "no bigger than".
> >
> > All receivers MUST be able to handle the minimum maximum 
> message size
> > X, and it is RECOMMENDED that all receivers be able to 
> handle messages
> > of size Y, and receivers MAY choose to support sizes larger than Y.
> >
> > Senders can rest assured that any standard-compliant 
> receiver WILL be
> > able to handle messages of size X, so the sender can send a 
> message of
> > that size or less and not worry about it being truncated or dropped
> > (so if it is a critical message, keep the message shorter than X).
> > Senders can rest assured that most, but not all, compliant receivers
> > WILL be able to handle messages of size Y, but there is a chance of
> > the message being truncated or dropped, so if the message 
> is important
> > but you can live with it being dropped, then keep the 
> message shorter
> > than Y, and it will usually work. Senders can try to send messages
> > larger than Y, but many receivers will be unable to handle such a
> > size.
> >
> > Transport mappings may apply different constraints, but 
> regardless of
> > the transport, a compliant implementation MUST support the
> > transport-independent limit X, and it is RECOMMENDED that the
> > transport-independent limit Y be supported for improved
> > interoperability. If desired an implemntation MAY allow 
> larger sizes.
> >
> > Writers of transport mappings should pay attention to these limits.
> > All transport mappings MUST support at least size X. If the 
> transport
> > can support size Y, then the transport mapping contraint 
> should be set
> > to no less than size Y, and for consistency with the
> > transport-independent recommendation, SHOULD RECOMMEND support for
> > size Y (rather than for size Y+1 or Y+2 or Y-7 or ...). If 
> a transport
> > mapping can handle sizes larger than Y, then the transport 
> mapping can
> > support larger messages, and MAY choose to set transport-specific
> > contraints larger than Y.
> >
> > Is this strictly about which transport mapping is used? No, 
> it is not!
> > It establishes some standards that should be followed regardless of
> > the transport used, if possible - all implementations MUST support
> > size X, SHOULD support size Y, and MAY support larger sizes.
> >
> > Dbh
> >
> >> -----Original Message-----
> >> From: [email-masked]
> >> [mailto:[email-masked]] On Behalf Of Chris Lonvick
> >> Sent: Wednesday, November 30, 2005 2:08 PM
> >> To: [email-masked]
> >> Subject: [Syslog] #2, max message size - Need to resolve this
> >>
> >> Hi Folks,
> >>
> >> We need to resolve this one.  I've heard from Rainer and a very few
> >> others.  I'd like to hear from more people on this.  Choose one:
> >>
> >> __  The maximum message length needs to be defined in
> > syslog-protocol.
> >>
> >>
> >> __  The maximum message length should be defined in the transport
> >>      documents.
> >>
> >>
> >> __  I have a different idea....
> >>
> >>
> >> Please VOTE NOW!
> >>
> >> Thanks,
> >> Chris
> >>
> >> _______________________________________________
> >> Syslog mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/syslog
> >>
> >
> 
> _______________________________________________
> Syslog mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/syslog
> 

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: Chris Lonvick <[email-masked]>
Date: Thu, 1 Dec 2005 18:59:56 -0800 (PST)

Hi Rainer,

You're the document author - you decide.  I'm the WG Chair and my job is 
to make sure that the work continues.  I think that we all would like for 
the document to be crisp, clear and to the point.

Thanks,
Chris