Subject: RE: [Syslog] WGLC and document advancement

From: "Anton Okmianski \(aokmians\)" <[email-masked]>
Date: Fri, 8 Sep 2006 14:38:40 -0400

David:

Part of it is that we reviewed a lot of the syslog-protocol before the
last WGLC, and it did not change much since. I think we just added the
<pri> header, right? 

So, I have not given this version a close review because I reviewed much
of the same content for 2 years up to the last WGLC.  

If there were significant other changes since the last WGLC, I'd like to
know. If there were a lot of minor changes, I'd appreciate a document
with tracked changes since last WGLC.  Word Compare feature may help
with that.  

Thanks,
Anton. 

> -----Original Message-----
> From: David Harrington [mailto:[email-masked]] 
> Sent: Friday, September 08, 2006 1:23 PM
> To: [email-masked]
> Subject: [Syslog] WGLC and document advancement
> 
> Hi,
> 
> There are good things and bad things that come with having a 
> new WG co-chair.
> I think I have helped the WG by driving the completion of milestones.
> That's the good part.
> The bad part is I bring my own opinions of what adequate review means.
> 
> The IETF has started using a new process, called document 
> shepherding, for the advancement of documents to the 
> standards-track. The chairs are given much more 
> responsibility and authority to decide whether documents are 
> ready for advancement. They are expected to write up their 
> analyses of WG issues, consensus, and degree of review of the 
> documents being submitted, and these analyses will be 
> reviewed at every step of the process after this point, as 
> the members of the IESG try to determine whether the document 
> really is ready for advancment to standards-track. You can 
> see the details they expect us to provide by reading 
> draft-ietf-proto-wgchair-doc-shepherding-07 (which has been 
> expanded quite a bit from the -05- draft used during your 
> earlier WGLCs).
> 
> I have shepherded a number of documents through the process, 
> and I know how difficult it can be to get documents through 
> the process, and how much the documents can be delayed during 
> the standards-approval process if they are not really ready 
> for submission to that process.
> 
> I am concerned that the documents have not gotten adequate 
> review during WGLC. There have been very few comments made, 
> and I would like to see more reviews done by the members of 
> the WG for each of these documents. 
> 
> If you have problems with the documents, speak up now, so the 
> chairs can be sure your concerns are recognized and have been 
> addressed. 
> 
> If you have read the document, and found no important 
> problems and have no significant objections to the document, 
> and belive it is ready to be submitted to the advancement 
> process, please send a note to the WG saying so. 
> 
> David Harrington
> [email-masked]
> [email-masked]
> [email-masked]
> 
> 
> _______________________________________________
> Syslog mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/syslog
> 

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: "David Harrington" <[email-masked]>
Date: Mon, 11 Sep 2006 12:53:01 -0400

Hi,

I realize the WG is tired of reviewing these documents. But the
documents have been changed since the last WGLC, and it is the
responsibility of the WG to review the documents for THIS WGLC.

I wasn't co-chair at the time of the last WGLC.
The last WGLC occurred more than a year ago.
The documents have changed since protocol-14 and udp-05. I personally
do not have copies of protocol-14 and udp-05 to do the diffs for you.
Since that time, we have had a new charter, and debated issues such
as:

 max message size, 
 structured data,
 NUL octets,
 binary data,
 octet counts,
 field order,
 character encoding,
 MSGID, PROCID, APP-NAME, and VERSION in the header
 the standardization of <PRI>
 message drops
 truncation

I do not believe reviewing just the diffs will be adequate given the
number and scope of changes.  

So, WG members should do a complete review again, as boring as such
reviews will be. Hopefully, this WILL be the last one.

David Harrington
[email-masked] 
[email-masked]
[email-masked]
co-chair, Syslog WG 

> From: Anton Okmianski (aokmians) [mailto:[email-masked]] 
> Sent: Friday, September 08, 2006 2:39 PM
> To: David Harrington; [email-masked]
> Subject: RE: [Syslog] WGLC and document advancement
> 
> David:
>