Subject: [Syslog] AD review discuss/comments for draft-ietf-syslog-dtls - DCCP and UDP

From: "t.petch" <[email-masked]>
Date: Sat, 22 May 2010 18:43:50 +0200

Another issue that came up from the IESG is the relative roles of UDP and DCCP
as a substrate.  In this context, the discussions on tsvwg which Lars is
steering about SCTP, DCCP and UDP make interesting reading, with some
contributors asserting that the only way to get a packet through a complex
network is with UDP, that SCTP and DCCP are (comparative) failures that just
don't get recognised widely enough.

Certainly my (limited) view is that UDP is the MUST HAVE, the one that will give
maximum interoperability so while DCCP is technically superior, making it the
MUST implement will simply cause this I-D to be ignored by most.

I haven't seen any response from Lars on this issue.

Tom Petch

---

From: "David Harrington" <[email-masked]>
Date: Mon, 24 May 2010 14:34:12 -0400

Hi,

Lars provided advice quite a while back. I concur with his advice.

Implementers MUST implement support for DCCP (which should require
minimal changes from support for UDP),
so that if DCCP is available, and the operator chooses to use DCCPP,
the implementation will work with DCCP.

I view this as very similar to our standard security posture - stroing
security is MUST implement, so it is available if the operator wants
it. The operator is not required to use it.

dbh

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of t.petch
> Sent: Saturday, May 22, 2010 12:44 PM
> To: [email-masked]; Chris Lonvick
> Cc: syslog
> Subject: [Syslog] AD review discuss/comments for 
> draft-ietf-syslog-dtls -DCCP and UDP
> 
> _______________________________________________
> Syslog mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/syslog
>

---

From: "David Harrington" <[email-masked]>
Date: Mon, 24 May 2010 23:38:56 -0400

Hi,

dbh