Subject: Re: [Taps] agenda planning for chicago

From: "Aaron Falk" <[email-masked]>
Date: Tue, 21 Feb 2017 16:15:01 -0500

Picking up on this thread and soliciting agenda items for Chicago.  What 
are the key questions TAPS should be focusing on at this meeting?

—aaron

On 22 Dec 2016, at 20:16, Michael Welzl wrote:

> Hi,
>
> We NEATers would love to give the presentation that was dropped the 
> last time.
> Other news from my / our side:
> - getting closer to the finish line with the -usage draft: quite a lot 
> of updates already done, one major one due early Jan, then we want to 
> submit…
> - some ideas (thanks to everyone for input at the last meeting! that 
> was helpful!) for the minset draft, it’s bound to change quite a bit 
> and hopefully provoke an interesting discussion; for now, the plan is 
> to also finish that off fast, i.e. maybe in january…
>
> cheers
> Michael
>
>
>> On Dec 21, 2016, at 4:25 PM, Aaron Falk <[email-masked]> wrote:
>>
>> The secretariat has issued the call for wg sessions.  It would be 
>> helpful if we had an early idea of the agenda for a TAPS meeting in 
>> March.  Should we try again to get in the talks on post-sockets and 
>> NEAT?  Are there any other implementation projects that would like to 
>> present?  Any other topics to discuss?
>>
>> —aaron
>>
>> _______________________________________________
>> Taps mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/taps

---

From: Michael Welzl <[email-masked]>
Date: Wed, 22 Feb 2017 01:19:33 +0100

Hi,

I’ll answer with an apology: "early Jan, then” turned out differently… indeed we’ve been working on the -usage and -minset docs since fall and did NOT just wait until the last minute!
BUT it’s taken so long!  It’s just… a lot of stuff.

I think we have some interesting suggestions to make, coming out of the minset draft. I do think these are important next things to discuss - we should be focusing on charter item 2, what *is* the subset of transport services that a TAPS system should provide?

From the top of my head, I can think of these 3 major questions that appeared to us when we worked on our drafts:
- how do we handle multi-streaming? It seems to us that it shouldn’t be visible as such, there should be “flows” or “channels” or “connections” or whatever, with priorities and a notion of groups (could be a float each, assigned to “flows” as a property)
- how do we handle messaging? If, starting from SCTP, we allow only transport features that can fall-back to TCP (a part of our minset work), then we end up with some ways to send a message, but we can only receive a bytestream.
This can lead to a nice and uniform and downwards-compatible interface for the case where a receiving application doesn't need the transport to tell it where messages begin / end (and that’s the ONLY limitation!). We came up with this “application-framed bytestream” (AFra-Bytestream) concept in NEAT)
- what about message sizes?  I’m not sure this was fully resolved on the mailing list…

Cheers
Michael

> On Feb 21, 2017, at 10:15 PM, Aaron Falk <[email-masked]> wrote:
> 
> Picking up on this thread and soliciting agenda items for Chicago.  What are the key questions TAPS should be focusing on at this meeting?
> 
> —aaron
> 
> 
> 
> 
>> We NEATers would love to give the presentation that was dropped the last time.
>> - getting closer to the finish line with the -usage draft: quite a lot of updates already done, one major one due early Jan, then we want to submit…
>> - some ideas (thanks to everyone for input at the last meeting! that was helpful!) for the minset draft, it’s bound to change quite a bit and hopefully provoke an interesting discussion; for now, the plan is to also finish that off fast, i.e. maybe in january…
>> 
>> cheers
>> Michael
>> 
>> 
>>> The secretariat has issued the call for wg sessions.  It would be helpful if we had an early idea of the agenda for a TAPS meeting in March.  Should we try again to get in the talks on post-sockets and NEAT?  Are there any other implementation projects that would like to present?  Any other topics to discuss?
>>> 
>>> —aaron
>>>

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Wed, 22 Feb 2017 15:45:09 +0100

hi Aaron,

Seconding Tommy: we'll (finally) have a draft-trammell-taps-post-sockets-00 out before Chicago. We should report out of an author's meeting we had in Zürich last week, and figure out what (if anything) we'd like to do with the document in the WG.

Cheers,

Brian

> On 21 Feb 2017, at 22:15, Aaron Falk <[email-masked]> wrote:
>

---

From: "Aaron Falk" <[email-masked]>
Date: Wed, 22 Feb 2017 09:54:19 -0500

Trimming for focus…

>>
>> What are the key questions TAPS should be focusing on at this 
>> meeting?
>>
> I can think of these 3 major questions that appeared to us when we 
> worked on our drafts:
>
> - how do we handle multi-streaming?
> - how do we handle messaging?
> - what about message sizes?

These seem like good discussion topics.  Who would like to lead a short 
discussion on each?

—aaron

---

From: Michael Welzl <[email-masked]>
Date: Thu, 23 Feb 2017 09:55:10 +0100

> On Feb 22, 2017, at 3:54 PM, Aaron Falk <[email-masked]> wrote:
> 
> Trimming for focus…
> 
>>> 
>>> What are the key questions TAPS should be focusing on at this meeting?
>>> 
>> I can think of these 3 major questions that appeared to us when we worked on our drafts:
>> 
> These seem like good discussion topics.  Who would like to lead a short discussion on each?

I’d volunteer for all 3. Priority order:
1. messaging - I’d really like to lead the discussion on this one
2. multi-streaming
3. message sizes  - this one I feel the least secure about.

Cheers,
Michael

---

From: Tommy Pauly <[email-masked]>
Date: Thu, 23 Feb 2017 10:05:56 -0800

> On Feb 23, 2017, at 12:55 AM, Michael Welzl <[email-masked]> wrote:
> 
> 

I'd like to volunteer to lead the discussion about how to handle multi streaming protocols. We've been working on that and giving it a lot of thought for our protocol stack.

Thanks,
Tommy

---

From: Michael Welzl <[email-masked]>
Date: Thu, 23 Feb 2017 19:33:02 +0100

> On Feb 23, 2017, at 7:05 PM, Tommy Pauly <[email-masked]> wrote:
> 
> 

Speaking as someone who volunteered for the same: I’d be absolutely fine with that.

Cheers,
Michael

---

From: "Aaron Falk" <[email-masked]>
Date: Thu, 23 Feb 2017 13:59:32 -0500

On 23 Feb 2017, at 13:33, Michael Welzl wrote:
>> I'd like to volunteer to lead the discussion about how to handle 
>> multi streaming protocols. We've been working on that and giving it a 
>> lot of thought for our protocol stack.
>

So, seems like we still could use someone to lead a discussion about 
message sizes.  I confess I don’t recall what the concern is.  
Michael, can you expand a little?

—aaron

---

From: Michael Welzl <[email-masked]>
Date: Fri, 24 Feb 2017 00:05:51 +0100

> On Feb 23, 2017, at 7:59 PM, Aaron Falk <[email-masked]> wrote:
> 
> So, seems like we still could use someone to lead a discussion about message sizes.  I confess I don’t recall what the concern is.  Michael, can you expand a little?

UDP applications (at least) sometimes need to know the PMTU - e.g. that was on the list of things a latency-critical application needs, presented by Colin at the last meeting.
The PMTU is a per-path property. Should a TAPS system be fully aware of a physical path? If so, consider: the PMTU is including all headers - so the message size that fits in will be different for v4 and v6.
For the real message size that fits in, subtract the UDP header too. Then we’re dependent on layers 3 AND 4 … not how a TAPS system should be!  Yet, for apps that want to do PMTUD (common above UDP), an app *must* be able to send a packet exceeding the MTU… how should all this be handled / exposed in a TAPS system?

Cheers,
Michael

---

From: Anna Brunstrom <[email-masked]>
Date: Mon, 27 Feb 2017 23:55:48 +0100

Hi Aaron, all,

We would like to give an update on our work on happy eyeballs. We plan 
to submit an updated draft before the meeting cut-off.

Cheers,
Anna

On 2017-02-21 22:15, Aaron Falk wrote:
> Picking up on this thread and soliciting agenda items for Chicago.  
>> - getting closer to the finish line with the -usage draft: quite a 
>> lot of updates already done, one major one due early Jan, then we 
>> want to submit…
>>> NEAT?  Are there any other implementation projects that would like 
>>> to present?  Any other topics to discuss?
>>>
>>> —aaron
>>>

---

From: Michael Welzl <[email-masked]>
Date: Tue, 28 Feb 2017 12:32:36 +0100

Hi,

Also from us - on top of the discussion items, there will be updates of our drafts to present:

draft-ietf-taps-transports-usage-03 (to be submitted):  10-15 mins if possible, Naeem Khademi or myself

draft-gjessing-taps-minset-04  (to be submitted): 10-15 mins if possible, Stein Gjessing

Cheers,
Michael

> On 27 Feb 2017, at 23:55, Anna Brunstrom <[email-masked]> wrote:
> 
> Hi Aaron, all,
> 
> We would like to give an update on our work on happy eyeballs. We plan to submit an updated draft before the meeting cut-off.
> 
> Cheers,
> Anna
> 
>

---

From: "Aaron Falk" <[email-masked]>
Date: Tue, 28 Feb 2017 10:24:31 -0500

Summarizing the agenda proposals.  Did I miss anything?  Names ok?  Note 
we need a leader for message sizes…

—aaron

- - -

Working group document updates

  * draft-ietf-taps-transports-usage-03 (to be submitted):  10-15 mins 
if possible, Naeem Khademi or myself
  * draft-gjessing-taps-minset-04  (to be submitted): 10-15 mins if 
possible, Stein Gjessing

TAPS Design Discussions

  * Messaging, introduced by Michael Welzl
  * Multi-streaming, introduced by Tommy Pauly
  * message sizes & PMTU, introduced by ???

Related Projects

  * Happy Eyeballs, Anna Brunstrom
  * NEAT, Naeem Khademi &/or Michael Welzl
  * Post-Sockets, Tommy Pauly &/or Brian Trammel (remote)