Subject: [Taps] Prague agenda planning

From: "Aaron Falk" <[email-masked]>
Date: Tue, 27 Jun 2017 15:21:21 -0400

Here the short list of topics recently raised for our next meeting and 
some questions/comments.  Please respond and suggest any other topics.

* `draft-gjessing-taps-minset-05.txt`
   * There’s been some interesting discussion on the draft.  Are there 
any specific topics we should set aside time to discuss?

* Socket Intents
   * Again, what specific topics should we discuss?
   * We’ve been told to expect 3 drafts: on general concepts, BSD 
implementation, & communication granularity.  What’s worth discussing?

* Michio Honda HotNets paper “[PASTE: Network Stacks Must Integrate 
with NVMM 
Abstractions](http://www.ht.sfc.keio.ac.jp/~micchie/papers/paste-hotnets16.pdf)”
   * *“These days I'm working on networking interface for non-volatile 
main memory (a.k.a. persistent memory and storage-class memory), because 
with such devices networking stack/API becomes a bottleneck in the 
end-to-end communication that involves persistent media (disk or SSDs 
for now).  I saw some post-socket discussion in the minutes of the last 
meeting, so I wonder if this type of work could give some useful 
information to IETFers who design new transport API standards.”*
   * Is there interest in this topic?  AFAIK, there’s no Internet 
Draft.  I will inquire whether Michio intends to submit one.

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 27 Jun 2017 13:22:59 -0700

Hi Aaron,

We have a draft we’ll be publishing in the next week that does a survey of Transport Security protocols, and the interfaces they expose to the transport layer as well as applications. We’d like to have a slot to discuss this topic with the WG.

Thanks,
Tommy

> On Jun 27, 2017, at 12:21 PM, Aaron Falk <[email-masked]> wrote:
> 
> Here the short list of topics recently raised for our next meeting and some questions/comments. Please respond and suggest any other topics.
> 
> draft-gjessing-taps-minset-05.txt
> 
> There’s been some interesting discussion on the draft. Are there any specific topics we should set aside time to discuss?
> Socket Intents
> 
> Again, what specific topics should we discuss?
> We’ve been told to expect 3 drafts: on general concepts, BSD implementation, & communication granularity. What’s worth discussing?
> Michio Honda HotNets paper “PASTE: Network Stacks Must Integrate with NVMM Abstractions <http://www.ht.sfc.keio.ac.jp/%7Emicchie/papers/paste-hotnets16.pdf>”
> 
> “These days I'm working on networking interface for non-volatile main memory (a.k.a. persistent memory and storage-class memory), because with such devices networking stack/API becomes a bottleneck in the end-to-end communication that involves persistent media (disk or SSDs for now). I saw some post-socket discussion in the minutes of the last meeting, so I wonder if this type of work could give some useful information to IETFers who design new transport API standards.”
> Is there interest in this topic? AFAIK, there’s no Internet Draft. I will inquire whether Michio intends to submit one.
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps

---

From: "Aaron Falk" <[email-masked]>
Date: Tue, 27 Jun 2017 16:44:10 -0400

Cool.  Are you proposing this as a wg item?

--aaron

On 27 Jun 2017, at 16:22, Tommy Pauly wrote:

> Hi Aaron,
>
> We have a draft we’ll be publishing in the next week that does a 
> survey of Transport Security protocols, and the interfaces they expose 
> to the transport layer as well as applications. We’d like to have a 
> slot to discuss this topic with the WG.
>
> Thanks,
> Tommy
>
>> Here the short list of topics recently raised for our next meeting 
>> and some questions/comments. Please respond and suggest any other 
>> topics.
>>
>> There’s been some interesting discussion on the draft. Are there 
>> We’ve been told to expect 3 drafts: on general concepts, BSD 
>> Michio Honda HotNets paper “PASTE: Network Stacks Must Integrate 
>> with NVMM Abstractions 
>> <http://www.ht.sfc.keio.ac.jp/%7Emicchie/papers/paste-hotnets16.pdf>”
>>
>> “These days I'm working on networking interface for non-volatile 
>> main memory (a.k.a. persistent memory and storage-class memory), 
>> because with such devices networking stack/API becomes a bottleneck 
>> in the end-to-end communication that involves persistent media (disk 
>> or SSDs for now). I saw some post-socket discussion in the minutes of 
>> the last meeting, so I wonder if this type of work could give some 
>> useful information to IETFers who design new transport API 
>> standards.”
>> Is there interest in this topic? AFAIK, there’s no Internet Draft. 
>> I will inquire whether Michio intends to submit one.

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 27 Jun 2017 14:33:58 -0700

Yes, we’d like to add this as a WG item once published. This is based on the conversation had at the meeting in Chicago about wanting a draft to include Security protocols for TAPS API considerations.

Thanks,
Tommy

> On Jun 27, 2017, at 1:44 PM, Aaron Falk <[email-masked]> wrote:
> 
>> On Jun 27, 2017, at 12:21 PM, Aaron Falk <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> [email-masked] <mailto:[email-masked]>

---

From: Michael Welzl <[email-masked]>
Date: Tue, 27 Jun 2017 23:55:50 +0200

… and the latest version of the minset draft excludes security from the final minset, mentioning that this will be addressed in a separate draft (which should be this one).

Cheers,
Michael

> On Jun 27, 2017, at 11:33 PM, Tommy Pauly <[email-masked]> wrote:
> 
>> On Jun 27, 2017, at 1:44 PM, Aaron Falk <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>> https://www.ietf.org/mailman/listinfo/taps <https://www.ietf.org/mailman/listinfo/taps>
>>

---

From: "Aaron Falk" <[email-masked]>
Date: Thu, 29 Jun 2017 11:36:11 -0400

Updating.  Our agenda time is much more productive if we can home in on 
specific questions to discuss rather than just give document overviews.  
Authors & other folk: what’s interesting, unclear, or controversial 
here?

* Socket Intents, Philipp
   * Again, what specific topics should we discuss?
   * We’ve been told to expect 3 drafts: on general concepts, BSD 
implementation, & communication granularity.  What’s worth discussing?

* Transport Security Protocol Survey, Tommy

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Thu, 29 Jun 2017 18:07:21 +0200

hi Aaron,

> On 29 Jun 2017, at 17:36, Aaron Falk <[email-masked]> wrote:
> 
> Updating. Our agenda time is much more productive if we can home in on specific questions to discuss rather than just give document overviews. Authors & other folk: what’s interesting, unclear, or controversial here?

I think it's time to level up and have a discussion about "policy" and how it relates to TAPS.

I'm going to leave the definition of "policy" here deliberately vague with the hope that we can start to build some terminology around it at the meeting.

> 
> 	• draft-gjessing-taps-minset-05.txt
> 
> 		• There’s been some interesting discussion on the draft. Are there any specific topics we should set aside time to discuss?
> 	• Socket Intents, Philipp
> 
> 		• Again, what specific topics should we discuss?
> 		• We’ve been told to expect 3 drafts: on general concepts, BSD implementation, & communication granularity. What’s worth discussing?

Given the focus of the socket intents and granularity work, I think starting the policy discussion here makes sense.

> 	• Michio Honda HotNets paper “PASTE: Network Stacks Must Integrate with NVMM Abstractions”
> 
> 		• “These days I'm working on networking interface for non-volatile main memory (a.k.a. persistent memory and storage-class memory), because with such devices networking stack/API becomes a bottleneck in the end-to-end communication that involves persistent media (disk or SSDs for now). I saw some post-socket discussion in the minutes of the last meeting, so I wonder if this type of work could give some useful information to IETFers who design new transport API standards.”
> 		• Is there interest in this topic? AFAIK, there’s no Internet Draft. I will inquire whether Michio intends to submit one.

IMO this is very interesting stuff. Might be better as a tsvarea presentation?

Cheers,

Brian

> 	• Transport Security Protocol Survey, Tommy
>

---

From: "Philipp S. Tiesel" <[email-masked]>
Date: Thu, 29 Jun 2017 18:27:06 +0200

Hi Aaron,

> On 29. Jun 2017, at 18:07, Brian Trammell (IETF) <[email-masked]> wrote:
> 
> hi Aaron,
> 

Agreed - 10min talk for context and run though about socket intents and granularity stuff would be great (plus 2 to 5min for discussion how to proceed with both drafts).

The Policy discussion following that might take some time…

The third draft is expected tomorrow or on Monday and I think it does not really need separate discussing in Prague.
It is mainly context for the socket intents draft and contains some lessons learned that might be useful for other projects around TAPS.

AVE!
  Philipp S. Tiesel / phils…

---

From: Tommy Pauly <[email-masked]>
Date: Thu, 29 Jun 2017 10:09:58 -0700

> On Jun 29, 2017, at 9:07 AM, Brian Trammell (IETF) <[email-masked]> wrote:
> 
> hi Aaron,
> 

+1 to having a general discussion on the topic of policy (both application-specified and system-specified), likely following onto the presentation of intents. Getting a formal set of definitions would really help moving forward in our discussions.
>> 	• Transport Security Protocol Survey, Tommy

Since the security part of the protocols is a bit new in TAPS, we’ll probably want to give a bit of document overview, but I think the interesting discussion points here are in:
- The common features/interface presented by various security protocols
- The ability to separate security handshakes from data encryption

Thanks,
Tommy

---

From: "Aaron Falk" <[email-masked]>
Date: Thu, 29 Jun 2017 15:53:22 -0400

Updated:

1. **`draft-gjessing-taps-minset-05.txt`**
   * There’s been some interesting discussion on the draft.  Are there 
any specific topics we should set aside time to discuss?

2.  **Transport Security Protocol Survey**, Tommy
   - The common features/interface presented by various security 
protocols
   - The ability to separate security handshakes from data encryption

3.  **Socket Intents, Concepts & Communication Granularity**, Phillipp

4.  **Application- & System-Specified Policy & TAPS**, Brian? Tommy?

____

Draft.  I will inquire whether Michio intends to submit one.  May end up 
in TSVAREA

---

From: Michael Welzl <[email-masked]>
Date: Thu, 29 Jun 2017 22:53:09 +0200

Hi,

In line:

> On Jun 29, 2017, at 9:53 PM, Aaron Falk <[email-masked]> wrote:
> 
> Updated:
> 

I appreciated this discussion much, but personally I don’t think know of any specific topic that we need to discuss here - plus, there seem to be plenty of other good things to talk about which will all need time.

Cheers,
Michael

> 
> Transport Security Protocol Survey, Tommy
> 
> The common features/interface presented by various security protocols
> The ability to separate security handshakes from data encryption
> Socket Intents, Concepts & Communication Granularity, Phillipp
> 
> Application- & System-Specified Policy & TAPS, Brian? Tommy?
> 
> Is there interest in this topic? AFAIK, there’s no Internet Draft. I will inquire whether Michio intends to submit one. May end up in TSVAREA

---

From: Michael Welzl <[email-masked]>
Date: Thu, 29 Jun 2017 23:09:54 +0200

Hi all,

> On Jun 29, 2017, at 7:09 PM, Tommy Pauly <[email-masked]> wrote:
> 
> 
> 

+1 from me too.

BTW, NEAT already has quite an elaborate policy system built in. Naeem gave a high-level look at it at the last meeting:
https://www.ietf.org/proceedings/98/slides/slides-98-taps-42-neat-naeem-khademi-00.pdf <https://www.ietf.org/proceedings/98/slides/slides-98-taps-42-neat-naeem-khademi-00.pdf>  (slides 6/7)

More details are here:
https://www.neat-project.org/wp-content/uploads/2017/03/commag16-accepted-version.pdf <https://www.neat-project.org/wp-content/uploads/2017/03/commag16-accepted-version.pdf>
This says “until published”, but I think this has just happened:
http://ieeexplore.ieee.org/document/7945852/ <http://ieeexplore.ieee.org/document/7945852/>

Cheers,
Michael

---

From: boza <[email-masked]>
Date: Fri, 30 Jun 2017 13:31:45 +0100

Hi All,

On Thu, Jun 29, 2017 at 10:09 PM, Michael Welzl <[email-masked]> wrote:

> I'm going to leave the definition of "policy" here deliberately vague with
> the hope that we can start to build some terminology around it at the
> meeting.
>
>
> +1 to having a general discussion on the topic of policy (both
> application-specified and system-specified), likely following onto the
> presentation of intents. Getting a formal set of definitions would really
> help moving forward in our discussions.
>
>
> +1 from me too.
>
> BTW, NEAT already has quite an elaborate policy system built in. Naeem
> gave a high-level look at it at the last meeting:
> https://www.ietf.org/proceedings/98/slides/slides-
> 98-taps-42-neat-naeem-khademi-00.pdf  (slides 6/7)
>
> More details are here:
> https://www.neat-project.org/wp-content/uploads/2017/03/
> commag16-accepted-version.pdf
> http://ieeexplore.ieee.org/document/7945852/
>
> I'd be happy join the discussion on policy aspects (unfortunately, only
remotely). As Michael mentioned, the implemented NEAT policy system is
fairly flexible. The most up-to-date documentation can be found on the NEAT
GitHub <https://github.com/NEAT-project/neat/blob/master/policy/README.md>
pages.
Let me know if you have any questions.

Cheers,
Zdravko