Subject: Re: [Taps] Prague agenda planning

From: Anna Brunstrom <[email-masked]>
Date: Sun, 2 Jul 2017 01:25:12 +0200

Hi Aaron, all,

We plan to submit an update to the happy-eyeballs  draft before the 
cut-off and would like to add that to the agenda as well. The update 
aims to address the feedback received so far.

I think it fits nicely with the policy discussion. The HE framework in 
the draft includes a Policy Management component. The HE algorithm makes 
certain assumptions on what it provides, but it is not part of the HE 
algorithm itself.

Two topics to discuss about the draft would be:
* the interface between the HE algorithm and the policy management
* what should be detailed in the specification of the HE algorithm and 
what should be left open for implementation

Cheers,
Anna

On 2017-06-29 21:53, Aaron Falk wrote:
>
> Updated:
>
> 1.
>
>     *|draft-gjessing-taps-minset-05.txt|*
>
>       * There’s been some interesting discussion on the draft. Are
>         there any specific topics we should set aside time to discuss?
> 2.
>
>     *Transport Security Protocol Survey*, Tommy
>
>       * The common features/interface presented by various security
>         protocols
>       * The ability to separate security handshakes from data encryption
> 3.
>
>     *Socket Intents, Concepts & Communication Granularity*, Phillipp
>
> 4.
>
>     *Application- & System-Specified Policy & TAPS*, Brian? Tommy?
>
> ------------------------------------------------------------------------
>
>   * Michio Honda HotNets paper “PASTE: Network Stacks Must Integrate
>     with NVMM Abstractions
>     <http://www.ht.sfc.keio.ac.jp/%7Emicchie/papers/paste-hotnets16.pdf>”
>       o /“These days I'm working on networking interface for
>         non-volatile main memory (a.k.a. persistent memory and
>         storage-class memory), because with such devices networking
>         stack/API becomes a bottleneck in the end-to-end communication
>         that involves persistent media (disk or SSDs for now). I saw
>         some post-socket discussion in the minutes of the last
>         meeting, so I wonder if this type of work could give some
>         useful information to IETFers who design new transport API
>         standards.”/
>       o Is there interest in this topic? AFAIK, there’s no Internet
>         Draft. I will inquire whether Michio intends to submit one.
>         May end up in TSVAREA
>
>
>
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps

---

From: "Aaron Falk" <[email-masked]>
Date: Wed, 05 Jul 2017 12:42:35 -0400

On 29 Jun 2017, at 16:53, Michael Welzl wrote:

>>   1. **`draft-gjessing-taps-minset-05.txt`**
>>
> I appreciated this discussion much, but personally I don’t think 
> know of any specific topic that we need to discuss here - plus, there 
> seem to be plenty of other good things to talk about which will all 
> need time.

Fair enough.  In that case, my question is what it needed to finish the 
document?  Are there any open issues?

—aaron

---

From: "Aaron Falk" <[email-masked]>
Date: Wed, 05 Jul 2017 12:55:54 -0400

Updated:

1. **Minimal Set of Transport Services for TAPS Systems**  [[XX who will 
present?  XX]]
   * `draft-gjessing-taps-minset-05.txt`
   * Open issues to finalize doc

2. **Transport Security Protocol Survey**, Tommy Pauly
   * At the meeting in Chicago, the question of how security protocols 
should be handled was brought up, and we suggested writing a draft to do 
a survey of Transport Security protocols, similar to the work done in 
RFC 8095 and the transport usage drafts. This document goes over several 
common transport security protocols and analyzes their features and 
interfaces, particularly with regards to how they interact with their 
associated transport protocols and applications.  For consideration as a 
TAPS working group doc.
   * `draft-pauly-taps-transport-security-00.txt`: The common 
features/interface presented by various security protocols
   * `draft-kuehlewind-taps-crypto-sep-00.txt`: The ability to separate 
security handshakes from data encryption

4. **Application- & System-Specified Policy & TAPS**, [[XX someone needs 
to frame this topic.  who?  Brian? Tommy?  XX]]

3. **Socket Intents, Concepts & Communication Granularity**, Phillipp 
Tiesel
   * Socket Intents allow applications to share their knowledge about 
upcoming
communication and express their performance preferences in an API 
independent way.
Therefore, thy can be used by an OS/API to gain enough knowledge to 
perform access
as well as transport protocol selection and tuning.
   * `draft-tiesel-taps-socketintents-00.txt`: concepts
   * `draft-tiesel-taps-communitgrany-00.txt`: endpoint and path 
selection
   * `draft-tiesel-taps-socketintents-bsdsockets-00.txt`: prototype

5. **Happy Eyeballs update**, Anna Brunstrom
   * `draft-grinnemo-taps-he-03.txt` (update expected)
   * The interface between the HE algorithm and the policy management
   * What should be detailed in the specification of the HE algorithm 
and what should be left open for implementation?

---

From: Michael Welzl <[email-masked]>
Date: Thu, 6 Jul 2017 00:14:32 +0200

> On Jul 5, 2017, at 6:42 PM, Aaron Falk <[email-masked]> wrote:
> 
> 
> 
>>>    * There’s been some interesting discussion on the draft. Are there any specific topics we should set aside time to discuss?
>>> 
>> 
>> I appreciated this discussion much, but personally I don’t think know of any specific topic that we need to discuss here - plus, there seem to be plenty of other good things to talk about which will all need time.
> 
> Fair enough.  In that case, my question is what it needed to finish the document?  Are there any open issues?

Well - IMO this version is a first “real complete” version - i.e. once the group reads, comments, and we incorporate fixes, we can be done quite quickly. I don’t think there’s anything truly major missing.

I’m happy about the first comments that have already come in, and we’ll address them in the next version (after Prague) - the most important thing being to work out a more comprehensive list of decisions to be taken *initially* (e.g. the reliability case that Philipp and Theresa pointed out, that’s a clear bug).

The draft will be presented by Naeem Khademi, who isn’t an author, on behalf of us authors. I hope that’s acceptable!  I’ll do my best to be remotely available for discussion too.

I think it makes sense for this presentation to focus on what’s new: the abstract API that we designed. I think this is an interesting thing with pretty straightforward yet important implications on other TAPS APIs (I’d hope).

Cheers,
Michael

---

From: "Aaron Falk" <[email-masked]>
Date: Thu, 06 Jul 2017 10:18:29 -0400

>>>> there any specific topics we should set aside time to discuss?

<snip>

> I think it makes sense for this presentation to focus on what’s new: 
> the abstract API that we designed. I think this is an interesting 
> thing with pretty straightforward yet important implications on other 
> TAPS APIs (I’d hope).
>

I see.  Sounds like a fairly short slot then. Say 10min?

—aaron

---

From: "Aaron Falk" <[email-masked]>
Date: Thu, 06 Jul 2017 10:56:42 -0400

Updated.  Still need a policy framing preso (#4) and timing.

1. **Minimal Set of Transport Services for TAPS Systems**, Naeem Khademi 
(presenting for authors)
   * `draft-gjessing-taps-minset-05.txt`
   *  What’s new: the abstract API

   * `draft-grinnemo-taps-he-03.txt`

---

From: Mirja Kühlewind <[email-masked]>
Date: Thu, 6 Jul 2017 17:20:06 +0200

I believe the idea was actually to have the policy after the socket intents talk; maybe even after HE?

Mirja

> Am 06.07.2017 um 16:56 schrieb Aaron Falk <[email-masked]>:
> 
> 	• Minimal Set of Transport Services for TAPS Systems, Naeem Khademi (presenting for authors)
> 
> 		• draft-gjessing-taps-minset-05.txt
> 		• What’s new: the abstract API
> 	• Transport Security Protocol Survey, Tommy Pauly
> 
> 		• At the meeting in Chicago, the question of how security protocols should be handled was brought up, and we suggested writing a draft to do a survey of Transport Security protocols, similar to the work done in RFC 8095 and the transport usage drafts. This document goes over several common transport security protocols and analyzes their features and interfaces, particularly with regards to how they interact with their associated transport protocols and applications. For consideration as a TAPS working group doc.
> 		• draft-pauly-taps-transport-security-00.txt: The common features/interface presented by various security protocols
> 		• draft-kuehlewind-taps-crypto-sep-00.txt: The ability to separate security handshakes from data encryption
> 	• Application- & System-Specified Policy & TAPS, [[XX someone needs to frame this topic. who? Brian? Tommy? XX]]
> 
> 	• Socket Intents, Concepts & Communication Granularity, Phillipp Tiesel
> 
> 		• Socket Intents allow applications to share their knowledge about upcoming communication and express their performance preferences in an API independent way. Therefore, thy can be used by an OS/API to gain enough knowledge to perform access as well as transport protocol selection and tuning.
> 		• draft-tiesel-taps-socketintents-00.txt: concepts
> 		• draft-tiesel-taps-communitgrany-00.txt: endpoint and path selection
> 		• draft-tiesel-taps-socketintents-bsdsockets-00.txt: prototype
> 	• Happy Eyeballs update, Anna Brunstrom
> 
> 		• draft-grinnemo-taps-he-03.txt
> 		• The interface between the HE algorithm and the policy management
> 		• What should be detailed in the specification of the HE algorithm and what should be left open for implementation?

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Thu, 6 Jul 2017 17:51:53 +0200

As did I. But if we want to separate the discussions more explicitly, I'm happy to throw together five minutes of slides to frame the discussion in a proposal-neutral way; I think we'll need at least twenty for the discussion though.

Cheers,

Brian

> On 06 Jul 2017, at 17:20, Mirja Kühlewind <[email-masked]> wrote:
>

---

From: "Aaron Falk" <[email-masked]>
Date: Thu, 06 Jul 2017 12:06:35 -0400

I don’t have a preference.  I was assuming

1. frame the topic
2. look at a few applications / use cases
3. discuss / wrestle / free-for-all

but I’m also ok with

1. example 1, 2, 3
2. abstract / summarize some questions
3. discuss / wrestle / free-for-all

I’ll leave whoever wants to take the framing talk to tell me where 
they want it.  Sounds like it’ll be Brian and have it after socket 
intents & HE.  Yes?

--aaron

On 6 Jul 2017, at 11:51, Brian Trammell (IETF) wrote:

> As did I. But if we want to separate the discussions more explicitly, 
> I'm happy to throw together five minutes of slides to frame the 
> discussion in a proposal-neutral way; I think we'll need at least 
> twenty for the discussion though.
>
> Cheers,
>
> Brian
>
>>> 		• At the meeting in Chicago, the question of how security 
>>> protocols should be handled was brought up, and we suggested writing 
>>> a draft to do a survey of Transport Security protocols, similar to 
>>> the work done in RFC 8095 and the transport usage drafts. This 
>>> document goes over several common transport security protocols and 
>>> analyzes their features and interfaces, particularly with regards to 
>>> how they interact with their associated transport protocols and 
>>> applications. For consideration as a TAPS working group doc.
>>> 		• draft-pauly-taps-transport-security-00.txt: The common 
>>> 		• draft-kuehlewind-taps-crypto-sep-00.txt: The ability to 
>>> separate security handshakes from data encryption
>>> 	• Application- & System-Specified Policy & TAPS, [[XX someone 
>>> needs to frame this topic. who? Brian? Tommy? XX]]
>>>
>>> 		• Socket Intents allow applications to share their knowledge 
>>> about upcoming communication and express their performance 
>>> preferences in an API independent way. Therefore, thy can be used by 
>>> an OS/API to gain enough knowledge to perform access as well as 
>>> transport protocol selection and tuning.
>>> 		• What should be detailed in the specification of the HE 
>>> algorithm and what should be left open for implementation?

---

From: "Aaron Falk" <[email-masked]>
Date: Thu, 06 Jul 2017 12:16:59 -0400

Updated.

0. **Agenda Bash & Working Group Status**, Aaron Falk & Zahed Sarker, 10 
min

1. **Minimal Set of Transport Services for TAPS Systems**, Naeem Khademi 
(presenting for authors), 20 min
   * `draft-gjessing-taps-minset-05.txt`
   *  What’s new: the abstract API

2. **Transport Security Protocol Survey**, Tommy Pauly, 20 min

Tiesel, 20 min

4. **Happy Eyeballs update**, Anna Brunstrom, 20 min

5. **Discussion: Application- & System-Specified Policy & TAPS**,  
Framed by Brian Trammell, 40 min