Subject: [Taps] AD Evaluation on the relationship between draft-ietf-taps-transports-usage-06 and draft-ietf-taps-transports-usage-udp-04

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 24 Aug 2017 15:24:13 -0500

Just to make these documents a bit more digestible by reviewers, ADs, and
readers, who will almost certainly be reading them as a set ...

I'm OK with the separation of the Pass 1 analysis of UDP(-lite) into a
separate draft, but I wish the relationship was a little clearer. It seems
like
https://tools.ietf.org/html/draft-ietf-taps-transports-usage-06#section-3.4
has more text describing UDP(-lite) than it needs, if it's just going to
say "The set of Pass 1 primitives for UDP and UDP-Lite is documented in
[FJ16].".

If this makes sense to the working group, that description of UDP could be
integrated into
https://tools.ietf.org/html/draft-ietf-taps-transports-usage-udp-04#section-3,
which only has a one-sentence description of UDP itself before beginning
its analysis.

Is there any chance that each document could provide a pointer to the other
document, in the Abstract and Introduction sections, and be clearer about
the relationship there?

Thanks,

Spencer

---

From: Michael Welzl <[email-masked]>
Date: Fri, 25 Aug 2017 19:47:59 +0200

> On Aug 24, 2017, at 10:24 PM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Just to make these documents a bit more digestible by reviewers, ADs, and readers, who will almost certainly be reading them as a set ...
> 
> I'm OK with the separation of the Pass 1 analysis of UDP(-lite) into a separate draft, but I wish the relationship was a little clearer. It seems like https://tools.ietf.org/html/draft-ietf-taps-transports-usage-06#section-3.4 <https://tools.ietf.org/html/draft-ietf-taps-transports-usage-06#section-3.4> has more text describing UDP(-lite) than it needs, if it's just going to say "The set of Pass 1 primitives for UDP and UDP-Lite is documented in [FJ16].". 
> 
> If  this makes sense to the working group, that description of UDP could be integrated into https://tools.ietf.org/html/draft-ietf-taps-transports-usage-udp-04#section-3 <https://tools.ietf.org/html/draft-ietf-taps-transports-usage-udp-04#section-3>, which only has a one-sentence description of UDP itself before beginning its analysis.

I agreed with the authors of the other document that this is the right way forward. This text in the -usage draft consisted of 3 paragraphs, followed by the sentence that you quote above (“The set of …”). I removed these preceding three paragraphs now.

> Is there any chance that each document could provide a pointer to the other document, in the Abstract and Introduction sections, and be clearer about the relationship there?

While there was a pointer to the other document in the intro of the -usage draft already, I agree it wasn’t very clear, sorry!
I now added, to both the intro and the abstract:

"For UDP and UDP-Lite, the first step of the protocol analysis -- a discussion of relevant RFC text -- is documented in [FJ16].”

Thanks a lot for your review!

Cheers,
Michael

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 25 Aug 2017 14:09:49 -0500

Hi, Michael,

On Fri, Aug 25, 2017 at 12:47 PM, Michael Welzl <[email-masked]> wrote:

> like https://tools.ietf.org/html/draft-ietf-taps-transports-
> usage-06#section-3.4 has more text describing UDP(-lite) than it needs,
> if it's just going to say "The set of Pass 1 primitives for UDP and
> UDP-Lite is documented in [FJ16].".
>
> integrated into https://tools.ietf.org/html/draft-ietf-taps-transports-
> usage-udp-04#section-3, which only has a one-sentence description of UDP
> itself before beginning its analysis.
>
>
> I agreed with the authors of the other document that this is the right way
> forward. This text in the -usage draft consisted of 3 paragraphs, followed
> by the sentence that you quote above (“The set of …”). I removed these
> preceding three paragraphs now.
>
>
> Is there any chance that each document could provide a pointer to the
> other document, in the Abstract and Introduction sections, and be clearer
> about the relationship there?
>
>
> While there was a pointer to the other document in the intro of the -usage
> draft already, I agree it wasn’t very clear, sorry!
> "For UDP and UDP-Lite, the first step of the protocol analysis -- a
> discussion of relevant RFC text -- is documented in [FJ16].”
>

Oh, thank you! The fast path to IESG approval is to confuse the ADs as
little as possible :-)

Spencer