Subject: [Taps] I-D Action: draft-ietf-taps-minset-00.txt

From: [email-masked]
Date: Sun, 22 Oct 2017 16:43:28 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Transport Services WG of the IETF.

        Title           : A Minimal Set of Transport Services for TAPS Systems
        Authors         : Michael Welzl
                          Stein Gjessing
	Filename        : draft-ietf-taps-minset-00.txt
	Pages           : 53
	Date            : 2017-10-22

Abstract:
   This draft recommends a minimal set of IETF Transport Services
   offered by end systems supporting TAPS, and gives guidance on
   choosing among the available mechanisms and protocols.  It is based
   on the set of transport features given in the TAPS document draft-
   ietf-taps-transports-usage-08.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-taps-minset/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-taps-minset-00
https://datatracker.ietf.org/doc/html/draft-ietf-taps-minset-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Michael Welzl <[email-masked]>
Date: Mon, 23 Oct 2017 10:38:01 +0200

Hi everyone,

This update addresses 2 out of 3 major comments that we got at the last meeting:

1) also fall-back to UDP  => done.  This turned out to be much easier than I thought because the set of transport features for which TCP is a possible fall-back is, with *one* exception (receiving a message) strictly a superset of transport features for which UDP is a possible fall-back.   Sorry for the clumsy sentence but the point is, TCP itself is of course *not* strictly a superset of UDP itself, but that doesn’t matter.  Anyway, because of this superset relationship, we were able to just mark limitations that arise when requiring to fall back to UDP with (!UDP).

2) make it clearer that the abstract interface description of the min set is *not* an API proposal => done. I hope this is now clear enough for folks.

3) make it less TCP-specific, also consider fall-back to e.g. TLS => not done. Maybe next time?

Thanks for the very useful feedback, everyone who was there last time!

Also, there are now considerations on how to begin. With the minset as it was, it is possible for TAPS to choose UDP as a protocol and for the application to later request reliability. At least such deadlocks must be prevented - I’m not claiming that what we put in there is generally ideal (in fact the text explains why it isn’t), but it is one possible approach that avoids such deadlocks.

Chairs: I’d like to request a 20-minute slot for this update, if possible  (I think this should be enough including discussions, as my presentation would probably fit in about 10 minutes).

Cheers,
Michael

> On Oct 23, 2017, at 1:43 AM, [email-masked] wrote:
> 
> 
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps