Subject: Re: [Taps] One RFC, or two, for draft-ietf-taps-transports-usage and draft-ietf-taps-transports-usage-udp

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 24 Oct 2017 13:34:43 -0500

Just to make a long-delayed decision ...

Based on responses to my question to TAPS about whether
draft-ietf-taps-transports-usage-udp should be folded into
draft-ietf-taps-transports-usage, I am seeing no support in the working
group for that, and reasons why the draft-ietf-taps-transports-usage-udp
draft is useful without reference to the draft-ietf-taps-transports-usage.

For these reasons, I ask that the authors submit an updated
draft-ietf-taps-transports-usage draft, taking into account the ballot
comments from Eric, Mirja, Ben, and Benoit.

I see that the draft-ietf-taps-transports-usage-udp draft has already been
updated to reflect comments received during balloting. I'll send the
Approved e-mails for both drafts as a set.

Thanks to everyone who provided input.

Spencer, as AD

On Wed, Sep 13, 2017 at 11:47 PM, Spencer Dawkins at IETF <
[email-masked]> wrote:

> Dear TAPS working group,
>
> Multiple ADs have asked why these two drafts aren't a single draft, in
> their ballots. Those are non-blocking comments, but I'd like to explore
> that, before making a decision about what should happen, and when.
>
> It occurs to me that these ADs are reading both drafts pretty much
> back-to-back in preparation for balloting during IESG Evaluation.
>
> If people reading the two drafts back-to-back find the split to be a
> distraction, I'd like to understand the views of the working group as to
> how often you expect people to read both drafts, in order to do TAPS.
>
> I could imagine that people working on complete TAPS APIs might need to
> read both drafts.
>
> What about other folks you expect to read these documents? Do you expect
> that some communities only need to read one of them?
>
> Thanks in advance for any thoughts you can share.
>
> Spencer, as responsible AD for TAPS
>

---

From: Michael Welzl <[email-masked]>
Date: Thu, 26 Oct 2017 09:59:10 +0200

Hi,

Thanks; I just posted an update of draft-ietf-taps-transports-usage which, I believe, addresses all the last comments. From the revision info in the draft:

***
   -09: for consistency with the draft-ietf-taps-minset-00, adjusted the
   following transport features in "pass 3": "Choice between unordered
   (potentially faster) or ordered delivery of messages" divided into
   two transport features (one for unordered, one for ordered); the word
   "reliably" was added to the transport features "Hand over a message
   to reliably transfer (possibly multiple times) before connection
   establishment" and "Hand over a message to reliably transfer during
   connection establishment".  Fixed RFC2119-style language into
   explicit citations (comment by Eric Rescorla and others).  Addressed
   editorial comments by Mirja Kuehlewind, Ben Campbell, Benoit Claise
   and the Gen-ART reviewer Roni Even, except for moving terminology
   section after the intro because the terminology is already used in
   the intro text.
***

Cheers,
Michael

> On Oct 24, 2017, at 8:34 PM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Based on responses to my question to TAPS about whether draft-ietf-taps-transports-usage-udp should be folded into draft-ietf-taps-transports-usage, I am seeing no support in the working group for that, and reasons why the draft-ietf-taps-transports-usage-udp draft is useful without reference to the draft-ietf-taps-transports-usage.
> 
> For these reasons, I ask that the authors submit an updated draft-ietf-taps-transports-usage draft, taking into account the ballot comments from Eric, Mirja, Ben, and Benoit.
> 
> I see that the draft-ietf-taps-transports-usage-udp draft has already been updated to reflect comments received during balloting. I'll send the Approved e-mails for both drafts as a set.
> 
> On Wed, Sep 13, 2017 at 11:47 PM, Spencer Dawkins at IETF <[email-masked] <mailto:[email-masked]>> wrote:
> Dear TAPS working group,
> 
> Multiple ADs have asked why these two drafts aren't a single draft, in their ballots. Those are non-blocking comments, but I'd like to explore that, before making a decision about what should happen, and when.
> 
> It occurs to me that these ADs are reading both drafts pretty much back-to-back in preparation for balloting during IESG Evaluation.
> 
> If people reading the two drafts back-to-back find the split to be a distraction, I'd like to understand the views of the working group as to how often you expect people to read both drafts, in order to do TAPS.
> 
> I could imagine that people working on complete TAPS APIs might need to read both drafts. 
> 
> What about other folks you expect to read these documents? Do you expect that some communities only need to read one of them?
> 
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps