Subject: Re: iss calculation during TIME_WAIT ressurection ?

From: David Borman <[email-masked]>
Date: Fri, 5 Feb 1999 10:04:00 -0600 (CST)

> Date: Thu, 4 Feb 1999 16:22:56 -0800 (PST)
> From: Mohan Parthasarathy <[email-masked]>
> Subject: iss calculation during TIME_WAIT ressurection ?
> ...
> Looking at BSD code, it used the "rcv_nxt" field to calculate the new
> iss :
>
> 			if (tiflags & TH_SYN &&
>                             tp->t_state == TCPS_TIME_WAIT &&
>                             SEQ_GT(ti->ti_seq, tp->rcv_nxt)) {
>                                 iss = tp->rcv_nxt + TCP_ISSINCR;
>                                 tp = tcp_close(tp);
>                                 goto findpcb;
>                         }
>
> Is this a bug in the TCP code ? Should it not use snd_nxt ?

Yes.  This was fixed in the 4.4BSD code.

			-David Borman, [email-masked]

---

From: [email-masked] (vijayaraghavan_jayanth)
Date: Fri, 5 Feb 1999 12:18:12 -0800 (PST)

The FreeBSD code and the 4.4BSD-Lite do not seem to have this fix.

jayanth