Subject: Re: revised internet draft on suggested mod to the Nagle algorithm

From: der Mouse <[email-masked]>
Date: Sat, 27 Feb 1999 01:00:59 -0500 (EST)

>    The proposed modification to the Nagle algorithm does,
>    unfortunately, require one new state variable to be kept by TCP:
>    ``snd.sml'' is a TCP variable which names the last byte of data in
>    the most recently transmitted small packet.
[...]
>    The proposed Nagle algorithm modifies this as follows:
> 
> 	"If a TCP has less than a full-sized packet to transmit,
> 	and if any previously transmitted less than full-sized
> 	packet has not yet been acknowledged, do not transmit
> 	a packet."

This sounds like what I remember seeing on the list.

>    and in pseudo-code:
> 
> 	if ((packet.size < Eff.snd.MSS) && (snd.sml > snd.una)) {
> 		do not send the packet;
> 	} else {
> 		snd.sml = snd.nxt+packet.size;
> 		send the packet;
> 	}

This does not.  Shouldn't the assignment be done only
if (packet.size < Eff.snd.MSS)?

					der Mouse

			       [email-masked]
		     7D C8 61 52 5D E7 2D 39  4E F1 31 3E E8 B3 27 4B

---

From: Greg Minshall <[email-masked]>
Date: Mon, 01 Mar 1999 10:23:17 -0800

> if (packet.size < Eff.snd.MSS)?

Yes, thanks, this is the *2nd* time i've gotten this wrong!