Subject: TCP-offload on IBM mainframe

From: vijay singh <[email-masked]>
Date: Wed, 3 Mar 1999 12:01:14 -0800 (PST)

I wanted to put a question before the forum:

On an IBM mainframe, while offloading the TCP
processing on a 3172 Controller, can we control the
buffer allocation (mbufs) on the offload (not on the
TCP MVS bufferpool). I face a problem where the
offload runs out of mbufs and the server application
come down and does not come up again as it fails in
the BIND call. Or can we free some mbufs by dropping
some connections through netstat.

Vijay
E-MAIL: [email-masked]

---Vernon Schryver <[email-masked]> wrote:
>
> While it's clear there is little support for the
current proposal for
> modifying the Nagle algorithm, I think it is also
clear that there would
> be wide support for an ID that said that the Nagle
algorithm should be
> implemented according to the spirit of RFC 896.  We
seem to agree that
> the right way is to delay an application's send
request when the connection
> is not idle, but not delay any anything otherwise.
> 
> 
> Vernon Schryver    [email-masked]
> 

_________________________________________________________
DO YOU YAHOO!?
Get your free @yahoo.com address at http://mail.yahoo.com

---

From: Rick Jones <[email-masked]>
Date: Wed, 03 Mar 1999 13:45:02 -0800

> some connections through netstat.

This might be straying a triffle too far from the _impl_ part of the
list but...

On the surface it sounds more like a capacity planning failure in
specing the capacity of the offload device. If one's netstat enables the
arbitrary dropping of connections, one could do that, but probably
should not, and it would probably not be a very long-term solution
regardless - having a bind succeede implies that there will be new
connections, which would just soak-up the mbufs again. 

Besides, how do you know what TCP connections are "safe" to drop? An
existing TCP connection could be for an application that does not know
how to recover gracefully. 

So, I would say that what you propose sounds like a rather bad practice,
and that the root cause needs to be addressed - the load of TCP
connections to the mainframe is beyond the capacity of the system. 

rick jones

-- 
these opinions are mine, all mine; HP might not want them anyway... :)
feel free to email, or post, but please do not do both...
my email address is raj in the cup.hp.com domain...

---

From: Oleg Vishnepolsky <[email-masked]>
Date: Thu, 04 Mar 1999 09:30:39 -1000

> E-MAIL: [email-masked]

I am the original author of the offload code on 3172, and of the
TCP/IP stack running on 3172 (and OS/2), although I left IBM
in 1993. Yes, you can blame everything on me :-)
Anyway, to increase the number of mbufs, the TCP/IP stack code,
that sits in a device driver, has to be recompiled. You can ask IBM
to do it for you.

Oleg Vishnepolsky