Subject: Re: Nagle -- again

From: Joe Touch <[email-masked]>
Date: Thu, 24 Jun 1999 12:10:28 -0700 (PDT)

> From [email-masked] Thu Jun 24 10:45:17 1999
> Date: Thu, 24 Jun 1999 09:58:24 -0700
> From: "Eric A. Hall" <[email-masked]>
> X-Accept-Language: en
> CC: [email-masked]
> Subject: Re: Nagle -- again
> 
> 
> I also think ACK-for-every-2nd is bad, although I've thought about this
> in terms of half-duplex links where ACKs just mean the sender can't keep
> streaming data.
> 
> >  (b) I'm sure there is a clever algorithm to be found that decides
> >      when the optimal time to send an ACK is; anybody got any ideas?
> 
> My thinking: the receiver should ACK when enough data has been received
> to fill 50% of the outstanding receive window. No more, no less.

This would encourage bursts of 1/2 the window size. 
Having ACKs more frequent avoids those bursts.

Joe

---

From: "Eric A. Hall" <[email-masked]>
Date: Thu, 24 Jun 1999 12:24:17 -0700

> This would encourage bursts of 1/2 the window size.

I prefaced this in terms of half-duplex links. Half/half is better than
2/2/2/2/2/etc in terms of actual utilization.

-- 
Eric A. Hall                                            [email-masked]
+1-650-685-0557                                    http://www.ehsco.com