Subject: Re: TCP's handling of IP precedence

From: Joe Touch <[email-masked]>
Date: Wed, 15 Sep 1999 18:06:01 -0700 (PDT)

> From [email-masked]  Wed Sep 15 17:58:27 1999
> Delivery-Date: Wed, 15 Sep 1999 17:58:27 -0700
> Return-Path: [email-masked]
> Date: Wed, 15 Sep 1999 17:58:29 -0700
> From: Alan Hannan <[email-masked]>
> To: Joe Touch <[email-masked]>
> Cc: [email-masked], [email-masked]
> Subject: Re: TCP's handling of IP precedence
> 
> 
> > If this document proposes to change IP TOS and doesn't address
> > how it affects existing standards, it is _they_ who should have
> > read, understood, and addressed these problems _before_ going to
> > proposed draft.
> 
>   There's lots of good discussion going on, and I'm glad that people
>   are giving this issue the focus it deserves.
...
>   Without this functionality, QOS w/ native IP is exceedingly
>   more difficult.
...
>   I wonder about the actual meaning and interpretation of the RFC
>   given the rare implementation.

But what about the reason behind TCP's spec...

The idea behind TCP aborting the connection when
the TOS bits change is that a property of the 
connection has changed after being negotiated.

Is it the case that Diffserv:

	- intends these bits to be used for TCP connections?

	- intends that they change after a connection is established?
		or would that constitute the need for 
		a TCP extension to renegotiate?

Joe

---

From: Alan Hannan <[email-masked]>
Date: Wed, 15 Sep 1999 18:19:50 -0700

> connection has changed after being negotiated.

  I'm not sure that's entirely the case, but it sounds
  very reasonable and I don't know it NOT to be the case.

> 	- intends these bits to be used for TCP connections?

  No.

> 		a TCP extension to renegotiate?

  Kind of, but not really.

  Rather, Diffserv intends that they change while the connection is
  being established.

  Remember that what happens is that the initiator tries to setup a 
  tcp session w/ TOS=0; but en route to the receiver, a router
  changes the DS bits from the original [as specificed by the
  initiator] to something else.  The receiver then 'plays along'
  because he doesn't know any better, and the initiator doesn't get
  back what he wants, so he breaks the connection.

  Ideally, the 'initiator' would negotiate the TOS w/ the receiver,
  but this doesn't happen.

  -alan