Subject: queue limits for DSL and modems

From: Rick Jones <[email-masked]>
Date: Wed, 13 Oct 1999 12:49:08 -0700

does anyone have pointers to or data for queue limits in the downstream
(ie towards the "user") direction for DSL links and/or dial-up modems?
I'm looking for numbers to plug into a crude Streams port of dummynet.

thanks,

rick jones
-- 
these opinions are mine, all mine; HP might not want them anyway... :)
feel free to email, or post, but please do not do both...
my email address is raj in the cup.hp.com domain...

---

From: [email-masked]
Date: Thu, 14 Oct 1999 14:31:25 -0400

I don't have a definitive answer, but a while back I did some performance testing over Westell Flexcap I ADSL modems
(1.5Mbps downstream, 64Kbps upstream). On a bulk FTP download, I measured the sender's output into the downstream queue
using Etherpeek and found it to be greater than the downstream ADSL bitrate of 1.5Mbps until ACK clocking eventually
throttled it back. During that initial period, the excess data sitting in the downstream queue built up to as much as
19,300 bytes (derived from a simple calculation: measured arrival rate minus the known service rate of 1.5Mbps). Since
no packets were dropped, I concluded that the queue is at least that deep. Incidentally, by doing measurements on the
receiver side instead, I found the _upstream_ queue to be at least 2000 bytes deep.

I don't know how representative this is of current ADSL modems, and I don't know how this compares to dialup modems,
except that my impression (from conversations with Tim Shepard when he was working on this) is that they have far less
buffer space than this Westell modem.

All very anecdotal, but I hope it helps...

= Peter
------------------------------------
Peter Warren
Principal Member of Technical Staff
GTE Laboratories
40 Sylvan Rd.
Waltham, MA 02451
------------------------------------

>-----Original Message-----
>From: [email-masked]
>[mailto:[email-masked]]On Behalf Of Rick Jones
>Sent: Wednesday, October 13, 1999 3:49 PM
>To: [email-masked]
>Subject: queue limits for DSL and modems
>
>