Subject: Why do large downloads fail ?

From: "R. S. Arkesh Kumar" <[email-masked]>
Date: Wed, 20 Oct 1999 04:56:22 -0700 (PDT)

Hi
    Why is it that we encounter problems of
connections breaking off when downloading large files.

Thanks in advance,
Arkesh

=====
R. S. Arkesh Kumar	
Research Engineer,
Centre for Development of Telematics(C-DOT),
71/1, Miller Road,
Bangalore-560 052, India.
Ph : 91-80-2263399 Ext:329
Fax : 91-80-2263256
__________________________________________________
Do You Yahoo!?
Bid and sell for free at http://auctions.yahoo.com

---

From: Lixia Zhang <[email-masked]>
Date: Wed, 20 Oct 1999 07:02:21 -0700

>connections breaking off when downloading large files.

I am not saying the fact below would be the cause, but I was a little
surprised to hear Lan Wang (a UCLA student) mentioned the other day that,
in freeBSD, TCP keeps a retransmission counter, whick gets reset to 0 only
when cwnd >= rwnd, otherwise the couner cumulates the number of
retransmissions, and causes the connection to reset when the value exceeds
a threshold (12 or 16?) 

I did not check myself, but if this is true I hardly believe this would be
a desired thing. if a receiver accidentally sets a big rwnd value, then
over a narrow communication pipe
- cwnd would always try to creep up to reach rwnd, and ends 
  in packet losses and cut back every time
- cwnd would never reach rwnd, thus all the rxt's get cumulated
  over time (and one gets a reset)

Lixia

---

From: "B. Scott Michel" <[email-masked]>
Date: Wed, 20 Oct 1999 10:55:07 -0700 (PDT)

>   over time (and one gets a reset)

This could happen as a matter of course if one sets up one's box to
exploit LFN (which FreeBSD does). All one has to do is set the default
TCP send and receive buffer spaces to a value greater than 65536.

Hopefully, this is not what's happening to Arkesh.

-scooter

---

From: "Kaushik Sridharan" <[email-masked]>
Date: Fri, 22 Oct 1999 13:21:18 +0530

I wonder if it is simply an increased probability that the connection 
times-out. The communication infrastructure here in India isn't 
exactly the best in the world...yet!

Kaushik
--
Kaushik Sridharan
Ruksun Software Technologies
Pune, India
http://www.ruksun.com

---

From: Arivu Mani <[email-masked]>
Date: Fri, 22 Oct 1999 08:44:20 -0700 (MST)

I have experienced the same problem here while downloading with Windows
NT. Start downloading a 3MB file using ftp.exe and it would time out.
While the same file is easily downloaded with Solaris.

-Mani.

On Fri, 22 Oct 1999, Kaushik Sridharan wrote:

*>  I wonder if it is simply an increased probability that the connection 
*>  times-out. The communication infrastructure here in India isn't 
*>  exactly the best in the world...yet!
*>  
*>  Kaushik
*>  --
*>  Kaushik Sridharan
*>  Ruksun Software Technologies
*>  Pune, India
*>  http://www.ruksun.com
*>  
*>  
*>  ----- Original Message -----
*>  > Hi
*>  >     Why is it that we encounter problems of
*>  > connections breaking off when downloading large files.
*>  >
*>  > Thanks in advance,
*>  > Arkesh
*>  >
*>  >
*>  > =====
*>  > R. S. Arkesh Kumar
*>  > Research Engineer,
*>  > Centre for Development of Telematics(C-DOT),
*>  > 71/1, Miller Road,
*>  > Bangalore-560 052, India.
*>  > Ph : 91-80-2263399 Ext:329
*>  > Fax : 91-80-2263256
*>  > __________________________________________________
*>  > Do You Yahoo!?
*>  > Bid and sell for free at http://auctions.yahoo.com
*>  
*>  
*>  

------------------------------------------------------------------
"Small opportunities are often the beginnings of great enterprises."
							-Demosthenes

Arivu Mani Ramasamy,
Graduate Student, ECE dept,
The University of Arizona.
(520) 903-9575
http://www.u.arizona.edu/~arivu