Subject: RE: Why do large downloads fail ?

From: Rahul Kasralikar <[email-masked]>
Date: Fri, 22 Oct 1999 11:22:23 -0700

I'm not sure whether there exists such a relation betn. large-download-
failure and communication-infrastructure-unreliability. IP works well
even with unreliable media. Also, if the media is so bad, then even the
small downloads (and other TCP apps) would fail.. Won't they?

Rahul Kasralikar

> -----Original Message-----
> From: Kaushik Sridharan [mailto:[email-masked]]
> Sent: Friday, October 22, 1999 12:51 AM
> To: R. S. Arkesh Kumar; [email-masked]
> Cc: [email-masked]
> Subject: Re: Why do large downloads fail ?
> 
> 
> I wonder if it is simply an increased probability that the connection 
> times-out. The communication infrastructure here in India isn't 
> exactly the best in the world...yet!
> 
> Kaushik
> --
> Kaushik Sridharan
> Ruksun Software Technologies
> Pune, India
> http://www.ruksun.com
> 
> 
> ----- Original Message -----
> > Hi
> >     Why is it that we encounter problems of
> > connections breaking off when downloading large files.
> >
> > Thanks in advance,
> > Arkesh
> >
> >
> > =====
> > R. S. Arkesh Kumar
> > Research Engineer,
> > Centre for Development of Telematics(C-DOT),
> > 71/1, Miller Road,
> > Bangalore-560 052, India.
> > Ph : 91-80-2263399 Ext:329
> > Fax : 91-80-2263256
> > __________________________________________________
> > Do You Yahoo!?
> > Bid and sell for free at http://auctions.yahoo.com
> 
>

---

From: Craig Partridge <[email-masked]>
Date: Fri, 22 Oct 1999 11:41:00 -0700

In message <[email-masked]>, Rahul 

>small downloads (and other TCP apps) would fail.. Won't they?

The probability of success is directly related to size of download.

TCP retransmits a finite number of times, T.  Assuming an error rate E,
the chance of a transfer failing due to unreliable link is approximately
(E**T)N, where N is the number of distinct datagrams to be transmitted.

So for a 10% loss rate with 7 retransmissions, a 5MB sent as 512 byte
datagrams has about a 0.1% chance of failing.

Note that this assumes uncorrelated errors -- in fact they are correlated
in most cases, so the odds of a failure given the initial transmission
failed are higher.  For instance, if the error rate is 10% on average
transmission but 30% on retransmits, you get a 70% chance of failure.

Craig (hoping he's done his quick calculations right:)