Subject: [tcpm] FW: Last Byte Send calculation

From: "Ehsan Hamadani" <[email-masked]>
Date: Tue, 30 Mar 2004 18:22:25 +0100

Dear all,
 
I have the following simple question; however I could not find the
answer in RFC's congestion control document.
 
In the congestion control algorithm, when TCP invokes fast retransmit
and sends the lost segment, which value does the TCP use for "last
segment send" in calculating "effective window"?
For instance, the segment that has been sent before fast retransmits was
20. Now because of receipt of 3 duplicate ACKs for segment 10, sender
retransmit segment 10 and set CWND to 1.
In this case, when another duplicate ACK for segment 10 arrives, and TCP
wants to calculate EffectiveWindow = CWND - (LastByteSent -
LastByteReceived) what is the value for LastByteSent??
Is it 10 or 20??
 
Thanks for your consideration.
 
Regards,
 
Ehsan

---

From: Janardhan Iyengar <[email-masked]>
Date: Tue, 30 Mar 2004 12:42:20 -0500 (EST)

Hi Ehsan,

> retransmit segment 10 and set CWND to 1.

If you are using RFC 2581, the cwnd will be set to flightsize/2 after a
fast retransmit, not to 1.

> LastByteReceived) what is the value for LastByteSent??

LastByteSent should really be HighestByteSent, and LastByteReceived should
be HighestByteReceived (assuming no SACKs). That makes the answer 20.

regards,
jana

---------------------------------------------------------------
         Visit www.narmada.org, www.indiatogether.org
---------------------------------------------------------------

_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm