Subject: Re: [tcpm] encouraging wider participation

From: Stephen Hemminger <[email-masked]>
Date: Wed, 3 Jan 2007 16:53:43 -0800

On Mon, 27 Nov 2006 13:27:24 -0800
Ted Faber <[email-masked]> wrote:

> On Mon, Nov 27, 2006 at 02:31:52AM -0300, Fernando Gont wrote:
> > At 20:56 22/11/2006, Duke, Martin wrote:
> > 
> > >If IETF would like to coordinate more with Linux, is the right move to
> > >send IETF reps to the next Linux meeting, to tell them what we're
> > >working on and how it might be useful to them?
> > 
> > I'd argue that, if anything, somebody from each major open source OS 
> > should be sent to the IETF meetings. That way, they could share their 
> > implementation/real-world experience in the meetings.
> 
> Make it so.
> 
> (See the problem?)
> 

Several core networking developers already go to IETF meetings.
Jamal Hadi Salam who worked on Traffic Control, and Yoshifuji from Linux IPV6
project attends as well.

-- 
Stephen Hemminger <[email-masked]>

_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm

---

From: Ted Faber <[email-masked]>
Date: Thu, 4 Jan 2007 14:41:03 -0800

> Jamal Hadi Salam who worked on Traffic Control, and Yoshifuji from Linux IPV6

I believe that OS network implementors attend.  I intended to point out
that *compelling* that participation is problematic at best.  It's the
"should be sent" that's hard to make so. :-)

-- 
Ted Faber
http://www.isi.edu/~faber           PGP: http://www.isi.edu/~faber/pubkeys.asc
Unexpected attachment on this mail? See http://www.isi.edu/~faber/FAQ.html#SIG
_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm

---

From: Fernando Gont <[email-masked]>
Date: Thu, 04 Jan 2007 23:31:12 -0300

>"should be sent" that's hard to make so. :-)

IMHO, the main reason for which many implementers don't come to (or 
actively participate in) the IETF is because participation usually 
leads into electro-political discussions.

I have seen many instances in which pretty straightforward stuff 
leads to endless discussions.
A current thread in the IETF list is one example. Discussions we have 
had here during the last couple of years is just another.
So it's really hard to come to the IETF, and at the same time be 
productive for the OS in which you work on.

And, when you read claims that "if you implement X, and it's not in 
the RFCs, it's a bug", you get even more reasons for doing the above.

Kindest regards,

--
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1