Subject: Re: [tcpm] [Tsvwg] API related DISCUSS for draft-ietf-tcpm-tcp-uto

From: Lars Eggert <[email-masked]>
Date: Fri, 23 Jan 2009 10:36:37 +0200

_______________________________________________
tcpm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tcpm

---

From: Joe Touch <[email-masked]>
Date: Thu, 29 Jan 2009 16:19:12 -0800

Chris Newman wrote:
> I absolutely agree with your position except the statement about the
> IETF refraining from APIs (we have done APIs such as getaddrinfo,
> advanced sockets, LDAP C API, GSSAPI, etc).  If you read my discuss
> position, I am not asking for inclusion of the API in this spec, but I
> am asking for the specification to be revised to either:
> 
> * Make it clear the intention is to have communication of this
> information between
>  application protocol implementations and the TCP stack.

IMO, this is OK since it's in the spirit of explaining the impact to the
TCP API, as specified in RFC793.

Joe