Subject: [tcpm] Fwd: New Version Notification for draft-lebovitz-ietf-tcpm-tcp-ao-crypto-01

From: "Gregory M. Lebovitz" <[email-masked]>
Date: Sat, 11 Jul 2009 23:56:32 -0700

Folks,
I just submitted the update for this document. Please have a quick 
review and provide feedback to me, cc'ing the [email-masked] list.

Wes and David B - the draft is posted, so you can link it in the WG agenda now.

Hope it helps,
Gregory.

>Delivered-To: [email-masked]
>Authentication-Results: mx.google.com; spf=neutral (google.com: 
>64.170.98.32 is neither permitted nor denied by best guess record 
>for domain of [email-masked]) smtp.mail=[email-masked]
>From: IETF I-D Submission Tool <[email-masked]>
>To: [email-masked]
>Subject: New Version Notification for
>          draft-lebovitz-ietf-tcpm-tcp-ao-crypto-01
>Date: Sat, 11 Jul 2009 23:48:20 -0700 (PDT)
>
>
>A new version of I-D, draft-lebovitz-ietf-tcpm-tcp-ao-crypto-01.txt 
>has been successfuly submitted by Gregory Lebovitz and posted to the 
>IETF repository.
>
>Filename:       draft-lebovitz-ietf-tcpm-tcp-ao-crypto
>Revision:       01
>Title:          Cryptographic Algorithms, Use, & Implementation 
>Requirments for TCP Authentication Option
>Creation_date:  2009-07-11
>WG ID:          Independent Submission
>Number_of_pages: 16
>
>Abstract:
>The TCP Authentication Option, TCP-AO, relies on security algorithms
>to provide authentication between two end-points.  There are many
>such algorithms available, and two TCP-AO systems cannot interoperate
>unless they are using the same algorithm(s).  This document specifies
>the algorithms and attributes that can be used in TCP-AO's current
>manual keying mechanism.
> 
>
>
>
>The IETF Secretariat.

+++++++++++++++++++++++
IETF-related email from
Gregory M. Lebovitz
Juniper Networks
g r e go r  y d o t  i e tf a t  g m a i l  do t c o  m

---

From: Joe Touch <[email-masked]>
Date: Sun, 12 Jul 2009 08:35:34 -0700

Gregory,

The document needs to be updated to align with AO-05 as follows:

	- remove the reference to the TAPD; use Master Key Tuple (MKT)
	instead

	- check spelling (TPC vs TCP)

	- AO uses the term data_block, not conn_block, for KDF input
	(conn_block could refer to the TCB from RFC 793,
	so I avoided that term)

	- the output of the PRF should be called the traffic key,
	not the connection key; similarly for the input to the MAC alg
		if a shorter term is needed in this doc, it
		needs to be defined in this doc (e.g., traff_key),
		because TCP-AO-05 doesn't define any notation
		other than "traffic key"

	- check formatting, esp. the line starting "where FR is always"

	- the tips for UI are useful, but 'tips' aren't a specification,
	so SHOULDs need to be removed

Joe

Gregory M. Lebovitz wrote:
>> 64.170.98.32 is neither permitted nor denied by best guess record for
>> domain of [email-masked]) smtp.mail=[email-masked]