Subject: [tcpm] WG status update

From: "Eddy, Wesley M. (GRC-MS00)[Verizon]" <[email-masked]>
Date: Tue, 18 Aug 2009 10:41:08 -0500

Since TCPM has a healthy plateful of items we're tracking and
either trying to wrap-up or trying to start-up, David and I
thought it would be a good idea to periodically send the list
a snapshot of the work items and actions needed as we see them.
The first such, is below.  If there are items not on the list
that you know of, please notify us :).

WG Items
========

TCP Authentication Option
http://www.ietf.org/id/draft-ietf-tcpm-tcp-auth-opt-05.txt
Milestone Target: Proposed Standard in April 2009
Action: Needs update parallel to AO-Crypto draft and then WGLC

TCP Authentication Option Crypto
http://www.ietf.org/internet-drafts/draft-lebovitz-ietf-tcpm-tcp-ao-crypto-02.txt
Milestone Target: Same as AO?  Need to clarify.
Action: Needs update parallel to AO draft and then WGLC

ICMP Attacks
http://www.ietf.org/id/draft-ietf-tcpm-icmp-attacks-05.txt
Milestone Target: Informational in July 2009
Action: Needs update and then WGLC

Early-Retransmit
http://tools.ietf.org/wg/tcpm/draft-ietf-tcpm-early-rexmt/
Milestone Target: Experimental in July 2009
Action: WGLC is finished; check if authors intend to update ... then send to IESG

1323bis
http://www.ietf.org/id/draft-ietf-tcpm-1323bis-01.txt
Milestone Target: Proposed Standard in July 2009
Action: Revise & WGLC

MSS Option
http://www.ietf.org/id/draft-ietf-tcpm-tcpmss-02.txt
Milestone Target: Proposed Standard in July 2009
Action: Needs WGLC

Urgent Pointer
http://www.ietf.org/id/draft-ietf-tcpm-urgent-data-00.txt
Milestone Target: Proposed Standard in January 2010
Action: Continue WG reviews

TCP Security
(Fernando will submit -00 I-D outline)
Milestone Target: need to submit for charter page - BCP in August 2010
Action: Fernando will be editor; WG needs to begin vetting and helping
revise into prescriptive format for BCP

Other Proposals
===============

Persist
http://tools.ietf.org/id/draft-ananth-tcpm-persist-01.txt
Action: WG Review

Timestamps
http://tools.ietf.org/id/draft-gont-tcpm-tcp-timestamps-01.txt
Action: ???

Parameter Tuning
(no I-D yet)
Action: continue good discussion on mailing list
Presentation given in Stockholm

Long Connectivity Disruptions
http://www.ietf.org/internet-drafts/draft-zimmermann-tcp-lcd-01.txt
Action: need WG to read/discuss
2x presentations (SFO and Stockholm) have been given

SACK Entry
http://tools.ietf.org/html/draft-jarvinen-tcpm-sack-recovery-entry-00
Action: need WG to read/discuss
presentation in Stockholm given

TCP Option for Transparent Middlebox Discovery
http://www.ietf.org/internet-drafts/draft-knutsen-tcpm-middlebox-discovery-00.txt
Action: Needs WG review / discussion

---------------------------
Wes Eddy
Network & Systems Architect
Verizon FNS / NASA GRC
Office: (216) 433-6682
---------------------------

---

From: Alexander Zimmermann <[email-masked]>
Date: Thu, 20 Aug 2009 11:48:02 +0200

Hi Wes,

two short comments:

1. What is about "draft-nishida-newreno-modification-01"? I think
we should add his draft too.

2. Minor correction :-): The draft "SACK Entry" was not only presented  
in
Stockholm but also in SFO by M. Kojo.

Alex

Am 18.08.2009 um 17:41 schrieb Eddy, Wesley M. (GRC-MS00)[Verizon]:

> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

//
// Dipl.-Inform. Alexander Zimmermann
// Department of Computer Science, Informatik 4
// RWTH Aachen University
// Ahornstr. 55, 52056 Aachen, Germany
// phone: (49-241) 80-21422, fax: (49-241) 80-22220
// email: [email-masked]
// web: http://www.umic-mesh.net
//

---

From: Fernando Gont <[email-masked]>
Date: Thu, 20 Aug 2009 07:29:47 -0300

> http://tools.ietf.org/id/draft-gont-tcpm-tcp-timestamps-01.txt

This document could possibly become a BCP.

I recall we talked with David Borman a little bit about this one in
MPLS, and I seem to recall that this one of the possible outcomes. I
also seem to recall that David was thinking about tweaking rfc1323 in
response to this I-D (e.g., recommend timestamps to be monotonically
increasing across connections).

David? (CC'ed)

Thanks!

Kind regards,
-- 
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1

---

From: Mark Allman <[email-masked]>
Date: Wed, 26 Aug 2009 09:59:05 -0400

> Action: WGLC is finished; check if authors intend to update ... then

We have received two reviews (from Zimmerman & Touch) and intend to rev
the document based on those reviews.  (Right now this is on my docket
for late next week, but that's far enough out that Things Could Change.)

allman