Subject: [tcpm] Additional feedback on draft-gont-tcpm-tcp-seq-validation-00

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Thu, 14 Mar 2013 18:57:02 +0100

Dear all,

In the TCPM meeting, there has been some interest in draft-gont-tcpm-tcp-seq-validation-00, which documents issues of RFC 793 with TCP simultaneous open, TCP self connects, TCP simultaneous close, and Simultaneous Window Probes.

However, the chairs have the impression that some TCPM contributors left the room for the parallel irtfopen session, and therefore the feedback from the room might not be representative. We therefore would like to ask for additional feedback on this draft on the mailing list.

Specifically, we are interested in feedback on the following two questions, given that at least a subset of the issues is already known for some time:

(1) Whether the problems described in the draft are relevant and should be addressed by a new milestone in the TCPM charter.

(2) If the updates to RFC 793 suggested in draft-gont-tcpm-tcp-seq-validation-00 are the right way to address the problems, or if there are other known solutions (possibly implemented already).

Any feedback would be very welcome!

Michael

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Thu, 14 Mar 2013 20:38:44 +0000

Hi,

As mentioned on the microphone, I think this draft is valuable and basically addresses an documentation bug/errata (Errata ID: 3305, reported in 2012 by Botong Huang, but preceeded by the IETF73 mentioned in the Acknowledgements).

However, I suggest to remove the verbatim quotation of RFC793; I observe that the formatting allows a "swap" of the two relevant pages of RFC793 with the fixed mechanism. I don't know if a document, that is to stand on its own needs to adhere that strictly to the original wording and structure.

Also, as an implementer I would want the "meat" sooner, and the detailed description what the problem is and how the change solves it, later (swap sections 3 and 4, basically).

There was some question, if other points that go into TCP window validation should be mentioned in this document. I think it would be beneficial to have everything relevant in that area in one complete document, rather than spread across a few documents.

In general, I like efforts that document the current implemented TCP stack behavior, fix documentation errata/bugs or speak about deployed and useful mechanisms, that haven't been documented in the IETF so far.

I have a draft sitting around, to describe TCP SACK Lost Retransmission Detection (LRD), as performed by Linux TCP since that stack supports SACK. Interestingly, there are also some research papers independent from Linux, discussing the properties of an optimal SACK stack that recovers lost retransmissions, and matches the runtime behavior of Linux. If there are a few reviewers for this draft, I would like to share that draft before bringing it to the WG for formal processing.

Any takers?

Best regards,

Richard Scheffenegger

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Scharf, Michael (Michael)
> Sent: Donnerstag, 14. März 2013 18:57
> To: [email-masked]
> Subject: [tcpm] Additional feedback on draft-gont-tcpm-tcp-seq-validation-
> 00
> 
> Dear all,
> 
> In the TCPM meeting, there has been some interest in draft-gont-tcpm-tcp-
> seq-validation-00, which documents issues of RFC 793 with TCP simultaneous
> open, TCP self connects, TCP simultaneous close, and Simultaneous Window
> Probes.
> 
> However, the chairs have the impression that some TCPM contributors left
> the room for the parallel irtfopen session, and therefore the feedback
> from the room might not be representative. We therefore would like to ask
> for additional feedback on this draft on the mailing list.
> 
> Specifically, we are interested in feedback on the following two
> questions, given that at least a subset of the issues is already known for
> some time:
> 
> (1) Whether the problems described in the draft are relevant and should be
> addressed by a new milestone in the TCPM charter.
> 
> (2) If the updates to RFC 793 suggested in draft-gont-tcpm-tcp-seq-
> validation-00 are the right way to address the problems, or if there are
> other known solutions (possibly implemented already).
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm