Subject: Re: [tcpm] "Fujitsu Develops New Data Transfer Protocol Enabling Improved Transmissions Speeds"

From: Anantha Ramaiah <[email-masked]>
Date: Sat, 9 Mar 2013 20:20:54 -0800

<Jumping in late>

>
> Congestion control is needed when sharing, but when you own and run a
> dedicated private link you can simplify and engineer for throughput. Using
> Internet technology doesn't mean you're on the shared Internet.
>
>
I share the same thought as above. I believe one could tune TCP based on
where you want to run it, but if we go one step further by standardizing
this  as a general purpose solution,  it becomes hard and needs support,
take for example quick start, it is a good RFC, but needs support from the
middle boxes in the path.  Let alone ECN etc.,

-Anantha

---

From: Anthony Sabatini <[email-masked]>
Date: Mon, 11 Mar 2013 11:13:38 -0400

All -

Two points.

First, by delaying the return of the received token in either TDLC or my changes to TCP you can control the link at quite a fine level.

But more importantly second. in TDLC we used an actively managed system where the transmitter was allocated a certain number of credits and then used them up as they transmitted.  The number of credits a message used was 1 plus the message length divided by the link speed constant (256 for slow links in TDLC, 512 for high speed links).  Credits were refreshed based on a certain number of credits per time period (where time period was normally a second).  Both the remote end and intermediate nodes (routers in non TDLC parlance) could set the refresh rate, allowing overall link congestion control.

What is most important here is the external control of congestion did not have unintended side effects that manipulating the link control does and unlike manipulating link control a credit based system does not cause "whipsaw" effects on the underlying protocol since the refresh rate provides a smoothing function.

Tony

Anthony Sabatini
200 West 20th Street
Apt. 1216
New York, NY 10011

Phone: (212) 867-7179
Mobile: (917) 224-8388

Date: Sat, 9 Mar 2013 20:20:54 -0800
Subject: Re: [tcpm] "Fujitsu Develops New Data Transfer Protocol Enabling Improved Transmissions Speeds"
From: [email-masked]
To: [email-masked]
CC: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]

<Jumping in late>

Congestion control is needed when sharing, but when you own and run a dedicated private link you can simplify and engineer for throughput. Using Internet technology doesn't mean you're on the shared Internet.

I share the same thought as above. I believe one could tune TCP based on where you want to run it, but if we go one step further by standardizing this  as a general purpose solution,  it becomes hard and needs support, take for example quick start, it is a good RFC, but needs support from the middle boxes in the path.  Let alone ECN etc.,  

-Anantha