Subject: [tcpm] Document Action: 'Proportional Rate Reduction for TCP' to Experimental RFC (draft-ietf-tcpm-proportional-rate-reduction-04.txt)

From: The IESG <[email-masked]>
Date: Sun, 10 Mar 2013 12:47:48 -0700

The IESG has approved the following document:
- 'Proportional Rate Reduction for TCP'
  (draft-ietf-tcpm-proportional-rate-reduction-04.txt) as Experimental
RFC

This document is the product of the TCP Maintenance and Minor Extensions
Working Group.

The IESG contact persons are Wesley Eddy and Martin Stiemerling.

A URL of this Internet Draft is:
http://datatracker.ietf.org/doc/draft-ietf-tcpm-proportional-rate-reduction/

Technical Summary

This document describes an algorithm to improve the accuracy
of the amount of data sent by TCP during loss recovery. The
existing TCP recovery algorithms can make excess window
adjustments in some situations, such as in the presence of
heavy losses, and may result in abrupt TCP behavior in the
form of packet bursts or increased risk of
timeouts. Proportional Rate Reduction aims to minimize the
needed window adjustments, to result in more stable TCP
congestion control behavior in the presence of losses. 

Working Group Summary

The document was adopted as Experimental TCPM working group
item by clear working group consensus, and no opinions against
it have been raised during its progress or in the working
group last call. 

Document Quality

The algorithm specified in the document has been implemented
in Linux and integrated to the main kernel distribution. The
algorithm has also been evaluated through measurements, and
the evaluation results reported in a paper published in the
IMC'11 conference. Different versions of the document have
been thoroughly reviewed by TCPM working group members. 

Personnel

Document Shepherd is Pasi Sarolahti <[email-masked]>.
Responsible Area Director is Wesley Eddy <[email-masked]>. 

RFC Editor Note

(1)
Please change the Abstract to:

   This document describes an experimental Proportional Rate Reduction
   (PPR) algorithm as an alternative to the widely deployed Fast Recovery
   and Rate Halving algorithms.  These algorithms determine the amount
   of data sent by TCP during loss recovery.  PRR minimizes excess
   window adjustments and the actual window size at the end of recovery
   will be as close as possible to the ssthresh determined by the congestion control algorithm.

(2)
Please change all occurrences of "PPR" to "PRR".

(3)
Please change all occurrences of "PRR+SSRB" to "PRR-SSRB"
and all occurrences of "PRR+CRB" to "PRR-CRB"

(4)
On Page 3, please change:
"slight difference" to
"slight differences"
and
"discussions algorithms" to
"discussions of algorithms"
and
"of RFC 3517 we are" to
"of RFC 3517, we are"

(5)
On Page 11, please change:
"Bound in very" to
"Bound is very"

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Mon, 11 Mar 2013 11:28:10 +0000

Hi,

One late additional nit:

Page 11, at the top:

If the
   transmissions are regulated directly by pipe as they are with RFC
   6675, such as step discontinuity in the pipe estimator causes a burst
   of data, which can not be retracted once the pipe estimator is
   corrected a few ACKs later.

Shouldn't the "as" be a "a" in this sentence? Or "such as a"?

Richard Scheffenegger

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> The IESG
> Sent: Sonntag, 10. März 2013 20:48
> To: IETF-Announce
> Cc: tcpm chair; tcpm mailing list; RFC Editor
> Subject: [tcpm] Document Action: 'Proportional Rate Reduction for TCP' to
> Experimental RFC (draft-ietf-tcpm-proportional-rate-reduction-04.txt)
> 
>   (draft-ietf-tcpm-proportional-rate-reduction-04.txt) as Experimental RFC
> 
> This document describes an algorithm to improve the accuracy of the amount
> of data sent by TCP during loss recovery. The existing TCP recovery
> algorithms can make excess window adjustments in some situations, such as
> in the presence of heavy losses, and may result in abrupt TCP behavior in
> the form of packet bursts or increased risk of timeouts. Proportional Rate
> Reduction aims to minimize the needed window adjustments, to result in
> more stable TCP congestion control behavior in the presence of losses.
> 
> Working Group Summary
> 
> The document was adopted as Experimental TCPM working group item by clear
> working group consensus, and no opinions against it have been raised
> during its progress or in the working group last call.
> 
> Document Quality
> 
> The algorithm specified in the document has been implemented in Linux and
> integrated to the main kernel distribution. The algorithm has also been
> evaluated through measurements, and the evaluation results reported in a
> paper published in the
> IMC'11 conference. Different versions of the document have been thoroughly
> reviewed by TCPM working group members.
> 
> Personnel
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm