Subject: Re: [tcpm] TCP Tail Loss Probe

From: Martin Winbjörk <[email-masked]>
Date: Mon, 3 Mar 2014 07:36:07 +0000

Hi

Thank you for the answer

Regards
Martin Winbjörk

-----Original Message-----
From: Yuchung Cheng [mailto:[email-masked]] 
Sent: den 28 februari 2014 19:35
To: Martin Winbjörk
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Ingemar Johansson S
Subject: Re: TCP Tail Loss Probe

On Fri, Feb 28, 2014 at 6:25 AM, Martin Winbjörk <[email-masked]> wrote:
> Hi
>
>
>
> I have a question regarding the draft for Tail Loss Probe found on the 
> following link
>
> http://tools.ietf.org/html/draft-dukkipati-tcpm-tcp-loss-probe-01
>
>
>
> What is the status of the draft? It has expired on August 29 2013. Is 
> it still relevant and updated or has it been abandoned or continued elsewhere?
Hi Martin,

The feedback on tcpm after several meetings was although it is solving an important problem, 1) it is fairly complicated and 2) it relies on FACK which is not standardized.

Therefore I and the other co-authors are working on a simpler solution with much wider scope: a new framework to encompass a dozen of heuristics developed in the last two decades: RFC3517, FACK, TLP, F-RTO, traditional RTO, lost retransmit, dynamic dupthresh for reordering, early retransmit etc. The underlying idea is to replace packet counter notion (e.g. 3 dupacks) with time. Allow fast timeout & recovery if network is still responsive, and only reset cwnd to 1 under extended silence. I was originally going to talk about this idea in this tcpm but have to cancel the trip  in the last minute.

Anyways, we are hopeful to come up a newer draft that subsumes TLP (and many other heuristics) and an implementation all together latter this year.

> Regards
> Martin Winbjörk

---

From: Martin Winbjörk <[email-masked]>
Date: Mon, 3 Mar 2014 07:36:26 +0000

Hi

Thank you for the answer

Regards

Martin Winbjörk

From: Scheffenegger, Richard [mailto:[email-masked]]
Sent: den 28 februari 2014 19:05
To: Martin Winbjörk; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: Ingemar Johansson S
Subject: RE: TCP Tail Loss Probe

Hi Martin,

I hope that work hasn't been abandoned.

For one, I would like this work being formally adopted as a TCPM item and discussed, as this mechanism would address some of the problems that I wanted addressed, which can be summarized as TCP HOL blocking latency.

Now that 1323bis is asymptotically nearing publication, I also want to revive some work that got me started with Timestamps. That work was also related to loss-related latency in TCP, but dealing with lost retransmissions (and the non-ambiguous detection that a retransmission was lost).

If time permits, I want to give a short overview of that work, even though the current (expired) drafts don't include things learned during the discussions of 1323bis:

http://tools.ietf.org/html/draft-scheffenegger-tcpm-timestamp-negotiation-05
http://tools.ietf.org/html/draft-trammell-tcpm-timestamp-interval-01

And ideally also the way Linux currently recovers from lost retransmissions (even though the scheme making use of a modified TS sematic does not incur unnecessary latency, or fails at the end-of-stream).

Best regards,

Richard Scheffenegger

From: tcpm [mailto:[email-masked]] On Behalf Of Martin Winbjörk
Sent: Freitag, 28. Februar 2014 15:26
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Ingemar Johansson S
Subject: [tcpm] TCP Tail Loss Probe

Hi

I have a question regarding the draft for Tail Loss Probe found on the following link
http://tools.ietf.org/html/draft-dukkipati-tcpm-tcp-loss-probe-01

What is the status of the draft? It has expired on August 29 2013. Is it still relevant and updated or has it been abandoned or continued elsewhere?

Regards
Martin Winbjörk

---

From: Ingemar Johansson S <[email-masked]>
Date: Wed, 5 Mar 2014 07:40:44 +0000

Thanks all for the prompt response. 

Short followup question, does the latest draft reflect the Linux TCP implementation or are there later changes done in the Linux code ?.
Martin is doing a master thesis (I am one of the supervisors). The objective is to implement new suggested additions to TCP in our Java based LTE system simulator  and study the impact on performance in various simulated traffic cases. He recently studied CWV and now the time has come to look closer at TLP, and even though the draft is exprired, it is still of interest as it is enabled by default in the Linux TCP stack.

/Ingemar

> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; Ingemar Johansson S
> The feedback on tcpm after several meetings was although it is solving an
> important problem, 1) it is fairly complicated and 2) it relies on FACK which is
> not standardized.
> 
> Therefore I and the other co-authors are working on a simpler solution with
> much wider scope: a new framework to encompass a dozen of heuristics
> developed in the last two decades: RFC3517, FACK, TLP, F-RTO, traditional
> RTO, lost retransmit, dynamic dupthresh for reordering, early retransmit etc.
> The underlying idea is to replace packet counter notion (e.g. 3 dupacks) with
> time. Allow fast timeout & recovery if network is still responsive, and only
> reset cwnd to 1 under extended silence. I was originally going to talk about
> this idea in this tcpm but have to cancel the trip  in the last minute.
> 
> Anyways, we are hopeful to come up a newer draft that subsumes TLP (and
> many other heuristics) and an implementation all together latter this year.
> 
> 
> >
> >
> >
> > Regards
> >
> > Martin Winbjörk

---

From: Nandita Dukkipati <[email-masked]>
Date: Wed, 5 Mar 2014 23:57:12 -0800

Hi Ingemar,

AFAIR the code does follow the draft closely. The draft allows for one or
two probes per tail loss episode - the implementation just sends one probe
before yielding to an RTO. You can quickly double check from these two
commits here-

Basic TLP algorithm (Section 2 of draft)
Commit:
http:///git/linux/kernel/cgit/torvalds/linux.git/commit/?id=6ba8a3b19e764b6a65e4030ab0999be50c291e6c<http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=6ba8a3b19e764b6a65e4030ab0999be50c291e6c>

Detecting recovered losses in TLP (Section 3 of draft)
Commit:
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9b717a8d245075ffb8e95a2dfb4ee97ce4747457

There have been a couple of bug fixes thereafter but it doesn't change the
basic algorithm.

Nandita

On Tue, Mar 4, 2014 at 11:40 PM, Ingemar Johansson S <
[email-masked]> wrote:
> Short followup question, does the latest draft reflect the Linux TCP
implementation or are there later changes done in the Linux code ?.
> Martin is doing a master thesis (I am one of the supervisors). The
objective is to implement new suggested additions to TCP in our Java based
LTE system simulator  and study the impact on performance in various
simulated traffic cases. He recently studied CWV and now the time has come
to look closer at TLP, and even though the draft is exprired, it is still
of interest as it is enabled by default in the Linux TCP stack.