Subject: [tcpm] thoughts on RTO restart and TSO

From: Andreas Petlund <[email-masked]>
Date: Thu, 6 Mar 2014 14:06:48 +0000

Hi

I think the issue of TSO might warrant a discussion in the document, but unless the initial segments are huge, the _actual_ flight_size will not be much different from the observed flight_size. Also, segmentation / fragmentation may happen on the network path (for instance if the traffic passes through a node doing TSO or the MTU changes) and that should not stop the deployment of such an algorithm. Besides, as was mentioned, EFR already uses this metric.

Cheers,
Andreas Petlund

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 6 Mar 2014 14:20:48 +0000

> I think the issue of TSO might warrant a discussion in the document, but unless the initial segments are huge, the _actual_ flight_size will not be much different from the observed flight_size. Als…
Hi Andreas,

I just wanted to know how difficult it is to keep a correct counter of
outstanding segments. And how bad is it just to ignore the counter?
That would definitely be simpler...

Best regards
Michael
> 
> Cheers,
> Andreas Petlund
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>

---

From: Andreas Petlund <[email-masked]>
Date: Thu, 6 Mar 2014 14:37:53 +0000

On 06 Mar 2014, at 14:20, Michael Tuexen <[email-masked]> wrote:

> That would definitely be simpler…
> 

There’s been some discussion on this earlier. Keeping the flight_size score is pretty simple. For discussion, see this thread: http://www.ietf.org/mail-archive/web/tcpm/current/msg08496.html

Cheers,
Andreas

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 6 Mar 2014 15:23:02 +0000

> There’s been some discussion on this earlier. Keeping the flight_size score is pretty simple. For discussion, see this thread: http://www.ietf.org/mail-archive/web/tcpm/current/msg08496.html
OK, so the statement seems to be that it is easy for TCP. For SCTP some logic
has to be implemented to manage this information...

Best regards
Michael

---

From: Andreas Petlund <[email-masked]>
Date: Thu, 6 Mar 2014 15:37:54 +0000

On 06 Mar 2014, at 15:23, Michael Tuexen <[email-masked]> wrote:

> has to be implemented to manage this information…
> 

That’s true. I don’t know the SCTP stack of Linux well enough to estimate the complexity of such score-boarding though. But by implementing it one will get the benefit of also enabling both RFC5827 and RTO restart.

Cheers,
Andreas