Subject: [tcpm] Definition of flow control

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 8 May 2014 15:54:49 +0000

Hi

I am writing up a paper that is fairly TCP-ish. I have a problem regarding the definition of the part of TCP that does the job to keep control over the packet transmission i.e the "simple" part that transmits segments whenever the bytes in flight is less than the congestion window. I call this part flow control but this is perhaps wrong ?. What is then the correct term, "rate control" or "rate limiting" or ?

/Ingemar
=================================
Ingemar Johansson  M.Sc.
Senior Researcher

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]<mailto:[email-masked]>
www.ericsson.com

"Those are my principles, and if you don't like them...
well, I have others."  Groucho Marx<http://www.brainyquote.com/quotes/authors/g/groucho_marx.html>
=================================

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Thu, 8 May 2014 16:35:58 +0000

Hi Ingemar,

if it really is only the function of "when to send" rather than "what to send", that would probably be called scheduler (unfortunately, the "what"/"when" are mingled together inseparable in most stacks - perhaps not in Laminar:

https://developers.google.com/speed/protocols/tcp-laminar

There, the term "transmission scheduling algorithm" is used...

Richard Scheffenegger

From: tcpm [mailto:[email-masked]] On Behalf Of Ingemar Johansson S
Sent: Donnerstag, 08. Mai 2014 17:55
To: [email-masked]
Subject: [tcpm] Definition of flow control

Hi

/Ingemar

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289

---

From: Joe Touch <[email-masked]>
Date: Thu, 08 May 2014 10:20:12 -0700

AFAICT, you answer your own question...

On 5/8/2014 8:54 AM, Ingemar Johansson S wrote:
> Hi
>
> I am writing up a paper that is fairly TCP-ish. I have a problem
> regarding the definition of the part of TCP that does the job to keep
> control over the packet transmission i.e the “simple” part that
> transmits segments whenever the bytes in flight is less than the
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> congestion window. I call this part flow control but this is perhaps
^^^^^^^^^^^^^^^^^^^
> wrong ?. What is then the correct term, “rate control” or “rate
> limiting” or ?

Congestion control.

Flow control is managed by the receive window.

TCP doesn't have rate control or rate limiting - it'll burst just fine, 
e.g., after the source goes idle during transactions like HTTP. Some 
variants have added rate management, but it's not part of the core 
required specification.

Joe

> [email-masked] <mailto:[email-masked]>
>
> www.ericsson.com
>
> “Those are my principles, and if you don't like them...
> well, I have others.” Groucho Marx
> <http://www.brainyquote.com/quotes/authors/g/groucho_marx.html>
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Thu, 8 May 2014 19:15:07 +0000

Keep in mind that there is not only the congestion window, but also the receive window.

>From RFC 5681: At any given time, a TCP MUST NOT send data with a sequence number higher than the sum of the highest acknowledged sequence number and the minimum of cwnd and rwnd.

In TCP contect, the term "flow control" IMHO usually refers to the handling of rwnd, while "congestion control" refers to the algorithms manipuiating cwnd. However, the term "flow control" is not always used consistently, in particular outside the IETF.

Michael

________________________________
Von: tcpm [[email-masked]]" im Auftrag von "Ingemar Johansson S [[email-masked]]
Gesendet: Donnerstag, 8. Mai 2014 17:54
Bis: [email-masked]
Betreff: [tcpm] Definition of flow control

Hi

I am writing up a paper that is fairly TCP-ish. I have a problem regarding the definition of the part of TCP that does the job to keep control over the packet transmission i.e the “simple” part that transmits segments whenever the bytes in flight is less than the congestion window. I call this part flow control but this is perhaps wrong ?. What is then the correct term, “rate control” or “rate limiting” or ?

/Ingemar

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]<mailto:[email-masked]>
www.ericsson.com<UrlBlockedError.aspx>

“Those are my principles, and if you don't like them...
well, I have others.”  Groucho Marx<http://www.brainyquote.com/quotes/authors/g/groucho_marx.html>
=================================

---

From: Ingemar Johansson S <[email-masked]>
Date: Fri, 9 May 2014 11:29:21 +0000

Thanks all, the TCP laminar definition "transmission scheduling algorithm" helped me a lot, most important I did not need to rewrite the whole document

/Ingemar

From: Scheffenegger, Richard [mailto:[email-masked]]
Sent: den 8 maj 2014 18:36
To: Ingemar Johansson S; [email-masked]
Subject: RE: Definition of flow control

Hi Ingemar,

Richard Scheffenegger

From: tcpm [mailto:[email-masked]] On Behalf Of Ingemar Johansson S
Sent: Donnerstag, 08. Mai 2014 17:55
To: [email-masked]<mailto:[email-masked]>
Subject: [tcpm] Definition of flow control

Hi

/Ingemar

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289