Subject: [tcpm] draft-ietf-tcpm-edo-01 status

From: Pasi Sarolahti <[email-masked]>
Date: Thu, 16 Oct 2014 21:42:14 +0300

Hi,

There has been pretty much discussion related to draft-ietf-tcpm-edo recently, so here is an attempt to summarize it. Hopefully we'd also get input from a wider set of TCPM people, who haven’t yet stated their opinion. Shout if I misrepresented something, or forgot something important.

So the main issue has been the possible interactions with middleboxes that may drop options, or blindly copy them while re-segmenting the data. Here are the main discussion points (or recent changes in -01), on which additional opinions would be useful:

1: Can the EDO extension be allowed in SYN/ACK? “Yes" would be nice, but an option-removing middlebox on return path would cause corruption of data (currently not allowed in -01).

2: MUST the EDO option be included in all subsequent segments after being negotiated? If this is required, lack of EDO option would cause the segment to be dropped (currently required in -01).

3: To detect segment coalescing, should there be a mechanism to detect that the segment modified? (not in -01). I recall two ways that have been suggested for this:

a) indicating payload size
b) checksum

An additional question to the above is, whether such mechanism should be part of EDO option, or a separate option in a separate document (in which case it might have also some use outside of EDO)?

Following this Email, I will start three Email threads for each of the above topics, hoping to organize the follow-up discussion a bit.

An overall consideration is, how cautiously should we consider different possible middlebox behaviors in our protocol design? EDO is a sensitive case, because in the worst case failures could cause corruption of data, but this is also a broader question we are every once in a while facing with different TCP extensions.

The question of intended document status has also come up, but I’d suggest that we focus on the technical content first, and return to the status later. Based on the current discussion, it seems obvious that at some point before the WGLC we’d need to re-check this. (This is not the first time we seem to struggle with the PS vs. Exp determination. Typically we have been quite — or maybe too? — conservative in taking the standards track.)

- Pasi

---

From: Joe Touch <[email-masked]>
Date: Thu, 16 Oct 2014 12:21:16 -0700

On 10/16/2014 11:42 AM, Pasi Sarolahti wrote:
> Hi,
> 
> There has been pretty much discussion related to draft-ietf-tcpm-edo
> recently, so here is an attempt to summarize it. Hopefully we'd also get
> input from a wider set of TCPM people, who haven’t yet stated their
> opinion. Shout if I misrepresented something, or forgot something important.
> 
> So the main issue has been the possible interactions with 
> middleboxes that may drop options, or blindly copy them while
> re-segmenting the data. Here are the main discussion points (or
> recent changes in -01), on which additional opinions would be useful:

It would be very useful to consider the summary in the current document
(01) that explains which middlebox behaviors have been seen to date.

I'll respond within each thread to the proposals, although I think this
is all one integrated concern.

Joe