Subject: Re: [tcpm] New Version - draft-ietf-tcpm-newcwv-07.txt

From: Mirja Kühlewind <[email-masked]>
Date: Mon, 06 Oct 2014 11:30:41 +0200

Hi Yucheng,

On 22.09.2014 21:40, Yuchung Cheng wrote:
> The latest Linux uses an algorithm by Neal Cardwell that incidentally is similar
> to the proposed newcwv draft sec 4.2. The key differences are
>
> 1) it uses FlightSize instead of the pipe variable
> 2) it takes care of the TSO deferral. The TSO deferral part is important because
> TCP may not always fill cwnd in order to build bigger packet.
>
> http://patchwork.ozlabs.org/patch/351512/

Would you and/or Neal be able to write this algorithm down in a small draft, so 
that it is easier to compare the differences between your approach and newcwv?

Mirja

>
> Note there is a preceeding bug-fix patch done by Eric Dumazet, where TSO and TCP
> small queue, could trick TCP not to slow start fast. This demonstrates the
> complexity to determine if TCP is cwnd limited or not, in modern networking stack.
>
> http://patchwork.ozlabs.org/patch/344293/
>
> Linux does not implement newcwv. I guess it's not clear if the other parts are
> useful or not, other than not being so conservative in growing cwnd. Lastly, I
> would recommend newcwv draft to be more specific on the algorithm in Sec 4.2.
>
> HTH
>
>

---

From: Yuchung Cheng <[email-masked]>
Date: Mon, 6 Oct 2014 15:23:43 -0700

[email-masked]

Neal: would you like to formalize the algorithm?

On Mon, Oct 6, 2014 at 2:30 AM, Mirja Kühlewind
<[email-masked]> wrote:
> Would you and/or Neal be able to write this algorithm down in a small draft,
> so that it is easier to compare the differences between your approach and
> newcwv?
>
> Mirja
>
>
>
>>