Subject: Re: [tcpm] #19 (tcp-edo): Should there be a mechanism to detect that the segment modified?

From: Joe Touch <[email-masked]>
Date: Thu, 16 Oct 2014 12:21:24 -0700

On 10/16/2014 12:04 PM, tcpm issue tracker wrote:
> #19: Should there be a mechanism to detect that the segment modified?
> 
>  I recall two ways that have been suggested for this:
> 
>  a) indicating payload size
>  b) checksum
> 
>  An additional question to the above is, whether such mechanism should be
>  part of EDO option, or a separate option in a separate document (in which
>  case it might have also some use outside of EDO)?

As with both Issues #17 and #18, I think we can include something to
detect when this would corrupt a segment. IMO, we don't need anything as
computationally complex as a checksum, so I prefer something based on
length.

Your original post included the following:

> An additional question to the above is, whether such mechanism
> should be part of EDO option, or a separate option in a separate
> document (in which case it might have also some use outside of EDO)?

If it's integrated we could save two bytes in the base header, but I
don't think that's necessary.

I continue to believe that TCP is not itself a diagnostic. I don't like
the idea of building diagnostics into every capability we add; I prefer
an orthogonal approach.

Joe

---

From: "Zimmermann, Alexander" <[email-masked]>
Date: Fri, 17 Oct 2014 06:53:27 +0000

> the idea of building diagnostics into every capability we add; I prefer

+1

> 
> Joe
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: "tcpm issue tracker" <[email-masked]>
Date: Thu, 16 Oct 2014 19:04:20 -0000

-- 
-------------------------+-------------------------------------------------
 Reporter:               |      Owner:  draft-ietf-tcpm-tcp-
  [email-masked]  |  [email-masked]
     Type:  task         |     Status:  new
 Priority:  major        |  Milestone:
Component:  tcp-edo      |    Version:
 Severity:  -            |   Keywords:
-------------------------+-------------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/tcpm/trac/ticket/19>
tcpm <http://tools.ietf.org/tcpm/>