Subject: Re: [tcpm] Four-way Handshake justification

From: David Borman <[email-masked]>
Date: Sat, 1 Nov 2014 12:07:57 -0500

> On Oct 31, 2014, at 3:20 PM, Joe Touch <[email-masked]> wrote:
> On 10/31/2014 11:01 AM, John Leslie wrote:
>>> (Yes, there are other timers, such as for delayed ACKs, but that is
>>>> an efficiency enhancement, TCP can functionally operate without them).
> 
> I'm not sure I agree with this.
> 
> It seems like TCP would lockup and never make progress if packets were lost.

The sentence right before that was:
	Timers ensure that control and data packets are retransmitted
	if they are not acknowledged.

Those timers ensure that TCP doesn’t lock up, by retransmitting un-ACKed
data and control(SYN,FIN) packets.  ACK only packets are never retransmitted.

The delayed ACK timer isn’t part of the reliability of TCP, it is a
performance improvement that allows consolidation of ACKs.  ACKs could
always be sent immediately in response to the incoming packet instead
of being delayed by a timer.

		-David

> 
> Joe
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: Joe Touch <[email-masked]>
Date: Sat, 1 Nov 2014 10:24:58 -0700

> On Nov 1, 2014, at 10:07 AM, David Borman <[email-masked]> wrote:
> 
> 

I'm not sure how you can claim tcp can functionally operate without them. Ip isn't lossless even over a lossless link layer. 

Many argue that timers are the only fundamental part of any protocol (esp. Watson, Day). 

> data and control(SYN,FIN) packets.  ACK only packets are never retransmitted.

What about keepalives?