Subject: Re: [tcpm] Rechartering TCPM for alternative congestion control algorithms

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 3 Feb 2015 15:32:51 +0000

Hi,

On 2015-1-27, at 11:21, Scharf, Michael (Michael) <[email-masked]> wrote:
> NEW:
> 
> TCPM also provides a venue for standardization of incremental
> enhancements of TCP's standard congestion control. In addition,
> TCPM may document alternative congestion control algorithms
> that are known to be widely deployed, and that are considered
> safe for large-scale deployment in the Internet. Changes of algorithms
> may require additional review by the IRTF Congestion Control
> Research Group (ICCRG). Fundamental changes to TCP or its congestion
> control algorithms (e.g., departure from loss-based congestion
> control) will be handled by other working groups or will require
> rechartering.

as one of the authors of the DCTCP draft, it remains a bit unclear to me whether that document would under the new text be something that TCPM was OK to work on.

DCTCP uses ECN (and redefines it, to some degree). That is certainly an "alternative congestion control algorithm" and hence now in scope for TCPM, unless it is also a "fundamental change", which would then mean the DCTCP document would need to go somewhere else?

Also, one could argue that DCTCP does not fulfill the "safe for large-scale deployment in the Internet" clause, since it's not intended to be used on the Internet and implementations typically have mechanisms to restrict its use. This again may mean that DCTCP is (still) out of scope for TCPM.

For the record, I believe TCPM is the right group to give feedback on the DCTCP document; the only viable alternative would be TSVWG, which has too much else on their plate.

So how about this new text?

TCPM also provides a venue for the standardization and documentation of
enhancements to TCP's standard congestion control, but such changes
may require additional review by the IRTF Congestion Control
Research Group (ICCRG). Fundamental changes to TCP or its congestion
control algorithms (e.g., departure from loss-based congestion
control) will require explicit Area Director approval before they may
become work items of the WG, and may require rechartering.

Lars

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Tue, 3 Feb 2015 16:21:28 +0000

Hi Lars,

> as one of the authors of the DCTCP draft, it remains a bit unclear to
> me whether that document would under the new text be something that
> TCPM was OK to work on.
> 
> DCTCP uses ECN (and redefines it, to some degree). That is certainly an
> "alternative congestion control algorithm" and hence now in scope for
> TCPM, unless it is also a "fundamental change", which would then mean
> the DCTCP document would need to go somewhere else?
> 
> Also, one could argue that DCTCP does not fulfill the "safe for large-
> scale deployment in the Internet" clause, since it's not intended to be
> used on the Internet and implementations typically have mechanisms to
> restrict its use. This again may mean that DCTCP is (still) out of
> scope for TCPM.

I guess TCPM would have to decide in a consensus call whether the mechanisms that restrict the use of DCTCP are reasonably "safe for avoiding Internet paths". Possibly TCPM would demand a special boilerblade text. Yet, we don't have to discuss this in this thread.

> For the record, I believe TCPM is the right group to give feedback on
> the DCTCP document; the only viable alternative would be TSVWG, which
> has too much else on their plate.
> 

To me, the suggested statement on Area Director approval has no effect, since *any* new milestone for TCPM already requires "consensus on acceptance in the working group and approval by the responsible Area Director" according to the last paragraph of the current TCPM charter (see https://datatracker.ietf.org/wg/tcpm/charter/). Right now, the AD has to approve even purely incremental changes of the congestion control. Recall that our previous charter in theory required even IESG approval for all milestones, so this was a significant improvement ;)

Assuming that we will not change this requirement of AD approval for all TCPM work, your suggested paragraph seems to be equivalent to:

TCPM also provides a venue for standardization and documentation of
enhancements of TCP's standard congestion control, but such changes
may require additional review by the IRTF Congestion Control
Research Group (ICCRG). Fundamental changes to TCP or its congestion
control algorithms (e.g., departure from loss-based congestion
control) may require rechartering.

My understanding is that such a wording would be more liberal, since it does not specify any constraints. Thoughts and feedback from the community on such a wording would be very welcome.

Thanks

Michael

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Tue, 17 Feb 2015 14:32:45 +0000

If somebody should have further thoughts on the suggested rechartering, it would be excellent to speak up NOW...

Michael

> -----Original Message-----
> From: tcpm [mailto:[email-masked]] On Behalf Of Scharf, Michael
> (Michael)
> Sent: Tuesday, January 27, 2015 11:22 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [tcpm] Rechartering TCPM for alternative congestion control
> algorithms
> 
> Hi,
> 
> This e-mails asks for community feedback on a suggested small addon to
> the TCPM charter [1].
> 
> In the last TCPM meeting [2] there was strong support for adopting a
> document describing the CUBIC congestion control algorithm [3]. To the
> chairs, it is not entirely obvious whether this document, or possibly
> other similar documents, would indeed be in scope of the current TCPM
> charter. Given the importance of the TCP congestion control, we prefer
> a community consensus explicitly documented in the charter instead of
> ambiguity.
> 
> The current charter limits the scope of TCPM to "modest changes to the
> protocol, algorithms, and interfaces". It allows "incremental
> enhancements of TCP's standard congestion control" but explicitly
> mandates rechartering for fundamental changes [1]:
> 
> OLD:
> 
> We suggest to update this paragraph in the TCPM charter by an explicit
> statement that "TCPM may document alternative congestion control
> algorithms that are known to be widely deployed, and that are
> considered safe for large-scale deployment in the Internet":
> 
> NEW:
> 
> In our reading, "TCP's standard congestion control" is currently
> defined by RFC 5681.
> 
> This e-mail and the suggested rechartering does not imply any adoption
> of one or more alternative congestion control algorithms.
> 
> Any feedback regarding this suggested rechartering would be very
> welcome. In particular, please let us know if there are any concerns
> with this proposal or if you have suggestions for a different wording.
> Please let us know any thoughts until Feb. 15, 2015.
> 
> Thanks a lot!
> 
> Michael, Pasi, Yoshifumi
> 
> 
> [1] https://datatracker.ietf.org/wg/tcpm/charter/
> 
> [2] http://www.ietf.org/proceedings/91/minutes/minutes-91-tcpm
> 
> [3] https://datatracker.ietf.org/doc/draft-zimmermann-tcpm-cubic/
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm