Subject: Re: [tcpm] [tsvwg] I-D Action: draft-sprecher-mobile-tg-exposure-req-arch-01.txt

From: "Eggert, Lars" <[email-masked]>
Date: Sat, 21 Feb 2015 04:42:08 +0000

Also CC'ing TCPM and ICCRG. Is there any experimental evaluation and/or simulation results for the proposed mechanism?

Lars

On 2015-2-20, at 14:46, Sprecher, Nurit (NSN - IL/Hod HaSharon) <[email-masked]> wrote:
> 
> Dear all,
> Please be aware of the new I-D we have submitted on “Requirements and reference architecture for Mobile Throughput Guidance Exposure”.
> The draft proposes principles for a mobile throughput guidance exposure mechanism that can be used  to assist TCP in cellular networks, and help to ensure better network  efficiency and enhanced service delivery performance.
> The draft presents the problems that the rapidly-varying conditions in a cellular network can cause to the TCP behavior and to the application performance.
> The draft specifies the requirements and reference architecture for the mechanism.
> While the proposed mechanism can be used to optimize any content delivery application, the draft describes its applicability to video delivery optimization in mobile networks.
> Your review and comments will be much appreciated. Comments can be sent on the tsvwg list or directly to the authors.
> Best regards,
> Nurit
> 
> 
> -----Original Message-----
> From: I-D-Announce [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of ext [email-masked] <mailto:[email-masked]>
> Sent: Friday, February 20, 2015 3:04 PM
> To: [email-masked] <mailto:[email-masked]>
> Subject: I-D Action: draft-sprecher-mobile-tg-exposure-req-arch-01.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : Requirements and reference architecture for Mobile Throughput Guidance Exposure
>         Authors         : Ankur Jain
>                           Andreas Terzis
>                           Nurit Sprecher
>                           Swaminathan Arunachalam
>                           Kevin Smith
>                           Guenter Klas
>       Filename        : draft-sprecher-mobile-tg-exposure-req-arch-01.txt
>       Pages           : 12
>       Date            : 2015-02-20
> 
> Abstract:
>    Rapidly-varying conditions in a cellular network can cause problems
>    for the Transmission Control Protocol (TCP), which in turn can
>    degrade application performance.
> 
>    This document presents the problem statement and proposes solution
>    principles.  It specifies the requirements and reference architecture
>    for a mobile throughput guidance exposure mechanism that can be used
>   to assist TCP in cellular networks, ensuring better network
>    efficiency and enhanced service delivery performance.
> 
>    The proposed mechanism can be applied to any content or TCP/IP based
>    application content delivery.  This document describes the
>    applicability of the mechanism for Intelligent Video Acceleration
>    over cellular networks.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-sprecher-mobile-tg-exposure-req-arch/ <https://datatracker.ietf.org/doc/draft-sprecher-mobile-tg-exposure-req-arch/>
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-sprecher-mobile-tg-exposure-req-arch-01 <http://tools.ietf.org/html/draft-sprecher-mobile-tg-exposure-req-arch-01>
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-sprecher-mobile-tg-exposure-req-arch-01 <http://www.ietf.org/rfcdiff?url2=draft-sprecher-mobile-tg-exposure-req-arch-01>
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/i-d-announce <https://www.ietf.org/mailman/listinfo/i-d-announce>
> Internet-Draft directories: http://www.ietf.org/shadow.html <http://www.ietf.org/shadow.html>
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt <ftp://ftp.ietf.org/ietf/1shadow-sites.txt>

---

From: Andreas Terzis <[email-masked]>
Date: Fri, 20 Feb 2015 23:21:54 -0800

Lars,

To be clear, the document that Nurit submitted talks about requirements and
doesn't propose any mechanism.

We will soon submit another document that describe one possible mechanism
for providing throughput guidance
and a strawman for leveraging this information. That draft will include
preliminary results from lab tests.

Best regards,

Andreas

On Fri, Feb 20, 2015 at 8:42 PM, Eggert, Lars <[email-masked]> wrote:

> Also CC'ing TCPM and ICCRG. Is there any experimental evaluation and/or
> simulation results for the proposed mechanism?
>
> Lars
>
> Please be aware of the new I-D we have submitted on “Requirements and
> reference architecture for Mobile Throughput Guidance Exposure”.
>
> The draft proposes principles for a mobile throughput guidance exposure
> mechanism that can be used  to assist TCP in cellular networks, and help to
> ensure better network  efficiency and enhanced service delivery performance.
>
>
> The draft presents the problems that the rapidly-varying conditions in a
> cellular network can cause to the TCP behavior and to the application
> performance.
>
> While the proposed mechanism can be used to optimize any content delivery
> application, the draft describes its applicability to video delivery optimization
> in mobile networks.
>
> Your review and comments will be much appreciated. Comments can be sent on
> the tsvwg list or directly to the authors.
>
> Best regards,
>
> Nurit
>
>
> From: I-D-Announce [mailto:[email-masked]
> <[email-masked]>] On Behalf Of ext [email-masked]
> To: [email-masked]
> https://datatracker.ietf.org/doc/draft-sprecher-mobile-tg-exposure-req-arch/
>
> http://tools.ietf.org/html/draft-sprecher-mobile-tg-exposure-req-arch-01
>
> http://www.ietf.org/rfcdiff?url2=draft-sprecher-mobile-tg-exposure-req-arch-01
>
>
> until the htmlized version and diff are available at tools.ietf.org.
>
> ftp://ftp.ietf.org/internet-drafts/
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
>

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Sat, 21 Feb 2015 22:39:48 +0100

Andreas,

From a quick read of the draft it seems to me that the functional architecture is only partially described as it is not clear to me how the Throughput Guidance Provider discovers which TCP server(s) it should be providing throughput guidance to or how a TCP server might discover & register with a Throughput Guidance Provider. 

Will the other document you mention also cover discovery?

Also, where is this document primarily being discussed (TSVWG?) as I am interested in the work but not sure which WG to subscribe to in order to follow/contribute towards it?

Thanks
Ben

> On 21 Feb 2015, at 08:21, Andreas Terzis <[email-masked]> wrote:
> 
> Lars,
> 
> To be clear, the document that Nurit submitted talks about requirements and doesn't propose any mechanism.
> 
> We will soon submit another document that describe one possible mechanism for providing throughput guidance
> and a strawman for leveraging this information. That draft will include preliminary results from lab tests. 
> 
> Best regards,
> 
> Andreas 
> 
> 
> 
>>> From: I-D-Announce [mailto:[email-masked]] On Behalf Of ext [email-masked]
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: Andreas Terzis <[email-masked]>
Date: Sat, 21 Feb 2015 22:32:30 -0800

Ben,

Thank you for your interest in our draft.

You raise a valid point, that the current draft doesn't explicitly mention
discovery. We were implicitly thinking that establishing who gets
throughput guidance from whom is established out of band through the same
process that establishes the security associations. We should have made
this clear and thank you for bringing this up.

The mechanism document will include more details on the discovery
mechanism.

Our current plan is to ask for a slot at the TSVWG and hopefully get a
chance to present this work and start a conversation in Dallas.

Best regards,

Andreas

On Sat, Feb 21, 2015 at 1:39 PM, Ben Niven-Jenkins <[email-masked]>
wrote:

> Andreas,
>
> From a quick read of the draft it seems to me that the functional
> architecture is only partially described as it is not clear to me how the
> Throughput Guidance Provider discovers which TCP server(s) it should be
> providing throughput guidance to or how a TCP server might discover &
> register with a Throughput Guidance Provider.
>
> Also, where is this document primarily being discussed (TSVWG?) as I am
> interested in the work but not sure which WG to subscribe to in order to
> follow/contribute towards it?
>
> Thanks
> Ben
>
>> Your review and comments will be much appreciated. Comments can be sent
>> on the tsvwg list or directly to the authors.
>>
>> Best regards,
>>
>> Nurit
>>
>>

---

From: "Eggert, Lars" <[email-masked]>
Date: Sun, 22 Feb 2015 10:47:54 +0000

Hi Nurit,

On 2015-2-21, at 18:22, Sprecher, Nurit (NSN - IL/Hod HaSharon) <[email-masked]> wrote:
> Please note that the document does not specify a solution protocol, but it proposes solution principles, requirements and a reference architecture. It also present an applicability statement.
> We will submit soon an I-D with a proposed solution protocol, which is based on running code. We will share some preliminary test results.

I'll look forward to the solution proposal. I have some general doubts about the feasibility of approaches in this space, and so commenting on the requirements and architecture feels a bit premature. I expect the solution proposal will add enough context to understand what is attempted.

Thanks,
Lars

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Sun, 22 Feb 2015 11:50:35 +0000

Dear all:

there has been a lot of work on how to "improve" TCP over all kinds of wireless networks in the past. Proxy based solutions for example. Or caching. Or network coding (on going work/research). Or combinations. And then solutions looking at MAC layer improvements and even lower layer which are outside the scope of the IETF. 

I like the fact your requirements state that there should not be any specific software on the end user device but that still leave a large solution space. And I agree with Lars that details will be important and real implementations even more.

/mjm

Marie-Jose Montpetit, Ph.D.
[email-masked]
@SocialTVMIT

> On Feb 22, 2015, at 5:47 AM, Eggert, Lars <[email-masked]> wrote:
> 
> Hi Nurit,
> 
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg