Subject: [tcpm] Question to TCP implementors regarding dupack threshold

From: Yuchung Cheng <[email-masked]>
Date: Sat, 17 Oct 2015 09:48:08 -0700

Hi,

The question is:

When a TCP sender receives a DUPACK with SACK option(s) covering at least
three packets (or three MSS bytes), will it trigger fast recovery
immediately?

I know Linux does (for at least +8 years). I am curious about other
implementations like Windows, Mac, *BSD?

Thanks.

Yuchung

---

From: Ilpo Järvinen <[email-masked]>
Date: Sat, 17 Oct 2015 22:10:04 +0300 (EEST)

> implementations like Windows, Mac, *BSD?

I don't know about implementations other than Linux, especially the 
current status, but RFC6675 uses less strict condition than "three
MSS bytes" for this detection:

      DupThresh discontiguous SACKed sequences have arrived above
      'SeqNum' or more than (DupThresh - 1) * SMSS with sequence
      numbers greater than 'SeqNum' have been SACKed

Some stacks wouldn't know where packet boundaries are anyway (I think that 
at least BSD is/was like that) so three packets cannot be tested other 
than using the above RFC6675 condition (or by depending on three DUPACKs).

-- 
 i.

---

From: hiren panchasara <[email-masked]>
Date: Sat, 17 Oct 2015 17:13:17 -0700

> implementations like Windows, Mac, *BSD?

FreeBSD doesn't do this currently. Looks like a sensible thing to do.

Cheers,
Hiren

---

From: Yuchung Cheng <[email-masked]>
Date: Tue, 20 Oct 2015 09:03:42 -0700

+tcpm
On Oct 19, 2015 4:03 PM, "Yuchung Cheng" <[email-masked]> wrote:

> On Sat, Oct 17, 2015 at 5:13 PM, hiren panchasara
> <[email-masked]> wrote:
> >
> yes I agree it's nice to have that. It's more robust against ACK
> suppression discussed in the other threads, and ack loss in general.
>
> Anyone know about Windows and Mac?
>
> >
> >
> > Cheers,
> > Hiren
>

---

From: Praveen Balasubramanian <[email-masked]>
Date: Tue, 20 Oct 2015 16:53:23 +0000

Windows does not do this today.

From: tcpm [mailto:[email-masked]] On Behalf Of Yuchung Cheng
Sent: Tuesday, October 20, 2015 9:04 AM
To: hiren panchasara <[email-masked]>; [email-masked] Extensions <[email-masked]>
Subject: Re: [tcpm] Question to TCP implementors regarding dupack threshold

+tcpm
On Oct 19, 2015 4:03 PM, "Yuchung Cheng" <[email-masked]<mailto:[email-masked]>> wrote:
On Sat, Oct 17, 2015 at 5:13 PM, hiren panchasara

---

From: hiren panchasara <[email-masked]>
Date: Wed, 21 Oct 2015 14:19:01 -0700

> > Anyone know about Windows and Mac?

A _very_ quick look through apple/xnu code tells me that they are also not
doing this currently.

Cheers,
Hiren

---

From: Karen Elisabeth Egede Nielsen <[email-masked]>
Date: Thu, 29 Oct 2015 09:37:05 +0100

HI,

We do this in our in-house TCP implementation today.

This is what RFC6675 prescribes for – do you not agree ?

BR, Karen

*From:* tcpm [mailto:[email-masked]] *On Behalf Of *Yuchung Cheng
*Sent:* 17. oktober 2015 18:48
*To:* [email-masked] Extensions <[email-masked]>
*Subject:* [tcpm] Question to TCP implementors regarding dupack threshold

Hi,

The question is:

Thanks.

Yuchung

---

From: Yuchung Cheng <[email-masked]>
Date: Fri, 30 Oct 2015 08:00:38 +0900

> This is what RFC6675 prescribes for – do you not agree ?
I do agree. Doing so will make Fast Recovery more robust on ACK losses
(or suppression). Glad to know one more stack that does that.

> Sent: 17. oktober 2015 18:48
> To: [email-masked] Extensions <[email-masked]>
> Subject: [tcpm] Question to TCP implementors regarding dupack threshold
>
>
>
> Hi,
>
>
>
> The question is:
>
>
>