Subject: [tcpm] FW: I-D Action: draft-ietf-tcpm-rto-consider-00.txt

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Wed, 3 Feb 2016 10:34:08 +0000

Since it has been suggested to move this short document forward relatively fast, please have look at this new version.

With chair hat off: To me, the sentence on page 5 "In such a case a congestion control action is not required." does not really cover an undo of congestion control actions once a non-congestion event is detected. But this may really be nitpicking...

Thanks

Michael

-----Original Message-----
From: I-D-Announce [mailto:[email-masked]] On Behalf Of EXT [email-masked]
Sent: Tuesday, February 02, 2016 3:02 PM
To: [email-masked]
Cc: [email-masked]
Subject: I-D Action: draft-ietf-tcpm-rto-consider-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the TCP Maintenance and Minor Extensions Working Group of the IETF.

        Title           : Retransmission Timeout Considerations
        Author          : Mark Allman
	Filename        : draft-ietf-tcpm-rto-consider-00.txt
	Pages           : 7
	Date            : 2016-02-02

Abstract:
    Each implementation of a retransmission timeout mechanism must
    balance correctness and timeliness and therefore no implementation
    suits all situations.  This document provides high-level guidance
    for retransmission timeout schemes appropriate for general use in
    the Internet.  Within the guidelines, implementations have latitude
    to define particulars that best address each situation.

Terminology

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tcpm-rto-consider/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-tcpm-rto-consider-00

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Mark Allman <[email-masked]>
Date: Thu, 04 Feb 2016 07:57:58 -0500

Michael-

> To me, the sentence on page 5 "In such a case a congestion control
> action is not required." does not really cover an undo of
> congestion control actions once a non-congestion event is
> detected. But this may really be nitpicking...

I am not sure I understand what you mean.

The full text says:

    (4) Retransmission timeouts MUST be taken as indications of
        congestion in the network and the sending rate adapted using a
        standard mechanism (e.g., TCP collapses the congestion window to
        one segment [RFC5681]).

        This ensures network safety.

        An exception is made to this rule if a standard mechanism is
        used to determine that a particular loss is due to a
        non-congestion event (e.g., bit errors or packet reordering).
        In such a case a congestion control action is not required.

Would you prefer this just explicitly notes that undo-ing CC
decisions (via a standard mechanism) is fine?  In other words, is
your comment that the language focuses too much on the initial
decision and not a later decision that might reverse course?

I am happy to try to make things more clear, but I don't quite
follow what isn't clear yet.

Thanks!

allman

---

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Thu, 4 Feb 2016 13:06:06 +0000

Yes, I think that a slightly different wording that also includes a later decision could be better. Possibly one could just add something like "... and could be undone".

Anyway, as I said, this may really be nitpicking - and I am not a native speaker.

Michael

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, February 04, 2016 1:58 PM
To: Scharf, Michael (Nokia - DE)
Cc: [email-masked] Extensions
Subject: Re: [tcpm] FW: I-D Action: draft-ietf-tcpm-rto-consider-00.txt 

Michael-

> action is not required." does not really cover an undo of congestion 
> control actions once a non-congestion event is detected. But this may 
> really be nitpicking...

The full text says:

Would you prefer this just explicitly notes that undo-ing CC decisions (via a standard mechanism) is fine?  In other words, is your comment that the language focuses too much on the initial decision and not a later decision that might reverse course?

I am happy to try to make things more clear, but I don't quite follow what isn't clear yet.

Thanks!

allman

---

From: Mark Allman <[email-masked]>
Date: Mon, 29 Feb 2016 09:00:52 -0500

> detected. But this may really be nitpicking...

I just submitted a new version (-01) that includes a tweaked version
of the text referenced above.

I have received no other comments and so this is the only change
between -00 and -01.  Please advise on next steps.

allman