Subject: Re: [tcpm] [tcpinc] TCP's treatment of data in SYN packets

From: Gavin McCullagh <[email-masked]>
Date: Mon, 1 Aug 2016 20:52:43 -0700

Just to satisfy my curiosity, how did this work (or did it?) with TCP SYN
Cookies?

I can imagine a tcp listener which was implementing SYN Cookies only ACKing
the initial SYN sequence number and not the data which it discarded, then
the application retransmitting that data either on the subsequent ACK or
the next data packet.  Does that generally just work with most/all tcp
implementations on the other side?  I suppose it ought to?

Gavin

On Wed, Jul 27, 2016 at 11:37 PM, Derek Fawcus <
[email-masked]> wrote:

> On Thu, Jul 28, 2016 at 12:24:19am +0100, Derek Fawcus wrote:
> >
> > Implying that a passive opener which chose to ack such data bytes would
> > have to buffer such data until the handshake completes;  but I'm not
> > aware of any stack which actually works that way.
>
> Except the old KA9Q NOS,  which was tickling my memory...
>
> It did have the ability to send such SYN data.
>
> DF
>
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>

---

From: Derek Fawcus <[email-masked]>
Date: Tue, 2 Aug 2016 09:24:25 +0100

On Mon, Aug 01, 2016 at 08:52:43pm -0700, Gavin McCullagh wrote:
> Just to satisfy my curiosity, how did this work (or did it?) with TCP SYN Cookies?

The sender of the SYN would simply send the data again once the 3whs completed.

This was before SYN cookies were invented.  As I recall,  I'd stopped using KA9Q
before '96,  which a search indicates is when SYN cookies started.

The KA9Q configuration option was 'tcp syndata',  if you do searches for 'ka9q nos'
you'll find the code if you wish to play (or just read it).

DF

---

From: Joe Touch <[email-masked]>
Date: Tue, 2 Aug 2016 11:04:32 -0700

> The sender of the SYN would simply send the data again once the 3whs completed.
An important point - it would send exactly the same data again (or if it
sent more data, the overlapping portions never changed).

Joe