Subject: Re: [tcpm] WG acceptance of draft-cheng-tcpm-rack-01

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Wed, 31 Aug 2016 09:41:08 +0000

Hi all,

I am not aware of further comments as a response to my email below. The consensus is therefore to adopt draft-cheng-tcpm-rack-01 as new TCPM WG item. 

@authors: Please resubmit as draft-ietf-tcpm-...

I'd suggest that the authors make a proposal whether to include TLP. We can come back to this question in one of the upcoming TCPM meetings, preferably based on a text proposal. 

Thanks

Michael 

-----Original Message-----
From: tcpm [mailto:[email-masked]] On Behalf Of Scharf, Michael (Nokia - DE)
Sent: Tuesday, July 19, 2016 8:37 AM
To: [email-masked]
Subject: [tcpm] WG acceptance of draft-cheng-tcpm-rack-01

Hi all,

Yesterday we had uniform consensus in the room to adopt draft-cheng-tcpm-rack-01 as a new TCPM working group item. As a remark, the support was the strongest I have recently seen in TCPM. 

Therefore I'd like to confirm on the list that it is working group consensus to add a new milestone to the TCPM charter

  Submit document on a time-based fast loss detection algorithm for TCP (RACK) to the IESG for publication as an Experimental RFC

and to use draft-cheng-tcpm-rack-01 as a starting point.

Two additional notes:

- It has been mentioned that further experimentation is needed e.g. regarding the parameters and therefore the suggested status is Experimental

- It has been proposed to also document TLP in this document as it is timer-based mechanism as well

If you have any feedback or suggestions, please let us know in the next two weeks.

Thanks

Michael

_______________________________________________
tcpm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tcpm

---

From: Yuchung Cheng <[email-masked]>
Date: Wed, 31 Aug 2016 08:24:52 -0700

> I'd suggest that the authors make a proposal whether to include TLP. We can come back to this question in one of the upcoming TCPM meetings, preferably based on a text proposal.
Thanks Michael. I've discussed with the authors of TLP Nandita and
Matt. Our consensus was to first fuse TLP (as an optimization) and
RACK together in one draft to get WG feedback. We'd resubmit a draft
before the next meeting deadline.

Personally I am continue to work on RACK implementation. One problem
is the current algorithm requires scanning the scoreboard for every
ACK. This can take too much cycles on fast connection with lots of
losses and sacks. Another test I am running is to use RACK + TLP alone
without any other recovery heuristics in Linux, and make sure we don't
see regressions in boundary cases. I think both are important to make
sure for the "working code" principle for the new proposal .