Subject: [tcpm] draft-ietf-tcpm-converters

From: "Scharf, Michael" <[email-masked]>
Date: Sun, 16 Jun 2019 08:28:01 +0000

Hi all,

In preparation of a planned WGLC (heads-up to all) I have read draft-ietf-tcpm-converters-07 again.

As a result, I have two further questions (as individual contributor, if that matters). Ideally I should have already noted when reading the document last time…

1/ The handling of the three-way handshake is well specified in the document, and this is what the convert protocol is about. Yet, I really wonder if some words are needed on what the endpoints can expect from the converter once the connection is established? In section 1, the document specifies that the converters „relay control messages and data between the client and the server“. While I believe most of us have an idea what this means, I wonder if it is formally clear what that implies for acknowledgements and connection management (e.g., FIN, RST, keepalives). For instance, if the client receives an ACK for a segment with FIN flag, can the client assume that the server has received a FIN from the converter and that the converter has received an ACK from the Server for that FIN? My understanding is that a converter is not required to guarantee these end-to-end semantics. If that is true, wouldn’t it be better to be explicit about that? This may also relate to what happens in case of failures inside the converter.

2/ The document uses the term „TCP extended header“, e.g. on page 10 and 23. As far as I know, we typically don’t use this term for the standard TCP header, either with or without options. draft-ietf-tcpm-tcp-edo uses a similar term, but as far as I understand the converter protocol does not rely on EDO. Wouldn’t it be more reasonable to replace „TCP extended header“ by a more common term, e.g. by „TCP header“?

Thanks

Michael

---

From: <[email-masked]>
Date: Mon, 17 Jun 2019 06:10:59 +0000

Hi Michael,

Please see inline.

Cheers,
Med

De : Scharf, Michael [mailto:[email-masked]]
Envoyé : dimanche 16 juin 2019 10:28
À : [email-masked]
Cc : [email-masked] Extensions
Objet : draft-ietf-tcpm-converters

Hi all,

[Med] We can add some details if you thnk this is useful. A first attempt to address your comment is available at: https://github.com/obonaventure/draft-tcp-converters/pull/60/files. We will further tweak the text and release a new revision soon.

[Med] Will be fixed.

Thanks

Michael

---

From: "Scharf, Michael" <[email-masked]>
Date: Mon, 17 Jun 2019 06:19:47 +0000

Hi Med,

The proposed text would address my concern.

Thanks

Michael

Von: [email-masked]<mailto:[email-masked]>
Gesendet: Montag, 17. Juni 2019 08:11
An: Scharf, Michael<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked] Extensions<mailto:[email-masked]>
Betreff: RE: draft-ietf-tcpm-converters

Hi Michael,

Please see inline.

Cheers,
Med

Hi all,

[Med] Will be fixed.

Thanks

Michael

---

From: <[email-masked]>
Date: Thu, 20 Jun 2019 05:19:49 +0000

Hi Michael,

FWIW, these changes are now implemented in -08. We also fixed some nits (thanks Adi).

Looking forward the WGLC.

Cheers,
Olivier & Med

De : Scharf, Michael [mailto:[email-masked]]
Envoyé : lundi 17 juin 2019 08:20
À : BOUCADAIR Mohamed TGI/OLN; [email-masked]
Cc : [email-masked] Extensions
Objet : Re: draft-ietf-tcpm-converters

Hi Med,

Thanks

Michael

Hi Michael,

Please see inline.

Cheers,
Med

Hi all,

As a result, I have two further questions (as individual contributor, if that matters). Ideally I should have already noted when reading the document last time...

1/ The handling of the three-way handshake is well specified in the document, and this is what the convert protocol is about. Yet, I really wonder if some words are needed on what the endpoints can expect from the converter once the connection is established? In section 1, the document specifies that the converters "relay control messages and data between the client and the server". While I believe most of us have an idea what this means, I wonder if it is formally clear what that implies for acknowledgements and connection management (e.g., FIN, RST, keepalives). For instance, if the client receives an ACK for a segment with FIN flag, can the client assume that the server has received a FIN from the converter and that the converter has received an ACK from the Server for that FIN? My understanding is that a converter is not required to guarantee these end-to-end semantics. If that is true, wouldn't it be better to be explicit about that? This may also relate to what happens in case of failures inside the converter.

2/ The document uses the term "TCP extended header", e.g. on page 10 and 23. As far as I know, we typically don't use this term for the standard TCP header, either with or without options. draft-ietf-tcpm-tcp-edo uses a similar term, but as far as I understand the converter protocol does not rely on EDO. Wouldn't it be more reasonable to replace "TCP extended header" by a more common term, e.g. by "TCP header"?

[Med] Will be fixed.

Thanks

Michael