Subject: Re: [tcpm] [Lwip] WGLC review of draft-ietf-lwig-tcp-constrained-node-networks

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Wed, 5 Jun 2019 11:34:58 +0200

Hi Ingemar,

Thank you very much for reviewing the draft and for your suggestions. Your
feedback is timely and very welcome.

Based on your comments, in the last revision of our document (-08) we have
added a new subsection (subsection 4.3.3) that discusses the Initial
Window setting in the context of CNNs.

Cheers,

Carles (on behalf of all authors)

> Hi
>
> I hope that I am not too late with the review.
>
> Perhaps this has been brought up earlier, and it that is the case then
> sorry
> for kicking in open doors.
>
>
>
> I have read but to not seen any mention of the initial congestion window
> size. Today the initial window in most TCP stacks is set to 10*MSS and
> this
> may well be used by Nb-IoT implementers that are unaware of default
> settings.
>
> While this is likely not an issue if he applications transmit small
> objects
> that fit in a few segments, it can become an issue with larger object
> transfers and if a burst of 14600 bytes overflows a tiny network buffer.
>
> Should this be addressed, possibly with a recommendation to adjust the
> initial window based on network constraints ?
>
>
>
> /Ingemar
>
> ==================================
>
> Ingemar Johansson  M.Sc.
>
> Master Researcher
>
>
>
> Ericsson Research
>
> Network Protocols & E2E Performance
>
> Labratoriegränd 11
>
> 971 28, Luleå, Sweden
>
> Phone +46-1071 43042
>
> SMS/MMS +46-73 078 3289
>
> [email-masked]
>
> www.ericsson.com
>
>
>
>                 Nothing to stop this
>
>              being the best day ever
>
>                             U2
>
> ==================================
>
>
>
> _______________________________________________
> Lwip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lwip
>

---

From: Ingemar Johansson S <[email-masked]>
Date: Wed, 5 Jun 2019 10:36:00 +0000

Hi
And thanks for the update, the added text looks very good

/Ingemar

> -----Original Message-----
> From: Carles Gomez Montenegro <[email-masked]>
> Sent: den 5 juni 2019 11:35
> To: Ingemar Johansson S <[email-masked]>
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Lwip] WGLC review of draft-ietf-lwig-tcp-constrained-node-
> networks
> 
> Hi Ingemar,
> 
Window
> setting in the context of CNNs.
> 
> Cheers,
> 
> > sorry for kicking in open doors.
> >
> >
> >
> > I have read but to not seen any mention of the initial congestion
> > window size. Today the initial window in most TCP stacks is set to
> > 10*MSS and this may well be used by Nb-IoT implementers that are
> > unaware of default settings.
> >
> > objects that fit in a few segments, it can become an issue with larger
> > object transfers and if a burst of 14600 bytes overflows a tiny
> > network buffer.
> >