Subject: Re: [tcpm] [tsvwg] L4S status tracking

From: "Scharf, Michael" <[email-masked]>
Date: Fri, 23 Aug 2019 14:01:15 +0000

Hi Wes,

I’d like to add a smaller item that is mostly editorial and can hopefully be sorted just out by re-wording, albeit it may require a careful analysis of all documents.

As already noted in https://mailarchive.ietf.org/arch/msg/tsvwg/zZkYZKF-hDvWO3I5MudwpNkKyHY , I object to the terms „traditional TCP“ and also „classic TCP“ or „legacy“ TCP when referring to a TCP implementation according to IETF standards-track RFCs.

To me as a non-native native speaker, all these terms have a negative connotation. I also think this language is typical to marketing material.

My prefered term when referring to TCP according to standards-track specification is „standard TCP“. I would also be fine with other terms as long as they are neutral and make clear that experiments do not replace, deprecate, or outperform standards.

Similarly, I think that term such as „classic“ is not appropriate for the TCP standard congestion control („Reno“). As of today, this is the TCP congestion control algorithm on standards track that has IETF consensus. The term in the TCPM charter is „TCP standard congestion control“. I also think that terms such as „Reno-compatible“ or the like would be neutral.

Note that I do not object to the terms „classic ECN“, „legacy ECN“, „legacy AQM“ or the like, i.e., if the context is ECN and not specifically TCP or the TCP congestion control. I believe it is up to the TSVWG do decide if this term shall be used for compliance to RFC 3168. I have no strong opinion on that. As far as I can see, most use of the term „classic“ is in this context and I don’t ask for changes in those cases.

Some use of the term „Classic Service“ may also require careful review to clearly separate it from TCP Standard behavior.

Note that some use of the term „Classic TCP“ would probably also apply to „Classic QUIC“ once the QUIC standard is finished. To me as a non-native speaker, it would be really strange to use the term „classic“ in the context of a brand-new transport protocol. IMHO in that case the term „classic“ would be even more confusing.

I also add the TCPM list in CC to ensure consistency.

Thanks

Michael (with no hat)

Von: Wesley Eddy<mailto:[email-masked]>
Gesendet: Sonntag, 11. August 2019 07:08
An: [email-masked]<mailto:[email-masked]>
Betreff: [tsvwg] L4S status tracking

I created tickets in the TSVWG "trac" tool in order to help keep track
of the individual things that look like they should be addressed in
progressing L4S document set:

https://trac.ietf.org/trac/tsvwg/report/1?sort=ticket&asc=1&page=1

I'll try to update these based on the ongoing discussions, updates,
etc., but it will make it very easy if you happen to mention the ticket
numbers or some key words in threads and messages, when significant.

---

From: "Black, David" <[email-masked]>
Date: Fri, 23 Aug 2019 14:23:14 +0000

> Note that I do not object to the terms "classic ECN", "legacy ECN", "legacy AQM" or the like, i.e.,

> if the context is ECN and not specifically TCP or the TCP congestion control. I believe it is up to

> the TSVWG do decide if this term shall be used for compliance to RFC 3168. I have no strong opinion on that.

> As far as I can see, most use of the term "classic" is in this context and I don't ask for changes in those cases.

"RFC 3168 ECN" is the more precise term, whose use I would encourage.  Use of "classic ECN" seems ok, as long as the draft makes it clear that "classic" means "RFC 3168" in this context.

Thanks, --David (as an author of RFC 3168)

From: tsvwg <[email-masked]> On Behalf Of Scharf, Michael
Sent: Friday, August 23, 2019 10:01 AM
To: Wesley Eddy; [email-masked]
Cc: [email-masked]
Subject: Re: [tsvwg] L4S status tracking

[EXTERNAL EMAIL]

Hi Wes,

I'd like to add a smaller item that is mostly editorial and can hopefully be sorted just out by re-wording, albeit it may require a careful analysis of all documents.

As already noted in https://mailarchive.ietf.org/arch/msg/tsvwg/zZkYZKF-hDvWO3I5MudwpNkKyHY<https://mailarchive..ietf.org/arch/msg/tsvwg/zZkYZKF-hDvWO3I5MudwpNkKyHY> , I object to the terms "traditional TCP" and also "classic TCP" or "legacy" TCP when referring to a TCP implementation according to IETF standards-track RFCs.

My prefered term when referring to TCP according to standards-track specification is "standard TCP". I would also be fine with other terms as long as they are neutral and make clear that experiments do not replace, deprecate, or outperform standards.

Similarly, I think that term such as "classic" is not appropriate for the TCP standard congestion control ("Reno"). As of today, this is the TCP congestion control algorithm on standards track that has IETF consensus. The term in the TCPM charter is "TCP standard congestion control". I also think that terms such as "Reno-compatible" or the like would be neutral.

Note that I do not object to the terms "classic ECN", "legacy ECN", "legacy AQM" or the like, i.e., if the context is ECN and not specifically TCP or the TCP congestion control. I believe it is up to the TSVWG do decide if this term shall be used for compliance to RFC 3168. I have no strong opinion on that. As far as I can see, most use of the term "classic" is in this context and I don't ask for changes in those cases.

Some use of the term "Classic Service" may also require careful review to clearly separate it from TCP Standard behavior.

Note that some use of the term "Classic TCP" would probably also apply to "Classic QUIC" once the QUIC standard is finished. To me as a non-native speaker, it would be really strange to use the term "classic" in the context of a brand-new transport protocol. IMHO in that case the term "classic" would be even more confusing.

Thanks

Michael (with no hat)