Subject: Re: [tcpm] Request for feedback on WG adoption of draft-scharf-tcpm-yang-tcp-04

From: tom petch <[email-masked]>
Date: Thu, 2 Apr 2020 11:45:20 +0000

Michael,
apologies, this got lost - inline

From: Scharf, Michael <[email-masked]>
Sent: 25 March 2020 16:39

Hi Tom,

> -----Original Message-----
> From: tom petch <[email-masked]>
> Sent: Wednesday, March 25, 2020 1:53 PM
>
> From: Idr <[email-masked]> on behalf of Scharf, Michael
> <[email-masked]>
> Sent: 18 March 2020 20:12
>
> Hi all,
>
> This is a heads-up regarding the ongoing adoption call for draft-scharf-tcpm-
> yang-tcp-04 in TCPM.
>
> <tp>
> Michael
>
> I note that you have also sent this to Netconf and that you import groupings
> from the netconf-tcp draft which makes the netconf draft a Normative
> Reference except that this I-D does not mention that fact.

[I-D.ietf-netconf-tcp-client-server] is listed as first normative reference in draft-scharf-tcpm-yang-tcp and that dependency is also mentioned in the abstract. With the current structure of the models, it is not clear to me why a reference in the reverse direction would be needed.

<tp>
RFC8407 says that YANG import must have a reference which must be a Normative Reference for the I-D.

So far, the feedback from the NETCONF chairs was that draft-ietf-netconf-tcp-client-server would most likely finish before a TCPM document. The work in the NETCONF WG started much earlier.

<tp>
I note that the chair is also the author:-)

> I think this is problematic.  Progress on the netconf I-D has been slow for some
> years and so your I-D could have to wait a while.  The solution would be to
> progress the netconf draft but I do not know how this can be expedited.

That is an interesting line of thought. Actually, when I wear the hat of a co-chair of TCPM, I get told again and again that TCPM is too slow... We currently try our best to speed up a bit. However, due to the complexity of TCP, the heterogeneity of implementations, and the scale of deployment of the protocol, TCPM needs some time to process documents. This would almost certainly also apply to a YANG model. In addition, TCPM has not dealt with YANG so far, i.e., it is a new topic for the working group.

Realistically, even if we as authors try our best, the normative reference to the netconf I-D would only become a problem if that document does not progress at all for a longer time.

Would you prefer a TCPM document without that normative reference? In any case, I doubt that timing should be the main motivation for that. Would there be other reasons?

<tp>
I see TCPM as the best of source of information about TCP in the IETF and so best qualified to produce an accurate YANG module which other WG then import.  The downside is that TCP has so many facets that the temptation will be to produce the kitchen sink which is never complete; but with ruthless control from Chairs and AD to keep a limit on the scope then I think that the TCPM WG is the place for it.

Tom Petch

> There are a lot of details in this I-D that I think of as admin which need fixing to
> conform to YANG Guidelines but would not see that as a bar to adoption
> whereas dependency on netconf is more debatable IMHO.

Indeed, many details require further work. That is well understood.

Thanks

Michael

> Tom Petch
>
>
> You may want to pay attention. For instance, this document defines groupings
> for TCP-AO and MD5, which are used by draft-ietf-idr-bgp-model.
>
> If you support work of this document in TCPM, or if you have any comments,
> please free to provide feedback on the TCPM list ([email-masked]).
>
> Thanks
>
> Michael (TCPM chair hat off)
>
>
> Von: Michael Tuexen<mailto:[email-masked]>
> Gesendet: Montag, 16. März 2020 21:44
> An: tcpm IETF list<mailto:[email-masked]>
> Cc: [email-masked]<mailto:draft-scharf-tcpm-yang-
> [email-masked]>
> Betreff: Request for feedback on WG adoption of draft-scharf-tcpm-yang-tcp-04
>
> Dear all,
>
> this mail starts a WG adoption call for
> https://tools.ietf.org/html/draft-scharf-tcpm-yang-tcp-04
>
> So I would like to solicit feedback regarding support for or objections against
> the
> adoption of the document as a WG document in TCPM.
>
> Please provide feedback before March 31st.
>
> For the context and current state of the document, see the presentation sent
> yesterday
> to the mailing list by Mahesh.
>
> Best regards
> Michael
>
>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 6 Apr 2020 20:52:09 -0700

Hi Tom,

> On Apr 2, 2020, at 4:45 AM, tom petch <[email-masked]> wrote:
> 
>> 

I will take care of adding a normative reference to [I-D.ietf-netconf-tcp-client-server] both in Section 4 and in the model, in the next version of the draft.

Cheers.

Mahesh Jethanandani
[email-masked]

---

From: <[email-masked]>
Date: Thu, 9 Apr 2020 16:08:40 +0000

From: tcpm <[email-masked]> on behalf of tom petch <[email-masked]>
Sent: 02 April 2020 12:45
To: Scharf, Michael; [email-masked]

Michael

A further thought on the netconf chairs  advice that the Netconf I-D would complete first so that the tcpm draft would not be delayed.

I worked on the syslog yang draft which the IESG approved.  It has two Normative references to that cluster of Netconf I-D that I have referred to.  It has now been waiting for MISSREF for 755 days - seven hundred and fifty five.  You seem to think that progress in tcpm is slower than that:-)   I cannot see any MISSREF on the tcpm datatracker pages.

Tom Petch

Michael,

Hi Tom,

<tp>

<tp>

<tp>

Tom Petch

Thanks

Michael

> to the mailing list by Mahesh.

_______________________________________________
tcpm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tcpm