Subject: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

From: Xufeng Liu <[email-masked]>
Date: Mon, 20 Feb 2017 15:31:27 +0000

Attendees:
Xufeng, Igor, Pavan, Carlo, Sergio, Tarek, Pawel Ka, Dieter

- Continued discussion on multi-layer topologies covering more than 2 layers.
  > Discussed the modeling transformation by using transitional link.
  > A 3-layer hybrid node might be decomposed into 3 logical nodes.
  > Dieter presented the use case of a multi-layer topology with 3 layers.
  > We have confirmed that the existing model can support such a
    modeling transformation.

- Comments from Ievgen seem to be related to TE model (not this
  model). Will respond to the email.

- Draft text
  > Discussed the clarification on customized topology vs. abstract topology
  > Will add more clarification texts in the draft

- Logistics
  > We will move the weekly meeting one hour earlier to resolve some conflicts.

Thanks,

- Xufeng

Note: Please drop me an email if you need an invite for joining the weekly call.

---

From: "Belotti, Sergio (Nokia - IT)" <[email-masked]>
Date: Mon, 20 Feb 2017 15:39:11 +0000

Hi Xufeng, Igor
May be it would be good , based on slides Dieter shown last time, to add a "model mapping" to see real yang entities   involved for TL definition .
We are trying to do this job in Transport Design Team in CCAMP for specific use cases.

What do you think?

Thanks
Sergio

From: Xufeng Liu [mailto:[email-masked]]
Sent: Monday, February 20, 2017 4:31 PM
To: Vishnu Pavan Beeram <[email-masked]>; Igor Bryskin <[email-masked]>; Oscar Gonzalez De Dios <[email-masked]>; Tarek Saad <[email-masked]>; Himanshu Shah <[email-masked]>; Lou Berger <[email-masked]>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]>; Susan Hares <[email-masked]>; Zafar Ali (zali) <[email-masked]>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]>; Tony Le <[email-masked]>; Belotti, Sergio (Nokia - IT) <[email-masked]>; Beller, Dieter (Nokia - DE) <[email-masked]>; Rajan Rao <[email-masked]>; Zhangxian (Xian) <[email-masked]>; [email-masked]; Belotti, Sergio (Nokia - IT) <[email-masked]>; Anurag Sharma <[email-masked]>; Italo Busi <[email-masked]>
Cc: [email-masked]
Subject: IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Attendees:

    modeling transformation.

- Draft text

- Logistics

Thanks,

- Xufeng

---

From: Dieter Beller <[email-masked]>
Date: Tue, 21 Feb 2017 14:45:34 +0100

Hi all,

please find attached the 3 slides we discussed last Wed (slide 1
just recaps the 2-layer case we discussed before).

Comments are welcome.

Thanks,

Dieter

On 20.02.2017 16:31, Xufeng Liu wrote:

Attendees:

Xufeng, Igor, Pavan, Carlo, Sergio, Tarek,
Pawel Ka, Dieter

- Continued discussion on multi-layer
topologies covering more than 2 layers.

> Discussed the modeling
transformation by using transitional link.

modeling transformation.

- Comments from Ievgen seem to be related
to TE model (not this

- Draft text

> Discussed the clarification on
customized topology vs. abstract topology

- Logistics

Thanks,

- Xufeng

Note: Please drop me an email if you need
an invite for joining the weekly call.

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: Igor Bryskin <[email-masked]>
Date: Tue, 21 Feb 2017 14:30:22 +0000

Hi Dieter,

I hope that  TP1, Tp2, .... TPn between N1 and N2 you mean LTPs (rather than TTPs) in the TE topology model language. In other words, TTPs are always inside physical nodes, correct?

From: Dieter Beller [mailto:[email-masked]]
Sent: Tuesday, February 21, 2017 8:46 AM
To: Xufeng Liu; Vishnu Pavan Beeram; Igor Bryskin; Oscar Gonzalez De Dios; Tarek Saad; Himanshu Shah; Lou Berger; BRUNGARD, DEBORAH A (ATTLABS); Susan Hares; Zafar Ali (zali); Khaddam, Mazen (CCI-Atlanta); Tony Le; BELOTTI, SERGIO (SERGIO); Beller, Dieter (Dieter); Rajan Rao; Zhangxian (Xian); [email-masked]; Belotti, Sergio (Nokia - IT); Anurag Sharma; Italo Busi
Cc: [email-masked]
Subject: Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi all,

please find attached the 3 slides we discussed last Wed (slide 1 just recaps the 2-layer case we discussed before).

Comments are welcome.

Thanks,
Dieter

    modeling transformation.

- Draft text

- Logistics

Thanks,

- Xufeng

Teas mailing list

[email-masked]<mailto:[email-masked]>

---

From: Dieter Beller <[email-masked]>
Date: Tue, 21 Feb 2017 16:56:17 +0100

Hi Igor, all,

On 21.02.2017 15:30, Igor Bryskin
wrote:

Hi Dieter,

I hope that
TP1, Tp2, …. TPn between N1 and N2 you mean LTPs (rather
than TTPs) in the TE topology model language. In other
words, TTPs are always inside physical nodes, correct?

you right - this is aligned with my understanding. My apologies for
being a bit sloppy when I added the labels to the figure.

Thanks,

Dieter

From:
Dieter Beller [mailto:[email-masked]]

To: Xufeng Liu; Vishnu Pavan Beeram; Igor
Bryskin; Oscar Gonzalez De Dios; Tarek Saad; Himanshu
Shah; Lou Berger; BRUNGARD, DEBORAH A (ATTLABS); Susan
Hares; Zafar Ali (zali); Khaddam, Mazen (CCI-Atlanta);
Tony Le; BELOTTI, SERGIO (SERGIO); Beller, Dieter
(Dieter); Rajan Rao; Zhangxian (Xian);
[email-masked]; Belotti, Sergio (Nokia - IT);
Anurag Sharma; Italo Busi

Cc: [email-masked]

Subject: Re: [Teas] IETF TE Topology YANG Model
Design Meeting Notes - 2017-02-15

Hi all,

please find attached the 3 slides we discussed last Wed (slide
1 just recaps the 2-layer case we discussed before).

Comments are welcome.

Thanks,

Dieter

Attendees:

Xufeng, Igor, Pavan, Carlo, Sergio,
Tarek, Pawel Ka, Dieter

modeling transformation.

- Draft text

- Logistics

> We will move the weekly meeting
one hour earlier to resolve some conflicts.

Thanks,

- Xufeng

Teas mailing list

[email-masked]

---

From: Xufeng Liu <[email-masked]>
Date: Tue, 21 Feb 2017 16:59:54 +0000

Hi Sergio,

This should be good. We already got the slides from Dieter, and we will add it as an example. Since you are doing this already, can you send me the YANG mapping once you get it done?

Thanks,

- Xufeng

From: Belotti, Sergio (Nokia - IT) [mailto:[email-masked]]
Sent: Monday, February 20, 2017 10:39 AM
Cc: [email-masked]
Subject: RE: IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Xufeng, Igor

What do you think?

Thanks
Sergio

From: Xufeng Liu [mailto:[email-masked]]
Sent: Monday, February 20, 2017 4:31 PM
Cc: [email-masked]<mailto:[email-masked]>
Subject: IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Attendees:

    modeling transformation.

- Draft text

- Logistics

Thanks,

- Xufeng

---

From: "Belotti, Sergio (Nokia - IT)" <[email-masked]>
Date: Tue, 21 Feb 2017 17:26:58 +0000

Hi Xufeng,
In the Transport Design team, we started with single domain , single layer topology, so no TL  or inter-layer lock are present. We have not yet done the multi-layer example.
My question is if it possible to understand how the model can be mapped on the Dieter's use case.
Question is if the intention is still based on what depicted here below

Here we are connecting two TTP at different layers , that I'm not sure is correct.

Thanks
Sergio

From: Xufeng Liu [mailto:[email-masked]]
Sent: Tuesday, February 21, 2017 6:00 PM
Cc: [email-masked]
Subject: RE: IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Sergio,

Thanks,

- Xufeng

Hi Xufeng, Igor

What do you think?

Thanks
Sergio

Attendees:

    modeling transformation.

- Draft text

- Logistics

Thanks,

- Xufeng

---

From: Igor Bryskin <[email-masked]>
Date: Tue, 21 Feb 2017 17:39:35 +0000

Hi Sergio,

We used to be able to connect higher layer LTP with a lower layer TTP via TL. This is not sufficient for the case when three or more layers are involved.

To describe a multi-layer potential layer hierarchy supported by a given multi-layer NE now we use the following chain:

LTP (client layer)-TL1---->TTP(server layer 1)-TL2-->TTP(server layer 2)-TL3-->...TTP(server layer n)

So, yes, TL can now inter-connect TTPs of adjacent in a given hierarchy layers.

Igor

From: Belotti, Sergio (Nokia - IT) [mailto:[email-masked]]
Sent: Tuesday, February 21, 2017 12:27 PM
To: Xufeng Liu; Vishnu Pavan Beeram; Igor Bryskin; Oscar Gonzalez De Dios; Tarek Saad; Himanshu Shah; Lou Berger; BRUNGARD, DEBORAH A (ATTLABS); Susan Hares; Zafar Ali (zali); Khaddam, Mazen (CCI-Atlanta); Tony Le; Beller, Dieter (Nokia - DE); Rajan Rao; Zhangxian (Xian); [email-masked]; Anurag Sharma; Italo Busi
Cc: [email-masked]
Subject: RE: IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Xufeng,

Thanks
Sergio

From: Xufeng Liu [mailto:[email-masked]]
Sent: Tuesday, February 21, 2017 6:00 PM
To: Belotti, Sergio (Nokia - IT) <[email-masked]>; Vishnu Pavan Beeram <[email-masked]>; Igor Bryskin <[email-masked]>; Oscar Gonzalez De Dios <[email-masked]>; Tarek Saad <[email-masked]>; Himanshu Shah <[email-masked]>; Lou Berger <[email-masked]>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]>; Susan Hares <[email-masked]>; Zafar Ali (zali) <[email-masked]>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]>; Tony Le <[email-masked]>; Beller, Dieter (Nokia - DE) <[email-masked]>; Rajan Rao <[email-masked]>; Zhangxian (Xian) <[email-masked]>; [email-masked]; Anurag Sharma <[email-masked]>; Italo Busi <[email-masked]>
Cc: [email-masked]
Subject: RE: IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Sergio,

Thanks,

- Xufeng

To: Xufeng Liu <[email-masked]<mailto:[email-masked]>>; Vishnu Pavan Beeram <[email-masked]<mailto:[email-masked]>>; Igor Bryskin <[email-masked]<mailto:[email-masked]>>; Oscar Gonzalez De Dios <[email-masked]<mailto:[email-masked]>>; Tarek Saad <[email-masked]<mailto:[email-masked]>>; Himanshu Shah <[email-masked]<mailto:[email-masked]>>; Lou Berger <[email-masked]<mailto:[email-masked]>>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; Zafar Ali (zali) <[email-masked]<mailto:[email-masked]>>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]<mailto:[email-masked]>>; Tony Le <[email-masked]<mailto:[email-masked]>>; Beller, Dieter (Nokia - DE) <[email-masked]<mailto:[email-masked]>>; Rajan Rao <[email-masked]<mailto:[email-masked]>>; Zhangxian (Xian) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Anurag Sharma <[email-masked]<mailto:[email-masked]>>; Italo Busi <[email-masked]<mailto:[email-masked]>>

Hi Xufeng, Igor

What do you think?

Thanks
Sergio

To: Vishnu Pavan Beeram <[email-masked]<mailto:[email-masked]>>; Igor Bryskin <[email-masked]<mailto:[email-masked]>>; Oscar Gonzalez De Dios <[email-masked]<mailto:[email-masked]>>; Tarek Saad <[email-masked]<mailto:[email-masked]>>; Himanshu Shah <[email-masked]<mailto:[email-masked]>>; Lou Berger <[email-masked]<mailto:[email-masked]>>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; Zafar Ali (zali) <[email-masked]<mailto:[email-masked]>>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]<mailto:[email-masked]>>; Tony Le <[email-masked]<mailto:[email-masked]>>; Belotti, Sergio (Nokia - IT) <[email-masked]<mailto:[email-masked]>>; Beller, Dieter (Nokia - DE) <[email-masked]<mailto:[email-masked]>>; Rajan Rao <[email-masked]<mailto:[email-masked]>>; Zhangxian (Xian) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Belotti, Sergio (Nokia - IT) <[email-masked]<mailto:[email-masked]>>; Anurag Sharma <[email-masked]<mailto:[email-masked]>>; Italo Busi <[email-masked]<mailto:[email-masked]>>

Attendees:

    modeling transformation.

- Draft text

- Logistics

Thanks,

- Xufeng

---

From: Gert Grammel <[email-masked]>
Date: Tue, 21 Feb 2017 19:41:21 +0000

Xufeng, Sergio, Dieter,

I had a look at the slide distributed by the Design Team earlier (see below) and wonder what it is supposed to depict. My starting point was a look at https://tools.ietf.org/html/rfc5212 which deals with optical only (covering what is called "Layer0" below). It would be great if the team could provide some more context as to where to drive the related YANG Model.
Let me share a few thoughts to illustrate the different interpretation without suggesting any of those would match the intention:

1.       At a glance, the drawing looks like the re-use of a classical ITU-T functional model but there the term "Layer" has a different connotation. If the intention is to depict data plane layers (according to ITU) then they should be spelled out in relevant terms (like OPU/ODU/OTU/OCH/OMS/OTS etc.). Evidently the picture would now grow from 3 to a double digit number of ITU-T Layers, but at least represent a half way accurate complexity/scale of the modelling effort.

2.       Maybe the aim is to depict technologies rather than Layers. However, in this case terms like "L0+L1-switch only" get problematic because there are several granularities of switching even inside technologies which aren't depicted here. So probably the YANG model would need to go into a deeper modelling exercise similar to point 1.

3.       Perhaps it shall represent a control plane view on switching rather than a data plane view. In that case however we'd probably need to use terms of  https://tools.ietf.org/html/rfc5212 where applicable, but this would change the picture/model even more

Thanks

Gert

From: Teas <[email-masked]> on behalf of Xufeng Liu <[email-masked]>
Date: Tuesday 21 February 2017 at 08:59
To: "Belotti, Sergio (Nokia - IT)" <[email-masked]>, Pavan Beeram <[email-masked]>, Igor Bryskin <[email-masked]>, "[email-masked]" <[email-masked]>, Tarek Saad <[email-masked]>, Himanshu Shah <[email-masked]>, Lou Berger <[email-masked]>, Deborah Brungard <[email-masked]>, Susan Hares <[email-masked]>, Zafar Ali <[email-masked]>, EXT - Mazen Khaddam <[email-masked]>, Tony Le <[email-masked]>, Dieter Beller <[email-masked]>, "[email-masked]" <[email-masked]>, Zhangxian <[email-masked]>, "[email-masked]" <[email-masked]>, Anurag Sharma <[email-masked]>, Italo Busi <[email-masked]>
Cc: TEAS WG <[email-masked]>
Subject: Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Sergio,

Thanks,

- Xufeng

From: Belotti, Sergio (Nokia - IT) [mailto:[email-masked]]
Sent: Monday, February 20, 2017 10:39 AM
To: Xufeng Liu <[email-masked]>; Vishnu Pavan Beeram <[email-masked]>; Igor Bryskin <[email-masked]>; Oscar Gonzalez De Dios <[email-masked]>; Tarek Saad <[email-masked]>; Himanshu Shah <[email-masked]>; Lou Berger <[email-masked]>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]>; Susan Hares <[email-masked]>; Zafar Ali (zali) <[email-masked]>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]>; Tony Le <[email-masked]>; Beller, Dieter (Nokia - DE) <[email-masked]>; Rajan Rao <[email-masked]>; Zhangxian (Xian) <[email-masked]>; [email-masked]; Anurag Sharma <[email-masked]>; Italo Busi <[email-masked]>
Cc: [email-masked]
Subject: RE: IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Xufeng, Igor
May be it would be good , based on slides Dieter shown last time, to add a “model mapping” to see real yang entities   involved for TL definition .
We are trying to do this job in Transport Design Team in CCAMP for specific use cases.

What do you think?

Thanks
Sergio

Attendees:

    modeling transformation.

- Draft text

- Logistics

Thanks,

- Xufeng

---

From: "Xufeng Liu" <[email-masked]>
Date: Wed, 22 Feb 2017 09:40:13 -0500

Hi Gert,

The thermology used in the draft is consistent with existing RFCs. The slides shown here are used for our premilitary discussions, and the used terms will be adjusted before they are incorporated into the draft.

Thanks,

- Xufeng  

From: Gert Grammel [mailto:[email-masked]] 
Sent: Tuesday, February 21, 2017 2:41 PM
Cc: [email-masked]
Subject: Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Xufeng, Sergio, Dieter,

 

Thanks

Gert

From: Teas <[email-masked] <mailto:[email-masked]> > on behalf of Xufeng Liu <[email-masked] <mailto:[email-masked]> >
Date: Tuesday 21 February 2017 at 08:59
Cc: TEAS WG <[email-masked] <mailto:[email-masked]> >
Subject: Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Sergio,

Thanks,

- Xufeng

From: Belotti, Sergio (Nokia - IT) [mailto:[email-masked]] 
Sent: Monday, February 20, 2017 10:39 AM
Cc: [email-masked] <mailto:[email-masked]> 
Subject: RE: IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Xufeng, Igor

What do you think?

Thanks

Sergio

From: Xufeng Liu [mailto:[email-masked]] 
Sent: Monday, February 20, 2017 4:31 PM
Cc: [email-masked] <mailto:[email-masked]> 
Subject: IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Attendees:

    modeling transformation. 

- Draft text

- Logistics

Thanks,

- Xufeng

---

From: Dieter Beller <[email-masked]>
Date: Wed, 22 Feb 2017 16:00:49 +0100

Hi Gert, all,

I concur with Xufeng - please bear in mind that we are working on a
technology neutral model and that the specific example was provided

to discuss whether the multi-layer model is not limited to just 2
layers but can also be applied to a network containing >2 layers.

It is always easier for discussions to provide a concrete example
rather than discussing abstract models and based on the feedback I
got,

people found it very useful during our discussion last week.

Thanks,

Dieter

On 22.02.2017 15:40, Xufeng Liu wrote:

Hi Gert,

The thermology used in the draft is
consistent with existing RFCs. The slides shown here are used
for our premilitary discussions, and the used terms will be
adjusted before they are incorporated into the draft.

Thanks,

- Xufeng

From: Gert Grammel
[mailto:[email-masked]]

To: Xufeng Liu <[email-masked]>;
Belotti, Sergio (Nokia - IT)
<[email-masked]>; Vishnu Pavan Beeram
<[email-masked]>; Igor Bryskin
<[email-masked]>; Oscar Gonzalez De Dios
<[email-masked]>; Tarek Saad
<[email-masked]>; Himanshu Shah
<[email-masked]>; Lou Berger
<[email-masked]>; BRUNGARD, DEBORAH A (ATTLABS)
<[email-masked]>; Susan Hares
<[email-masked]>; Zafar Ali (zali)
<[email-masked]>; EXT - Mazen Khaddam
<[email-masked]>; Tony Le
<[email-masked]>; Beller, Dieter (Nokia - DE)
<[email-masked]>; Rajan Rao
<[email-masked]>; Zhangxian (Xian)
<[email-masked]>;
[email-masked]; Anurag Sharma
<[email-masked]>; Italo Busi
<[email-masked]>

Cc: [email-masked]

Xufeng, Sergio, Dieter,

I had a look at the slide distributed by the
Design Team earlier (see below) and wonder what it is
supposed to depict. My starting point was a look at https://tools.ietf.org/html/rfc5212
which deals with optical only (covering what is called
"Layer0" below). It would be great if the team could
provide some more context as to where to drive the related
YANG Model.

Let me share a few thoughts to illustrate the
different interpretation without suggesting any of those
would match the intention:

At a
glance, the drawing looks like the re-use of a classical
ITU-T functional model but there the term "Layer" has a
different connotation. If the intention is to depict
data plane layers (according to ITU) then they should be
spelled out in relevant terms (like
OPU/ODU/OTU/OCH/OMS/OTS etc.). Evidently the picture
would now grow from 3 to a double digit number of ITU-T
Layers, but at least represent a half way accurate
complexity/scale of the modelling effort.

Maybe
the aim is to depict technologies rather than Layers.
However, in this case terms like "L0+L1-switch only" get
problematic because there are several granularities of
switching even inside technologies which aren't depicted
here. So probably the YANG model would need to go into a
deeper modelling exercise similar to point 1.

Perhaps
it shall represent a control plane view on switching
rather than a data plane view. In that case however we'd
probably need to use terms of  https://tools.ietf.org/html/rfc5212
where applicable, but this would change the
picture/model even more

Thanks

Gert

From: Teas <[email-masked]>
on behalf of Xufeng Liu <[email-masked]>

To: "Belotti, Sergio (Nokia - IT)" <[email-masked]>,
Pavan Beeram <[email-masked]>,
Igor Bryskin <[email-masked]>,
"[email-masked]"
<[email-masked]>,
Tarek Saad <[email-masked]>,
Himanshu Shah <[email-masked]>,
Lou Berger <[email-masked]>,
Deborah Brungard <[email-masked]>,
Susan Hares <[email-masked]>,
Zafar Ali <[email-masked]>,
EXT - Mazen Khaddam <[email-masked]>,
Tony Le <[email-masked]>,
Dieter Beller <[email-masked]>,
"[email-masked]"
<[email-masked]>,
Zhangxian <[email-masked]>,
"[email-masked]"
<[email-masked]>,
Anurag Sharma <[email-masked]>,
Italo Busi <[email-masked]>

Hi Sergio,

This should be good.
We already got the slides from Dieter, and we will add it
as an example. Since you are doing this already, can you
send me the YANG mapping once you get it done?

Thanks,

- Xufeng

To: Xufeng Liu <[email-masked]>;
Vishnu Pavan Beeram <[email-masked]>;
Igor Bryskin <[email-masked]>;
Oscar Gonzalez De Dios <[email-masked]>;
Tarek Saad <[email-masked]>;
Himanshu Shah <[email-masked]>;
Lou Berger <[email-masked]>;
BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]>;
Susan Hares <[email-masked]>;
Zafar Ali (zali) <[email-masked]>;
Khaddam, Mazen (CCI-Atlanta) <[email-masked]>;
Tony Le <[email-masked]>;
Beller, Dieter (Nokia - DE) <[email-masked]>;
Rajan Rao <[email-masked]>;
Zhangxian (Xian) <[email-masked]>;
[email-masked];
Anurag Sharma <[email-masked]>;
Italo Busi <[email-masked]>

Cc: [email-masked]

Subject: RE: IETF TE Topology YANG Model
Design Meeting Notes - 2017-02-15

Hi Xufeng, Igor

May be it would be
good , based on slides Dieter shown last time, to add a
“model mapping” to see real yang entities   involved for
TL definition .

We are trying to do
this job in Transport Design Team in CCAMP for specific
use cases.

What do you think?

Thanks

Sergio

To: Vishnu Pavan Beeram <[email-masked]>;
Igor Bryskin <[email-masked]>;
Oscar Gonzalez De Dios <[email-masked]>;
Tarek Saad <[email-masked]>;
Himanshu Shah <[email-masked]>;
Lou Berger <[email-masked]>;
BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]>;
Susan Hares <[email-masked]>;
Zafar Ali (zali) <[email-masked]>;
Khaddam, Mazen (CCI-Atlanta) <[email-masked]>;
Tony Le <[email-masked]>;
Belotti, Sergio (Nokia - IT) <[email-masked]>;
Beller, Dieter (Nokia - DE) <[email-masked]>;
Rajan Rao <[email-masked]>;
Zhangxian (Xian) <[email-masked]>;
[email-masked];
Belotti, Sergio (Nokia - IT) <[email-masked]>;
Anurag Sharma <[email-masked]>;
Italo Busi <[email-masked]>

Cc: [email-masked]

Subject: IETF TE Topology YANG Model Design
Meeting Notes - 2017-02-15

Attendees:

Xufeng, Igor, Pavan,
Carlo, Sergio, Tarek, Pawel Ka, Dieter

- Continued
discussion on multi-layer topologies covering more than
2 layers.

> Discussed the
modeling transformation by using transitional link.

> A 3-layer
hybrid node might be decomposed into 3 logical nodes.

> Dieter
presented the use case of a multi-layer topology with 3
layers.

> We have
confirmed that the existing model can support such a

modeling
transformation.

- Comments from
Ievgen seem to be related to TE model (not this

model). Will
respond to the email.

- Draft text

> Discussed the
clarification on customized topology vs. abstract
topology

- Logistics

> We will move
the weekly meeting one hour earlier to resolve some
conflicts.

Thanks,

- Xufeng

Note: Please drop me
an email if you need an invite for joining the weekly
call.

---

From: Gert Grammel <[email-masked]>
Date: Wed, 22 Feb 2017 20:25:49 +0000

Xufeng,

Which RFC numbers did you have in mind?

Gert

From: Xufeng Liu <[email-masked]>
Date: Wednesday 22 February 2017 at 06:40
Cc: TEAS WG <[email-masked]>
Subject: RE: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Gert,

Xufeng, Sergio, Dieter,

Thanks

Gert

From: Teas <[email-masked]<mailto:[email-masked]>> on behalf of Xufeng Liu <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 21 February 2017 at 08:59
Cc: TEAS WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Sergio,

Thanks,

- Xufeng

Hi Xufeng, Igor

What do you think?

Thanks
Sergio

Attendees:

    modeling transformation.

- Draft text

- Logistics

Thanks,

- Xufeng

---

From: Gert Grammel <[email-masked]>
Date: Wed, 22 Feb 2017 20:54:47 +0000

Dieter,

As concrete examples are useful, It might be worth to make the example a little more concrete than it is right now:

If you had ITU-T Layers in mind, the "Layer1" construct alone would end up with something like (apologies if I missed or added a layer)
·         OPU0, OPU1, OPU2, OPU2e, OPU3, OPU3e, OPU4, OPUFlex
·         ODU0, ODU1, ODU2, ODU2e, ODU3, ODU3e, ODU4, ODUFlex,  each having 7 TCM Layers
·         OTU1, OTU2, OTU2e, OTU3, OTU3e, OTU4, OTUCn

That gives you 8 + 8*7 + 7 = 71 Layer constructs in what is called "Layer1".
Layer0 will likely add another dozen or so and a few others for L2 Ethernet but I didn't bother to count them so I guess they would add another 20+.

Was it obvious to the design team that the simple example depicted contained implicitly ~90 layers?
Is the assumption that the yang model for 3 layers can be extended recursively to model all 90?
Did the design team have in mind to cut down the 90 into 3 "super-Layers" and by which consideration?

If the design team feels that new terminology is needed for the YANG Model, so let's define it and move on. Using instead terminology that has such a baggage, is unlikely to accelerate the process nor does it clearly highlight the scale of the issues we'd run into.

My 2c

Gert

From: Dieter Beller <[email-masked]>
Organization: Nokia
Date: Wednesday 22 February 2017 at 07:00
To: Xufeng Liu <[email-masked]>, Gert Grammel <[email-masked]>, 'Xufeng Liu' <[email-masked]>, "'Belotti, Sergio (Nokia - IT)'" <[email-masked]>, Pavan Beeram <[email-masked]>, 'Igor Bryskin' <[email-masked]>, "[email-masked]" <[email-masked]>, 'Tarek Saad' <[email-masked]>, 'Himanshu Shah' <[email-masked]>, Lou Berger <[email-masked]>, Deborah Brungard <[email-masked]>, Susan Hares <[email-masked]>, Zafar Ali <[email-masked]>, EXT - Mazen Khaddam <[email-masked]>, Tony Le <[email-masked]>, "[email-masked]" <[email-masked]>, Zhangxian <[email-masked]>, 'Anurag Sharma' <[email-masked]>, 'Italo Busi' <[email-masked]>
Cc: TEAS WG <[email-masked]>
Subject: Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Gert, all,
I concur with Xufeng - please bear in mind that we are working on a technology neutral model and that the specific example was provided
to discuss whether the multi-layer model is not limited to just 2 layers but can also be applied to a network containing >2 layers.

It is always easier for discussions to provide a concrete example rather than discussing abstract models and based on the feedback I got,
people found it very useful during our discussion last week.

Thanks,
Dieter

To: Xufeng Liu <[email-masked]><mailto:[email-masked]>; Belotti, Sergio (Nokia - IT) <[email-masked]><mailto:[email-masked]>; Vishnu Pavan Beeram <[email-masked]><mailto:[email-masked]>; Igor Bryskin <[email-masked]><mailto:[email-masked]>; Oscar Gonzalez De Dios <[email-masked]><mailto:[email-masked]>; Tarek Saad <[email-masked]><mailto:[email-masked]>; Himanshu Shah <[email-masked]><mailto:[email-masked]>; Lou Berger <[email-masked]><mailto:[email-masked]>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]><mailto:[email-masked]>; Susan Hares <[email-masked]><mailto:[email-masked]>; Zafar Ali (zali) <[email-masked]><mailto:[email-masked]>; EXT - Mazen Khaddam <[email-masked]><mailto:[email-masked]>; Tony Le <[email-masked]><mailto:[email-masked]>; Beller, Dieter (Nokia - DE) <[email-masked]><mailto:[email-masked]>; Rajan Rao <[email-masked]><mailto:[email-masked]>; Zhangxian (Xian) <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Anurag Sharma <[email-masked]><mailto:[email-masked]>; Italo Busi <[email-masked]><mailto:[email-masked]>

Xufeng, Sergio, Dieter,

Thanks

Gert

To: "Belotti, Sergio (Nokia - IT)" <[email-masked]<mailto:[email-masked]>>, Pavan Beeram <[email-masked]<mailto:[email-masked]>>, Igor Bryskin <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Tarek Saad <[email-masked]<mailto:[email-masked]>>, Himanshu Shah <[email-masked]<mailto:[email-masked]>>, Lou Berger <[email-masked]<mailto:[email-masked]>>, Deborah Brungard <[email-masked]<mailto:[email-masked]>>, Susan Hares <[email-masked]<mailto:[email-masked]>>, Zafar Ali <[email-masked]<mailto:[email-masked]>>, EXT - Mazen Khaddam <[email-masked]<mailto:[email-masked]>>, Tony Le <[email-masked]<mailto:[email-masked]>>, Dieter Beller <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Zhangxian <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Anurag Sharma <[email-masked]<mailto:[email-masked]>>, Italo Busi <[email-masked]<mailto:[email-masked]>>

Hi Sergio,

Thanks,

- Xufeng

Hi Xufeng, Igor

What do you think?

Thanks
Sergio

Attendees:

    modeling transformation.

- Draft text

- Logistics

Thanks,

- Xufeng

---

From: "Xufeng Liu" <[email-masked]>
Date: Thu, 23 Feb 2017 11:31:00 -0500

Hi Gert,

Those include  4328,  4206, 5212, 5339, 6001, 7926, 5623, 7138.

Thanks,

- Xufeng

From: Gert Grammel [mailto:[email-masked]] 
Sent: Wednesday, February 22, 2017 3:26 PM
Cc: [email-masked]
Subject: Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Xufeng,

Gert

From: Xufeng Liu <[email-masked] <mailto:[email-masked]> >
Date: Wednesday 22 February 2017 at 06:40
Cc: TEAS WG <[email-masked] <mailto:[email-masked]> >
Subject: RE: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Gert,

Thanks,

- Xufeng  

Xufeng, Sergio, Dieter,

 

Thanks

Gert

Hi Sergio,

Thanks,

- Xufeng

Hi Xufeng, Igor

What do you think?

Thanks

Sergio

Attendees:

    modeling transformation. 

- Draft text

- Logistics

Thanks,

- Xufeng

---

From: Gert Grammel <[email-masked]>
Date: Thu, 23 Feb 2017 18:14:59 +0000

Xufeng,

Thank you for the references (expanded below for better reading).  They are predominantly GMPLS related, which suggests the DT is looking at modelling control plane entities. So coming back to the initial question about interpreting the DT output. Would interpretation #3 kind of capture the intention of the example?
<snip> 3.  Perhaps it shall represent a control plane view on switching rather than a data plane view. <snip>

Given the different history of people in the DT, you may also benefit from considering as a reference https://tools.ietf.org/html/rfc4397:
<snip>  Because the GMPLS and ASON architectures were developed by different people in different standards bodies, and because the architectures have very different historic backgrounds (the Internet, and transport networks respectively), the terminology used is different. <snip>

The WG would certainly benefit if terminology used by the DT is clarified to avoid ambiguity in interpreting the output.

Thanks

Gert

·         https://tools.ietf.org/html/rfc4328 Generalized Multi-Protocol Label Switching (GMPLS) Signaling Extensions for G.709 Optical Transport Networks Control

·         https://tools.ietf.org/html/rfc4206 Label Switched Paths (LSP) Hierarchy with Generalized Multi-Protocol Label Switching (GMPLS) Traffic Engineering (TE)

·         https://tools.ietf.org/html/rfc5212 Requirements for GMPLS-Based Multi-Region and Multi-Layer Networks (MRN/MLN)

·         https://tools.ietf.org/html/rfc5339 Evaluation of Existing GMPLS Protocols against Multi-Layer and Multi-Region Networks (MLN/MRN)

·         https://tools.ietf.org/html/rfc6001 Generalized MPLS (GMPLS) Protocol Extensions for Multi-Layer and Multi-Region Networks (MLN/MRN)

·         https://tools.ietf.org/html/rfc7926 Problem Statement and Architecture for Information Exchange between Interconnected Traffic-Engineered Networks

·         https://tools.ietf.org/html/rfc5623 Framework for PCE-Based Inter-Layer MPLS and GMPLS Traffic Engineering

·         https://tools.ietf.org/html/rfc7138 Traffic Engineering Extensions to OSPF for GMPLS Control of Evolving G.709 Optical Transport Networks

From: Xufeng Liu <[email-masked]>
Date: Thursday 23 February 2017 at 08:31
Cc: TEAS WG <[email-masked]>
Subject: RE: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Gert,

Xufeng,

Gert

From: Xufeng Liu <[email-masked]<mailto:[email-masked]>>
Date: Wednesday 22 February 2017 at 06:40
Cc: TEAS WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Hi Gert,

Xufeng, Sergio, Dieter,

Thanks

Gert

Hi Sergio,

Thanks,

- Xufeng

Hi Xufeng, Igor

What do you think?

Thanks
Sergio

Attendees:

    modeling transformation.

- Draft text

- Logistics

Thanks,

- Xufeng

---

From: "Xufeng Liu" <[email-masked]>
Date: Fri, 24 Feb 2017 11:38:02 -0500

Hi Gert,

Yes. We do benefit from the reference that you mentioned.

Thanks,

- Xufeng

From: Gert Grammel [mailto:[email-masked]] 
Sent: Thursday, February 23, 2017 1:15 PM
Cc: [email-masked]
Subject: Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-02-15

Xufeng,

Thanks

Gert

*	https://tools.ietf.org/html/rfc4328 Generalized Multi-Protocol Label Switching (GMPLS) Signaling Extensions for G.709 Optical Transport Networks Control
*	https://tools.ietf.org/html/rfc4206 Label Switched Paths (LSP) Hierarchy with Generalized Multi-Protocol Label Switching (GMPLS) Traffic Engineering (TE)
*	https://tools.ietf.org/html/rfc5212 Requirements for GMPLS-Based Multi-Region and Multi-Layer Networks (MRN/MLN)
*	https://tools.ietf.org/html/rfc5339 Evaluation of Existing GMPLS Protocols against Multi-Layer and Multi-Region Networks (MLN/MRN)
*	https://tools.ietf.org/html/rfc6001 Generalized MPLS (GMPLS) Protocol Extensions for Multi-Layer and Multi-Region Networks (MLN/MRN)
*	https://tools.ietf.org/html/rfc7926 Problem Statement and Architecture for Information Exchange between Interconnected Traffic-Engineered Networks
*	https://tools.ietf.org/html/rfc5623 Framework for PCE-Based Inter-Layer MPLS and GMPLS Traffic Engineering
*	https://tools.ietf.org/html/rfc7138 Traffic Engineering Extensions to OSPF for GMPLS Control of Evolving G.709 Optical Transport Networks

 

Hi Gert,

Thanks,

- Xufeng

Xufeng,

Gert

Hi Gert,

Thanks,

- Xufeng  

Xufeng, Sergio, Dieter,

 

Thanks

Gert

Hi Sergio,

Thanks,

- Xufeng

Hi Xufeng, Igor

What do you think?

Thanks

Sergio

Attendees:

    modeling transformation. 

- Draft text

- Logistics

Thanks,

- Xufeng