Subject: [Teas] Alia Atlas' Discuss on draft-ietf-teas-p2mp-loose-path-reopt-08: (with DISCUSS)

From: "Alia Atlas" <[email-masked]>
Date: Wed, 01 Feb 2017 19:53:38 -0800

Alia Atlas has entered the following ballot position for
draft-ietf-teas-p2mp-loose-path-reopt-08: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-teas-p2mp-loose-path-reopt/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Thank you for a clearly written document.  I have a couple technical
concerns that I think should
be quick to handle.

  Section 4.1: "A mid-point LSR MAY send an unsolicited PathErr with the
Notify error
   code and sub-code "Preferable P2MP-TE Tree Exists" to the ingress
   node to notify of a preferred P2MP-TE LSP tree when it determines it
   exists. "   I think it would be better to have some text about
dampening so that PathErrs are
   emitted at a reasonable rate. 

   Related, I see " The sending of an RSVP PathErr with the Notify error
code and
   "Preferable P2MP-TE Tree Exists" sub-code to the ingress node
   notifies the ingress node of the existence of a preferable P2MP-TE
   LSP tree and upon receiving this PathErr, the ingress node MUST
   trigger re-optimization of the LSP using the MBB method with a
different LSP-ID."
   At a minimum can you please explain why this would be a MUST instead
of a MAY or a SHOULD?
   I believe this would need to be in the document to be clear  what
the
  assumptions are.  The rest of the document is providing mechanisms for
fragmenting
  and requesting reoptimization checks.

---

From: "Rakesh Gandhi (rgandhi)" <[email-masked]>
Date: Thu, 2 Feb 2017 13:27:53 +0000

Hi Alia,

Thank you for the review of the document. Please see inline <RG> ...

On 2017-02-01, 10:53 PM, "Alia Atlas" <[email-masked]> wrote:

    

    
<RG> This proposed PathErr itself is an optimization as only one PathErr message is sent for the entire P2MP-TE tree.

<RG> Agree, SHOULD is more appropriate for this case.

Thanks,
Rakesh (for authors and contributors).

---

From: Alia Atlas <[email-masked]>
Date: Thu, 2 Feb 2017 08:47:23 -0500

On Thu, Feb 2, 2017 at 8:27 AM, Rakesh Gandhi (rgandhi) <[email-masked]>
wrote:

> <RG> This proposed PathErr itself is an optimization as only one PathErr
> message is sent for the entire P2MP-TE tree.
>

Well, it's unsolicited, so any mid-point LSR can send one at any point and
as frequently as it chooses.
I'm just looking for some text  indicating the trade-offs such as

"A mid-point LSR should consider how frequently it
chooses to send such a PathErr - considering both that a PathErr may be
lost on its transit to the
ingress node and that the ingress node may choose not to reoptimze when
such a PathErr is received."

> <RG> Agree, SHOULD is more appropriate for this case.

Sounds good..

Thanks for the quick response.

Regards,
Alia

---

From: "Rakesh Gandhi (rgandhi)" <[email-masked]>
Date: Thu, 2 Feb 2017 13:50:42 +0000

Hi Alia,

Thank you for your feedback. Please see inline <RG1> ..

From: Alia Atlas <[email-masked]>
Date: Thursday, February 2, 2017 at 8:47 AM
To: "=SMTP:rgandhi@cisco. com" <[email-masked]>
Cc: The IESG <[email-masked]>, "[email-masked]" <[email-masked]>, Loa Andersson <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Alia Atlas' Discuss on draft-ietf-teas-p2mp-loose-path-reopt-08: (with DISCUSS)

On Thu, Feb 2, 2017 at 8:27 AM, Rakesh Gandhi (rgandhi) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Alia,

On 2017-02-01, 10:53 PM, "Alia Atlas" <[email-masked]<mailto:[email-masked]>> wrote:

Well, it's unsolicited, so any mid-point LSR can send one at any point and as frequently as it chooses.
I'm just looking for some text  indicating the trade-offs such as

"A mid-point LSR should consider how frequently it
chooses to send such a PathErr - considering both that a PathErr may be lost on its transit to the
ingress node and that the ingress node may choose not to reoptimze when such a PathErr is received."

<RG1> Yes, we can add this text.

Thanks,
Rakesh (for authors and contributors)

Sounds good..

Regards,
Alia

Thanks,

---

From: Alia Atlas <[email-masked]>
Date: Thu, 2 Feb 2017 08:52:04 -0500

Hi Rakesh,

Excellent.  As soon as I see an updated draft, I'm happy to clear.
The IESG telechat isn't until 10am EST today....

Regards,
Alia

On Thu, Feb 2, 2017 at 8:50 AM, Rakesh Gandhi (rgandhi) <[email-masked]>
wrote:

> *From: *Alia Atlas <[email-masked]>
> *Date: *Thursday, February 2, 2017 at 8:47 AM
> *To: *"=SMTP:rgandhi@cisco. com" <[email-masked]>
> *Cc: *The IESG <[email-masked]>, "draft-ietf-teas-p2mp-loose-
> [email-masked]" <[email-masked]>,
> Loa Andersson <[email-masked]>, "[email-masked]" <[email-masked]>,
> "[email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *Re: Alia Atlas' Discuss on draft-ietf-teas-p2mp-loose-path-reopt-08:
> (with DISCUSS)
>
>
>

---

From: "Rakesh Gandhi (rgandhi)" <[email-masked]>
Date: Thu, 2 Feb 2017 14:29:18 +0000

Hi Alia,
Thank you for your review. Please see updated draft posted that addresses your comments. This update also addresses the nits received from IANA and Suresh Krishnan.

Name:                   draft-ietf-teas-p2mp-loose-path-reopt

Revision:               09

Title:                      RSVP Extensions For Re-optimization of Loosely Routed Point-to-Multipoint Traffic Engineering Label Switched Paths (LSPs)

Document date: 2017-02-02

Group:                   teas

Pages:                    17

URL:            https://www.ietf.org/internet-drafts/draft-ietf-teas-p2mp-loose-path-reopt-09.txt

Status:         https://datatracker.ietf.org/doc/draft-ietf-teas-p2mp-loose-path-reopt/

Htmlized:       https://tools.ietf.org/html/draft-ietf-teas-p2mp-loose-path-reopt-09

Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-p2mp-loose-path-reopt-09

Thanks,
Rakesh

Date: Thursday, February 2, 2017 at 8:52 AM

Hi Rakesh,

Regards,
Alia

On Thu, Feb 2, 2017 at 8:50 AM, Rakesh Gandhi (rgandhi) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Alia,

From: Alia Atlas <[email-masked]<mailto:[email-masked]>>
Date: Thursday, February 2, 2017 at 8:47 AM
To: "=SMTP:rgandhi@cisco. com" <[email-masked]<mailto:[email-masked]>>
Cc: The IESG <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Loa Andersson <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Alia Atlas' Discuss on draft-ietf-teas-p2mp-loose-path-reopt-08: (with DISCUSS)

Thanks,

Sounds good..

Regards,
Alia

Thanks,