Subject: [Teas] FW: New Version Notification for draft-ietf-teas-actn-framework-03.txt

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 2 Feb 2017 11:19:18 +0000

Hi WG,

We posted a new version of the ACTN fwk (03).

It addresses all the comments from Adrian (https://mailarchive.ietf.org/arch/msg/teas/K6jCQFL3ruPpSt1VRAaawpxgw64 ) and most of the comments from Michael (https://www.ietf.org/mail-archive/web/teas/current/msg01861.html ), in particular the following ones:

-	Remove orchestration from Page 5 and substitute with: domains coordination
-	Comment on PNC and NMS: Added  this sentence to the definition in order to solve the following issues on NMS:
		oPNC: A Physical Network Controller is a domain controller that is responsible for controlling virtual or physical devices or NEs under its direct control. This can be an SDN controller, a Network Management System (NMS), an Element Management System (EMS) or any other mean to dynamically control a set of nodes and that is implementing an NBI compliant with ACTN specification.
-	Fixed the reference to the ONF architecture
-	Removed the PCE in figure 3 below the PNC , actually the PCE is a PNC
-	Removed this sentence: “A hierarchy of PNCs can be foreseen for scalability and administrative choices.”…the hierarchy of PNCs can’t exist.

Thanks
Daniele for the authors.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: giovedì 2 febbraio 2017 12:13
> To: Daniele Ceccarelli <[email-masked]>; Young Lee
> <[email-masked]>
> Subject: New Version Notification for draft-ietf-teas-actn-framework-03.txt
> 
> 
> A new version of I-D, draft-ietf-teas-actn-framework-03.txt
> has been successfully submitted by Daniele Ceccarelli and posted to the IETF
> repository.
> 
> Name:		draft-ietf-teas-actn-framework
> Revision:	03
> Title:		Framework for Abstraction and Control of Traffic Engineered
> Networks
> Document date:	2017-02-02
> Group:		teas
> Pages:		34
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-teas-actn-
> framework-03.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-teas-actn-framework/
> Htmlized:       https://tools.ietf.org/html/draft-ietf-teas-actn-framework-03
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-actn-framework-03
> 
> Abstract:
>    Traffic Engineered networks have a variety of mechanisms to
>    facilitate the separation of the data plane and control plane. They
>    also have a range of management and provisioning protocols to
>    configure and activate network resources.  These mechanisms
>    represent key technologies for enabling flexible and dynamic
>    networking.
> 
>    Abstraction of network resources is a technique that can be applied
>    to a single network domain or across multiple domains to create a
>    single virtualized network that is under the control of a network
>    operator or the customer of the operator that actually owns
>    the network resources.
> 
>    This document provides a framework for Abstraction and Control of
>    Traffic Engineered Networks (ACTN).
> 
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Leeyoung <[email-masked]>
Date: Thu, 2 Feb 2017 16:36:03 +0000

Hi WG,

The new version also made a new section 4.1 where VN creation process is illustrated to show how a VN is created recursively in the hierarchy of MDSCs. 

With all the changes made in this version, the co-authors believe the document is ready for WG LC. If there are any comments on this version, please provide your comments in the list. 

Thanks,
Young (on behalf of co-authors).

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, February 02, 2017 5:19 AM
To: TEAS WG ([email-masked]) <[email-masked]>
Subject: [Teas] FW: New Version Notification for draft-ietf-teas-actn-framework-03.txt

Hi WG,

Thanks
Daniele for the authors.

> has been successfully submitted by Daniele Ceccarelli and posted to 
> the IETF repository.
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Sun, 5 Feb 2017 18:41:20 +0000

Hi Daniele,

Thanks for addressing "most" of my comments. One question, though...

> Sent: Thursday, February 02, 2017 12:19 PM
> To: TEAS WG ([email-masked])
> It addresses all the comments from Adrian
> (https://mailarchive.ietf.org/arch/msg/teas/K6jCQFL3ruPpSt1VRAaawpxgw64 ) and
> most of the comments from Michael (https://www.ietf.org/mail-
> archive/web/teas/current/msg01861.html ), in particular the following ones:
> 
> 		oPNC: A Physical Network Controller is a domain controller that
> is responsible for controlling virtual or physical devices or NEs under its
> direct control. This can be an SDN controller, a Network Management System
> (NMS), an Element Management System (EMS) or any other mean to dynamically
> control a set of nodes and that is implementing an NBI compliant with ACTN
> specification.

Is it intentional that the reference is to ONF TR-502 (1.0, year 2014), and not the more recent document ONF TR-521 (1.1, year 2016)? 

Thanks

Michael

> -	Removed this sentence: “A hierarchy of PNCs can be foreseen for
> scalability and administrative choices.”…the hierarchy of PNCs can’t exist.
> 
> Thanks
> Daniele for the authors.
> 
> 
>

---

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Sun, 5 Feb 2017 18:47:04 +0000

Hi Young,

While I agree that an example in Section 4.1 is a good idea, I personally find the ASCII art in Figure 6 quite confusing. Maybe I miss something, but neither the meaning of ".." and "..." is obvious to me, and also for "o" I have to guess quite a bit what this could be.

I think instead of trying to fit a lot into one Figure 6, it could be better to depict the topologies by ASCII art symbols similar to what is used elsewhere in the document, and use labels, e.g. with the terminology in Section 1.1. If the Figure gets too large with such symbols, I think separating it into several pieces would be possible.

My 2 cents...

Michael

> From: Teas [mailto:[email-masked]] On Behalf Of Leeyoung
> Sent: Thursday, February 02, 2017 5:36 PM
> To: Daniele Ceccarelli; TEAS WG ([email-masked])
> Subject: Re: [Teas] FW: New Version Notification for draft-ietf-teas-actn-
> framework-03.txt
> 
> Hi WG,
> 
> The new version also made a new section 4.1 where VN creation process is
> illustrated to show how a VN is created recursively in the hierarchy of MDSCs.
> 
> With all the changes made in this version, the co-authors believe the document
> is ready for WG LC. If there are any comments on this version, please provide
> your comments in the list.
> 
> Thanks,

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 6 Feb 2017 08:49:50 +0000

Hi Michael,

No it's not intentional, my mistake. It reflects my conflicting relationship with Google.

I'll fix it.

Thanks
Daniele  

> From: Teas [mailto:[email-masked]] On Behalf Of Scharf, Michael
> (Nokia - DE)
> Sent: domenica 5 febbraio 2017 19:41
> To: Daniele Ceccarelli <[email-masked]>; TEAS WG
> ([email-masked]) <[email-masked]>
> > (https://mailarchive.ietf.org/arch/msg/teas/K6jCQFL3ruPpSt1VRAaawpxgw6
> > 4 ) and most of the comments from Michael (https://www.ietf.org/mail-
> > -	Comment on PNC and NMS: Added  this sentence to the definition in
> order
> > to solve the following issues on NMS:
> is
> > responsible for controlling virtual or physical devices or NEs under
> > its direct control. This can be an SDN controller, a Network
> > Management System (NMS), an Element Management System (EMS) or any
> > other mean to dynamically control a set of nodes and that is
> > implementing an NBI compliant with ACTN specification.
> Is it intentional that the reference is to ONF TR-502 (1.0, year 2014), and not
> the more recent document ONF TR-521 (1.1, year 2016)?
> 
> Thanks
> 
> Michael
> 
>

---

From: Leeyoung <[email-masked]>
Date: Mon, 6 Feb 2017 16:00:17 +0000

Hi Michael,

Thanks for your agreement and support for Section 4.1. I will try to improve the ASCII art and update as such. To give you a quick answer to the meaning of ".." and "...", they are just domain boundary and "o" is node. 

Best regards,
Young

-----Original Message-----
From: Scharf, Michael (Nokia - DE) [mailto:[email-masked]] 
Sent: Sunday, February 05, 2017 12:47 PM
To: Leeyoung <[email-masked]>; Daniele Ceccarelli <[email-masked]>; TEAS WG ([email-masked]) <[email-masked]>
Subject: RE: [Teas] FW: New Version Notification for draft-ietf-teas-actn-framework-03.txt

Hi Young,

My 2 cents...

Michael

> Subject: Re: [Teas] FW: New Version Notification for 
> draft-ietf-teas-actn- framework-03.txt
> 
> Hi WG,
> 
> The new version also made a new section 4.1 where VN creation process 
> is illustrated to show how a VN is created recursively in the hierarchy of MDSCs.
> 
> With all the changes made in this version, the co-authors believe the 
> document is ready for WG LC. If there are any comments on this 
> version, please provide your comments in the list.
> 
> Thanks,
> 		oPNC: A Physical Network Controller is a domain controller that is