Subject: [Teas] draft-ietf-ccamp-ospf-availability-extension-08 and draft-ietf-teas-gmpls-scsi-01

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 6 Feb 2017 22:16:08 +0000

Dear WG, chairs,

the CCAMP document in object (draft-ietf-ccamp-ospf-availability-extesions-08) is ready and waiting for the progressing of draft-ietf-teas-gmpls-scsi-01.
Could  you please review the TEAS document so to help moving the CCAMP ID along?

Many thanks
Daniele

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Tue, 7 Feb 2017 14:08:58 -0500

Daniele, Hi!
At the last IETF, you were trying to seek opinion on the semantics of the
value field in the SCSI TLV. You had it listed as an Open-Item in your
presentation
(Slide 5 -
https://www.ietf.org/proceedings/97/slides/slides-97-teas-draft-ceccarelli-teas-gneralized-scsi-00.pptx).
Is it safe to assume that this closed now (no changes to the original
proposal)?

WG,
Please do review the current version (-01) of the draft and reach out to
the authors if there are any questions/concerns. We would like to take this
to LC soon.

Regards,
- Pavan

On Mon, Feb 6, 2017 at 5:16 PM, Daniele Ceccarelli <
[email-masked]> wrote:

> Dear WG, chairs,
>
>
>
> the CCAMP document in object (draft-ietf-ccamp-ospf-availability-extesions-08)
> is ready and waiting for the progressing of draft-ietf-teas-gmpls-scsi-01.
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>
>

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 8 Feb 2017 08:50:44 +0000

Hi Pavan,

That’s correct.
Actually there was the proposal to split the value range into two ranges, one for specific technologies and one for others. There is no major concern about this split proposal hence I assume it is safe to assume we can keep it.

Thanks
Daniele

From: Teas [mailto:[email-masked]] On Behalf Of Vishnu Pavan Beeram
Sent: martedì 7 febbraio 2017 20:09
To: Daniele Ceccarelli <[email-masked]>
Cc: TEAS WG ([email-masked]) <[email-masked]>
Subject: Re: [Teas] draft-ietf-ccamp-ospf-availability-extension-08 and draft-ietf-teas-gmpls-scsi-01

Daniele, Hi!
At the last IETF, you were trying to seek opinion on the semantics of the value field in the SCSI TLV. You had it listed as an Open-Item in your presentation
(Slide 5 - https://www.ietf.org/proceedings/97/slides/slides-97-teas-draft-ceccarelli-teas-gneralized-scsi-00.pptx). Is it safe to assume that this closed now (no changes to the original proposal)?
WG,
Please do review the current version (-01) of the draft and reach out to the authors if there are any questions/concerns. We would like to take this to LC soon.
Regards,
- Pavan

On Mon, Feb 6, 2017 at 5:16 PM, Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>> wrote:
Dear WG, chairs,

Many thanks
Daniele

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

---

From: Julien Meuric <[email-masked]>
Date: Thu, 9 Feb 2017 15:35:10 +0100

Hi Daniele,

I am fine with the proposed split: I do not see much drawback in
defining 2 categories in a 16-bit space.

The I-D is clear enough to be moved to LC. Just a few minor
comments:

- In the title, the term "routing" makes parsing quite hard: why not
just "Generalized ISCD SCSI"?

- Since we are considering a generic TLV, what would you think about
allocating a codepoint as a DATA-LINK subject in LMP (besides the
IGPs)?

- Nits:

* Along the document, capital letters and hyphens on "Switching
Capability-Specific Information" must be made consistent.

* s/technology specific formats/technology-specific formats/

* s/ISIS/IS-IS/

* s/technology specific information/technology-specific
information/

* s/a SCSI-TLV/an SCSI-TLV/

* s/these SCSI-TLV/these SCSI-TLVs/

* s/technology specific formats/technology-specific formats/

* s/definition on the type/definition of the type/

Regards,

Julien

Feb. 08, 2017 -
[email-masked]:

Hi Pavan,

That’s correct.

Actually there was the proposal to split the
value range into two ranges, one for specific technologies
and one for others. There is no major concern about this
split proposal hence I assume it is safe to assume we can
keep it.

Thanks

Daniele

From: Teas [mailto:[email-masked]]
On Behalf Of Vishnu Pavan Beeram

Daniele,
Hi!

At the last IETF, you were trying to seek opinion on the
semantics of the value field in the SCSI TLV. You had it
listed as an Open-Item in your presentation

(Slide 5 - https://www.ietf.org/proceedings/97/slides/slides-97-teas-draft-ceccarelli-teas-gneralized-scsi-00.pptx).
Is it safe to assume that this closed now (no changes to
the original proposal)?

WG,

Please
do review the current version (-01) of the draft and
reach out to the authors if there are any
questions/concerns. We would like to take this to LC
soon.

Regards,

- Pavan

On Mon, Feb 6, 2017 at 5:16 PM,
Daniele Ceccarelli <[email-masked]>
wrote:

Dear
WG, chairs,

the CCAMP document in object
(draft-ietf-ccamp-ospf-availability-extesions-08)
is ready and waiting for the progressing of
draft-ietf-teas-gmpls-scsi-01.

Could  you please review the TEAS
document so to help moving the CCAMP ID along?

Many thanks

Daniele

Teas mailing list

[email-masked]

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 9 Feb 2017 16:01:15 +0000

Hi Julien,

Thanks a lot for the review.

I'd say OK to all.

-          OK with removing the term routing from the title

-          OK to allocate a codepoint as a DATA LINK subject in LMP (are you volunteering to write a draft in CCAMP?) :)

-          OK for the nits, will fix them.
Thanks
Daniele

From: Julien Meuric [mailto:[email-masked]]
Sent: giovedì 9 febbraio 2017 15:35
To: Daniele Ceccarelli <[email-masked]>
Cc: TEAS WG ([email-masked]) <[email-masked]>
Subject: Re: [Teas] draft-ietf-ccamp-ospf-availability-extension-08 and draft-ietf-teas-gmpls-scsi-01

Hi Daniele,

I am fine with the proposed split: I do not see much drawback in defining 2 categories in a 16-bit space.

The I-D is clear enough to be moved to LC. Just a few minor comments:
- In the title, the term "routing" makes parsing quite hard: why not just "Generalized ISCD SCSI"?
- Since we are considering a generic TLV, what would you think about allocating a codepoint as a DATA-LINK subject in LMP (besides the IGPs)?
- Nits:
  * Along the document, capital letters and hyphens on "Switching Capability-Specific Information" must be made consistent.
  * s/technology specific formats/technology-specific formats/
  * s/ISIS/IS-IS/
  * s/technology specific information/technology-specific information/
  * s/a SCSI-TLV/an SCSI-TLV/
  * s/these SCSI-TLV/these SCSI-TLVs/
  * s/technology specific formats/technology-specific formats/
  * s/definition on the type/definition of the type/

Regards,

Julien

Feb. 08, 2017 - [email-masked]<mailto:[email-masked]>:
Hi Pavan,

That's correct.

Thanks
Daniele

Daniele, Hi!

Many thanks
Daniele

Teas mailing list

---

From: Julien Meuric <[email-masked]>
Date: Thu, 9 Feb 2017 17:54:19 +0100

Ciao again.

Actually, I was thinking about allocating codepoints both for the
IGPs and for LMP (e.g. DATA-LINK sub-object) using this I-D. Do you
think the CCAMP chairs/WG would be more offended with that idea than
OSPF/ISIS WGs?

Cheers,

Julien

Feb. 09, 2017 -

Hi Julien,

I’d say OK to all.

-
OK with removing the term routing from the
title

-
OK to allocate a codepoint as a DATA LINK
subject in LMP (are you volunteering to write a draft in
CCAMP?)
J

-
OK for the nits, will fix them.

Thanks

Daniele

From: Julien Meuric
[mailto:[email-masked]]

Hi Daniele,

I am fine with the proposed split: I do not see much
drawback in defining 2 categories in a 16-bit space.

- In the title, the term "routing" makes parsing quite hard:
why not just "Generalized ISCD SCSI"?

- Since we are considering a generic TLV, what would you
think about allocating a codepoint as a DATA-LINK subject in
LMP (besides the IGPs)?

- Nits:

* Along the document, capital letters and hyphens on
"Switching Capability-Specific Information" must be made
consistent.

* s/technology specific formats/technology-specific
formats/

* s/ISIS/IS-IS/

* s/technology specific formats/technology-specific
formats/

Regards,

Julien

Feb. 08, 2017 -

Hi Pavan,

That’s correct.

Actually there was the proposal to split
the value range into two ranges, one for specific
technologies and one for others. There is no major
concern about this split proposal hence I assume it is
safe to assume we can keep it.

Thanks

Daniele

Daniele,
Hi!

At the last IETF, you were trying to seek opinion on
the semantics of the value field in the SCSI TLV.
You had it listed as an Open-Item in your
presentation

(Slide 5 - https://www.ietf.org/proceedings/97/slides/slides-97-teas-draft-ceccarelli-teas-gneralized-scsi-00.pptx).
Is it safe to assume that this closed now (no
changes to the original proposal)?

WG,

Please

Regards,

- Pavan

Dear
WG, chairs,

Could  you please review the
TEAS document so to help moving the CCAMP ID
along?

Many thanks

Daniele

Teas mailing list

[email-masked]

Teas mailing list

[email-masked]

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 9 Feb 2017 17:11:36 +0000

Hi Julien, Daniele,

From: Teas <[email-masked]<mailto:[email-masked]>> on behalf of Julien Meuric <[email-masked]<mailto:[email-masked]>>
Organization: Orange
Date: Thursday, February 9, 2017 at 11:54 AM
To: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>
Cc: "TEAS WG ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] draft-ietf-ccamp-ospf-availability-extension-08 and draft-ietf-teas-gmpls-scsi-01

Ciao again.

Actually, I was thinking about allocating codepoints both for the IGPs and for LMP (e.g. DATA-LINK sub-object) using this I-D. Do you think the CCAMP chairs/WG would be more offended with that idea than OSPF/ISIS WGs?

For the GMPLS OSPF-TE media-specific extensions (e.g., optical), the OSPF WG has allowed the CCAMP drafts to allocate the OSPF-TE TLV code points. We started having them presented in both WGs but there proved to be neither the WG time nor the interest to follow them in OSPF.

More generally applicable OSPF-TE extensions should be taken to the OSPF WG.

Thanks,
Acee

Cheers,

Julien

Feb. 09, 2017 - [email-masked]<mailto:[email-masked]>:
Hi Julien,

I'd say OK to all.

Hi Daniele,

Regards,

Julien

That's correct.

Thanks
Daniele

Daniele, Hi!

Many thanks
Daniele

Teas mailing list

---

From: Daniele Ceccarelli <[email-masked]>
Date: Sat, 11 Feb 2017 20:56:52 +0000

Hi Acee,

Correct, I didn't mean to change the agreement, just didn't get correctly what Julien was proposing...i understood he was asking for LMP extensions.

Cheers
Daniele

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: giovedì 9 febbraio 2017 18:12
To: Julien Meuric <[email-masked]>; Daniele Ceccarelli <[email-masked]>
Cc: TEAS WG ([email-masked]) <[email-masked]>; OSPF WG List <[email-masked]>
Subject: Re: [Teas] draft-ietf-ccamp-ospf-availability-extension-08 and draft-ietf-teas-gmpls-scsi-01

Hi Julien, Daniele,

Ciao again.

Thanks,
Acee

Cheers,

Julien

I'd say OK to all.

Hi Daniele,

Regards,

Julien

That's correct.

Thanks
Daniele

Daniele, Hi!

Many thanks
Daniele

Teas mailing list