Subject: [Teas] How to use the TE Tunnel YANG model to setup a Tunnel Segment

From: Italo Busi <[email-masked]>
Date: Wed, 12 Apr 2017 14:45:22 +0000

Within the CCAMP Transport NBI DT, we are analyzing the possibility to request the setup of a transit Tunnel Segment at the northbound interface of an SDN controller (e.g., an ACTN MPI interface) using the TE Tunnel YANG model and got some questions for clarification.

Looking at the current YANG model we have seen the following information:

       |  +--rw tunnel* [name]
       |  |  +--rw name                         -> ../config/name
       |  |  +--rw identifier?                  -> ../config/identifier
       |  |  +--rw config
<...>

       |  |  |  +--rw source?                          inet:ip-address

       |  |  |  +--rw destination?                     inet:ip-address

       |  |  |  +--rw src-tp-id?                          binary

       |  |  |  +--rw dst-tp-id?                          Binary

It is our understanding that the source/destination or the src-tp-id/dst-tp-id represents the endpoints of the E2E Tunnel.

Since in case the endpoints of the E2E Tunnel are outside the domain controlled by the SDN controller (e.g., ACTN PNC), we have understood that the client (e.g., ACTN MDSC) would leave all these four attributes empty. We have understood that this is possible since these attributes are optional.

Is our understanding correct?

In order to specify the ingress and egress links of the Tunnel Segment, the explicit-route-object list is used:

       |  +--rw named-explicit-paths

       |  |  +--rw named-explicit-path* [name]

       |  |     +--rw name      -> ../config/name

       |  |     +--rw config

       |  |     |  +--rw name?                     string

       |  |     |  +--rw explicit-route-objects

       |  |     |     +--rw explicit-route-object* [index]

       |  |     |        +--rw index                 -> ../config/index

       |  |     |        +--rw explicit-route-usage?   identityref

       |  |     |        +--rw config

       |  |     |        |  +--rw index?            uint32

       |  |     |        |  +--rw (type)?

       |  |     |        |     +--:(ip-address)

       |  |     |        |     |  +--rw ip-address-hop

       |  |     |        |     |     +--rw address?    inet:ip-address

       |  |     |        |     |     +--rw hop-type?   te-hop-type
<...>

       |  |     |        |     +--:(unnumbered-link)

       |  |     |        |     |  +--rw unnumbered-hop

       |  |     |        |     |     +--rw router-id?    inet:ip-address

       |  |     |        |     |     +--rw interface-id?   uint32

       |  |     |        |     |     +--rw hop-type?       te-hop-type

In particular, the first element in the explicit-route-object list identifies the ingress link while the last element in the explicit-route-object list identifies the egress link.

Is our understanding correct?

Carlo, Italo, Gianmarco and Sergio on behalf of DT members

Italo Busi
Principal Optical Transport Network Research Engineer
____________________________________________________________________________
Huawei Technologies Italia S.r.l.
Address：Centro Direzionale Milano 2, Palazzo Verrocchio, 3° Floor, 20090 Segrate (MI), Italy
Tel：+39 02 399948 32    Fax：   Mobile：+39 345 4721946
_____________________________________________________________________________
Huawei Technologies Italia S.r.l. is a company registered in Italy at the Company Registration Office of Milan, with registered number 04501190963 and equity capital €3,000,000 fully paid up, whose registered office is in Milan, Via Lorenteggio 257, Tower B, 20152 Milan. Huawei Technologies Italia S.r.l. is 100% owned by Huawei Technologies Cooperatief U.A
_____________________________________________________________________________
This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
PRIVACY NOTICE: Pursuant to Art. 13 of Legislative Decree 196/03, so called "Data Protection Code", Huawei Technologies Italia Srl. informs you that the personal data provided by you will be treated for the acquisition of information preliminary to the conclusion of contracts, for the definition and formalization of contractual relationship with you as well as for their management and for the fulfillment of legal requirements related to civil, tax and accounting law. Data are processed both through computer or paper in a lawful and correct manner and in compliance with the Decree. Personal data and its processing are necessary for business negotiation and will not be subject to disclosure and spread out the circumstances permitted by law, on the same you can exercise your rights under art. 7 of the above mentioned decree. The Data Controller is Huawei Technologies Italia Srl, which has appointed Data Processors, the list of which is available at [email-masked]<mailto:[email-masked]>.

---

From: Igor Bryskin <[email-masked]>
Date: Wed, 12 Apr 2017 14:53:27 +0000

IMHO your understanding is correct on both accounts.

>> In particular, the first element in the explicit-route-object list identifies the ingress link while the last element in the explicit-route-object list identifies the egress link.

First and last links in the explicit path may be followed by one or two lavels

Igor

From: Teas [mailto:[email-masked]] On Behalf Of Italo Busi
Sent: Wednesday, April 12, 2017 10:45 AM
To: TEAS WG ([email-masked])
Cc: Gianmarco Bruno; Belotti, Sergio (Nokia - IT); Carlo Perocchio; Italo Busi
Subject: [Teas] How to use the TE Tunnel YANG model to setup a Tunnel Segment

       |  +--rw tunnel* [name]

       |  |     +--rw config

       |  |     |  +--rw name?                     string

       |  |     |        +--rw config

       |  |     |        |  +--rw (type)?

       |  |     |        |     +--:(ip-address)

Italo Busi