Subject: [Teas] Follow up with Lou's comments on ACTN

From: Leeyoung <[email-masked]>
Date: Mon, 15 May 2017 15:21:51 +0000

Hi Lou,

We'd like to follow-up with you on some of the comments you made during Chicago TEAS WG meeting. You commented during ACTN framework & requirement presentation the following:

*        Lou Berger: I see this as multi-domain orchestration. I am proposing to take the text from the mapping draft into the framework draft to help people understanding the ACTN terminology. We need to help people understand how the terms in this document relate to the terms they already understand.

Our response: in the revision we have created section 5 where we took some text from the mapping draft (https://tools.ietf.org/html/draft-zhang-teas-actn-yang-04) and drew a figure that shows the relationship between ACTN terminology and service/network orchestration. Please see Section 5.2 and Appendix A (for an example) https://tools.ietf.org/html/draft-ietf-teas-actn-framework-05

On the ACTN abstraction model presentation (https://tools.ietf.org/html/draft-lee-teas-actn-abstraction-01) , you made a comment:

*        Lou Berger: after you've moved text to the framework document, will anything be left in this one?
Young Lee: there's still stuff that is useful in here.
Lou: if you aren't using the whole of this document to the framework document, it'd be good if you sent a mail to the list to say which bits are moving. A complete merge is also OK.

Our response: We created a new section 6 (Topology Abstraction Method) in the ACTN framework where we imported some key texts from the ACTN abstraction method  draft: https://tools.ietf.org/html/draft-lee-teas-actn-abstraction-01.  Our plan is to keep some details (such as motivation, specific requirements, etc) on the ACTN abstraction methods draft.

Please let us know if our response satisfies you so that we can close these two pending issues; and if not, please give us further comments.

Thanks.

Young and Daniele

-----Original Message-----

From: Leeyoung

Sent: Friday, May 05, 2017 1:41 PM

To: [email-masked]<mailto:[email-masked]>

Subject: RE: [Teas] I-D Action: draft-ietf-teas-actn-framework-05.txt

Hi,

This update is intended to incorporate the comments from the last WG meeting and any pending issues. We also have taken the global editorial changes to make it consistent through the document. Major changes are:

- Inclusion of "network slicing" definition from ACTN perspective (in the terminology section)

- Added virtual network service (VNS) section (Section 3) to define types of VNS.

- Incorporated "orchestration" (service/network) mapping to ACTN architecture (See Section 5.2)

- Created a new section 6 (Topology Abstraction Method) where we imported some texts from ACTN abstraction method  https://tools.ietf.org/html/draft-lee-teas-actn-abstraction-01

- Added Appendices A & B to discuss example deployment scenarios such as example of MDSC and PNC functions integrated in Service/Network Orchestrator (Appendix A) and example of IP + Optical network with L3VPN service (Appendix B)

In regard to ACTN abstraction method draft, we are going to keep it as a separate draft and use this document to elaborate other aspects not imported to the framework document.

The following diff pointer will help you see the changes with this revision:

https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-actn-framework-05

The co-authors believe that the document is ready for WG LC. Any changes/comments will be appreciated.

Thanks & Best regards,

Young & Daniele (on behalf of other co-authors/contributors)

-----Original Message-----

From: Teas [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>

Sent: Friday, May 05, 2017 10:41 AM

To: [email-masked]<mailto:[email-masked]>

Cc: [email-masked]<mailto:[email-masked]>

Subject: [Teas] I-D Action: draft-ietf-teas-actn-framework-05.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

This draft is a work item of the Traffic Engineering Architecture and Signaling of the IETF.

        Title           : Framework for Abstraction and Control of Traffic Engineered Networks

        Authors         : Daniele Ceccarelli

                          Young Lee

               Filename        : draft-ietf-teas-actn-framework-05.txt

               Pages           : 41

               Date            : 2017-05-05

Abstract:

   Traffic Engineered networks have a variety of mechanisms to

   facilitate the separation of the data plane and control plane. They

   also have a range of management and provisioning protocols to

   configure and activate network resources.  These mechanisms

   represent key technologies for enabling flexible and dynamic

   networking.

   Abstraction of network resources is a technique that can be applied

   to a single network domain or across multiple domains to create a

   single virtualized network that is under the control of a network

   operator or the customer of the operator that actually owns

   the network resources.

   This document provides a framework for Abstraction and Control of

   Traffic Engineered Networks (ACTN).

The IETF datatracker status page for this draft is:

https://datatracker.ietf.org/doc/draft-ietf-teas-actn-framework/

There are also htmlized versions available at:

https://tools.ietf.org/html/draft-ietf-teas-actn-framework-05

https://datatracker.ietf.org/doc/html/draft-ietf-teas-actn-framework-05

A diff from the previous version is available at:

https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-actn-framework-05

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:

ftp://ftp.ietf.org/internet-drafts/

_______________________________________________

Teas mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/teas

---

From: Lou Berger <[email-masked]>
Date: Tue, 23 May 2017 14:23:44 -0400

Young and Daniel,

Thanks for the response.

On 5/15/2017 11:21 AM, Leeyoung wrote:
>
> Hi Lou,
>
>  
>
> We’d like to follow-up with you on some of the comments you made
> during Chicago TEAS WG meeting. You commented during ACTN framework &
> requirement presentation the following:
>
>  
>
> ·        /Lou Berger: I see this as multi-domain orchestration. I am
> proposing to take the text from the mapping draft into the framework
> draft to help people understanding the ACTN terminology. We need to
> help people understand how the terms in this document relate to the
> terms they already understand. ///
>
>  
>
> Our response: in the revision we have created section 5 where we took
> some text from the mapping draft
> (https://tools.ietf.org/html/draft-zhang-teas-actn-yang-04)
>

The mapping draft I was referring to was the mapping draft on the agenda
at the meeting:
https://tools.ietf.org/html/draft-lee-teas-te-service-mapping-yang

> and drew a figure that shows the relationship between ACTN terminology
> and service/network orchestration. Please see Section 5.2 and Appendix
> A (for an example)

I think the changes are generally helpful -- of course we still detailed
comments from the WG.

> On the ACTN abstraction model presentation
> (https://tools.ietf.org/html/draft-lee-teas-actn-abstraction-01) , you
> made a comment:
>
> ·        /Lou Berger: after you've moved text to the framework
> document, will anything be left in this one?
> /
>
Right, this was/following up on Danielle's comment during his
presentation that parts/much of the document could be moved to the
framework.

/
>
> /Young Lee: there's still stuff that is useful in here.
> Lou: if you aren't using the whole of this document to the framework
> document, it'd be good if you sent a mail to the list to say which
> bits are moving. A complete merge is also OK./
>
>  
>
> Our response: We created a new section 6 (Topology Abstraction Method)
> in the ACTN framework where we imported some key texts from the ACTN
> abstraction method  draft:
> https://tools.ietf.org/html/draft-lee-teas-actn-abstraction-01.  Our
> plan is to keep some details (such as motivation, specific
> requirements, etc) on the ACTN abstraction methods draft. 
>
So if you eliminate the text that is now redundant with other documents,
what's new in this draft?
Section 1 is intro, sections 2 and 3 are in other documents -- so this
leaves just section 4 right?  Is there another existing WG document
where this 1.5 pages of text can go?

Thanks,
Lou

>  
>
> Please let us know if our response satisfies you so that we can close
> these two pending issues; and if not, please give us further comments.
>
>  
>
> Thanks.
>
> Young and Daniele
>
> To: [email-masked] <mailto:[email-masked]>
>
> This update is intended to incorporate the comments from the last WG
> meeting and any pending issues. We also have taken the global
> editorial changes to make it consistent through the document. Major
> changes are:
>
>  
>
> - Created a new section 6 (Topology Abstraction Method) where we
> imported some texts from ACTN abstraction method 
> https://tools.ietf.org/html/draft-lee-teas-actn-abstraction-01
>
> - Added Appendices A & B to discuss example deployment scenarios such
> as example of MDSC and PNC functions integrated in Service/Network
> Orchestrator (Appendix A) and example of IP + Optical network with
> L3VPN service (Appendix B)
>
>  
>
> In regard to ACTN abstraction method draft, we are going to keep it as
> a separate draft and use this document to elaborate other aspects not
> imported to the framework document.
>
>  
>
> From: Teas [mailto:[email-masked]] On Behalf Of
> [email-masked] <mailto:[email-masked]>
>
> To: [email-masked] <mailto:[email-masked]>
>
> Cc: [email-masked] <mailto:[email-masked]>
>
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
>  
>
> [email-masked] <mailto:[email-masked]>
>
> [email-masked]

---

From: Leeyoung <[email-masked]>
Date: Tue, 30 May 2017 14:52:21 +0000

Hi Lou,

Thanks for your comments. Please see inline for our response. 

Thanks.
Young

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Tuesday, May 23, 2017 1:24 PM
To: Leeyoung <[email-masked]>; [email-masked]
Subject: Re: [Teas] Follow up with Lou's comments on ACTN

Young and Daniel,

Thanks for the response.

On 5/15/2017 11:21 AM, Leeyoung wrote:
>
> Hi Lou,
>
>  
>
> We'd like to follow-up with you on some of the comments you made 
> *        /Lou Berger: I see this as multi-domain orchestration. I am

The mapping draft I was referring to was the mapping draft on the agenda at the meeting:
https://tools.ietf.org/html/draft-lee-teas-te-service-mapping-yang

YOUNG>> OK. Thanks for pointing this out. We will review the draft (the right one you pointed out) and see if there is any helpful text/terminology that can be exported to the framework. But it looks like, given your next comment, the updated framework draft has already accommodated your comment. Let us know if this is correct. 

> https://tools.ietf.org/html/draft-ietf-teas-actn-framework-05

I think the changes are generally helpful -- of course we still detailed comments from the WG.

YOUNG>> Great. 

> *        /Lou Berger: after you've moved text to the framework
Right, this was/following up on Danielle's comment during his presentation that parts/much of the document could be moved to the framework.

/
> requirements, etc) on the ACTN abstraction methods draft.
So if you eliminate the text that is now redundant with other documents, what's new in this draft?
Section 1 is intro, sections 2 and 3 are in other documents -- so this leaves just section 4 right?  Is there another existing WG document where this 1.5 pages of text can go?

YOUNG>> Our intention was to export terminology (white/grey/black topology) to the framework while keeping the bulk of the content in draft-lee-teas-actn-abstraction. What will remain in this draft is: Introduction, Section 3 (factors), Section 3.4 (how to build grey topology) and Section 4 (Protocol/Data Model Requirements). We still think that we have enough useful text in this draft. 

Thanks,
Lou