Subject: Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-05-03

From: Xufeng Liu <[email-masked]>
Date: Fri, 5 May 2017 20:45:25 +0000

Attendees:
Xufeng, Igor, Carlo, Dieter, Tarek

- TE topology model draft
  > Discussed NMDA update
  > Authors prefer to proceed with the current model to last call
  > If NMDA guidelines do not slow down the process, we can do some adjustments

- Tutorial/Manual
  > Igor provided tree snippets in Section 1.
  > Xufeng is working on JSON data for Use Case 1.
    o Cover OTN abstract nodes and links.
    o Some underlay OCh data will be put into appendix as reference.
  > Sergio to provide comments to discuss.

Thanks,

- Xufeng

Note: Please drop me an email if you need an invite for joining the weekly call.

---

From: Fatai Zhang <[email-masked]>
Date: Tue, 9 May 2017 06:35:26 +0000

Hi Xufeng,
Thanks for the minutes.
Do you mean “ the current model” is “draft-ietf-teas-yang-te-topo-08” (that has not been updated after IETF 98) or 09 version to be uploaded?
===============================================================================================================
- TE topology model draft
> If NMDA guidelines do not slow down the process, we can do some adjustments

Thanks

Fatai

发件人: Teas [mailto:[email-masked]] 代表 Xufeng Liu
发送时间: 2017年5月6日 4:45
收件人: Vishnu Pavan Beeram; Igor Bryskin; Oscar Gonzalez De Dios; Tarek Saad; Himanshu Shah; Lou Berger; BRUNGARD, DEBORAH A (ATTLABS); Susan Hares; Zafar Ali (zali); Khaddam, Mazen (CCI-Atlanta); BELOTTI, SERGIO (SERGIO); Beller, Dieter (Dieter); Rajan Rao; Zhangxian (Xian); [email-masked]; Belotti, Sergio (Nokia - IT); Anurag Sharma; Italo Busi
抄送: [email-masked]
主题: Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-05-03

Attendees:

- Tutorial/Manual

Thanks,

- Xufeng

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 10 May 2017 13:26:12 +0000

Hi Fatai,

This discussion is under the context of NMDA (https://tools.ietf.org/html/draft-dsdt-nmda-guidelines-01).  The “current model” means the model structure that we are using now without re-structuring to the NMDA style. We may include the NMDA style during the last call process if doing so would not slow down the process.

We’d like to process with the last call with “draft-ietf-teas-yang-te-topo-08”. We understand that there will be changes during the process and 09 will come at that time.

Thanks,
- Xufeng

From: Fatai Zhang [mailto:[email-masked]]
Sent: Tuesday, May 9, 2017 2:35 AM
To: Xufeng Liu <[email-masked]>; Vishnu Pavan Beeram <[email-masked]>; Igor Bryskin <[email-masked]>; Oscar Gonzalez De Dios <[email-masked]>; Tarek Saad <[email-masked]>; Himanshu Shah <[email-masked]>; Lou Berger <[email-masked]>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]>; Susan Hares <[email-masked]>; Zafar Ali (zali) <[email-masked]>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]>; BELOTTI, SERGIO (SERGIO) <[email-masked]>; Beller, Dieter (Dieter) <[email-masked]>; Rajan Rao <[email-masked]>; Zhangxian (Xian) <[email-masked]>; [email-masked]; Belotti, Sergio (Nokia - IT) <[email-masked]>; Anurag Sharma <[email-masked]>; Italo Busi <[email-masked]>
Cc: [email-masked]
Subject: 答复: IETF TE Topology YANG Model Design Meeting Notes - 2017-05-03

Hi Xufeng,
Thanks for the minutes.

Thanks

Fatai

发件人: Teas [mailto:[email-masked]] 代表 Xufeng Liu
发送时间: 2017年5月6日 4:45
收件人: Vishnu Pavan Beeram; Igor Bryskin; Oscar Gonzalez De Dios; Tarek Saad; Himanshu Shah; Lou Berger; BRUNGARD, DEBORAH A (ATTLABS); Susan Hares; Zafar Ali (zali); Khaddam, Mazen (CCI-Atlanta); BELOTTI, SERGIO (SERGIO); Beller, Dieter (Dieter); Rajan Rao; Zhangxian (Xian); [email-masked]<mailto:[email-masked]>; Belotti, Sergio (Nokia - IT); Anurag Sharma; Italo Busi
抄送: [email-masked]<mailto:[email-masked]>
主题: Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-05-03

Attendees:

- Tutorial/Manual

Thanks,

- Xufeng

---

From: Fatai Zhang <[email-masked]>
Date: Thu, 11 May 2017 06:19:39 +0000

Hi Xufeng,

Thanks, got it.

I agree on that your (the authors’) proposal is very efficient way to move forward and hope the WG LC will be announced soon.

Thanks

Fatai

发件人: Xufeng Liu [mailto:[email-masked]]
发送时间: 2017年5月10日 21:26
收件人: Fatai Zhang; Vishnu Pavan Beeram; Igor Bryskin; Oscar Gonzalez De Dios; Tarek Saad; Himanshu Shah; Lou Berger; BRUNGARD, DEBORAH A (ATTLABS); Susan Hares; Zafar Ali (zali); Khaddam, Mazen (CCI-Atlanta); BELOTTI, SERGIO (SERGIO); Beller, Dieter (Dieter); Rajan Rao; Zhangxian (Xian); [email-masked]; Belotti, Sergio (Nokia - IT); Anurag Sharma; Italo Busi
抄送: [email-masked]
主题: RE: IETF TE Topology YANG Model Design Meeting Notes - 2017-05-03

Hi Fatai,

Thanks,
- Xufeng

From: Fatai Zhang [mailto:[email-masked]]
Sent: Tuesday, May 9, 2017 2:35 AM
To: Xufeng Liu <[email-masked]<mailto:[email-masked]>>; Vishnu Pavan Beeram <[email-masked]<mailto:[email-masked]>>; Igor Bryskin <[email-masked]<mailto:[email-masked]>>; Oscar Gonzalez De Dios <[email-masked]<mailto:[email-masked]>>; Tarek Saad <[email-masked]<mailto:[email-masked]>>; Himanshu Shah <[email-masked]<mailto:[email-masked]>>; Lou Berger <[email-masked]<mailto:[email-masked]>>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; Zafar Ali (zali) <[email-masked]<mailto:[email-masked]>>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]<mailto:[email-masked]>>; BELOTTI, SERGIO (SERGIO) <[email-masked]<mailto:[email-masked]>>; Beller, Dieter (Dieter) <[email-masked]<mailto:[email-masked]>>; Rajan Rao <[email-masked]<mailto:[email-masked]>>; Zhangxian (Xian) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Belotti, Sergio (Nokia - IT) <[email-masked]<mailto:[email-masked]>>; Anurag Sharma <[email-masked]<mailto:[email-masked]>>; Italo Busi <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: 答复: IETF TE Topology YANG Model Design Meeting Notes - 2017-05-03

Hi Xufeng,
Thanks for the minutes.

Thanks

Fatai

Attendees:

- Tutorial/Manual

Thanks,

- Xufeng

---

From: Lou Berger <[email-masked]>
Date: Thu, 11 May 2017 08:21:37 -0400

Xufeng/Authors,

    Thanks for the update and proactively looking at this.  Did you also
discuss the 'refactored' NMDA compatible version put together (see
https://github.com/rgwilton/ietf-models-to-combined)? What were your
thoughts?

Thanks,

Lou

On 5/10/2017 9:26 AM, Xufeng Liu wrote:
>
> Hi Fatai,
>
>  
>
> This discussion is under the context of NMDA
> (https://tools.ietf.org/html/draft-dsdt-nmda-guidelines-01).  The
> “current model” means the model structure that we are using now
> without re-structuring to the NMDA style. We may include the NMDA
> style during the last call process if doing so would not slow down the
> process.
>
>  
>
> We’d like to process with the last call with
> “draft-ietf-teas-yang-te-topo-08”. We understand that there will be
> changes during the process and 09 will come at that time.
>
>  
>
> Thanks,
>
> - Xufeng
>
>  
>
> *From:* Fatai Zhang [mailto:[email-masked]]
> *Sent:* Tuesday, May 9, 2017 2:35 AM
> *To:* Xufeng Liu <[email-masked]>; Vishnu Pavan Beeram
> <[email-masked]>; Igor Bryskin <[email-masked]>; Oscar
> Gonzalez De Dios <[email-masked]>; Tarek Saad
> <[email-masked]>; Himanshu Shah <[email-masked]>; Lou Berger
> <[email-masked]>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]>;
> Susan Hares <[email-masked]>; Zafar Ali (zali) <[email-masked]>;
> Khaddam, Mazen (CCI-Atlanta) <[email-masked]>; BELOTTI, SERGIO
> (SERGIO) <[email-masked]>; Beller, Dieter (Dieter)
> <[email-masked]>; Rajan Rao <[email-masked]>;
> Zhangxian (Xian) <[email-masked]>; [email-masked];
> Belotti, Sergio (Nokia - IT) <[email-masked]>; Anurag Sharma
> <[email-masked]>; Italo Busi <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* 答复: IETF TE Topology YANG Model Design Meeting Notes -
> 2017-05-03
>
>  
>
> Hi Xufeng,
>
> Thanks for the minutes.
>
> Do you mean “ the current model” is “draft-ietf-teas-yang-te-topo-08”
> (that has not been updated after IETF 98) or 09 version to be uploaded?
>
> *发件人**:*Teas [mailto:[email-masked]] *代表 *Xufeng Liu
> *发送时间:* 2017年5月6日 4:45
> *收件人:* Vishnu Pavan Beeram; Igor Bryskin; Oscar Gonzalez De Dios;
> Tarek Saad; Himanshu Shah; Lou Berger; BRUNGARD, DEBORAH A (ATTLABS);
> Susan Hares; Zafar Ali (zali); Khaddam, Mazen (CCI-Atlanta); BELOTTI,
> SERGIO (SERGIO); Beller, Dieter (Dieter); Rajan Rao; Zhangxian (Xian);
> [email-masked] <mailto:[email-masked]>; Belotti,
> Sergio (Nokia - IT); Anurag Sharma; Italo Busi
> *抄送:* [email-masked] <mailto:[email-masked]>
> *主题:* Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes -
> 2017-05-03
>
>  
>
> Attendees:
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

---

From: Xufeng Liu <[email-masked]>
Date: Fri, 12 May 2017 02:33:12 +0000

Will bring this up again to discuss. People may accept putting them together during the process if doing so will not slow down the process. Putting the current model as non-normative may discourage the current implementers.

Thanks,
- Xufeng

From: Lou Berger [mailto:[email-masked]]
Sent: Thursday, May 11, 2017 8:22 AM
To: Xufeng Liu <[email-masked]>
Cc: TEAS WG <[email-masked]>; Robert Wilton <[email-masked]>
Subject: Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-05-03

Xufeng/Authors,

    Thanks for the update and proactively looking at this.  Did you also discuss the 'refactored' NMDA compatible version put together (see https://github.com/rgwilton/ietf-models-to-combined)? What were your thoughts?

Thanks,

Lou

Thanks,
- Xufeng

To: Xufeng Liu <[email-masked]><mailto:[email-masked]>; Vishnu Pavan Beeram <[email-masked]><mailto:[email-masked]>; Igor Bryskin <[email-masked]><mailto:[email-masked]>; Oscar Gonzalez De Dios <[email-masked]><mailto:[email-masked]>; Tarek Saad <[email-masked]><mailto:[email-masked]>; Himanshu Shah <[email-masked]><mailto:[email-masked]>; Lou Berger <[email-masked]><mailto:[email-masked]>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]><mailto:[email-masked]>; Susan Hares <[email-masked]><mailto:[email-masked]>; Zafar Ali (zali) <[email-masked]><mailto:[email-masked]>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]><mailto:[email-masked]>; BELOTTI, SERGIO (SERGIO) <[email-masked]><mailto:[email-masked]>; Beller, Dieter (Dieter) <[email-masked]><mailto:[email-masked]>; Rajan Rao <[email-masked]><mailto:[email-masked]>; Zhangxian (Xian) <[email-masked]><mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Belotti, Sergio (Nokia - IT) <[email-masked]><mailto:[email-masked]>; Anurag Sharma <[email-masked]><mailto:[email-masked]>; Italo Busi <[email-masked]><mailto:[email-masked]>

Hi Xufeng,
Thanks for the minutes.

Thanks

Fatai

Attendees:

- Tutorial/Manual

Thanks,

- Xufeng

Teas mailing list

[email-masked]<mailto:[email-masked]>

---

From: Lou Berger <[email-masked]>
Date: Fri, 12 May 2017 06:17:13 -0400

Thanks Xufeng. Keep in mind that the non-nmda modules will still be in a 
Standards Track RFC,  just in an appendix.  I suspect those that would be 
discouraged by a non-PS document will miss the subtly of the implications 
of being in an appendix...

Lou

On May 11, 2017 10:41:03 PM Xufeng Liu <[email-masked]> wrote:

> Will bring this up again to discuss. People may accept putting them 
> together during the process if doing so will not slow down the process. 
> Putting the current model as non-normative may discourage the current 
> implementers.
>
> Thanks,
> - Xufeng
>
>     https://github.com/rgwilton/ietf-models-to-combined)? What were your thoughts?
>
> Thanks,
>
> Lou
>
> (https://tools.ietf.org/html/draft-dsdt-nmda-guidelines-01).  The “current 
> model” means the model structure that we are using now without 
> re-structuring to the NMDA style. We may include the NMDA style during the 
> last call process if doing so would not slow down the process.
>
> “draft-ietf-teas-yang-te-topo-08”. We understand that there will be changes 
> during the process and 09 will come at that time.
>
> Thanks,
> - Xufeng
>
> To: Xufeng Liu <[email-masked]><mailto:[email-masked]>; Vishnu 
> Pavan Beeram <[email-masked]><mailto:[email-masked]>; Igor 
> Bryskin <[email-masked]><mailto:[email-masked]>; Oscar 
> Gonzalez De Dios 
> <[email-masked]><mailto:[email-masked]>; 
> Tarek Saad <[email-masked]><mailto:[email-masked]>; Himanshu Shah 
> <[email-masked]><mailto:[email-masked]>; Lou Berger 
> <[email-masked]><mailto:[email-masked]>; BRUNGARD, DEBORAH A (ATTLABS) 
> <[email-masked]><mailto:[email-masked]>; Susan Hares 
> <[email-masked]><mailto:[email-masked]>; Zafar Ali (zali) 
> <[email-masked]><mailto:[email-masked]>; Khaddam, Mazen (CCI-Atlanta) 
> <[email-masked]><mailto:[email-masked]>; BELOTTI, SERGIO 
> (SERGIO) 
> <[email-masked]><mailto:[email-masked]>; 
> Beller, Dieter (Dieter) 
> <[email-masked]><mailto:[email-masked]>; 
> Rajan Rao <[email-masked]><mailto:[email-masked]>; Zhangxian (Xian) 
> <[email-masked]><mailto:[email-masked]>; 
> [email-masked]<mailto:[email-masked]>; Belotti, 
> Sergio (Nokia - IT) 
> <[email-masked]><mailto:[email-masked]>; Anurag Sharma 
> <[email-masked]><mailto:[email-masked]>; Italo Busi 
> <[email-masked]><mailto:[email-masked]>
> Do you mean “ the current model” is “draft-ietf-teas-yang-te-topo-08” (that 
> has not been updated after IETF 98) or 09 version to be uploaded?
> 收件人: Vishnu Pavan Beeram; Igor Bryskin; Oscar Gonzalez De Dios; Tarek Saad; 
> Himanshu Shah; Lou Berger; BRUNGARD, DEBORAH A (ATTLABS); Susan Hares; 
> Zafar Ali (zali); Khaddam, Mazen (CCI-Atlanta); BELOTTI, SERGIO (SERGIO); 
> Beller, Dieter (Dieter); Rajan Rao; Zhangxian (Xian); 
> [email-masked]<mailto:[email-masked]>; Belotti, 
> ----------