Subject: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2017-06-14

From: Xufeng Liu <[email-masked]>
Date: Mon, 19 Jun 2017 18:42:22 +0000

Attendees: Igor, Xufeng, Dieter, Young, Carlo, Italo, Sergio

- Discussed some type sharing with TE tunnel model
  > path-properties
   o Tarek will move the grouping to te-types
   o The groupings are still being discussed during the weekly TE tunnel discussion meetings.
   o The current proposal is:

augment /nw:networks/nw:network/nw:node:
   +--rw te!
      +--rw config
      |  +--rw te-node-attributes
      |     +--rw connectivity-matrices
      |     |  +--rw number-of-entries?         uint16
      |     |  +--rw label-restriction* [inclusive-exclusive label-start]
      |     |  +--rw is-allowed?                boolean
      |     |  +--rw underlay! {te-topology-hierarchy}?
-      |     |  +--rw max-lsp-bandwidth* [priority]
-      |     |  +--rw max-link-bandwidth?        te-types:te-bandwidth
-      |     |  +--rw max-resv-link-bandwidth?   te-types:te-bandwidth
-      |     |  +--rw unreserved-bandwidth* [priority]
-      |     |  +--rw te-default-metric?         uint32
-      |     |  +--rw te-delay-metric?           uint32
-      |     |  +--rw te-srlgs
-      |     |  |  +--rw value*   te-types:srlg
-      |     |  +--rw te-nsrlgs {nsrlg}?
-      |     |  |  +--rw id*   uint32

=============== ietf-te.yang
+            +--rw path-constraints
+            |  +--rw path-metric-bound* [metric-type]
+            |  |  +--rw metric-type    identityref
+            |  |  +--rw upper-bound?   uint64
+            |  +--rw topology-id?         te-types:te-topology-id
+            |  +--rw ignore-overload?     boolean
+            |  +--rw bandwidth-generic?   te-types:te-bandwidth
+            |  +--rw disjointness?        te-types:te-path-disjointness
+            |  +--rw setup-priority?      uint8
+            |  +--rw hold-priority?       uint8
+            |  +--rw signaling-type?      identityref
+            |  +--rw path-affinities
+            |  |  +--rw constraint* [usage]
+            |  |     +--rw usage    identityref
+            |  |     +--rw value?   admin-groups
+            |  +--rw path-srlgs
+            |     +--rw usage?    identityref
+            |     +--rw values*   srlg

======== new grouping generic-path-optimization in ietf-te-types.yang
+            +--rw optimizations
+            |  +--rw (algorithm)?
+            |     +--:(metric) {path-optimization-metric}?
+            |     |  +--rw optimization-metric* [metric-type]
+            |     |  |  +--rw metric-type    identityref
+            |     |  |  +--rw weight?        uint8
+            |     |  +--rw tiebreakers
+            |     |     +--rw tiebreaker* [tiebreaker-type]
+            |     |        +--rw tiebreaker-type    identityref
+            |     +--:(objective-function) {path-optimization-objective-function}?
+            |        +--rw objective-function
+            |           +--rw objective-function-type?   Identityref
======== end of new grouping generic-path-optimization in ietf-te-types.yang

      |     |  +--rw connectivity-matrix* [id]
      |     |     +--rw id                         uint32
      |     |     +--rw from
      |     |     |  +--rw tp-ref?              leafref
      |     |     +--rw to
      |     |     |  +--rw tp-ref?              leafref
      |     |     +--rw is-allowed?                boolean
      |     |     +--rw underlay! {te-topology-hierarchy}?
      |     |     +--rw max-lsp-bandwidth* [priority]
      |     |     +--rw max-link-bandwidth?        te-types:te-bandwidth
      |     |     +--rw max-resv-link-bandwidth?   te-types:te-bandwidth
      |     |     +--rw unreserved-bandwidth* [priority]
      |     |     +--rw te-default-metric?         uint32
      |     |     +--rw te-delay-metric?           uint32
      |     |     +--rw te-srlgs
      |     |     |  +--rw value*   te-types:srlg
      |     |     +--rw te-nsrlgs {nsrlg}?
      |     |        +--rw id*   uint32
      +--ro state
      |  +--ro te-node-template*           leafref {template}?
      |  +--ro te-node-attributes
      |  |  +--ro admin-status?            te-types:te-admin-status
      |  |  +--ro connectivity-matrices
      |  |  |  +--ro number-of-entries?         uint16
      |  |  |  +--ro label-restriction* [inclusive-exclusive label-start]
      |  |  |  +--ro is-allowed?                boolean
      |  |  |  +--ro underlay! {te-topology-hierarchy}?
      |  |  |  +--ro max-lsp-bandwidth* [priority]
      |  |  |  +--ro max-link-bandwidth?        te-types:te-bandwidth
      |  |  |  +--ro max-resv-link-bandwidth?   te-types:te-bandwidth
      |  |  |  +--ro unreserved-bandwidth* [priority]
      |  |  |  +--ro te-default-metric?         uint32
      |  |  |  +--ro te-delay-metric?           uint32
      |  |  |  +--ro te-srlgs
      |  |  |  |  +--ro value*   te-types:srlg
      |  |  |  +--ro te-nsrlgs {nsrlg}?
      |  |  |  |  +--ro id*   uint32
      |  |  |  +--ro connectivity-matrix* [id]
      |  |  |     +--ro id                         uint32
      |  |  |     +--ro from
      |  |  |     |  +--ro tp-ref?              leafref
      |  |  |     +--ro to
      |  |  |     |  +--ro tp-ref?              leafref
      |  |  |     +--ro is-allowed?                boolean
      |  |  |     +--ro underlay! {te-topology-hierarchy}?
-      |  |  |     +--ro max-lsp-bandwidth* [priority]
-      |  |  |     +--ro max-link-bandwidth?        te-types:te-bandwidth
-      |  |  |     +--ro max-resv-link-bandwidth?   te-types:te-bandwidth
-      |  |  |     +--ro unreserved-bandwidth* [priority]
-      |  |  |     +--ro te-default-metric?         uint32
-      |  |  |     +--ro te-delay-metric?           uint32
-      |  |  |     +--ro te-srlgs
-      |  |  |     |  +--ro value*   te-types:srlg
-      |  |  |     +--ro te-nsrlgs {nsrlg}?
-      |  |  |        +--ro id*   uint32

===== new grouping generic-computed-path-properties in ietf-te-types.yang
+                  +--ro computed-path-properties
+                      +--ro path-metric* [metric-type]
+                      |  +--ro metric-type           identityref
+                      |  +--ro accumulative-value?   uint64
+                      +--ro path-affinities
+                      |  +--ro constraint* [usage]
+                      |     +--ro usage    identityref
+                      |     +--ro value?   admin-groups
+                      +--ro path-srlgs
+                      |  +--ro usage?    identityref
+                      |  +--ro values*   srlg
+                      +--ro path-computed-route-objects
+                         +--ro path-computed-route-object* [index]
+                            +--ro index             uint32
+                            +--ro (type)?
+                               +--:(numbered)
+                               |  +--ro numbered-hop
+                               |     +--ro address?    te-types:te-tp-id
+                               |     +--ro hop-type?   te-hop-type
+                               +--:(as-number)
+                               |  +--ro as-number-hop
+                               |     +--ro as-number?   binary
+                               |     +--ro hop-type?    te-hop-type
+                               +--:(unnumbered)
+                               |  +--ro unnumbered-hop
+                               |     +--ro node-id?      te-types:te-node-id
+                               |     +--ro link-tp-id?   te-types:te-tp-id
+                               |     +--ro hop-type?     te-hop-type
+                               +--:(label)
+                               |  +--ro label-hop
+                               |     +--ro value?   rt-types:generalized-label
+                               +--:(sid)
+                                  +--ro sid-hop
+                                     +--ro sid?   rt-types:generalized-label
===== end of new grouping generic-computed-path-properties in ietf-te-types.yang

- Discussed a few comments from CCAMP Transport NBI Design Team
  > Agreed to added missing label restrictions on link

augment /nw:networks/nw:network/nt:link:
   +--rw te!
      +--rw config
      |  +--rw te-link-attributes
+      |     |  +--rw label-restriction* [inclusive-exclusive label-start]
+      |     |  |  +--rw inclusive-exclusive    enumeration
+      |     |  |  +--rw label-start            rt-types:generalized-label
+      |     |  |  +--rw label-end?             rt-types:generalized-label
+      |     |  |  +--rw range-bitmap?          binary

  > Agreed to add IGP cost on link, as proposed by Carlo

  > Discussed the modeling of generic bandwidth
    o Current generic bandwidth is modeled as string, which does not
      provide clear structures for various technologies, leaving too
      much to the interpretations and implementations.
    o Discussed possible improvements, including union and choice.
    o Xufeng to propose a possible approach.

Thanks,

- Xufeng

Note: Please drop me an email if you need an invite for joining the weekly call.

---

From: Xufeng Liu <[email-masked]>
Date: Mon, 19 Jun 2017 18:44:49 +0000

For the generic TE bandwidth, a proposed grouping is:

+--rw te-bandwidth
   +--rw (layer)?
      +--:(psc)
      |  +--rw psc?       rt-types:bandwidth-ieee-float32
      +--:(otn)
      |  +--rw otn* [rate-type]
      |     +--rw rate-type    identityref
      |     +--rw counter?     uint16
      +--:(lsc)
      |  +--rw wdm* [spectrum slot]
      |     +--rw spectrum    identityref
      |     +--rw slot        uint8
      |     +--rw width?      uint8
      +--:(generic)
         +--rw generic?   te-bandwidth

  identity otn-rate-type {
    description
      "Base type to identify OTN bit rates of various information
       structures.";
  }
  identity odu0 {
    base otn-rate-type;
    description
        "ODU 0 bit rate.";
  }
  identity odu1 {
    base otn-rate-type;
    description
        "ODU 1 bit rate.";
  }
  identity odu2 {
    base otn-rate-type;
    description
        "ODU 2 bit rate.";
  }
  identity odu3 {
    base otn-rate-type;
    description
        "ODU 3 bit rate.";
  }
  identity odu4 {
    base otn-rate-type;
    description
        "ODU 4 bit rate.";
  }
  identity odu2e {
    base otn-rate-type;
    description
        "ODU2e bit rate.";
  }
  identity oduc {
    base otn-rate-type;
    description
        "ODUCn bit rate.";
  }
  identity oduflex {
    base otn-rate-type;
    description
        "ODUflex bit rate.";
  }

  identity wdm-spectrum-type {
    description
      "Base type to identify WDM spectrum type.";
  }
  identity cwdm {
    base wdm-spectrum-type;
    description
        "CWDM.";
  }
  identity dwdm {
    base wdm-spectrum-type;
    description
        "DWDM.";
  }
  identity flexible-grid {
    base wdm-spectrum-type;
    description
        "Flexible grid.";
  }

  grouping te-bandwidth {
    description
      "";
    container te-bandwidth {
      description
        "";
      choice layer {
        default generic;
        description
          "";
        case psc {
          leaf psc {
            type rt-types:bandwidth-ieee-float32;
            description "";
          }
        }
        case otn {
          list otn {
            key "rate-type";
            description "";
            leaf rate-type {
              type identityref {
                base otn-rate-type;
              }
              description
                "";
            }
            leaf counter {
              type uint16;
              description
                "";
            }
          }
        }
        case lsc {
          list wdm {
            key "spectrum slot";
            description "";
            leaf spectrum {
              type identityref {
                base wdm-spectrum-type;
              }
              description
                "";
            }
            leaf slot {
              type uint8;
              description
                "";
            }
            leaf width {
              type uint8;
              description
                "";
            }
          }
        }
        case generic {
          leaf generic {
            type te-bandwidth;
            description "";
          }
        }
      }
    }
  }

Thanks,
- Xufeng

From: Xufeng Liu
Sent: Monday, June 19, 2017 2:42 PM
To: 'Vishnu Pavan Beeram' <[email-masked]>; 'Igor Bryskin' <[email-masked]>; 'Oscar Gonzalez De Dios' <[email-masked]>; 'Tarek Saad' <[email-masked]>; 'Himanshu Shah' <[email-masked]>; 'Lou Berger' <[email-masked]>; 'BRUNGARD, DEBORAH A (ATTLABS)' <[email-masked]>; 'Susan Hares' <[email-masked]>; 'Zafar Ali (zali)' <[email-masked]>; 'Khaddam, Mazen (CCI-Atlanta)' <[email-masked]>; 'BELOTTI, SERGIO (SERGIO)' <[email-masked]>; 'Beller, Dieter (Dieter)' <[email-masked]>; 'Rajan Rao' <[email-masked]>; 'Zhangxian (Xian)' <[email-masked]>; [email-masked]' <[email-masked]>; 'Belotti, Sergio (Nokia - IT)' <[email-masked]>; 'Anurag Sharma' <[email-masked]>; 'Paweł Kaczmarek' <[email-masked]>; 'Monali Chakrabarty' <[email-masked]>; 'Italo Busi' <[email-masked]>; 'Carlo Perocchio' <[email-masked]>; 'Rakesh Gandhi (rgandhi)' <[email-masked]>; 'Giles Heron (giheron)' <[email-masked]>; 'Jeff Tantsura' <[email-masked]>; 'Leeyoung' <[email-masked]>
Cc: [email-masked]' <[email-masked]>
Subject: IETF TE Topology YANG Model Design Meeting Notes - 2017-06-14

Thanks,

- Xufeng

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Tue, 20 Jun 2017 09:09:59 +0000

Hi Xufeng,
Thanks for the minute .
See below for some comment/clarification .

Cheers
Sergio

From: Xufeng Liu [mailto:[email-masked]]
Sent: Monday, June 19, 2017 8:42 PM
To: Vishnu Pavan Beeram <[email-masked]>; Igor Bryskin <[email-masked]>; Oscar Gonzalez De Dios <[email-masked]>; Tarek Saad <[email-masked]>; Himanshu Shah <[email-masked]>; Lou Berger <[email-masked]>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]>; Susan Hares <[email-masked]>; Zafar Ali (zali) <[email-masked]>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>; Rajan Rao <[email-masked]>; Zhangxian (Xian) <[email-masked]>; [email-masked]; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; Anurag Sharma <[email-masked]>; Paweł Kaczmarek <[email-masked]>; Monali Chakrabarty <[email-masked]>; Italo Busi <[email-masked]>; Carlo Perocchio <[email-masked]>; Rakesh Gandhi (rgandhi) <[email-masked]>; Giles Heron (giheron) <[email-masked]>; Jeff Tantsura <[email-masked]>; Leeyoung <[email-masked]>
Cc: [email-masked]
Subject: [ALU] IETF TE Topology YANG Model Design Meeting Notes - 2017-06-14

   o Tarek will move the grouping to te-types
SB> Are you referring to p2p path-properties_config grouping ?

=============== ietf-te.yang
SB> Is what you're pointing here below what you want to move as common path-constraints in te-types ?

+            +--rw path-constraints

  > Agreed to added missing label restrictions on link
SB> This is not related to "access-link/inter-domain link" right ? It is a link full controlled by a domain controller . Jus to check and verify we are on the same page.

Thanks,

- Xufeng

---

From: Igor Bryskin <[email-masked]>
Date: Tue, 20 Jun 2017 11:50:57 +0000

Hi  sergio,

To your question WRT label restriction on a link. Nothing will restrict from specifying such restrictions for every link of a topology. However, I think this will be useful only for open ended links (i.e. access and inter-domain ), where the topology provider has no information on remote sides of such links. For regular inter-domain links the provider, knowing all details of both ends, is capable of providing matching bandwidth (e.g. counters only for matching containers on both sides).

Igor
From:Belotti, Sergio (Nokia - IT/Vimercate)
To:Xufeng Liu,Vishnu Pavan Beeram,Igor Bryskin,Oscar Gonzalez De Dios,Tarek Saad,Himanshu Shah,Lou Berger,BRUNGARD, DEBORAH A (ATTLABS),Susan Hares,Zafar Ali (zali),Khaddam, Mazen (CCI-Atlanta),Beller, Dieter (Nokia - DE/Stuttgart),Rajan Rao,Zhangxian (Xian),[email-masked],Anurag Sharma,Paweł Kaczmarek,Monali Chakrabarty,Italo Busi,Carlo Perocchio,Rakesh Gandhi (rgandhi),Giles Heron (giheron),Jeff Tantsura,Leeyoung,
Cc:[email-masked],
Date:2017-06-20 05:11:04
Subject:Re: [Teas] [ALU] IETF TE Topology YANG Model Design Meeting Notes - 2017-06-14

Hi Xufeng,
Thanks for the minute .

Cheers
Sergio

=============== ietf-te.yang
SB> Is what you’re pointing here below what you want to move as common path-constraints in te-types ?

+            +--rw path-constraints

  > Agreed to added missing label restrictions on link
SB> This is not related to “access-link/inter-domain link” right ? It is a link full controlled by a domain controller . Jus to check and verify we are on the same page.

Thanks,

- Xufeng

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Tue, 20 Jun 2017 11:58:13 +0000

Hi Igor, thanks , this is the "topology" modification coming from Carlo's proposal that is expecting to be inserted to tunnel model too, right?
So, you're right that is related to access link/inter-domain link.

Thanks for clarification
Cheers
Sergio

From: Igor Bryskin [mailto:[email-masked]]
Sent: Tuesday, June 20, 2017 1:51 PM
To: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; [email-masked]; [email-masked]; Igor Bryskin <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>; [email-masked]; Zhangxian (Xian) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Italo Busi <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Leeyoung <[email-masked]>
Cc: [email-masked]
Subject: Re: [Teas] [ALU] IETF TE Topology YANG Model Design Meeting Notes - 2017-06-14

Hi  sergio,

Igor

Hi Xufeng,
Thanks for the minute .

Cheers
Sergio

From: Xufeng Liu [mailto:[email-masked]]
Sent: Monday, June 19, 2017 8:42 PM
To: Vishnu Pavan Beeram <[email-masked]<mailto:[email-masked]>>; Igor Bryskin <[email-masked]<mailto:[email-masked]>>; Oscar Gonzalez De Dios <[email-masked]<mailto:[email-masked]>>; Tarek Saad <[email-masked]<mailto:[email-masked]>>; Himanshu Shah <[email-masked]<mailto:[email-masked]>>; Lou Berger <[email-masked]<mailto:[email-masked]>>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; Zafar Ali (zali) <[email-masked]<mailto:[email-masked]>>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]<mailto:[email-masked]>>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]<mailto:[email-masked]>>; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]<mailto:[email-masked]>>; Rajan Rao <[email-masked]<mailto:[email-masked]>>; Zhangxian (Xian) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]<mailto:[email-masked]>>; Anurag Sharma <[email-masked]<mailto:[email-masked]>>; Paweł Kaczmarek <[email-masked]<mailto:[email-masked]>>; Monali Chakrabarty <[email-masked]<mailto:[email-masked]>>; Italo Busi <[email-masked]<mailto:[email-masked]>>; Carlo Perocchio <[email-masked]<mailto:[email-masked]>>; Rakesh Gandhi (rgandhi) <[email-masked]<mailto:[email-masked]>>; Giles Heron (giheron) <[email-masked]<mailto:[email-masked]>>; Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Leeyoung <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [ALU] IETF TE Topology YANG Model Design Meeting Notes - 2017-06-14

+            +--rw path-constraints

Thanks,

- Xufeng

---

From: Igor Bryskin <[email-masked]>
Date: Tue, 20 Jun 2017 12:33:34 +0000

Correct.

Igor
From:Belotti, Sergio (Nokia - IT/Vimercate)
To:Igor Bryskin,[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],[email-masked],Beller, Dieter (Nokia - DE/Stuttgart),[email-masked],Zhangxian (Xian),[email-masked],[email-masked],[email-masked],[email-masked],Italo Busi,[email-masked],[email-masked],[email-masked],[email-masked],Leeyoung,
Cc:[email-masked],
Date:2017-06-20 07:58:46
Subject:RE: [Teas] [ALU] IETF TE Topology YANG Model Design Meeting Notes - 2017-06-14

Hi Igor, thanks , this is the “topology” modification coming from Carlo’s proposal that is expecting to be inserted to tunnel model too, right?
So, you’re right that is related to access link/inter-domain link.

Thanks for clarification
Cheers
Sergio

Hi  sergio,

Igor

Hi Xufeng,
Thanks for the minute .

Cheers
Sergio

+            +--rw path-constraints

Thanks,

- Xufeng

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 21 Jun 2017 14:30:10 +0000

Hi Sergio,

More clarifications below inline.

Thanks,
- Xufeng

From: Belotti, Sergio (Nokia - IT/Vimercate) [mailto:[email-masked]]
Sent: Tuesday, June 20, 2017 5:10 AM
To: Xufeng Liu <[email-masked]>; Vishnu Pavan Beeram <[email-masked]>; Igor Bryskin <[email-masked]>; Oscar Gonzalez De Dios <[email-masked]>; Tarek Saad <[email-masked]>; Himanshu Shah <[email-masked]>; Lou Berger <[email-masked]>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]>; Susan Hares <[email-masked]>; Zafar Ali (zali) <[email-masked]>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]>; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>; Rajan Rao <[email-masked]>; Zhangxian (Xian) <[email-masked]>; [email-masked]; Anurag Sharma <[email-masked]>; Paweł Kaczmarek <[email-masked]>; Monali Chakrabarty <[email-masked]>; Italo Busi <[email-masked]>; Carlo Perocchio <[email-masked]>; Rakesh Gandhi (rgandhi) <[email-masked]>; Giles Heron (giheron) <[email-masked]>; Jeff Tantsura <[email-masked]>; Leeyoung <[email-masked]>
Cc: [email-masked]
Subject: RE: [ALU] IETF TE Topology YANG Model Design Meeting Notes - 2017-06-14

Hi Xufeng,
Thanks for the minute .

Cheers
Sergio

   o Tarek will move the grouping to te-types
SB> Are you referring to p2p path-properties_config grouping ?
[Xufeng] I mean the ones we will use as below, including generic-path-optimization, generic-path-constraints, generic-computed-path-properties, along with dependent groupings.

[Xufeng] Yes.

+            +--rw path-constraints

Thanks,

- Xufeng

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Wed, 21 Jun 2017 14:39:51 +0000

Thanks Xufeng ! Clear.

Sergio

From: Xufeng Liu [mailto:[email-masked]]
Sent: Wednesday, June 21, 2017 4:30 PM
To: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; Vishnu Pavan Beeram <[email-masked]>; Igor Bryskin <[email-masked]>; Oscar Gonzalez De Dios <[email-masked]>; Tarek Saad <[email-masked]>; Himanshu Shah <[email-masked]>; Lou Berger <[email-masked]>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]>; Susan Hares <[email-masked]>; Zafar Ali (zali) <[email-masked]>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]>; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>; Rajan Rao <[email-masked]>; Zhangxian (Xian) <[email-masked]>; [email-masked]; Anurag Sharma <[email-masked]>; Paweł Kaczmarek <[email-masked]>; Monali Chakrabarty <[email-masked]>; Italo Busi <[email-masked]>; Carlo Perocchio <[email-masked]>; Rakesh Gandhi (rgandhi) <[email-masked]>; Giles Heron (giheron) <[email-masked]>; Jeff Tantsura <[email-masked]>; Leeyoung <[email-masked]>
Cc: [email-masked]
Subject: RE: [ALU] IETF TE Topology YANG Model Design Meeting Notes - 2017-06-14

Hi Sergio,

Thanks,
- Xufeng

To: Xufeng Liu <[email-masked]<mailto:[email-masked]>>; Vishnu Pavan Beeram <[email-masked]<mailto:[email-masked]>>; Igor Bryskin <[email-masked]<mailto:[email-masked]>>; Oscar Gonzalez De Dios <[email-masked]<mailto:[email-masked]>>; Tarek Saad <[email-masked]<mailto:[email-masked]>>; Himanshu Shah <[email-masked]<mailto:[email-masked]>>; Lou Berger <[email-masked]<mailto:[email-masked]>>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; Zafar Ali (zali) <[email-masked]<mailto:[email-masked]>>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]<mailto:[email-masked]>>; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]<mailto:[email-masked]>>; Rajan Rao <[email-masked]<mailto:[email-masked]>>; Zhangxian (Xian) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Anurag Sharma <[email-masked]<mailto:[email-masked]>>; Paweł Kaczmarek <[email-masked]<mailto:[email-masked]>>; Monali Chakrabarty <[email-masked]<mailto:[email-masked]>>; Italo Busi <[email-masked]<mailto:[email-masked]>>; Carlo Perocchio <[email-masked]<mailto:[email-masked]>>; Rakesh Gandhi (rgandhi) <[email-masked]<mailto:[email-masked]>>; Giles Heron (giheron) <[email-masked]<mailto:[email-masked]>>; Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; Leeyoung <[email-masked]<mailto:[email-masked]>>

Hi Xufeng,
Thanks for the minute .

Cheers
Sergio

+            +--rw path-constraints

Thanks,

- Xufeng