Subject: Re: [Teas] Follow up with Lou's comments on ACTN

From: Lou Berger <[email-masked]>
Date: Fri, 2 Jun 2017 09:29:45 -0400

Young,

   Taking a step back -- The basic gist of my comments are that there
seems to a number of individual documents that (a) repeat text from
other documents and (b) introduce text that could be readily
incorporated in those other "base" documents and would even result in an
improved base document.   

I think (a) is unhelpful as we can end up with subtly different versions
of the same text, and this imposes extra work on the readers to identify
changes, identify which are significant and rule out the insignificant
ones. 

I think publishing new documents, i.e.,  (b), is fine but once once
published it would be good to fold text into existing (or consolidated
individual drafts) wherever appropriate.  BTW Adding new sections to WG
drafts doesn't require new drafts - a (typically) faster way to go is to
send the proposed text to the list and discuss it there -- once accepted
it can go right in the existing WG document.

I hope this clarifies the motivation for my comments on the two drafts
mentioned below (draft-lee-teas-te-service-mapping-yang and
draft-lee-teas-actn-abstraction).

Thanks,
Lou

On 5/30/2017 10:52 AM, Leeyoung wrote:
> Hi Lou,
>
> Thanks for your comments. Please see inline for our response. 
>
> Thanks.
> Young
>
> -----Original Message-----
> From: Lou Berger [mailto:[email-masked]] 
> Sent: Tuesday, May 23, 2017 1:24 PM
> To: Leeyoung <[email-masked]>; [email-masked]
> Subject: Re: [Teas] Follow up with Lou's comments on ACTN
>
> Young and Daniel,
>
> Thanks for the response.
>
>
> On 5/15/2017 11:21 AM, Leeyoung wrote:
>> Hi Lou,
>>
>>  
>>
>> We'd like to follow-up with you on some of the comments you made 
>> during Chicago TEAS WG meeting. You commented during ACTN framework & 
>> requirement presentation the following:
>>
>>  
>>
>> *        /Lou Berger: I see this as multi-domain orchestration. I am
>> proposing to take the text from the mapping draft into the framework 
>> draft to help people understanding the ACTN terminology. We need to 
>> help people understand how the terms in this document relate to the 
>> terms they already understand. ///
>>
>>  
>>
>> Our response: in the revision we have created section 5 where we took 
>> some text from the mapping draft
>> (https://tools.ietf.org/html/draft-zhang-teas-actn-yang-04)
>>
> The mapping draft I was referring to was the mapping draft on the agenda at the meeting:
> https://tools.ietf.org/html/draft-lee-teas-te-service-mapping-yang
>
> YOUNG>> OK. Thanks for pointing this out. We will review the draft (the right one you pointed out) and see if there is any helpful text/terminology that can be exported to the framework. But it looks like, given your next comment, the updated framework draft has already accommodated your comment. Let us know if this is correct. 
>
>> and drew a figure that shows the relationship between ACTN terminology 
>> and service/network orchestration. Please see Section 5.2 and Appendix 
>> A (for an example)
>> https://tools.ietf.org/html/draft-ietf-teas-actn-framework-05
>>
>>  
>>
> I think the changes are generally helpful -- of course we still detailed comments from the WG.
>
> YOUNG>> Great. 
>
>> On the ACTN abstraction model presentation
>> (https://tools.ietf.org/html/draft-lee-teas-actn-abstraction-01) , you 
>> made a comment:
>>
>> *        /Lou Berger: after you've moved text to the framework
>> document, will anything be left in this one?
>> /
>>
> Right, this was/following up on Danielle's comment during his presentation that parts/much of the document could be moved to the framework.
>
> /
>> /Young Lee: there's still stuff that is useful in here.
>> Lou: if you aren't using the whole of this document to the framework 
>> document, it'd be good if you sent a mail to the list to say which 
>> bits are moving. A complete merge is also OK./
>>
>>  
>>
>> Our response: We created a new section 6 (Topology Abstraction Method) 
>> in the ACTN framework where we imported some key texts from the ACTN 
>> abstraction method  draft:
>> https://tools.ietf.org/html/draft-lee-teas-actn-abstraction-01.  Our 
>> plan is to keep some details (such as motivation, specific 
>> requirements, etc) on the ACTN abstraction methods draft.
>>
> So if you eliminate the text that is now redundant with other documents, what's new in this draft?
> Section 1 is intro, sections 2 and 3 are in other documents -- so this leaves just section 4 right?  Is there another existing WG document where this 1.5 pages of text can go?
>
> YOUNG>> Our intention was to export terminology (white/grey/black topology) to the framework while keeping the bulk of the content in draft-lee-teas-actn-abstraction. What will remain in this draft is: Introduction, Section 3 (factors), Section 3.4 (how to build grey topology) and Section 4 (Protocol/Data Model Requirements). We still think that we have enough useful text in this draft. 
>
> Thanks,
> Lou
>
>>  
>>
>> Please let us know if our response satisfies you so that we can close 
>> these two pending issues; and if not, please give us further comments.
>>
>>  
>>
>> Thanks.
>>
>> Young and Daniele
>>
>> -----Original Message-----
>>
>> From: Leeyoung
>>
>> Sent: Friday, May 05, 2017 1:41 PM
>>
>> To: [email-masked] <mailto:[email-masked]>
>>
>> Subject: RE: [Teas] I-D Action: draft-ietf-teas-actn-framework-05.txt
>>
>>  
>>
>> Hi,
>>
>>  
>>
>> This update is intended to incorporate the comments from the last WG 
>> meeting and any pending issues. We also have taken the global 
>> editorial changes to make it consistent through the document. Major 
>> changes are:
>>
>>  
>>
>> - Inclusion of "network slicing" definition from ACTN perspective (in 
>> the terminology section)
>>
>> - Added virtual network service (VNS) section (Section 3) to define 
>> types of VNS.
>>
>> - Incorporated "orchestration" (service/network) mapping to ACTN 
>> architecture (See Section 5.2)
>>
>> - Created a new section 6 (Topology Abstraction Method) where we 
>> imported some texts from ACTN abstraction method
>> https://tools.ietf.org/html/draft-lee-teas-actn-abstraction-01
>>
>> - Added Appendices A & B to discuss example deployment scenarios such 
>> as example of MDSC and PNC functions integrated in Service/Network 
>> Orchestrator (Appendix A) and example of IP + Optical network with 
>> L3VPN service (Appendix B)
>>
>>  
>>
>> In regard to ACTN abstraction method draft, we are going to keep it as 
>> a separate draft and use this document to elaborate other aspects not 
>> imported to the framework document.
>>
>>  
>>
>> The following diff pointer will help you see the changes with this
>> revision:
>>
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-actn-framework-05
>>
>>  
>>
>> The co-authors believe that the document is ready for WG LC. Any 
>> changes/comments will be appreciated.
>>
>>  
>>
>> Thanks & Best regards,
>>
>> Young & Daniele (on behalf of other co-authors/contributors)
>>
>>  
>>
>> -----Original Message-----
>>
>> From: Teas [mailto:[email-masked]] On Behalf Of 
>> [email-masked] <mailto:[email-masked]>
>>
>> Sent: Friday, May 05, 2017 10:41 AM
>>
>> To: [email-masked] <mailto:[email-masked]>
>>
>> Cc: [email-masked] <mailto:[email-masked]>
>>
>> Subject: [Teas] I-D Action: draft-ietf-teas-actn-framework-05.txt
>>
>>  
>>
>>  
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts 
>> directories.
>>
>> This draft is a work item of the Traffic Engineering Architecture and 
>> Signaling of the IETF.
>>
>>  
>>
>>         Title           : Framework for Abstraction and Control of
>> Traffic Engineered Networks
>>
>>         Authors         : Daniele Ceccarelli
>>
>>                           Young Lee
>>
>>                Filename        : draft-ietf-teas-actn-framework-05.txt
>>
>>                Pages           : 41
>>
>>                Date            : 2017-05-05
>>
>>  
>>
>> Abstract:
>>
>>    Traffic Engineered networks have a variety of mechanisms to
>>
>>    facilitate the separation of the data plane and control plane. They
>>
>>    also have a range of management and provisioning protocols to
>>
>>    configure and activate network resources.  These mechanisms
>>
>>    represent key technologies for enabling flexible and dynamic
>>
>>    networking.
>>
>>  
>>
>>    Abstraction of network resources is a technique that can be applied
>>
>>    to a single network domain or across multiple domains to create a
>>
>>    single virtualized network that is under the control of a network
>>
>>    operator or the customer of the operator that actually owns
>>
>>    the network resources.
>>
>>  
>>
>>    This document provides a framework for Abstraction and Control of
>>
>>    Traffic Engineered Networks (ACTN).
>>
>>  
>>
>>  
>>
>>  
>>
>> The IETF datatracker status page for this draft is:
>>
>> https://datatracker.ietf.org/doc/draft-ietf-teas-actn-framework/
>>
>>  
>>
>> There are also htmlized versions available at:
>>
>> https://tools.ietf.org/html/draft-ietf-teas-actn-framework-05
>>
>> https://datatracker.ietf.org/doc/html/draft-ietf-teas-actn-framework-0
>> 5
>>
>>  
>>
>> A diff from the previous version is available at:
>>
>> https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-actn-framework-05
>>
>>  
>>
>>  
>>
>> Please note that it may take a couple of minutes from the time of 
>> submission until the htmlized version and diff are available at 
>> tools.ietf.org.
>>
>>  
>>
>> Internet-Drafts are also available by anonymous FTP at:
>>
>> ftp://ftp.ietf.org/internet-drafts/
>>
>>  
>>
>> _______________________________________________
>>
>> Teas mailing list
>>
>> [email-masked] <mailto:[email-masked]>
>>
>> https://www.ietf.org/mailman/listinfo/teas
>>
>>
>>
>> _______________________________________________
>> Teas mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/teas
>

---

From: Leeyoung <[email-masked]>
Date: Sun, 4 Jun 2017 08:50:12 +0000

Hi Lou,

Thanks for your clarification. I think the two drafts you mentioned have the following characteristics. 

draft-lee-teas-te-service-mapping-yang --- It has YANG models that connect Service Models to TE Models. So this was proposed as a solution draft for Service-TE mapping. I am not sure how this can be integrated to framework other than making sure terminology be made consistent and eliminating duplicated text. It will be helpful to hear from you what part of this draft can be exported to the framework. 

draft-lee-teas-actn-abstraction --- We exported already some text (including terminology) to the latest framework. The revision of this document (which is yet to be done) will delete all duplicated text. As proposed in the previous email response, there are still some sections in this draft that are worth to keep as a separate document. But as you suggested, we will evaluate if we can fold the remaining text into the framework. 

What do you think? 

Thanks.
Young

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Friday, June 02, 2017 8:30 AM
To: Leeyoung <[email-masked]>; [email-masked]
Subject: Re: [Teas] Follow up with Lou's comments on ACTN

Young,

   Taking a step back -- The basic gist of my comments are that there seems to a number of individual documents that (a) repeat text from other documents and (b) introduce text that could be readily incorporated in those other "base" documents and would even result in an
improved base document.   

I think (a) is unhelpful as we can end up with subtly different versions of the same text, and this imposes extra work on the readers to identify changes, identify which are significant and rule out the insignificant ones. 

I think publishing new documents, i.e.,  (b), is fine but once once published it would be good to fold text into existing (or consolidated individual drafts) wherever appropriate.  BTW Adding new sections to WG drafts doesn't require new drafts - a (typically) faster way to go is to send the proposed text to the list and discuss it there -- once accepted it can go right in the existing WG document.

I hope this clarifies the motivation for my comments on the two drafts mentioned below (draft-lee-teas-te-service-mapping-yang and draft-lee-teas-actn-abstraction).

Thanks,
Lou

On 5/30/2017 10:52 AM, Leeyoung wrote:
>> and drew a figure that shows the relationship between ACTN 
>> terminology and service/network orchestration. Please see Section 5.2 
>> and Appendix A (for an example)
>> (https://tools.ietf.org/html/draft-lee-teas-actn-abstraction-01) , 
>> you made a comment:
>>
>> Our response: We created a new section 6 (Topology Abstraction 
>> Method) in the ACTN framework where we imported some key texts from 
>> the ACTN abstraction method  draft:
>> In regard to ACTN abstraction method draft, we are going to keep it 
>> as a separate draft and use this document to elaborate other aspects 
>> not imported to the framework document.
>>
>>  
>>

---

From: Lou Berger <[email-masked]>
Date: Mon, 5 Jun 2017 15:14:25 -0400

Young,

> draft-lee-teas-te-service-mapping-yang --- It has YANG models that connect Service Models to TE Models. So this was proposed as a solution draft for Service-TE mapping. I am not sure how this can b…
In chicago, your coauthor made the comment that parts could be moved and
my in-session comment on this draft was in response to his statement. 
Skimming the document, it certainly seems that the basic concepts are
applicable to any transport technology and any framework for TE service
mapping, so perhaps that is a direction to go in.

> draft-lee-teas-actn-abstraction --- We exported already some text (including terminology) to the latest framework. The revision of this document (which is yet to be done) will delete all duplicated…
It's hard to say more than I already have (on the current text) without
seeing the new text, so once the new draft is published we can revisit this.
Thanks,
Lou

---

From: Leeyoung <[email-masked]>
Date: Tue, 6 Jun 2017 05:05:50 +0000

Hi Lou,

Thanks for your quick reply and useful suggestions. Please see inline for my comment. 

Thanks.
Young

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Monday, June 05, 2017 2:14 PM
To: Leeyoung <[email-masked]>; [email-masked]
Subject: Re: [Teas] Follow up with Lou's comments on ACTN

Young,

> draft-lee-teas-te-service-mapping-yang --- It has YANG models that connect Service Models to TE Models. So this was proposed as a solution draft for Service-TE mapping. I am not sure how this can b…
In chicago, your coauthor made the comment that parts could be moved and my in-session comment on this draft was in response to his statement. 
Skimming the document, it certainly seems that the basic concepts are applicable to any transport technology and any framework for TE service mapping, so perhaps that is a direction to go in.

YOUNG>> Thanks. This is good. We will continue working on this draft. 

> draft-lee-teas-actn-abstraction --- We exported already some text (including terminology) to the latest framework. The revision of this document (which is yet to be done) will delete all duplicated…
It's hard to say more than I already have (on the current text) without seeing the new text, so once the new draft is published we can revisit this.

YOUNG>> We have updated the revision. I appreciate your feedback on this. 

Thanks,
Lou

>>> during Chicago TEAS WG meeting. You commented during ACTN framework 
>>> & requirement presentation the following:
>>>
>>>  
>>>
>>> Our response: in the revision we have created section 5 where we 
>>> took some text from the mapping draft
>>> terminology and service/network orchestration. Please see Section 
>>> 5.2 and Appendix A (for an example)
>>> Please let us know if our response satisfies you so that we can 
>>> close these two pending issues; and if not, please give us further comments.
>>>
>>>  
>>>
>>> Thanks.
>>>
>>> Young and Daniele
>>>
>>> - Inclusion of "network slicing" definition from ACTN perspective 
>>> (in the terminology section)
>>>
>>> - Added Appendices A & B to discuss example deployment scenarios 
>>> such as example of MDSC and PNC functions integrated in 
>>> Service/Network Orchestrator (Appendix A) and example of IP + 
>>> Optical network with L3VPN service (Appendix B)
>>>
>>>  
>>>
>>> This draft is a work item of the Traffic Engineering Architecture 
>>> and Signaling of the IETF.
>>>
>>>  
>>>
>>> https://datatracker.ietf.org/doc/html/draft-ietf-teas-actn-framework
>>> -
>>> 0
>>> 5
>>>
>>>  
>>>