Subject: [Teas] Structure and status of TE YANG models

From: Robert Wilton <[email-masked]>
Date: Wed, 21 Jun 2017 10:25:37 +0100

Hi all,

The YANG doctors review thread discusses the structure of the Teas YANG 
modules (draft-ietf-teas-yang-te-topo-08), and the path to 
standardization.  I thought that it would be useful to pull the proposal 
out as a top level thread so ensure that everyone has a chance to see it 
and discuss it.

Xufeng's summary is:

The authors and contributors have discussed the adoption of the NMDA style, and currently prefer the following strategy:
	o  Publish the document with the current model style without structure changes, allowing the on-going implementations to continue, supporting necessary operational states before the NMDA protocol specification is updated and supporting implementations are available.
	o  Follow this up ASAP with an NMDA-compatible model draft (WG could adopt this right away). This was suggested by Kent, and is considered to fit our situation the best, allowing the implementations to migrate to the long term approach without interruption.

The questions that I have are:

Do you still intended to publish the existing draft as Standards Track, 
or would it make more sense for it to be Informational?

Will the NMDA compatible models immediately deprecate the current 
models, or is the plan to have two competing sets of TE models for a 
period of time?

Thanks,
Rob

---

From: "Xufeng Liu" <[email-masked]>
Date: Wed, 21 Jun 2017 23:15:02 -0400

Hi Rob and All,

Added some explanations below. Wish to get more opinions from the working group.

Thanks,
- Xufeng

> -----Original Message-----
> From: Robert Wilton [mailto:[email-masked]]
> Sent: Wednesday, June 21, 2017 5:26 AM
> To: [email-masked]
> Cc: Benoit Claise (bclaise) <[email-masked]>; Xufeng Liu
> <[email-masked]>
> Subject: Structure and status of TE YANG models
> 
> Hi all,
> 
> modules (draft-ietf-teas-yang-te-topo-08), and the path to standardization.  I
> thought that it would be useful to pull the proposal out as a top level thread so
> ensure that everyone has a chance to see it and discuss it.
> 
> Xufeng's summary is:
> 
> The authors and contributors have discussed the adoption of the NMDA style,
> and currently prefer the following strategy:
> 	o  Publish the document with the current model style without structure
> changes, allowing the on-going implementations to continue, supporting
> necessary operational states before the NMDA protocol specification is updated
> and supporting implementations are available.
> 	o  Follow this up ASAP with an NMDA-compatible model draft (WG could
> adopt this right away). This was suggested by Kent, and is considered to fit our
> situation the best, allowing the implementations to migrate to the long term
> approach without interruption.
> 
[Xufeng] The reasons for this preference are:
	o  There are multiple on-going implementations. Implementers wish for advancing this document without unnecessary delays, and before the final NETCONF/RESTCON protocol support for NMDA.
	o  Operational states are essential to this model so that the pure NMDA compatible structure cannot be used before the relevant protocol specifications are updated and supporting implementations are available.
	o  This model augments I2RS network topology model (https://tools.ietf.org/html/draft-ietf-i2rs-yang-network-topo-12), and the I2RS model does not have the “-state” module recommended in https://tools.ietf.org/html/draft-dsdt-nmda-guidelines-01.
	o  To make I2RS network topology model support the top level “-state” module, it is needed to re-open the discussions for the I2RS network topology model, including  
the issues of cross referencing between config branch and state branch (which was brought up by I2RS model and has no good solution currently).
	o  The above structure changes will affect on-going implementations with no functional benefits, and delay publishing both the I2RS base network topology model and this document.

> Do you still intended to publish the existing draft as Standards Track, or would it
> make more sense for it to be Informational?
[Xufeng] Yes. Standards Track is preferred.

> 
> Will the NMDA compatible models immediately deprecate the current models,
> or is the plan to have two competing sets of TE models for a period of time?
[Xufeng] The NMDA compatible model is not immediately implementable, so the current model needs to be used for a period of time.

---

From: Robert Wilton <[email-masked]>
Date: Thu, 22 Jun 2017 10:52:56 +0100

Hi Xufeng,

> 	o  There are multiple on-going implementations. Implementers wish for advancing this document without unnecessary delays, and before the final NETCONF/RESTCON protocol support for NMDA.
OK, I get this point.  But I don't think that this should make it a 
standard, at least when we know that the structure is flawed in the 
sense that it doesn't align to the long term direction of the IETF YANG 
models.

> 	o  Operational states are essential to this model so that the pure NMDA compatible structure cannot be used before the relevant protocol specifications are updated and supporting implementations a…
Yes, and there is also an interim solution for this of generating an 
extra "-state" tree.

> 	o  This model augments I2RS network topology model (https://tools.ietf.org/html/draft-ietf-i2rs-yang-network-topo-12), and the I2RS model does not have the “-state” module recommended in https://t…
This is trivial to generate by hand.  I would anticipate that the I2RS 
WG would be willing to generate the additional -state tree and add it 
into an appendix so that the TE models can make use of it.

> the issues of cross referencing between config branch and state branch (which was brought up by I2RS model and has no good solution currently).
The latest I2RS topology draft that was published today has already been 
updated to NMDA style since the conclusion was that was the only 
workable solution.

I think (but it probably requires further discussion to ensure that this 
pans out) that the generated "-state" tree also solves the cross 
referencing issue.

> 	o  The above structure changes will affect on-going implementations with no functional benefits, and delay publishing both the I2RS base network topology model and this document.
The main functional benefit is that it gives a more consistent/flexible 
solution.  E.g.  the current TE model is presumably not usable if the 
underlying I2RS network hasn't all been explicitly configured, since the 
I2RS topology module is all config true.  Perhaps this isn't an issue?

Other benefits of immediately moving to the NMDA style now are:
  - the configuration paths would not change over time.
  - consistency with other IETF YANG modules
  - no need to publish two versions of the TE models
  - implementable now (with the extra -state tree), and when NMDA 
implementations become available.

> [Xufeng] Yes. Standards Track is preferred.
If there current models are published at all then I think that they 
should be published as Informational.  I don't think that it makes sense 
for IETF to have two competing sets of YANG models for the same 
protocols.  Surely, this would just cause confusion and fragmentation in 
the industry?

> [Xufeng] The NMDA compatible model is not immediately implementable, so the current model needs to be used for a period of time.
The NMDA compatible model could be published with the extra transient 
"-state" trees and then it would be immediately implementable on current 
NETCONF and RESTCONF implementations.

Thanks,
Rob

>
>> Thanks,
>> Rob
>>
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

---

From: "Xufeng Liu" <[email-masked]>
Date: Fri, 23 Jun 2017 09:59:49 -0400

HI Rob,

> Sent: Thursday, June 22, 2017 5:53 AM
> To: Xufeng Liu <[email-masked]>; [email-masked]
> Cc: 'Benoit Claise (bclaise)' <[email-masked]>
> Subject: Re: [Teas] Structure and status of TE YANG models
> 
> Hi Xufeng,
> 
> >> The YANG doctors review thread discusses the structure of the Teas
> >> YANG modules (draft-ietf-teas-yang-te-topo-08), and the path to
> >> standardization.  I thought that it would be useful to pull the
> >> proposal out as a top level thread so ensure that everyone has a chance to
> see it and discuss it.
> >>
> >> Xufeng's summary is:
> >>
> >> The authors and contributors have discussed the adoption of the NMDA
> >> style, and currently prefer the following strategy:
> >> 	o  Publish the document with the current model style without
> >> structure changes, allowing the on-going implementations to continue,
> >> supporting necessary operational states before the NMDA protocol
> >> specification is updated and supporting implementations are available.
> >> adopt this right away). This was suggested by Kent, and is considered
> >> to fit our situation the best, allowing the implementations to
> >> migrate to the long term approach without interruption.
> >>
> > 	o  There are multiple on-going implementations. Implementers wish for
> advancing this document without unnecessary delays, and before the final
> NETCONF/RESTCON protocol support for NMDA.
> OK, I get this point.  But I don't think that this should make it a standard, at least
> when we know that the structure is flawed in the sense that it doesn't align to
> the long term direction of the IETF YANG models.
> 
> > 	o  Operational states are essential to this model so that the pure NMDA
> compatible structure cannot be used before the relevant protocol specifications
> are updated and supporting implementations are available.
> Yes, and there is also an interim solution for this of generating an extra "-state"
> tree.
> 
> > 	o  This model augments I2RS network topology model
> (https://tools.ietf.org/html/draft-ietf-i2rs-yang-network-topo-12), and the I2RS
> model does not have the “-state” module recommended in
> https://tools.ietf.org/html/draft-dsdt-nmda-guidelines-01.
> This is trivial to generate by hand.  I would anticipate that the I2RS WG would be
> willing to generate the additional -state tree and add it into an appendix so that
> the TE models can make use of it.
> 
> > 	o  To make I2RS network topology model support the top level “-state”
> > module, it is needed to re-open the discussions for the I2RS network topology
> model, including the issues of cross referencing between config branch and
> state branch (which was brought up by I2RS model and has no good solution
> currently).
> updated to NMDA style since the conclusion was that was the only workable
> solution.
> 
> I think (but it probably requires further discussion to ensure that this pans out)
> that the generated "-state" tree also solves the cross referencing issue.
> 

[Xufeng] Probably yes, but it might need further discussions like you said, and hence delay the publishing.

> > 	o  The above structure changes will affect on-going implementations
> with no functional benefits, and delay publishing both the I2RS base network
> topology model and this document.
> The main functional benefit is that it gives a more consistent/flexible solution.
> E.g.  the current TE model is presumably not usable if the underlying I2RS
> network hasn't all been explicitly configured, since the I2RS topology module is
> all config true.  Perhaps this isn't an issue?
> 
> > [Xufeng] The NMDA compatible model is not immediately implementable, so
> the current model needs to be used for a period of time.

[Xufeng] Again, this would require the enhancement of I2RS base topology model to add the "-state" module. If so, then yes.

---

From: Robert Wilton <[email-masked]>
Date: Fri, 23 Jun 2017 16:36:49 +0100

Hi Alex, Sue, Xufeng,

> [Xufeng] Again, this would require the enhancement of I2RS base topology model to add the "-state" module. If so, then yes.
The I2RS topology module has just gone to WGLC and I've asked the 
authors if they can consider adding the "-state" tree into an appendix 
so that it doesn't delay the TE modules that augments the I2RS topology 
module.

Thanks,
Rob

> .