Subject: Re: [Teas] CCDR scenarios, simulation and suggestions

From: "Aijun Wang" <[email-masked]>
Date: Thu, 20 Jul 2017 14:17:28 +0800

Hi, Julien, Michael and Deborah:

Thanks for your comments on Mr.Huang Lu’s presentation(CCDR Presentation
Material
<https://www.ietf.org/proceedings/99/slides/slides-99-teas-sessa-13-ccdr-cen
trally-control-dynamic-routing-scenario-simulation-and-suggestion-01.pdf> )
about the CCDR on Tuesday Morning’s TEAS session.

The presentation illustrates the traffic engineering scenarios that we
encountered in our native IP network.

Traditional solutions to these scenarios are to apply MPLS technologies
within the whole network and using RSVP-TE or SR-TE to steer the traffic.
These technologies are valid but they either increase the network/device
complexity or we must using the different solutions to cope with the
intra-domain/inter-domain traffic engineering requirements.

Based on the above situation and the development of SDN concept/related
technologies, we want to let the SDN controller do the most complex
algorithm, let it instruct the devices for the optimal action, thus to
alleviate the burden of the underlay network devices, reduce the complexity
of synchronous signaling between them.

The key idea of the draft PCE in Native IP network is to let the PCE/SDN
controller instructs the devices on the optimal path via PCEP and keep the
default path calculated by the normal IGP/BGP protocol. We think such
solution has more network controllability in global view and thus easy to
accomplish the complex TE requirements in one unified solution.

We are also eager to hear more opinions or suggestions on this topic to
solve the problem that we encountered.

Best Regards.

Aijun Wang

Network R&D and Operation Support Department

China Telecom Corporation Limited Beijing Research Institute,Beijing, China.

发件人: Teas [mailto:[email-masked]] 代表 Aijun Wang
发送时间: 2017年6月30日 14:33
收件人: 'TEAS WG'
主题: [Teas] CCDR scenarios, simulation and suggestions

Hi,All:

We have uploaded the draft about CCDR scenarios, simulation and suggestions
at https://tools.ietf.org/html/draft-wang-teas-ccdr-00. 

Below is the brief introduction to it, wish to hear more valuable comments
on it. We will also prepare to introduce it at the coming IETF meeting in
Prague.

Abstract

   This document describes the scenarios, simulation and suggestions

   for the "Centrally Control Dynamic Routing (CCDR)" architecture,

   which integrates the merit of traditional distributed protocols

   (IGP/BGP), and the power of centrally control technologies (PCE/SDN)

   to provide one feasible traffic engineering solution in various

   complex scenarios for the service provider.

   Traditional MPLS-TE solution is mainly used in static network

   planning scenario and is difficult to meet the QoS assurance

   requirements in real-time traffic network. With the emerge of SDN

   concept and related technologies, it is possible to simplify the

   complexity of distributed control protocol, utilize the global view

   of network condition, give more efficient solution for traffic

   engineering in various complex scenarios.

Best Regards.

Aijun Wang

Network R&D and Operation Support Department

China Telecom Corporation Limited Beijing Research Institute,Beijing, China.

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Thu, 20 Jul 2017 08:15:23 +0000

Hi Aijun,

I would like to better understand why PCEP would be the best approach for this  problem. I think the motivation is well understood, but couldn’t this also be achieved by other, existing means?

Thanks

Michael

From: Aijun Wang [mailto:[email-masked]]
Sent: Thursday, July 20, 2017 8:17 AM
To: [email-masked]; Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]>; [email-masked]
Cc: 'TEAS WG' <[email-masked]>; 'LuHuang' <[email-masked]>
Subject: Re: [Teas] CCDR scenarios, simulation and suggestions

Thanks for your comments on Mr.Huang Lu’s presentation(CCDR Presentation Material<https://www.ietf.org/proceedings/99/slides/slides-99-teas-sessa-13-ccdr-centrally-control-dynamic-routing-scenario-simulation-and-suggestion-01.pdf>) about the CCDR on Tuesday Morning’s TEAS session.
The presentation illustrates the traffic engineering scenarios that we encountered in our native IP network.
Traditional solutions to these scenarios are to apply MPLS technologies within the whole network and using RSVP-TE or SR-TE to steer the traffic. These technologies are valid but they either increase the network/device complexity or we must using the different solutions to cope with the intra-domain/inter-domain traffic engineering requirements.

Based on the above situation and the development of SDN concept/related technologies, we want to let the SDN controller do the most complex algorithm, let it instruct the devices for the optimal action, thus to alleviate the burden of the underlay network devices, reduce the complexity of synchronous signaling between them.

The key idea of the draft PCE in Native IP network<PCE%20in%20Native%20IP%20network> is to let the PCE/SDN controller instructs the devices on the optimal path via PCEP and keep the default path calculated by the normal IGP/BGP protocol. We think such solution has more network controllability in global view and thus easy to accomplish the complex TE requirements in one unified solution.

We are also eager to hear more opinions or suggestions on this topic to solve the problem that we encountered.

Best Regards.

Aijun Wang

Hi,All:

We have uploaded the draft about CCDR scenarios, simulation and suggestions at https://tools.ietf.org/html/draft-wang-teas-ccdr-00.
Below is the brief introduction to it, wish to hear more valuable comments on it. We will also prepare to introduce it at the coming IETF meeting in Prague.

Abstract

Best Regards.

Aijun Wang

---

From: "Aijun Wang" <[email-masked]>
Date: Fri, 21 Jul 2017 09:59:35 +0800

Hi, Michael:

We have investigated the current existing solutions and the most applicable one seems to be SR-TE.  But SR-TE can only applicable to MPLS based network and it is only simple within one pure SR-capable network or else it must handle the interoperability between different TE technology(like the coexistence of RSVP-TE and SR-TE etc.).

Another drawback of SR-TE is it uses different forwarding paradigm for MPLS and IPv6, which may put burden on the network devices. 

And on the other hand, the advantage and benefit of SR-TE is mainly from the centrally optimal path computation, but this is also the core idea of CCDR(Centrally Control Dynamic Routing). The reason that we prefer CCDR over SR is that it does not change the forwarding behavior of existing devices and can be applicable to any network type, regardless of them are IPv4, MPLS, or IPv6.

Best Regards.

Aijun Wang

发件人: Scharf, Michael (Nokia - DE/Stuttgart) [mailto:[email-masked]] 
发送时间: 2017年7月20日 16:15
收件人: Aijun Wang; [email-masked]; [email-masked]
抄送: 'TEAS WG'; 'LuHuang'
主题: RE: [Teas] CCDR scenarios, simulation and suggestions

Hi Aijun,

Thanks

Michael

Thanks for your comments on Mr.Huang Lu’s presentation(CCDR Presentation Material <https://www.ietf.org/proceedings/99/slides/slides-99-teas-sessa-13-ccdr-centrally-control-dynamic-routing-scenario-simulation-and-suggestion-01.pdf> ) about the CCDR on Tuesday Morning’s TEAS session.

The key idea of the draft PCE in Native IP network is to let the PCE/SDN controller instructs the devices on the optimal path via PCEP and keep the default path calculated by the normal IGP/BGP protocol. We think such solution has more network controllability in global view and thus easy to accomplish the complex TE requirements in one unified solution.

 

Best Regards.

Aijun Wang

Hi,All:

 

Abstract

 

Best Regards.

Aijun Wang

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Fri, 21 Jul 2017 07:29:24 +0000

Understood. My question is why PCEP would be needed for all this.

Michael

From: Aijun Wang [mailto:[email-masked]]
Sent: Friday, July 21, 2017 4:00 AM
To: Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]>; [email-masked]; [email-masked]
Cc: 'TEAS WG' <[email-masked]>; 'LuHuang' <[email-masked]>
Subject: 答复: [Teas] CCDR scenarios, simulation and suggestions

Hi, Michael:

Best Regards.

Aijun Wang

发件人: Scharf, Michael (Nokia - DE/Stuttgart) [mailto:[email-masked]]
发送时间: 2017年7月20日 16:15
收件人: Aijun Wang; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
抄送: 'TEAS WG'; 'LuHuang'
主题: RE: [Teas] CCDR scenarios, simulation and suggestions

Hi Aijun,

Thanks

Michael

From: Aijun Wang [mailto:[email-masked]]
Sent: Thursday, July 20, 2017 8:17 AM
To: [email-masked]<mailto:[email-masked]>; Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: 'TEAS WG' <[email-masked]<mailto:[email-masked]>>; 'LuHuang' <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] CCDR scenarios, simulation and suggestions

Best Regards.

Aijun Wang

Hi,All:

Abstract

Best Regards.

Aijun Wang

---

From: "Aijun Wang" <[email-masked]>
Date: Fri, 21 Jul 2017 18:37:27 +0800

Hi, Michael:

Just because almost all network device vendors are supporting PCEP, it is easy to extension and there is another WG(PCE) within IETF standardizing these extensions.

Jonathan Hardwick has initiated the discussion “PCEP as an SDN Controller protocol” within the PCE WG mailing list. If you are interested, you can follow that thread J

We are eager to get more feedbacks from Nokia and other device vendor on this issue.  Thanks in advance.

Best Regards.

Aijun Wang

发件人: Teas [mailto:[email-masked]] 代表 Scharf, Michael (Nokia - DE/Stuttgart)
发送时间: 2017年7月21日 15:29
收件人: Aijun Wang; [email-masked]; [email-masked]
抄送: 'LuHuang'; 'TEAS WG'
主题: Re: [Teas] CCDR scenarios, simulation and suggestions

Michael

Hi, Michael:

 

Best Regards.

Aijun Wang

Hi Aijun,

Thanks

Michael

 

Best Regards.

Aijun Wang

Hi,All:

 

Abstract

 

Best Regards.

Aijun Wang