Subject: Re: [Teas] "Hierarchical T-SDN Controller"

From: Jeff Tantsura <[email-masked]>
Date: Wed, 19 Jul 2017 10:58:09 +0200

dealing with this on daily bases, outside of our, rather small world, transport is commonly understood as L4 “stuff”

Cheers,

Jeff

From: Teas <[email-masked]> on behalf of Daniele Ceccarelli <[email-masked]>
Date: Wednesday, July 19, 2017 at 10:49
To: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>, TEAS WG <[email-masked]>
Subject: Re: [Teas] "Hierarchical T-SDN Controller"

And on that i totally agree with you.

…and yes, on the netslices mailing list I was reprimanded by the transport ADs for using the term transport for non layer 4 stuff 😊

BR
Daniele  

From: Teas [mailto:[email-masked]] On Behalf Of Scharf, Michael (Nokia - DE/Stuttgart)
Sent: mercoledì 19 luglio 2017 10:41
To: Daniele Ceccarelli <[email-masked]>; TEAS WG <[email-masked]>
Subject: Re: [Teas] "Hierarchical T-SDN Controller"

Well, the IETF has an area called “TSV” and so in the IETF “transport” has yet another meaning ;-)

Given that, such terminology would have to be defined in IETF documents anyway. A definition of these terms could clarify the meaning for MPLS-TE and SR-TE.

Anyway, my key point is that I think the terminology used by draft-bryskin-te-topo-and-tunnel-modeling-00 is easy to understand by people outside the IETF.

Michael

From: Daniele Ceccarelli [mailto:[email-masked]] 
Sent: Wednesday, July 19, 2017 10:28 AM
To: Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]>; TEAS WG <[email-masked]>
Subject: RE: "Hierarchical T-SDN Controller"

+1 , BUT…

We need to be careful with the word “transport”. In some contexts it refers to pure transport technologies (e.g. OTN, WDM) and does not include other upper layer TE technologies (e.g. MPLS-TE and SR-TE), in other contexts it includes also the latter. 
I’m more than happy to use the term transport SDN controller provided we’re all on the same page (which should be the second).

BR
Daniele  

From: Teas [mailto:[email-masked]] On Behalf Of Scharf, Michael (Nokia - DE/Stuttgart)
Sent: mercoledì 19 luglio 2017 10:01
To: TEAS WG <[email-masked]>
Subject: [Teas] "Hierarchical T-SDN Controller"

In the (useful) I-D draft-bryskin-te-topo-and-tunnel-modeling-00, Section 1.9. “Multi-Domain Transport Service Coordination” uses the following wording:

   A client of multiple TE network domains may need to

   orchestrate/coordinate its transport service setup/manipulation

   across some or all the domains. One example of such a client is a

   Hierarchical T-SDN Controller, HC, managing a connected multi-domain

   transport network where each of the domains is controlled by a

   separate Domain T-SDN Controller, DC.

Outside the IETF, I have the impression that this terminology is quite common when discussing TEAS YANG models. I wonder whether we could use this terminology more frequently inside in TEAS.

Michael

_______________________________________________ Teas mailing list [email-masked] https://www.ietf.org/mailman/listinfo/teas

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Wed, 19 Jul 2017 09:02:26 +0000

As a chair in TSV, I can confirm that “transport” is used for L4 “stuff”.

As far as I can tell, the term “transport network” is not used for L4 “stuff”.

Michael

From: Jeff Tantsura [mailto:[email-masked]]
Sent: Wednesday, July 19, 2017 10:58 AM
To: Daniele Ceccarelli <[email-masked]>; Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]>; TEAS WG <[email-masked]>
Subject: Re: [Teas] "Hierarchical T-SDN Controller"

Cheers,
Jeff

From: Teas <[email-masked]<mailto:[email-masked]>> on behalf of Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 19, 2017 at 10:49
To: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]<mailto:[email-masked]>>, TEAS WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] "Hierarchical T-SDN Controller"

BR
Daniele

From: Teas [mailto:[email-masked]] On Behalf Of Scharf, Michael (Nokia - DE/Stuttgart)
Sent: mercoledì 19 luglio 2017 10:41
To: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; TEAS WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] "Hierarchical T-SDN Controller"

Michael

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: Wednesday, July 19, 2017 10:28 AM
To: Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]<mailto:[email-masked]>>; TEAS WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: "Hierarchical T-SDN Controller"

+1 , BUT…

BR
Daniele

From: Teas [mailto:[email-masked]] On Behalf Of Scharf, Michael (Nokia - DE/Stuttgart)
Sent: mercoledì 19 luglio 2017 10:01
To: TEAS WG <[email-masked]<mailto:[email-masked]>>
Subject: [Teas] "Hierarchical T-SDN Controller"

Michael
_______________________________________________ Teas mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/teas

---

From: Loa Andersson <[email-masked]>
Date: Thu, 20 Jul 2017 07:02:34 +0200

Michael,

Are you saying that making this Software Defined Transport Network
(SDTN) Controller would be acceptable?

/Loa

On 2017-07-19 11:02, Scharf, Michael (Nokia - DE/Stuttgart) wrote:
> *From:* Jeff Tantsura [mailto:[email-masked]]
> *Sent:* Wednesday, July 19, 2017 10:58 AM
> *To:* Daniele Ceccarelli <[email-masked]>; Scharf,
> Michael (Nokia - DE/Stuttgart) <[email-masked]>; TEAS WG
> <[email-masked]>
> *Subject:* Re: [Teas] "Hierarchical T-SDN Controller"
>
>
>
> dealing with this on daily bases, outside of our, rather small world,
> transport is commonly understood as L4 “stuff”
>
>
>
> Cheers,
>
> Jeff
>
>
>
> *From: *Teas <[email-masked] <mailto:[email-masked]>> on
> behalf of Daniele Ceccarelli <[email-masked]
> <mailto:[email-masked]>>
> *Date: *Wednesday, July 19, 2017 at 10:49
> *To: *"Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]
> <mailto:[email-masked]>>, TEAS WG <[email-masked]
> <mailto:[email-masked]>>
> *Subject: *Re: [Teas] "Hierarchical T-SDN Controller"
>
>
>
> …and yes, on the netslices mailing list I was reprimanded by the
> transport ADs for using the term transport for non layer 4 stuff 😊
>
>
>
> BR
> Daniele
>
>
>
> *From:* Teas [mailto:[email-masked]] *On Behalf Of *Scharf,
> Michael (Nokia - DE/Stuttgart)
> *Sent:* mercoledì 19 luglio 2017 10:41
> *To:* Daniele Ceccarelli <[email-masked]
> <mailto:[email-masked]>>; TEAS WG <[email-masked]
> <mailto:[email-masked]>>
> *Subject:* Re: [Teas] "Hierarchical T-SDN Controller"
>
>
>
> Given that, such terminology would have to be defined in IETF documents
> anyway. A definition of these terms could clarify the meaning for
> MPLS-TE and SR-TE.
>
>
>
> Anyway, my key point is that I think the terminology used by
> draft-bryskin-te-topo-and-tunnel-modeling-00 is easy to understand by
> people outside the IETF.
>
>
>
> Michael
>
>
>
>
>
>
>
> *From:* Daniele Ceccarelli [mailto:[email-masked]]
> *Sent:* Wednesday, July 19, 2017 10:28 AM
> *To:* Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]
> <mailto:[email-masked]>>; TEAS WG <[email-masked]
> <mailto:[email-masked]>>
> *Subject:* RE: "Hierarchical T-SDN Controller"
>
>
>
> +1 , BUT…
>
>
>
> We need to be careful with the word “transport”. In some contexts it
> refers to pure transport technologies (e.g. OTN, WDM) and does not
> include other upper layer TE technologies (e.g. MPLS-TE and SR-TE), in
> other contexts it includes also the latter.
> I’m more than happy to use the term transport SDN controller provided
> we’re all on the same page (which should be the second).
>
>
>
> BR
> Daniele
>
>
>
>
>
>
>
> *From:* Teas [mailto:[email-masked]] *On Behalf Of *Scharf,
> Michael (Nokia - DE/Stuttgart)
> *Sent:* mercoledì 19 luglio 2017 10:01
> *To:* TEAS WG <[email-masked] <mailto:[email-masked]>>
> *Subject:* [Teas] "Hierarchical T-SDN Controller"
>
>
>
> In the (useful) I-D draft-bryskin-te-topo-and-tunnel-modeling-00,
> Section 1.9. “Multi-Domain Transport Service Coordination” uses the
> following wording:
>
>
>
> Outside the IETF, I have the impression that this terminology is quite
> common when discussing TEAS YANG models. I wonder whether we could use
> this terminology more frequently inside in TEAS.
>
>
>
> Michael
>
> _______________________________________________ Teas mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/teas
>
>
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Thu, 20 Jul 2017 07:03:40 +0000

I have done a litmus test by entering ...

  Software Defined Transport Network (SDTN) Controller

in some Web search engine. I have repeated the same experiment for ...

  Physical Network Controller

The experiment outcome looks relatively clear to me, but of course I may be opinionated.

Michael

PS: I will certainly not insist in the specific term "transport network".

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: Thursday, July 20, 2017 7:03 AM
> To: [email-masked]; Scharf, Michael (Nokia - DE/Stuttgart)
> <[email-masked]>
> > *To: *"Scharf, Michael (Nokia - DE/Stuttgart)"
> > <[email-masked] <mailto:[email-masked]>>, TEAS
> WG
> > <[email-masked] <mailto:[email-masked]>>
> > Given that, such terminology would have to be defined in IETF
> > documents anyway. A definition of these terms could clarify the
> > meaning for MPLS-TE and SR-TE.
> >
> >
> >