Subject: [Teas] "Hierarchical T-SDN Controller"

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Wed, 19 Jul 2017 08:01:02 +0000

In the (useful) I-D draft-bryskin-te-topo-and-tunnel-modeling-00, Section 1.9. "Multi-Domain Transport Service Coordination" uses the following wording:

   A client of multiple TE network domains may need to
   orchestrate/coordinate its transport service setup/manipulation
   across some or all the domains. One example of such a client is a
   Hierarchical T-SDN Controller, HC, managing a connected multi-domain
   transport network where each of the domains is controlled by a
   separate Domain T-SDN Controller, DC.

Outside the IETF, I have the impression that this terminology is quite common when discussing TEAS YANG models. I wonder whether we could use this terminology more frequently inside in TEAS.

Michael

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 19 Jul 2017 08:27:58 +0000

+1 , BUT...

We need to be careful with the word "transport". In some contexts it refers to pure transport technologies (e.g. OTN, WDM) and does not include other upper layer TE technologies (e.g. MPLS-TE and SR-TE), in other contexts it includes also the latter.
I'm more than happy to use the term transport SDN controller provided we're all on the same page (which should be the second).

BR
Daniele

From: Teas [mailto:[email-masked]] On Behalf Of Scharf, Michael (Nokia - DE/Stuttgart)
Sent: mercoledì 19 luglio 2017 10:01
To: TEAS WG <[email-masked]>
Subject: [Teas] "Hierarchical T-SDN Controller"

Michael

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Wed, 19 Jul 2017 08:41:06 +0000

Well, the IETF has an area called "TSV" and so in the IETF "transport" has yet another meaning ;-)

Given that, such terminology would have to be defined in IETF documents anyway. A definition of these terms could clarify the meaning for MPLS-TE and SR-TE.

Anyway, my key point is that I think the terminology used by draft-bryskin-te-topo-and-tunnel-modeling-00 is easy to understand by people outside the IETF.

Michael

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: Wednesday, July 19, 2017 10:28 AM
To: Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]>; TEAS WG <[email-masked]>
Subject: RE: "Hierarchical T-SDN Controller"

+1 , BUT...

BR
Daniele

From: Teas [mailto:[email-masked]] On Behalf Of Scharf, Michael (Nokia - DE/Stuttgart)
Sent: mercoledì 19 luglio 2017 10:01
To: TEAS WG <[email-masked]<mailto:[email-masked]>>
Subject: [Teas] "Hierarchical T-SDN Controller"

Michael

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 19 Jul 2017 08:49:22 +0000

And on that i totally agree with you.

…and yes, on the netslices mailing list I was reprimanded by the transport ADs for using the term transport for non layer 4 stuff 😊

BR
Daniele

From: Teas [mailto:[email-masked]] On Behalf Of Scharf, Michael (Nokia - DE/Stuttgart)
Sent: mercoledì 19 luglio 2017 10:41
To: Daniele Ceccarelli <[email-masked]>; TEAS WG <[email-masked]>
Subject: Re: [Teas] "Hierarchical T-SDN Controller"

Well, the IETF has an area called “TSV” and so in the IETF “transport” has yet another meaning ;-)

Michael

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: Wednesday, July 19, 2017 10:28 AM
To: Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]<mailto:[email-masked]>>; TEAS WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: "Hierarchical T-SDN Controller"

+1 , BUT…

We need to be careful with the word “transport”. In some contexts it refers to pure transport technologies (e.g. OTN, WDM) and does not include other upper layer TE technologies (e.g. MPLS-TE and SR-TE), in other contexts it includes also the latter.
I’m more than happy to use the term transport SDN controller provided we’re all on the same page (which should be the second).

BR
Daniele

In the (useful) I-D draft-bryskin-te-topo-and-tunnel-modeling-00, Section 1.9. “Multi-Domain Transport Service Coordination” uses the following wording:

Michael

---

From: Fatai Zhang <[email-masked]>
Date: Wed, 19 Jul 2017 15:10:58 +0000

I agree with Michael.

BTW, I think it is also easy to understand by people in CCAMP, TEAS and PCE WGs, which are inside of the IETF, :)

Thanks

Fatai

发件人: Teas [mailto:[email-masked]] 代表 Scharf, Michael (Nokia - DE/Stuttgart)
发送时间: 2017年7月19日 16:41
收件人: Daniele Ceccarelli; TEAS WG
主题: Re: [Teas] "Hierarchical T-SDN Controller"

Michael

+1 , BUT…

BR
Daniele

Michael

---

From: Lou Berger <[email-masked]>
Date: Wed, 19 Jul 2017 18:27:35 +0200

TE-SDN? SDN-TE? SDN4TE?

TE orchistrator?
TE controller?

...

On July 19, 2017 10:28:40 AM Daniele Ceccarelli 
<[email-masked]> wrote:

> +1 , BUT...
>
> We need to be careful with the word "transport". In some contexts it refers 
> to pure transport technologies (e.g. OTN, WDM) and does not include other 
> upper layer TE technologies (e.g. MPLS-TE and SR-TE), in other contexts it 
> includes also the latter.
> I'm more than happy to use the term transport SDN controller provided we're 
> all on the same page (which should be the second).
>
> BR
> Daniele
>
>
>
> In the (useful) I-D draft-bryskin-te-topo-and-tunnel-modeling-00, Section 
> 1.9. "Multi-Domain Transport Service Coordination" uses the following wording:
>
> Outside the IETF, I have the impression that this terminology is quite 
> common when discussing TEAS YANG models. I wonder whether we could use this 
> terminology more frequently inside in TEAS.
>
> Michael
>
>
>
> ----------
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Wed, 19 Jul 2017 16:47:13 +0000

I have the impression that the TEAS YANG models may be implemented by a (TE) function/component/entity/… inside what others in industry may call (T-SDN) domain controller or (T-SDN) hierarchical controller. Orchestrator or coordinator may also work for the latter.

Specifically, I find it confusing to use the term “controller” for a (TE) function/component/entity/… *inside* of what may be called a domain controller, e.g., outside the IETF.

Anyway, I have no particular opinion on whether to use “T-SDN” or another term as long as those terms are not too far away from what somebody outside the IETF would typically enter into a search engine.

Michael

From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, July 19, 2017 6:28 PM
To: Daniele Ceccarelli <[email-masked]>; Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]>; TEAS WG <[email-masked]>
Subject: Re: [Teas] "Hierarchical T-SDN Controller"

TE-SDN? SDN-TE? SDN4TE?

TE orchistrator?
TE controller?

...

On July 19, 2017 10:28:40 AM Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>> wrote:
+1 , BUT…

BR
Daniele

Michael
_______________________________________________
Teas mailing list
[email-masked]<mailto:Teas%40ietf.org>
https://www.ietf.org/mailman/listinfo/teas

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 19 Jul 2017 18:06:41 +0000

Pony?

😊

From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: mercoledì 19 luglio 2017 18:28
To: Daniele Ceccarelli <[email-masked]>; Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]>; TEAS WG <[email-masked]>
Subject: Re: [Teas] "Hierarchical T-SDN Controller"

TE-SDN? SDN-TE? SDN4TE?

TE orchistrator?
TE controller?

...

BR
Daniele

Michael

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 19 Jul 2017 18:09:46 +0000

I agree,

and this is also the major change in the latest version of the framework.

IMO it is correct to say that the MDSC is a functionality of the Orchestrator and that the PNC is a functionality of the domain T-SDN controller, hence speaking about Orchestration and T-SDN is not inappropriate.

BR
Daniele

From: Scharf, Michael (Nokia - DE/Stuttgart) [mailto:[email-masked]]
Sent: mercoledì 19 luglio 2017 18:47
To: Lou Berger <[email-masked]>; Daniele Ceccarelli <[email-masked]>; TEAS WG <[email-masked]>
Subject: RE: [Teas] "Hierarchical T-SDN Controller"

Michael

From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, July 19, 2017 6:28 PM
To: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]<mailto:[email-masked]>>; TEAS WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] "Hierarchical T-SDN Controller"

TE-SDN? SDN-TE? SDN4TE?

TE orchistrator?
TE controller?

...

BR
Daniele

Michael

---

From: Igor Bryskin <[email-masked]>
Date: Wed, 19 Jul 2017 20:24:24 +0000

I tend to agree with Michael. I think SDN in general and T-SDN in particular starts north of (i.e. on  an NBI)  an ACTN  PNC (which in English means Domain controller).

Cheers,
Igor

From:Scharf, Michael (Nokia - DE/Stuttgart)
To:Lou Berger,Daniele Ceccarelli,TEAS WG,
Date:2017-07-19 12:47:44
Subject:Re: [Teas] "Hierarchical T-SDN Controller"

Michael

TE-SDN? SDN-TE? SDN4TE?

TE orchistrator?
TE controller?

...

BR
Daniele

Michael