Subject: [Teas] TE Topology YANG Model: connectivity-matrix definition

From: Dieter Beller <[email-masked]>
Date: Fri, 21 Jul 2017 14:31:27 +0200

Hi Xufeng, Igor, all,

looking again at the connectivity-matrix definition, I have the
following question: based on the current definition there are
multiple separate entries

for the same "from TP" to all potential "to TPs":

+--rw connectivity-matrix* [id]
+--rw id uint32
+--rw from
| +--rw tp-ref? leafref
| +--rw label-restriction* [inclusive-exclusive label-start]
| +--rw inclusive-exclusive enumeration
| +--rw label-start rt-types:generalized-label
| +--rw label-end? rt-types:generalized-label
| +--rw range-bitmap? binary
+--rw to
| +--rw tp-ref? leafref
| +--rw label-restriction* [inclusive-exclusive label-start]
| +--rw inclusive-exclusive enumeration
| +--rw label-start rt-types:generalized-label
| +--rw label-end? rt-types:generalized-label
| +--rw range-bitmap? binary

I think that it is more efficient to have a single entry for each
"from TP" and a list with all potentially connectable "to TPs"

+--rw id uint32
+--rw from
| +--rw tp-ref? leafref
| +--rw label-restriction* [inclusive-exclusive label-start]
| +--rw inclusive-exclusive enumeration
| +--rw label-start rt-types:generalized-label
| +--rw label-end? rt-types:generalized-label
| +--rw range-bitmap? binary
+--rw to-tp-list* [tp-id]
| +--rw tp-id te-types:te-tp-id
| +--rw tp-ref? leafref
| +--rw label-restriction* [inclusive-exclusive label-start]
| +--rw inclusive-exclusive enumeration
| +--rw label-start rt-types:generalized-label
| +--rw label-end? rt-types:generalized-label
| +--rw range-bitmap? binary

If the label restrictions of the "from TP" are
the same (or do not exist, which is typically the case) for
multiple or all connectable "to TPs", the

connectivity matrix description using the to-tp-list becomes much
more compact compared to the description above. (I am not sure
whether

the tp-id can be used as list index. So, if this is not correct,
it has to be replace it by some other index.)

Thanks,

Dieter

---

From: Igor Bryskin <[email-masked]>
Date: Fri, 21 Jul 2017 19:59:54 +0000

Hi Dieter,

Please note that we are modeling not just 1:1 switching, but also 1+1 splitting and merging.

Igor
From:Dieter Beller
To:Xufeng Liu,Vishnu Pavan Beeram,Igor Bryskin,Oscar Gonzalez De Dios,Tarek Saad,Himanshu Shah,Lou Berger,BRUNGARD, DEBORAH A (ATTLABS),Susan Hares,Zafar Ali (zali),Khaddam, Mazen (CCI-Atlanta),Tony Le,BELOTTI, SERGIO (SERGIO),Beller, Dieter (Dieter),Rajan Rao,Zhangxian (Xian),[email-masked],Belotti, Sergio (Nokia - IT),Anurag Sharma,
Cc:[email-masked],
Date:2017-07-21 08:31:44
Subject:TE Topology YANG Model: connectivity-matrix definition

Hi Xufeng, Igor, all,

looking again at the connectivity-matrix definition, I have the following question: based on the current definition there are multiple separate entries
for the same "from TP" to all potential "to TPs":

I think that it is more efficient to have a single entry for each "from TP" and a list with all potentially connectable "to TPs"

      +--rw id   uint32
      +--rw from
      |  +--rw tp-ref?   leafref

If the label restrictions of the "from TP" are the same (or do not exist, which is typically the case) for multiple or all connectable "to TPs", the
connectivity matrix description using the to-tp-list becomes much more compact compared to the description above. (I am not sure whether
the tp-id can be used as list index. So, if this is not correct, it has to be replace it by some other index.)

Thanks,
Dieter

---

From: Igor Bryskin <[email-masked]>
Date: Sat, 22 Jul 2017 13:41:49 +0000

Hi Dieter,

One thing to keep in mind is that LTP X could be connected to LTPY with a metric (e.g. delay) M1, while to LTPZ with a different metric M2. This is especially important when a node is abstract (e.g. representing a domain) rather than a physical switch. We might think about equal cost single list optimization you are proposing, but this is just an optimization, which is even less important when CM changes very rarely (as the case with physical switches). Abstract node CM may change dynamically, but it is unlikely to contain equal cost entries.
This is to explain as to why we modeled CM the way we did.

Igor

From: Dieter Beller [mailto:[email-masked]]
Sent: Friday, July 21, 2017 8:31 AM
To: Xufeng Liu; Vishnu Pavan Beeram; Igor Bryskin; Oscar Gonzalez De Dios; Tarek Saad; Himanshu Shah; Lou Berger; BRUNGARD, DEBORAH A (ATTLABS); Susan Hares; Zafar Ali (zali); Khaddam, Mazen (CCI-Atlanta); Tony Le; BELOTTI, SERGIO (SERGIO); Beller, Dieter (Dieter); Rajan Rao; Zhangxian (Xian); [email-masked]; Belotti, Sergio (Nokia - IT); Anurag Sharma
Cc: [email-masked]
Subject: TE Topology YANG Model: connectivity-matrix definition

Hi Xufeng, Igor, all,

      +--rw id                          uint32

      +--rw from

      |  +--rw tp-ref?              leafref

      +--rw to

      |  +--rw tp-ref?              leafref

      +--rw id   uint32

      +--rw from

      |  +--rw tp-ref?   leafref

      |  +--rw tp-ref?   leafref

Thanks,
Dieter

---

From: Dieter Beller <[email-masked]>
Date: Sun, 23 Jul 2017 13:45:01 +0200

Hi Igor, all,

it was clear to me that you have to describe each element of the n x
n connectivity matrix of an abstract node separately if the elements
have

different properties like for example cost, latency, etc.

If you are at the device level (a wavelength selective switch in a
ROADM for eample), however, the connectivity matrix elements
typically have

the same properties, you can describe the entire row of the
connectivity matrix (from_TP, to_TP) with the list approach. The
list approach does

also include the extreme case where each element is decsribed
separately (one single element in the lsit). So, why not providing
this possibility?

One more question: do you have to provide a connectivity matrix also
for a device that has full connectivity like for example OTN
switches that

typically can switch any ODUk signal from any incoming OTN port
(LTPX) to any outgoing OTN port (LTPY)?

I agree with you that the connectivity matrix of a physical device
typically does not change over time.

Thanks,

Dieter

On 22.07.2017 15:41, Igor Bryskin
wrote:

Hi
Dieter,

One
thing to keep in mind is that LTP X could be connected to
LTPY with a metric (e.g. delay) M1, while to LTPZ with a
different metric M2. This is especially important when a
node is abstract (e.g. representing a domain) rather than a
physical switch. We might think about equal cost single list
optimization you are proposing, but this is just an
optimization, which is even less important when CM changes
very rarely (as the case with physical switches). Abstract
node CM may change dynamically, but it is unlikely to
contain equal cost entries.

This
is to explain as to why we modeled CM the way we did.

Igor

From:
Dieter Beller [mailto:[email-masked]]

To: Xufeng Liu; Vishnu Pavan Beeram; Igor
Bryskin; Oscar Gonzalez De Dios; Tarek Saad; Himanshu
Shah; Lou Berger; BRUNGARD, DEBORAH A (ATTLABS); Susan
Hares; Zafar Ali (zali); Khaddam, Mazen (CCI-Atlanta);
Tony Le; BELOTTI, SERGIO (SERGIO); Beller, Dieter
(Dieter); Rajan Rao; Zhangxian (Xian);
[email-masked]; Belotti, Sergio (Nokia - IT);
Anurag Sharma

Cc: [email-masked]

Subject: TE Topology YANG Model:
connectivity-matrix definition

Hi Xufeng, Igor, all,

looking again at the connectivity-matrix definition, I have
the following question: based on the current definition there
are multiple separate entries

+--rw id                          uint32

+--rw from

|  +--rw tp-ref?              leafref

+--rw to

|  +--rw tp-ref?              leafref

I think that it is more efficient to have a single entry for
each "from TP" and a list with all potentially connectable "to
TPs"

+--rw id   uint32

+--rw from

|  +--rw tp-ref?   leafref

|  +--rw tp-ref?   leafref

If
the label restrictions of the "from TP" are the same (or do
not exist, which is typically the case) for multiple or all
connectable "to TPs", the

connectivity matrix description using the to-tp-list becomes
much more compact compared to the description above. (I am
not sure whether

the tp-id can be used as list index. So, if this is not
correct, it has to be replace it by some other index.)

Thanks,

Dieter

---

From: Igor Bryskin <[email-masked]>
Date: Sun, 23 Jul 2017 13:11:14 +0000

Dieter,

> One more question: do you have to provide a connectivity matrix also for a device that has full connectivity like for example OTN switches that
typically can switch any ODUk signal from any incoming OTN port (LTPX) to any outgoing OTN port (LTPY)?

No,. If a TE node has no or empty CM, the node should be perceived by a client as unconstrained, that is, any pair of same layer LTPs could be cross-connected.

Igor

From: Dieter Beller [mailto:[email-masked]]
Sent: Sunday, July 23, 2017 7:45 AM
To: Igor Bryskin; Xufeng Liu; Vishnu Pavan Beeram; Oscar Gonzalez De Dios; Tarek Saad; Himanshu Shah; Lou Berger; BRUNGARD, DEBORAH A (ATTLABS); Susan Hares; Zafar Ali (zali); Khaddam, Mazen (CCI-Atlanta); Tony Le; Rajan Rao; Zhangxian (Xian); [email-masked]; Belotti, Sergio (Nokia - IT); Anurag Sharma
Cc: [email-masked]
Subject: Re: RE: TE Topology YANG Model: connectivity-matrix definition

Hi Igor, all,

it was clear to me that you have to describe each element of the n x n connectivity matrix of an abstract node separately if the elements have
different properties like for example cost, latency, etc.

If you are at the device level (a wavelength selective switch in a ROADM for eample), however, the connectivity matrix elements typically have
the same properties, you can describe the entire row of the connectivity matrix (from_TP, to_TP) with the list approach. The list approach does
also include the extreme case where each element is decsribed separately (one single element in the lsit). So, why not providing this possibility?

One more question: do you have to provide a connectivity matrix also for a device that has full connectivity like for example OTN switches that
typically can switch any ODUk signal from any incoming OTN port (LTPX) to any outgoing OTN port (LTPY)?

I agree with you that the connectivity matrix of a physical device typically does not change over time.

Thanks,
Dieter
On 22.07.2017 15:41, Igor Bryskin wrote:
Hi Dieter,

Igor

From: Dieter Beller [mailto:[email-masked]]
Sent: Friday, July 21, 2017 8:31 AM
To: Xufeng Liu; Vishnu Pavan Beeram; Igor Bryskin; Oscar Gonzalez De Dios; Tarek Saad; Himanshu Shah; Lou Berger; BRUNGARD, DEBORAH A (ATTLABS); Susan Hares; Zafar Ali (zali); Khaddam, Mazen (CCI-Atlanta); Tony Le; BELOTTI, SERGIO (SERGIO); Beller, Dieter (Dieter); Rajan Rao; Zhangxian (Xian); [email-masked]<mailto:[email-masked]>; Belotti, Sergio (Nokia - IT); Anurag Sharma
Cc: [email-masked]<mailto:[email-masked]>
Subject: TE Topology YANG Model: connectivity-matrix definition

Hi Xufeng, Igor, all,

      +--rw id                          uint32

      +--rw from

      |  +--rw tp-ref?              leafref

      +--rw to

      |  +--rw tp-ref?              leafref

      +--rw id   uint32

      +--rw from

      |  +--rw tp-ref?   leafref

      |  +--rw tp-ref?   leafref

Thanks,
Dieter