Subject: [Teas] draft-huang-teas-bgp-community-pce-00

From: LuHuang <[email-masked]>
Date: Thu, 13 Jul 2017 16:03:01 +0000 (UTC)

Hi, all
Please see the attachment for draft-huang-teas-bgp-community-pce-00.
This document is for the same scenario and requirements as [I-D.wang-teas-pce-native-ip], however, a BGP community based method is used for steering traffic instead of dual/multi-BGP sessions.
Hope to receive your comments and suggestions.
Thanks a lot. --------------------LuHuang
China Mobile Research Institute
Mobile: +86 13810820540

---

From: "Bhatia, Manav (Nokia - IN/Bangalore)" <[email-masked]>
Date: Sun, 16 Jul 2017 00:50:00 +0000

Hi,

This draft describes how a standard community could be used to steer traffic. Why do we need an IETF draft for this? What’s there to standardize here?

Cheers, Manav

From: Teas <[email-masked]> on behalf of LuHuang <[email-masked]>
Reply-To: LuHuang <[email-masked]>
Date: Thursday, 13 July 2017 at 9:33 PM
To: "[email-masked]" <[email-masked]>
Subject: [Teas] draft-huang-teas-bgp-community-pce-00

Hi, all

Thanks a lot.

--------------------
LuHuang

---

From: Aijun Wang <[email-masked]>
Date: Sun, 16 Jul 2017 13:42:04 +0800

Hi, Manav:
There are several scenarios that we want to control the traffic in central mode with the help of traditional distributed routing protocols in Native IP network. Draft https://tools.ietf.org/html/draft-wang-teas-pce-native-ip-03 gives the solution by using multi-BGP sessions and this draft give another way to steer traffic via the related PCEP extension to transfer the key parameters about BGP community/prefix/nexthop information.

Mr.Huang Lu will introduce the related scenarios(we call it CCDR in abbreviated as Central Control Dynamics Routing) and the solution based on BGP community at Tuesday morning's meeting. Please keep the trace of them.

From Aijun Wang

> 在 2017年7月16日，08:50，Bhatia, Manav (Nokia - IN/Bangalore) <[email-masked]> 写道：
> 
> Hi,
>  
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

---

From: LuHuang <[email-masked]>
Date: Mon, 17 Jul 2017 05:51:32 +0000 (UTC)

Hi, Manav
This draft is related to https://datatracker.ietf.org/doc/draft-wang-teas-pce-native-ip/ and propose another optional way to distinguish traffics which is based on BGP community instead of generating multiple BGP sessions.
As same as the method of multiple BGP sessions, in a native ip network PCEP need to be extended to support BGP community based traffic steering. 
Thanks.
--------------------
LuHuang
China Mobile Research Institute
Mobile: +86 13810820540

    "Bhatia, Manav (Nokia - IN/Bangalore)" <[email-masked]> 于 2017年7月16日, 星期日, 上午 2:50 写道：

 #yiv6630921558 #yiv6630921558 -- _filtered #yiv6630921558 {panose-1:2 4 5 3 5 4 6 3 2 4;} _filtered #yiv6630921558 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;} _filtered #yiv6630921558 {panose-1:2 0 5 3 0 0 0 2 0 4;}#yiv6630921558 #yiv6630921558 p.yiv6630921558MsoNormal, #yiv6630921558 li.yiv6630921558MsoNormal, #yiv6630921558 div.yiv6630921558MsoNormal {margin:0cm;margin-bottom:.0001pt;font-size:12.0pt;}#yiv6630921558 a:link, #yiv6630921558 span.yiv6630921558MsoHyperlink {color:#0563C1;text-decoration:underline;}#yiv6630921558 a:visited, #yiv6630921558 span.yiv6630921558MsoHyperlinkFollowed {color:#954F72;text-decoration:underline;}#yiv6630921558 span.yiv6630921558EmailStyle17 {font-family:Calibri;color:windowtext;}#yiv6630921558 span.yiv6630921558msoIns {text-decoration:underline;color:teal;}#yiv6630921558 .yiv6630921558MsoChpDefault {font-size:10.0pt;} _filtered #yiv6630921558 {margin:72.0pt 72.0pt 72.0pt 72.0pt;}#yiv6630921558 div.yiv6630921558WordSection1 {}#yiv6630921558 Hi,    This draft describes how a standard community could be used to steer traffic. Why do we need an IETF draft for this? What’s there to standardize here?    Cheers, Manav    From:Teas <[email-masked]> on behalf of LuHuang <[email-masked]>
Reply-To: LuHuang <[email-masked]>
Date: Thursday, 13 July 2017 at 9:33 PM
To: "[email-masked]" <[email-masked]>
Subject: [Teas] draft-huang-teas-bgp-community-pce-00    Hi, all    Please see the attachment for draft-huang-teas-bgp-community-pce-00.    This document is for the same scenario and requirements as [I-D.wang-teas-pce-native-ip], however, a BGP community based method is used for steering traffic instead of dual/multi-BGP sessions.    Hope to receive your comments and suggestions.    Thanks a lot.   -------------------- LuHuang
China Mobile Research Institute
Mobile: +86 13810820540

---

From: "Bhatia, Manav (Nokia - IN/Bangalore)" <[email-masked]>
Date: Mon, 17 Jul 2017 10:06:30 +0000

Hi LuHang,

I skimmed through draft-wang-teas-pce-native-ip and I still don’t understand what needs to be standardized there.

I don’t think I like the idea of configuring a static route that binds a physical interface to a loopback IP – just looks too fragile to me. And which ironically also defeats the reason you have a loopback interface.

I also find the following text wrong:

“For Flow No.1, we can select the shortest distance path to carry the
   traffic; for Flow No.2, we can select the idle links to form its end
   to end path; for Flow No.3, we can let all the traffic pass one
   single path, no ECMP distribution on the parallel links is required.”

The shortest distance in IP does NOT necessarily mean that the traffic will experience least latency. This is plain wrong. Everything said in Section 5 to me is wrong. Choosing the idle links does NOT mean that the packet losses will be least. HINT: What if you have a faulty line card in that path?

Cheers, Manav

From: LuHuang <[email-masked]>
Reply-To: LuHuang <[email-masked]>
Date: Monday, 17 July 2017 at 11:21 AM
To: "Bhatia, Manav (Nokia - IN/Bangalore)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: 回复： [Teas] draft-huang-teas-bgp-community-pce-00

Hi, Manav

Thanks.

--------------------
LuHuang

Hi,

Cheers, Manav

Hi, all

Thanks a lot.

--------------------
LuHuang

---

From: Aijun Wang <[email-masked]>
Date: Mon, 17 Jul 2017 20:38:18 +0800

Hi，Manav：
It seems that you did not understand the key idea of these solutions. The main use of the loopback address is to differentiate the prefixes group and thus to reduce the specific policy on the on-path routers.
If one line card is fault, it will not be on the calculated path.

From Aijun Wang

> 在 2017年7月17日，18:06，Bhatia, Manav (Nokia - IN/Bangalore) <[email-masked]> 写道：
> 
> Hi LuHang,
>

---

From: "Aijun Wang" <[email-masked]>
Date: Mon, 17 Jul 2017 21:35:27 +0800

Hi, Manav:

You can refer the attached presentation material in IETF98 to get the main idea of these solutions.

We are likely to hear more suggestions from you on them.

Best Regards.

Aijun Wang

Network R&D and Operation Support Department

China Telecom Corporation Limited Beijing Research Institute,Beijing, China.

发件人: Teas [mailto:[email-masked]] 代表 Aijun Wang
发送时间: 2017年7月17日 20:38
收件人: Bhatia, Manav (Nokia - IN/Bangalore)
抄送: [email-masked]; LuHuang
主题: Re: [Teas] 回复： draft-huang-teas-bgp-community-pce-00

Hi，Manav：

Hi LuHang,

Cheers, Manav

Hi, Manav

Thanks.

--------------------

LuHuang

Hi,

Cheers, Manav

Hi, all

Thanks a lot.

-------------------- 

LuHuang

---

From: "Bhatia, Manav (Nokia - IN/Bangalore)" <[email-masked]>
Date: Tue, 18 Jul 2017 00:46:00 +0000

Hi Aijun,

The faulty line card comment was for the statement in the draft that said that packet losses will be minimum on the links that are most idle.

I concede that I perhaps don’t understand the idea. I will go through the slides that you have sent and see if that helps.

However, my stand on the section 5 still stands – I think its not entirely correct and the inferences that you have drawn don’t look right.

Cheers, Manav

From: Aijun Wang <[email-masked]>
Date: Monday, 17 July 2017 at 6:08 PM
To: "Bhatia, Manav (Nokia - IN/Bangalore)" <[email-masked]>
Cc: LuHuang <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Teas] 回复： draft-huang-teas-bgp-community-pce-00

Hi，Manav：

From Aijun Wang

在 2017年7月17日，18:06，Bhatia, Manav (Nokia - IN/Bangalore) <[email-masked]<mailto:[email-masked]>> 写道：
Hi LuHang,

Cheers, Manav

From: LuHuang <[email-masked]<mailto:[email-masked]>>
Reply-To: LuHuang <[email-masked]<mailto:[email-masked]>>
Date: Monday, 17 July 2017 at 11:21 AM
To: "Bhatia, Manav (Nokia - IN/Bangalore)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: 回复： [Teas] draft-huang-teas-bgp-community-pce-00

Hi, Manav

Thanks.

--------------------
LuHuang

"Bhatia, Manav (Nokia - IN/Bangalore)" <[email-masked]<mailto:[email-masked]>> 于 2017年7月16日, 星期日, 上午 2:50 写道：

Hi,

Cheers, Manav

From: Teas <[email-masked]<mailto:[email-masked]>> on behalf of LuHuang <[email-masked]<mailto:[email-masked]>>
Reply-To: LuHuang <[email-masked]<mailto:[email-masked]>>
Date: Thursday, 13 July 2017 at 9:33 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Teas] draft-huang-teas-bgp-community-pce-00

Hi, all

Thanks a lot.

--------------------
LuHuang

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

---

From: "Aijun Wang" <[email-masked]>
Date: Tue, 18 Jul 2017 11:03:35 +0800

Hi, Manav:

The core idea of these drafts is to exploit the merit of traditional distributed protocol and the power of centrally control mode. 

We think such direction can lower the requirements/complexity of the devices, increase the efficiency of device coordination process(comparing with the distributed protocol such as RSVP-TE) and the controllability of the network in global view.

We are also seeking the help of device vendors to accomplish this aim.  Thanks in advance for your constructive suggestions.

Best Regards.

Aijun Wang

发件人: Teas [mailto:[email-masked]] 代表 Bhatia, Manav (Nokia - IN/Bangalore)
发送时间: 2017年7月18日 8:46
收件人: Aijun Wang
抄送: [email-masked]; LuHuang
主题: Re: [Teas] 回复： draft-huang-teas-bgp-community-pce-00

Hi Aijun,

Cheers, Manav

Hi，Manav：

Hi LuHang,

Cheers, Manav

Hi, Manav

Thanks.

--------------------

LuHuang

Hi,

Cheers, Manav

Hi, all

Thanks a lot.

-------------------- 

LuHuang

---

From: Glen Kent <[email-masked]>
Date: Fri, 21 Jul 2017 13:24:35 +0530

Aijun,

How will you ensure that traffic follows different paths? By configuring
static routes along each router?

Glen

On Mon, Jul 17, 2017 at 6:08 PM, Aijun Wang <[email-masked]>
wrote:

> Hi，Manav：
> It seems that you did not understand the key idea of these solutions. The
> main use of the loopback address is to differentiate the prefixes group and
> thus to reduce the specific policy on the on-path routers.
> I skimmed through draft-wang-teas-pce-native-ip and I still don’t
> understand what needs to be standardized there.
>
>
>
> I don’t think I like the idea of configuring a static route that binds a
> physical interface to a loopback IP – just looks too fragile to me. And
> which ironically also defeats the reason you have a loopback interface.
>
>
>
> The shortest distance in IP does NOT necessarily mean that the traffic
> will experience least latency. This is plain wrong. Everything said in
> Section 5 to me is wrong. Choosing the idle links does NOT mean that the
> packet losses will be least. HINT: What if you have a faulty line card in
> that path?
>
>
>
> Cheers, Manav
>
>
>
> *From: *LuHuang <[email-masked]>
> *Reply-To: *LuHuang <[email-masked]>
> *Date: *Monday, 17 July 2017 at 11:21 AM
> *To: *"Bhatia, Manav (Nokia - IN/Bangalore)" <[email-masked]>, "
> [email-masked]" <[email-masked]>
> *Subject: *回复： [Teas] draft-huang-teas-bgp-community-pce-00
>
>
>
> Hi, Manav
>
>
>
> This draft is related to https://datatracker.ietf.org/
> doc/draft-wang-teas-pce-native-ip/ and propose another optional way to
> distinguish traffics which is based on BGP community instead of generating
> multiple BGP sessions.
>
>
>
> As same as the method of multiple BGP sessions, in a native ip network
> PCEP need to be extended to support BGP community based traffic steering.
>
>
>
> Thanks.
>
>
>
> --------------------
>
> LuHuang
> This draft describes how a standard community could be used to steer
> traffic. Why do we need an IETF draft for this? What’s there to standardize
> here?
>
>
>
> Cheers, Manav
>
>
>
> *From: *Teas <[email-masked]> on behalf of LuHuang <
> [email-masked]>
> *Reply-To: *LuHuang <[email-masked]>
> *Date: *Thursday, 13 July 2017 at 9:33 PM
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *[Teas] draft-huang-teas-bgp-community-pce-00
>
>
>
> Hi, all
>
>
>
> This document is for the same scenario and requirements as
> [I-D.wang-teas-pce-native-ip], however, a BGP community based method is
> used for steering traffic instead of dual/multi-BGP sessions.
>
>
>

---

From: "Aijun Wang" <[email-masked]>
Date: Fri, 21 Jul 2017 18:58:05 +0800

Hi, Kent:

The most simple and efficient way to different paths is to use static route along each router on the path, but this work will be done via PCEP protocol automatically according to instructions from PCE/SDN controller.

Additionally, because we differentiates the prefixes via the BGP nexthop, the intermediate routers need only keep the optimal path to these BGP nexthop, not the routes to the thousands of prefixes. This can assure the extensibility of the solution, lower the burden of the devices to keep thousands special policy as done by other solution.

After the rapid deployment, the PCE/SDN controller should supervise these path dynamically and make the real-time update upon the topology change.

Actually, we should know that these dynamic-deployed static paths are optimal path for those special traffic. If there are some broken along these paths, they will fall back to the IGP shortest path automatically. The PCE should keep the TI-LFA effects upon the node/link failure.

Best Regards.

Aijun Wang

发件人: Teas [mailto:[email-masked]] 代表 Glen Kent
发送时间: 2017年7月21日 15:55
收件人: Aijun Wang
抄送: LuHuang; [email-masked]
主题: Re: [Teas] 回复： draft-huang-teas-bgp-community-pce-00

Aijun,

How will you ensure that traffic follows different paths? By configuring static routes along each router?

Glen

On Mon, Jul 17, 2017 at 6:08 PM, Aijun Wang <[email-masked]> wrote:

Hi，Manav：

Hi LuHang,

Cheers, Manav

Hi, Manav

Thanks.

--------------------

LuHuang

Hi,

Cheers, Manav

Hi, all

Thanks a lot.

-------------------- 

LuHuang