Subject: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

From: [email-masked]
Date: Wed, 18 Oct 2017 14:30:43 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Traffic Engineering Architecture and Signaling WG of the IETF.

        Title           : Framework for Abstraction and Control of Traffic Engineered Networks
        Authors         : Daniele Ceccarelli
                          Young Lee
	Filename        : draft-ietf-teas-actn-framework-10.txt
	Pages           : 37
	Date            : 2017-10-18

Abstract:
   Traffic Engineered networks have a variety of mechanisms to
   facilitate the separation of the data plane and control plane. They
   also have a range of management and provisioning protocols to
   configure and activate network resources.  These mechanisms
   represent key technologies for enabling flexible and dynamic
   networking.

   Abstraction of network resources is a technique that can be applied
   to a single network domain or across multiple domains to create a
   single virtualized network that is under the control of a network
   operator or the customer of the operator that actually owns
   the network resources.

   This document provides a framework for Abstraction and Control of
   Traffic Engineered Networks (ACTN).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-teas-actn-framework/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-teas-actn-framework-10
https://datatracker.ietf.org/doc/html/draft-ietf-teas-actn-framework-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-actn-framework-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Leeyoung <[email-masked]>
Date: Wed, 18 Oct 2017 21:36:33 +0000

Hi,

This update was the result of offline discussions with the chairs.  The only change is Section 5.5 where VN recursion with network layers was added per Chairs' request. 

Hope this is the last change (until the next one) :)  

Thanks & Best regards,
Young (on behalf of co-authors and contributors).

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, October 18, 2017 4:31 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: Leeyoung <[email-masked]>
Date: Mon, 23 Oct 2017 16:41:40 +0000

Hi, 

With -10, we have addressed all comments that we have received and believe that the document is complete and ready for WG last call. The companion drafts (i.e., ACTN  requirements and Info Model)  are already completely aligned with the Framework Draft (This version). Obviously some other documents will need to be updated to bring them in synch especially with minor changes in the terminology, but we do not think that those changes are in anyway gating the progress of this draft through WG LC and RFC publication.

We'd appreciate your comment on this version 10 which was published last week. 

Thanks & Best regards,
Young (on behalf of co-authors and contributors)

-----Original Message-----
From: Leeyoung 
Sent: Wednesday, October 18, 2017 4:37 PM
To: TEAS WG <[email-masked]>
Subject: RE: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

Hi,

Thanks & Best regards,

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, October 18, 2017 4:31 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

Abstract:

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 23 Oct 2017 23:38:08 +0100

All,

I'm sorry that I'm the cause of a lot of the changes in the last couple of
revisions. The authors have been most accommodating of my requests and
suggestions for changes and I think the resulting document is a whole lot
clearer. I have no further issues with this document.

Adrian

> From: Teas [mailto:[email-masked]] On Behalf Of Leeyoung
> Sent: 23 October 2017 17:42
> To: TEAS WG
> Cc: TEAS WG Chairs
> Subject: Re: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt
> 
> Hi,
> 
> With -10, we have addressed all comments that we have received and believe
> that the document is complete and ready for WG last call. The companion drafts
> (i.e., ACTN  requirements and Info Model)  are already completely aligned with
> the Framework Draft (This version). Obviously some other documents will need
> to be updated to bring them in synch especially with minor changes in the
> terminology, but we do not think that those changes are in anyway gating the
> progress of this draft through WG LC and RFC publication.
> 
> This update was the result of offline discussions with the chairs.  The only
change
> is Section 5.5 where VN recursion with network layers was added per Chairs'
> request.
> 
> This draft is a work item of the Traffic Engineering Architecture and
Signaling WG
> of the IETF.
> 
>         Title           : Framework for Abstraction and Control of Traffic
Engineered
> Networks

---

From: 윤빈영 <[email-masked]>
Date: Tue, 24 Oct 2017 15:07:15 +0000

Hi,

I read it.
It has been progressed a lot, so it is stable and clear to me.
I think that it is ready for WG LC.

Bin

2017. 10. 24. 오전 1:42, "Teas(Leeyoung 대신)" <[email-masked]([email-masked] 대신)> 작성:

    Hi, 

    
    Thanks & Best regards,

    -----Original Message-----
    From: Leeyoung 
    Sent: Wednesday, October 18, 2017 4:37 PM
    To: TEAS WG <[email-masked]>
    Subject: RE: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt
    
    Hi,

    
    Thanks & Best regards,
    
    -----Original Message-----
    From: Teas [mailto:[email-masked]] On Behalf Of [email-masked]
    Sent: Wednesday, October 18, 2017 4:31 PM
    To: [email-masked]
    Cc: [email-masked]
    Subject: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

    
    Abstract:

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 24 Oct 2017 13:47:15 -0400

I agree, it’s time for WG LC.

Cheers,
Andy

On Tue, Oct 24, 2017 at 11:07 AM, 윤빈영 <[email-masked]> wrote:

>     With -10, we have addressed all comments that we have received and
> believe that the document is complete and ready for WG last call. The
> companion drafts (i.e., ACTN  requirements and Info Model)  are already
> completely aligned with the Framework Draft (This version). Obviously some
> other documents will need to be updated to bring them in synch especially
> with minor changes in the terminology, but we do not think that those
> changes are in anyway gating the progress of this draft through WG LC and
> RFC publication.
>
>     This update was the result of offline discussions with the chairs.
> The only change is Section 5.5 where VN recursion with network layers was
> added per Chairs' request.
>
> Signaling WG of the IETF.
>
>     Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>

---

From: Ricard Vilalta <[email-masked]>
Date: Wed, 25 Oct 2017 13:46:16 +0200

Hi all,

I agree with Adrian's comment. I have read the latest changes and I 
think that the document is ready for WC LC.

Thanks,

Ricard

-- 

Dr. Ricard Vilalta
Senior Researcher
Optical Networks and Systems Department
Communication Networks Division
Centre Tecnològic de Telecomunicacions de Catalunya (CTTC/CERCA).

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Wed, 25 Oct 2017 12:03:36 +0000

Since the terminology for "PNC" got changed recently, wouldn't it make sense to review the term "CNC" as well?

Due to topology abstraction, the entity that implements the CNC functionality may not have much "control" over the network. And, as an example, the CNC functionality could also be implemented as part of a portal. In such cases the term "controller" may perhaps not be a widely used in industry. 

For what it is worth, an alternative expansion would be "Customer Network Commissioning". Other terms may exist as well.

Just as a thought - this would be editorial only

Michael

> Sent: Monday, October 23, 2017 6:42 PM
> Cc: TEAS WG Chairs <[email-masked]>
> change is Section 5.5 where VN recursion with network layers was added per
> Chairs' request.
>

---

From: Lou Berger <[email-masked]>
Date: Wed, 25 Oct 2017 08:56:58 -0400

Michael,

What about adding some text (that you propose ;-) to section 3.2 to
clarify this point and leaving the CNC name as is.  Perhaps something like:

    The capability of a CNC beyond its CMI role is outside the scope of
    ACTN and may be implemented in different ways.  For example, the CNC
    may in fact be a controller in the customer's domain , or the CNC
    functionality could also be implemented as part of a provisioning
    portal.

Lou

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Wed, 25 Oct 2017 13:16:53 +0000

Your proposed wording would help.

BTW, according to section 5.5, the "CNC" may also be embedded inside a PNC. This "controller-in-controller" embedding could perhaps also be mentioned earlier in the document, e.g., as part of your proposed text. It could be something like: "For example, the CNC may in fact be a controller or part of a controller in the customer's domain".

Anyway, I was just wondering if terminology other than the generic "controller" could perhaps better distinguish the different functionality. I won't insist on any change.

Michael

> From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
> Sent: Wednesday, October 25, 2017 2:57 PM
> To: Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]>;
> Leeyoung <[email-masked]>; TEAS WG <[email-masked]>
> What about adding some text (that you propose ;-) to section 3.2 to clarify
> this point and leaving the CNC name as is.  Perhaps something like:
> 
> > Due to topology abstraction, the entity that implements the CNC
> functionality may not have much "control" over the network. And, as an
> example, the CNC functionality could also be implemented as part of a portal.
> In such cases the term "controller" may perhaps not be a widely used in
> industry.
> >
> > For what it is worth, an alternative expansion would be "Customer
> Network Commissioning". Other terms may exist as well.
> >
> >> companion drafts (i.e., ACTN  requirements and Info Model)  are
> >> already completely aligned with the Framework Draft (This version).
> >> Obviously some other documents will need to be updated to bring them
> >> in synch especially with minor changes in the terminology, but we do
> >> not think that those changes are in anyway gating the progress of
> >> this draft through WG LC and RFC publication.
> >>
> >> The only change is Section 5.5 where VN recursion with network layers
> >> was added per Chairs' request.
> >>

---

From: Leeyoung <[email-masked]>
Date: Wed, 25 Oct 2017 13:26:20 +0000

Hi Michael and Lou,

I agree that the suggested description of CNC would help. I  would leave the CNC name as is  with the reason Michael quoted from Section 5.5. 

Thanks,
Young

-----Original Message-----
From: Scharf, Michael (Nokia - DE/Stuttgart) [mailto:[email-masked]] 
Sent: Wednesday, October 25, 2017 8:17 AM
To: Lou Berger <[email-masked]>; Leeyoung <[email-masked]>; TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: RE: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

Michael

> > Since the terminology for "PNC" got changed recently, wouldn't it 
> > make
> sense to review the term "CNC" as well?
> >
> In such cases the term "controller" may perhaps not be a widely used 
> in industry.
> >
> >> believe that the document is complete and ready for WG last call. 
> >> The companion drafts (i.e., ACTN  requirements and Info Model)  are 
> >> Obviously some other documents will need to be updated to bring 
> >> them in synch especially with minor changes in the terminology, but 
> >> we do not think that those changes are in anyway gating the 
> >> The only change is Section 5.5 where VN recursion with network 
> >> layers was added per Chairs' request.
> >>
> >> https://datatracker.ietf.org/doc/html/draft-ietf-teas-actn-framewor
> >> k-
> >> 10
> >>

---

From: Leeyoung <[email-masked]>
Date: Wed, 25 Oct 2017 14:14:24 +0000

Hi,

Combining CNC description suggested by Lou and Michael (to be added in Section 3.2) can be:

NEW: 

>     portal. For example, the CNC may in fact be a controller or part of a controller in the customer's domain.

Let us know if this is good to go. 

Thanks.
Young

-----Original Message-----
From: Leeyoung 
Sent: Wednesday, October 25, 2017 8:26 AM
To: 'Scharf, Michael (Nokia - DE/Stuttgart)' <[email-masked]>; Lou Berger <[email-masked]>; TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: RE: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

Hi Michael and Lou,

Thanks,
Young

-----Original Message-----
From: Scharf, Michael (Nokia - DE/Stuttgart) [mailto:[email-masked]]
Sent: Wednesday, October 25, 2017 8:17 AM
To: Lou Berger <[email-masked]>; Leeyoung <[email-masked]>; TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: RE: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

Michael

---

From: Fatai Zhang <[email-masked]>
Date: Thu, 26 Oct 2017 07:19:07 +0000

Hi Young,

I think you repeat some text, should it be as follows?

NEW: 

>     may in fact be a controller or part of a controller in the customer's domain , or the CNC

Thanks

Fatai

-----邮件原件-----
发件人: Teas [mailto:[email-masked]] 代表 Leeyoung
发送时间: 2017年10月25日 22:14
收件人: Scharf, Michael (Nokia - DE/Stuttgart); Lou Berger; TEAS WG
抄送: TEAS WG Chairs
主题: Re: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

Hi,

Thanks.
Young

-----Original Message-----
From: Leeyoung
Sent: Wednesday, October 25, 2017 8:26 AM
To: 'Scharf, Michael (Nokia - DE/Stuttgart)' <[email-masked]>; Lou Berger <[email-masked]>; TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: RE: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

Hi Michael and Lou,

Thanks,
Young

-----Original Message-----
From: Scharf, Michael (Nokia - DE/Stuttgart) [mailto:[email-masked]]
Sent: Wednesday, October 25, 2017 8:17 AM
To: Lou Berger <[email-masked]>; Leeyoung <[email-masked]>; TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: RE: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

Michael

---

From: Leeyoung <[email-masked]>
Date: Fri, 27 Oct 2017 20:43:36 +0000

Hi Fatai,

Yes, this is clear. Thanks for catching this. Will correct this in the next opportunity for the revision. 

Best regards,
Young

-----Original Message-----
From: Fatai Zhang 
Sent: Thursday, October 26, 2017 2:19 AM
To: Leeyoung <[email-masked]>; Scharf, Michael (Nokia - DE/Stuttgart) <[email-masked]>; Lou Berger <[email-masked]>; TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: 答复: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

Hi Young,

Thanks

Fatai

-----邮件原件-----
发件人: Teas [mailto:[email-masked]] 代表 Leeyoung
发送时间: 2017年10月25日 22:14
收件人: Scharf, Michael (Nokia - DE/Stuttgart); Lou Berger; TEAS WG
抄送: TEAS WG Chairs
主题: Re: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

Hi,

Thanks.
Young

-----Original Message-----
From: Leeyoung
Sent: Wednesday, October 25, 2017 8:26 AM
To: 'Scharf, Michael (Nokia - DE/Stuttgart)' <[email-masked]>; Lou Berger <[email-masked]>; TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: RE: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

Hi Michael and Lou,

Thanks,
Young

-----Original Message-----
From: Scharf, Michael (Nokia - DE/Stuttgart) [mailto:[email-masked]]
Sent: Wednesday, October 25, 2017 8:17 AM
To: Lou Berger <[email-masked]>; Leeyoung <[email-masked]>; TEAS WG <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>
Subject: RE: [Teas] I-D Action: draft-ietf-teas-actn-framework-10.txt

Michael