Subject: [Teep] Conference Call Notes ... was RE: Re-sending TEEP BOF Discussion Conference Call Info

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 3 Mar 2017 15:02:21 +0000

Hi Michael,

We had a high-level conversation about what we need to prepare for the meeting.

* CBOR: We briefly spoke about the draft submission of the CBOR-based encoding of messages. Alibaba clarified that they will submit a draft in time for the deadline and are looking for other contributors.

* Use cases: We used a bit more time to speak about the various use cases that are implicitly covered in the document and Ming promised to post the use cases he has in mind to the mailing list.
A draft may be submitted to describe the use cases. We also spoke about the batch use case, see https://www.ietf.org/mail-archive/web/teep/current/msg00020.html. We weren't quite sure whether this implies that the TAM has to generate a number of identical requests. We should also identify use cases that are not covered by the specification, such as the use of multiple TEEs in a single device.

* Remote Participation: Nick mentioned that he will not be able to attend the IETF meeting due to family reasons and I promised to post a message to the list about remote participation possibilities.

* Pete Resnick suggested to distribute some introductory material about TEEs and TrustZone to the mailing list to provide participants with enough background for the meeting. Hannes will ask company-internally for some useful material.

* Ming promised to work on an architecture and stakeholder diagram, which can be shown during the meeting since the previously distributed slide deck does not do a great job in illustrating those two aspects.

Ciao
Hannes

-----Original Message-----
From: Michael Richardson [mailto:[email-masked]]
Sent: 01 March 2017 15:49
To: [email-masked]; [email-masked]
Cc: Hannes Tschofenig
Subject: Re: [Teep] Re-sending TEEP BOF Discussion Conference Call Info

[email-masked] wrote:
    > 2PM CST doesn't makes sense as that's 1AM EST, it should say 12PM CST,
    > correct?

CST == China Standard Time, not Central.
Maybe next time link to timeanddate.com or some such and/or attach an ics file.

I set my alarm since I couldn't stay awake that late, but I rolled over and turned it off.

Hoping for some minutes, but I also haven't finished reading the drafts yet.

--
Michael Richardson <[email-masked]>, Sandelman Software Works  -= IPv6 IoT consulting =-

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Kathleen Moriarty <[email-masked]>
Date: Fri, 3 Mar 2017 10:21:26 -0500

Hannes,

Thanks for the notes.  I'd like to see some rotation in the times for
the calls to make it a bit more fair for the global participants and
so that as AD, I can join the calls.  The chairs have just agreed to
assist and I'll send that out separately.  One is on Pacific time (US)
and the other is on eastern European time, I believe.

I don't think there was a poll on list for the call times.

Thanks,
Kathleen

On Fri, Mar 3, 2017 at 10:02 AM, Hannes Tschofenig
<[email-masked]> wrote:
> _______________________________________________
> TEEP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teep

-- 

Best regards,
Kathleen

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 3 Mar 2017 16:52:12 +0100

Hello all,

in general, I would recommend to skim/take into account the 
corresponding solution specification of Global Platform, which is in 
public review process up until exactly today :)

GP TEE Management Framework (published December 2016)
> http://www.globalplatform.org/specifications/review/GPD_TEE_MgmtFramework_AsymmetricCryptoSecurityLayer_v0.0.0.24_PublicReview.pdf

Viele Grüße,

Henk

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 3 Mar 2017 17:00:13 +0100

Complementing my last mail, the complete set of TEE specifications might 
be of interest, although there is the requirement to register in order 
to acquire access to a set of free documents....

> https://www.globalplatform.org/specificationsdevice.asp

On 03/03/2017 04:52 PM, Henk Birkholz wrote:

> in general

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 3 Mar 2017 16:31:11 +0000

Yes, those are the problems with international standardization when participants come from Asia, Europe and the US. There is essentially no ideal time anymore.

Ciao
Hannes

-----Original Message-----
From: Kathleen Moriarty [mailto:[email-masked]]
Sent: 03 March 2017 16:21
To: Hannes Tschofenig
Cc: Michael Richardson; [email-masked]
Subject: Re: [Teep] Conference Call Notes ... was RE: Re-sending TEEP BOF Discussion Conference Call Info

Hannes,

Thanks for the notes.  I'd like to see some rotation in the times for the calls to make it a bit more fair for the global participants and so that as AD, I can join the calls.  The chairs have just agreed to assist and I'll send that out separately.  One is on Pacific time (US) and the other is on eastern European time, I believe.

Thanks,
Kathleen

--

Best regards,
Kathleen

---

From: Kathleen Moriarty <[email-masked]>
Date: Fri, 3 Mar 2017 11:40:27 -0500

> Yes, those are the problems with international standardization when participants come from Asia, Europe and the US. There is essentially no ideal time anymore.

Yes, so let's rotate the times to make it a bit better for all.

Thank you,
Kathleen

-- 

Best regards,
Kathleen

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 7 Mar 2017 07:45:50 +0000

Thanks for sharing, Henk.
I guess many people are already aware of the ongoing efforts in GlobalPlatform.

Ciao
Hannes

-----Original Message-----
From: TEEP [mailto:[email-masked]] On Behalf Of Henk Birkholz
Sent: 03 March 2017 16:52
To: [email-masked]
Subject: Re: [Teep] Conference Call Notes ... was RE: Re-sending TEEP BOF Discussion Conference Call Info

Hello all,

in general, I would recommend to skim/take into account the corresponding solution specification of Global Platform, which is in public review process up until exactly today :)

> http://www.globalplatform.org/specifications/review/GPD_TEE_MgmtFramew
> ork_AsymmetricCryptoSecurityLayer_v0.0.0.24_PublicReview.pdf

Viele Grüße,

Henk

---

From: "O'Donoghue, Jeremy" <[email-masked]>
Date: Wed, 8 Mar 2017 15:34:27 +0000

Hi all,

A few points regarding the issues discussed below.

  *   The document mentioned by Henk contains only a security layer, and cannot be understood independent of other documents. I do not recommend it to anyone trying to understand other efforts in this area.
  *   The essence of the “batch” use case is for systems which are not online 100% of the time, or where online communication is costly. I would envisage at least the following “batch” use cases for consideration:
     *   TAM wishes to install or update a TA using a distribution model in which the TA is distributed as part of an REE app package. In this case many identical requests may be envisaged.
     *   TAM wishes to personalise a TA. In this case requests are not identical, but are delivered offline.
  *   The best introductory TEE document I know of is the GlobalPlatform "TEE System Architecture v1.1”, which is available from the GlobalPlatform specification area - behind a click-through license. It provides considerably more information than the Wikipedia article.

Best regards
Jeremy

---
Jeremy O’Donoghue                            email: [email-masked]<mailto:[email-masked]>
Engineer, Principal/Manager                  tel:   +44 1252 363189
NFC & Secure Software and Systems

On 7 Mar 2017, at 07:45, Hannes Tschofenig <[email-masked]<mailto:[email-masked]>> wrote:

Ciao
Hannes

-----Original Message-----
From: TEEP [mailto:[email-masked]] On Behalf Of Henk Birkholz
Sent: 03 March 2017 16:52
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Teep] Conference Call Notes ... was RE: Re-sending TEEP BOF Discussion Conference Call Info

Hello all,

Viele Grüße,

Henk

_______________________________________________
TEEP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teep
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 8 Mar 2017 17:04:26 +0100

Hey Jeremy,

thanks for the clarification. I referenced the exemplary document 
because at the time of writing it was the only freely accessible document.

> behind a click-through license.

That's why I put the link to the license-bound spec set in the next mail.

> https://www.globalplatform.org/specificationsdevice.asp

In regard to batch, it could be useful to consider referencing similar 
prior work. The Multiple-Hash Attestation Protocol, for example, 
presented in the ACM paper "Improving the scalability of platform 
attestation." includes existing security considerations, which might (or 
might not) be applicable here.

Cheers,

Henk

On 03/08/2017 04:34 PM, O'Donoghue, Jeremy wrote:
>   * The document mentioned by Henk contains only a security layer, and
>     cannot be understood independent of other documents. I do not
>     recommend it to anyone trying to understand other efforts in this area.
>   * The essence of the “batch” use case is for systems which are not
>     online 100% of the time, or where online communication is costly. I
>     would envisage at least the following “batch” use cases for
>     consideration:
>       o TAM wishes to install or update a TA using a distribution model
>         in which the TA is distributed as part of an REE app package. In
>         this case many identical requests may be envisaged.
>       o TAM wishes to personalise a TA. In this case requests are not
>         identical, but are delivered offline.
>   * The best introductory TEE document I know of is the GlobalPlatform
>     "TEE System Architecture v1.1”, which is available from the
>     GlobalPlatform specification area - behind a click-through license.
>     It provides considerably more information than the Wikipedia article.
>
>
> Best regards
> Jeremy
>
> ---
> Jeremy O’Donoghue                            email:
> [email-masked] <mailto:[email-masked]>
>> On 7 Mar 2017, at 07:45, Hannes Tschofenig <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>> To: [email-masked] <mailto:[email-masked]>
>>> * Pete Resnick suggested to distribute some introductory material
>>> about TEEs and TrustZone to the mailing list to provide participants
>>> with enough background for the meeting. Hannes will ask
>>> company-internally for some useful material.
>>
>> [email-masked] <mailto:[email-masked]>
>> IMPORTANT NOTICE: The contents of this email and any attachments are
>> confidential and may also be privileged. If you are not the intended
>> recipient, please notify the sender immediately and do not disclose
>> the contents to any other person, use it for any purpose, or store or
>> copy the information in any medium. Thank you.
>>

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 8 Mar 2017 17:43:25 +0100

On 03/08/2017 04:34 PM, O'Donoghue, Jeremy wrote:
> # The best introductory TEE document I know of is the GlobalPlatform "TEE
> System Architecture v1.1”, which is available from the GlobalPlatform
> specification area - behind a click-through license. It provides
> considerably more information than the Wikipedia article.

Thanks, Jeremy! That's a useful pointer.