Subject: [Teep] BoF approved

From: Kathleen Moriarty <[email-masked]>
Date: Mon, 9 Oct 2017 11:50:37 -0400

Hello,

Thank you all for your work on the charter and shaping the discussions
to demonstrate a clear scope of work.  TEEP was approved to have a BoF
in Singapore and there was one request from Suresh.  He'd like to see
how existing work from vendors is separate from TEEP in the charter
text.

Thank you!

-- 

Best regards,
Kathleen

---

From: [email-masked]
Date: Fri, 13 Oct 2017 16:19:05 +0000

Depending on the schedule of the BoF, I may be unable to participate remotely to the Singapore meeting, but I have been following the discussions on the list and I have some concerns about the proposed charter.

As far as I can tell, there is no technical benefit to the IETF working on OTrP as currently contributed given that it has already been accepted as a work item at GlobalPlatform. GlobalPlatform already publishes a significant number of other specifications around TEE, and OTrP is a clear fit with this portfolio. GlobalPlatform already plans to deliver a public document release well ahead of the proposed TEEP  schedule.

Many of the listed document editors are acting as both editors and contributors in the relevant GlobalPlatform WG.

Given the effort at GlobalPlatform, I do not see what technical benefit the IETF can usefully add to the OTrP specification. While it is clear that there is useful work to be done in the area of TEE-like environments which are not based on a secure boot as a root of trust, I am not sure whether this is in scope for the the IETF.

In particular, I would be very concerned to see two different versions of the same protocol, given the significant risk of market fragmentation and non-interoperability that would result.

In conclusion, I do not believe that the IETF should go ahead with WG formation based on the current charter text. If there is a role for an IETF WG, it should be clearly differentiated from the GlobalPlatform effort. I hope that there is significant time on the BoF agenda to discuss this.

Best regards
Jeremy

> On 9 Oct 2017, at 16:50, Kathleen Moriarty <[email-masked]> wrote:
> 
> Hello,
> 
> _______________________________________________
> TEEP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teep