Subject: [Teep] APIs

From: Dave Thaler <[email-masked]>
Date: Thu, 2 Nov 2017 01:06:07 +0000

As promised when I posted my review, I am starting several email threads for discussions on specific technical topics.
This is one of them.

Currently the document specifies both a protocol and an API.   The IETF today does not really do concrete APIs (i.e.,
APIs in specific programming languages), just abstract APIs.   Other orgs own concrete APIs, like W3C does JavaScript,
the POSIX standard covers C, etc.   GlobalPlatform does do concrete APIs, so one potential way forward would be to
*concrete* API portion out of the draft, let GlobalPlatform do that, and keep the protocol and an *abstract* API in the IETF.

Dave

From: Dave Thaler
Sent: Saturday, September 23, 2017 12:24 PM
To: [email-masked]' <[email-masked]>
Subject: Review of draft-pei-opentrustprotocol-04

I've finally made it through a detailed review of draft-pei-opentrustprotocol-04 and my marked up copy is at
https://www.microsoft.com/en-us/research/wp-content/uploads/2017/05/draft-pei-opentrustprotocol-04.pdf

I have lots of editorial fixes throughout, and a number of technical comments/questions/issues.

I'll start separate email threads for some of them over the next several days.

Dave

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 6 Nov 2017 19:11:50 +0000

Hi Dave,

I agree with you that the standardization work should not define APIs and should instead re-use existing APIs as much as possible.

Ciao
Hannes

From: TEEP [mailto:[email-masked]] On Behalf Of Dave Thaler
Sent: 02 November 2017 02:06
To: [email-masked]
Subject: [Teep] APIs

Dave

From: Dave Thaler
Sent: Saturday, September 23, 2017 12:24 PM
To: [email-masked]' <[email-masked]<mailto:[email-masked]>>
Subject: Review of draft-pei-opentrustprotocol-04

Dave
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.