Subject: [Teep] Applicability to constrained environments

From: Dave Thaler <[email-masked]>
Date: Thu, 2 Nov 2017 00:57:13 +0000

As promised when I posted my review, I am starting several email threads for discussions on specific technical topics.
This is one of them.

TEEs are critical in many IoT environments, as is the ability to install apps after the device is originally provisioned,
so I would want OTrP to be applicable (or said more generally, I would want IoT environments to be one of the use cases
in scope for TEEP).

JSON is notably inefficient for IoT environments because of its verbosity, and CBOR is often used instead.
So I think a CBOR encoded version is needed.   That may be as simple as specifying it in JSON and then saying CBOR can be
used simply by using the CBOR that you'd get when converting JSON to CBOR, which mapping is fairly well specified.

It could also be done as part of a specific transport protocol binding, but my preference would be to keep it separate.

Dave

From: Dave Thaler
Sent: Saturday, September 23, 2017 12:24 PM
To: [email-masked]' <[email-masked]>
Subject: Review of draft-pei-opentrustprotocol-04

I've finally made it through a detailed review of draft-pei-opentrustprotocol-04 and my marked up copy is at
https://www.microsoft.com/en-us/research/wp-content/uploads/2017/05/draft-pei-opentrustprotocol-04.pdf

I have lots of editorial fixes throughout, and a number of technical comments/questions/issues.

I'll start separate email threads for some of them over the next several days.

Dave

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 6 Nov 2017 19:25:05 +0000

Hi Dave,

I believe the requirement for CBOR arises when one wants to reduce the over-the-air overhead, which is typically the case for low power WANs or mesh networks.

In the typical environments where TEEs are used you often have a somewhat good Internet connectivity, such as with smart TVs, set-top boxes, entertainment systems, etc.

Hence, I think an IoT environment does not automatically mandate the use of CBOR (or a protocol like CoAP).

Ciao
Hannes

From: TEEP [mailto:[email-masked]] On Behalf Of Dave Thaler
Sent: 02 November 2017 01:57
To: [email-masked]
Subject: [Teep] Applicability to constrained environments

Dave

From: Dave Thaler
Sent: Saturday, September 23, 2017 12:24 PM
To: [email-masked]' <[email-masked]<mailto:[email-masked]>>
Subject: Review of draft-pei-opentrustprotocol-04

Dave
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.