Subject: Re: [Teep] Transport Protocol

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Mon, 6 Nov 2017 19:17:33 +0000

Hi,
I think it is OK to define more than one applicable transport, does it make sense to mandate one though?  If this is to be used in IoT use cases, they may prefer CoAP?

                Nancy

From: TEEP <[email-masked]> on behalf of Hannes Tschofenig <[email-masked]>
Date: Monday, November 6, 2017 at 11:10 AM
To: Dave Thaler <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Teep] Transport Protocol

Hi Dave,

This is an interesting question. For the main use case where the a software update in a TEE on a mobile device is provided I believe it is fair to say that the protocol we are talking about here is HTTPS. As you know, there have been other use cases described by Dapeng in https://tools.ietf.org/html/draft-liu-opentrustprotocol-usecase-01, which may require other protocols. If I have standardize and mandate at least one protocol then I would pick HTTPS here.

Ciao
Hannes

From: TEEP [mailto:[email-masked]] On Behalf Of Dave Thaler
Sent: 02 November 2017 01:52
To: [email-masked]
Subject: [Teep] Transport Protocol

As promised when I posted my review, I am starting several email threads for discussions on specific technical topics.
This is one of them.

Section 1:
> This specification defines message payloads exchanged between devices

> and a TSM but does not mandate a specific transport.

Section 5:
> The communication method of OTrP Messages between a TSM and TEE in a
> device is left to TSM providers for maximal interoperability.

I disagree, the lack of any spec for a transport results in lack of maximal interoperability.
The TSM and the TEE may be from different vendors as the draft nicely explains earlier.
So bindings to one or more transport protocol (the thing that carries the JSON messages inside it) must be standardized.
Otherwise, in my view there’s little value in standardizing the payload formats.

Such a transport protocol binding might be in the same spec or in a different spec, but either way
I think specifying at least one is mandatory.

Dave

From: Dave Thaler
Sent: Saturday, September 23, 2017 12:24 PM
To: [email-masked]' <[email-masked]<mailto:[email-masked]>>
Subject: Review of draft-pei-opentrustprotocol-04

I’ve finally made it through a detailed review of draft-pei-opentrustprotocol-04 and my marked up copy is at
https://www.microsoft.com/en-us/research/wp-content/uploads/2017/05/draft-pei-opentrustprotocol-04.pdf

I have lots of editorial fixes throughout, and a number of technical comments/questions/issues.

I’ll start separate email threads for some of them over the next several days.

Dave
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 6 Nov 2017 19:20:46 +0000

Hi Nancy,

If the IoT scenario includes a device that runs an powerful processor that includes a Trusted Execution Environment but has a very low bandwidth connection then CoAP would make sense.
However, in that case I could also imagine removing other features as well besides changing the transport alone.

Ciao
Hannes

From: Nancy Cam-Winget (ncamwing) [mailto:[email-masked]]
Sent: 06 November 2017 20:18
To: Hannes Tschofenig; Dave Thaler; [email-masked]
Subject: Re: [Teep] Transport Protocol

Hi,

                Nancy

From: TEEP <[email-masked]<mailto:[email-masked]>> on behalf of Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Date: Monday, November 6, 2017 at 11:10 AM
To: Dave Thaler <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teep] Transport Protocol

Hi Dave,

Ciao
Hannes

From: TEEP [mailto:[email-masked]] On Behalf Of Dave Thaler
Sent: 02 November 2017 01:52
To: [email-masked]<mailto:[email-masked]>
Subject: [Teep] Transport Protocol

Dave

From: Dave Thaler

Dave