Subject: [Teep] Multiple SPs under the same TSM

From: Dave Thaler <[email-masked]>
Date: Thu, 2 Nov 2017 01:01:40 +0000

As promised when I posted my review, I am starting several email threads for discussions on specific technical topics.
This is one of them.

The draft talks about multiple Service Providers (SP) under the same Trust Service Manager (TSM), and then
specifies a bunch of extra complexity to deal with that case.   But it never motivates why such a case is important.
Why is the extra complexity needed?  Wouldn't it be simpler to just say there's one TSM per SP?

If there's a real-world scenario that requires the extra complexity, what is it?   (And the draft should be updated
with motivation)   Alternatively, it would simplify the protocol to remove the extra complexity.

Dave

From: Dave Thaler
Sent: Saturday, September 23, 2017 12:24 PM
To: [email-masked]' <[email-masked]>
Subject: Review of draft-pei-opentrustprotocol-04

I've finally made it through a detailed review of draft-pei-opentrustprotocol-04 and my marked up copy is at
https://www.microsoft.com/en-us/research/wp-content/uploads/2017/05/draft-pei-opentrustprotocol-04.pdf

I have lots of editorial fixes throughout, and a number of technical comments/questions/issues.

I'll start separate email threads for some of them over the next several days.

Dave

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 6 Nov 2017 19:16:45 +0000

Hi Dave,

This is a clarifying question. Maybe there is fuzzy wording in there but I am wondering whether you are talking an SP developing multiple TAs and a TA belonging to a single security domain, as described in this entity relationship diagram:
https://www.ietf.org/mail-archive/web/teep/current/png9JvwvLJCdH.png

Ciao
Hannes

From: TEEP [mailto:[email-masked]] On Behalf Of Dave Thaler
Sent: 02 November 2017 02:02
To: [email-masked]
Subject: [Teep] Multiple SPs under the same TSM

Dave

From: Dave Thaler
Sent: Saturday, September 23, 2017 12:24 PM
To: [email-masked]' <[email-masked]<mailto:[email-masked]>>
Subject: Review of draft-pei-opentrustprotocol-04

Dave
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.