Subject: Re: [Teep] Applicability to constrained environments

From: "刘大鹏(鹏成)" <[email-masked]>
Date: Thu, 02 Nov 2017 16:10:47 +0800

Hello Dave,
We have a draft that proposes to use CBOR for OTrP:   https://tools.ietf.org/html/draft-liu-opentrustprotocol-cbor-00Your comments are welcomed.
Thanks,Regards,Dapeng Liu------------------------------------------------------------------Dave Thaler <[email-masked]>2017年11月2日(星期四) 08:[email-masked] <[email-masked]>[Teep] Applicability to constrained environments
As promised when I posted my review, I am starting several email threads for discussions on specific technical topics.This is one of them. TEEs are critical in many IoT environments, as is the ability to install apps after the device is originally provisioned,so I would want OTrP to be applicable (or said more generally, I would want IoT environments to be one of the use casesin scope for TEEP). JSON is notably inefficient for IoT environments because of its verbosity, and CBOR is often used instead.So I think a CBOR encoded version is needed.   That may be as simple as specifying it in JSON and then saying CBOR can beused simply by using the CBOR that you’d get when converting JSON to CBOR, which mapping is fairly well specified. It could also be done as part of a specific transport protocol binding, but my preference would be to keep it separate. Dave From: Dave Thaler 
Sent: Saturday, September 23, 2017 12:24 PM
To: [email-masked]' <[email-masked]>
Subject: Review of draft-pei-opentrustprotocol-04 I’ve finally made it through a detailed review of draft-pei-opentrustprotocol-04 and my marked up copy is athttps://www.microsoft.com/en-us/research/wp-content/uploads/2017/05/draft-pei-opentrustprotocol-04.pdf I have lots of editorial fixes throughout, and a number of technical comments/questions/issues. I’ll start separate email threads for some of them over the next several days. Dave

---

From: Dave Thaler <[email-masked]>
Date: Thu, 2 Nov 2017 20:30:51 +0000

Thanks, glad to hear it.

But it appears to respecify the format of each message.
Why not just say all formats are the CBOR equivalent of the JSON?

From: TEEP [mailto:[email-masked]] On Behalf Of ???(??)
Sent: Thursday, November 2, 2017 1:11 AM
To: TEEP <[email-masked]>; [email-masked]
Subject: Re: [Teep] Applicability to constrained environments

Hello Dave,

We have a draft that proposes to use CBOR for OTrP:   https://tools.ietf.org/html/draft-liu-opentrustprotocol-cbor-00
Your comments are welcomed.

Thanks,
Regards,
Dapeng Liu
------------------------------------------------------------------
Dave Thaler <[email-masked]<mailto:[email-masked]>>
2017年11月2日(星期四) 08:57
[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
[Teep] Applicability to constrained environments

As promised when I posted my review, I am starting several email threads for discussions on specific technical topics.
This is one of them.

TEEs are critical in many IoT environments, as is the ability to install apps after the device is originally provisioned,
so I would want OTrP to be applicable (or said more generally, I would want IoT environments to be one of the use cases
in scope for TEEP).

JSON is notably inefficient for IoT environments because of its verbosity, and CBOR is often used instead.
So I think a CBOR encoded version is needed.   That may be as simple as specifying it in JSON and then saying CBOR can be
used simply by using the CBOR that you’d get when converting JSON to CBOR, which mapping is fairly well specified.

It could also be done as part of a specific transport protocol binding, but my preference would be to keep it separate.

Dave

From: Dave Thaler
Sent: Saturday, September 23, 2017 12:24 PM
To: [email-masked]' <[email-masked]<mailto:[email-masked]>>
Subject: Review of draft-pei-opentrustprotocol-04

I’ve finally made it through a detailed review of draft-pei-opentrustprotocol-04 and my marked up copy is at
https://www.microsoft.com/en-us/research/wp-content/uploads/2017/05/draft-pei-opentrustprotocol-04.pdf<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.microsoft.com%2Fen-us%2Fresearch%2Fwp-content%2Fuploads%2F2017%2F05%2Fdraft-pei-opentrustprotocol-04.pdf&data=02%7C01%7Cdthaler%40microsoft.com%7Ccfd9a3a758964200ec0708d521c94016%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636452070606261594&sdata=FAR1U1klITay%2F07tiyjVKQgoB069Ax03MeytQ8biKrY%3D&reserved=0>

I have lots of editorial fixes throughout, and a number of technical comments/questions/issues.

I’ll start separate email threads for some of them over the next several days.

Dave