Subject: [TLS] Registering SHA256 null encryption ciphersuites

From: "Lewis, Nick" <[email-masked]>
Date: Wed, 30 May 2012 10:23:00 +0100

May I please have the views of the people on this list as to the merit of registering some SHA256 null encryption cipher suites

We have a requirement for secure authenticated communications that does not involve the passing of shared keys, PINs, PII or other confidential data and therefore no encryption is required

RFC4492 defines the following null encryption cipher suites:

TLS_ECDH_ECDSA_WITH_NULL_SHA
TLS_ECDHE_ECDSA_WITH_NULL_SHA
TLS_ECDH_RSA_WITH_NULL_SHA
TLS_ECDHE_RSA_WITH_NULL_SHA

These cipher suites are closest to our requirements. However we cannot use 160bit SHA require that SHA256 be used.

I am thinking that it may be appropriate to have new cipher suite identifiers registered in the IANA TLS Cipher Suite Registry for the following:

TLS_ECDH_ECDSA_WITH_NULL_SHA256
TLS_ECDHE_ECDSA_WITH_NULL_SHA256
TLS_ECDH_RSA_WITH_NULL_SHA256
TLS_ECDHE_RSA_WITH_NULL_SHA256

Is this suggestion sensible?

Although not required in our application, is it also worth including ECDH_anon_WITH_NULL_SHA256 and SHA384 variants of the ciphersuites too?

Best Regards
Nick

Nick Lewis
[email-masked]<mailto:[email-masked]>
+44 1684 277137<tel:+441684277137>
www.g4stechnology.com<http://www.g4stechnology.com/>
New Challenge House, International Drive, Tewkesbury, Gloucestershire, GL20 8UQ, UK

P Please consider the environment before printing this email

________________________________
The details of this company are as follows:
G4S Technology Limited, Registered Office: Challenge House, International Drive, Tewkesbury, Gloucestershire GL20 8UQ, Registered in England No. 2382338.

This communication may contain information which is confidential, personal and/or privileged.

It is for the exclusive use of the intended recipient(s).
If you are not the intended recipient(s), please note that any distribution, forwarding, copying or use of this communication or the information in it is strictly prohibited.

Any personal views expressed in this e-mail are those of the individual sender and the company does not endorse or accept responsibility for them.

Prior to taking any action based upon this e-mail message, you should seek appropriate confirmation of its authenticity.

This e-mail has been scanned for all viruses by MessageLabs.

---

From: Patrick Pelletier <[email-masked]>
Date: Wed, 06 Jun 2012 00:29:31 -0700

On 5/30/12 2:23 AM, Lewis, Nick wrote:

> Although not required in our application, is it also worth including
> ECDH_anon_WITH_NULL_SHA256 and SHA384 variants of the ciphersuites too?

I could easily be missing something, but what would the intended use of 
this ciphersuite (or any "*_anon_WITH_NULL_*" ciphersuite) be?  Since it 
has no encryption, it doesn't offer any protection against passive 
eavesdroppers.  But since it has no authentication, it doesn't offer any 
protection against active attackers.  What sort of attack is it meant to 
protect against?

(There is currently one "*_anon_WITH_NULL_*" ciphersuite registered with 
IANA, TLS_ECDH_anon_WITH_NULL_SHA, and my puzzlement extends to that 
ciphersuite, as well.)

--Patrick