Subject: [TLS] [Technical Errata Reported] RFC6066 (3283)

From: RFC Errata System <[email-masked]>
Date: Thu, 12 Jul 2012 21:10:13 -0700 (PDT)

The following errata report has been submitted for RFC6066,
"Transport Layer Security (TLS) Extensions: Extension Definitions".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6066&eid=3283

--------------------------------------
Type: Technical
Reported by: Brad Wetmore <[email-masked]>

Section: Appendix A

Original Text
-------------
Appendix A:     The Server Name extension...(deleted)... It is provided that the ServerNameList can contain more than only one name of any particular name_type.

Corrected Text
--------------
Appendix A:     The Server Name extension...deleted..It is provided that the ServerNameList can contain only one name of any particular name_type.

Notes
-----
Section 3 and Appendix A seem to be conflict with each other.  Am I parsing something incorrectly here:

Section 3:   The ServerNameList MUST NOT contain more than one name of the same name_type.

Appendix A:     The Server Name extension...deleted..It is provided that the ServerNameList can contain more than only one name of any particular name_type.

I think the words "more than" were not supposed to appear in the final RFC.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6066 (draft-ietf-tls-rfc4366-bis-12)
--------------------------------------
Title               : Transport Layer Security (TLS) Extensions: Extension Definitions
Publication Date    : January 2011
Author(s)           : D. Eastlake 3rd
Category            : PROPOSED STANDARD
Source              : Transport Layer Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 17 Jul 2012 00:25:37 -0400

I believe this Errata is correct. The words "more than" should not be
there in the appendix. I would guess that at one point it said "no
more than one" and somehow, in changing to "only one", it got garbled.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]