Subject: [TLS] WG Call for adoption of draft-rescorla-tls-subcerts

From: Sean Turner <[email-masked]>
Date: Wed, 12 Apr 2017 15:31:05 -0400

All,

At our IETF 98 session, there was support in the room to adopt draft-rescorla-tls-subcerts [0].  We need to confirm this support on the list so please let the list know whether you support adoption of the draft and are willing to review/comment on the draft before 20170429.  If you object to its adoption, please let us know why.

Clearly, the WG is going to need to work through the trade-offs between short-lived certificates and sub-certs because both seem, to some, to be addressing the same problem. 

Cheers,

J&S

[0] https://datatracker.ietf.org/doc/html/draft-rescorla-tls-subcerts

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 12 Apr 2017 12:33:49 -0700

Unsurprisingly, I favor adopting this draft.

-Ekr

On Wed, Apr 12, 2017 at 12:31 PM, Sean Turner <[email-masked]> wrote:

> All,
>
> At our IETF 98 session, there was support in the room to adopt
> draft-rescorla-tls-subcerts [0].  We need to confirm this support on the
> list so please let the list know whether you support adoption of the draft
> and are willing to review/comment on the draft before 20170429.  If you
> object to its adoption, please let us know why.
>
> Clearly, the WG is going to need to work through the trade-offs between
> short-lived certificates and sub-certs because both seem, to some, to be
> addressing the same problem.
>
> Cheers,
>
> J&S
>
> _______________________________________________
> Lurk mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lurk
>

---

From: Richard Barnes <[email-masked]>
Date: Wed, 12 Apr 2017 17:25:23 -0400

Likewise.

On Wed, Apr 12, 2017 at 3:33 PM, Eric Rescorla <[email-masked]> wrote:

> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>
>

---

From: Melinda Shore <[email-masked]>
Date: Wed, 12 Apr 2017 13:37:14 -0800

On 4/12/17 11:31 AM, Sean Turner wrote:
> draft-rescorla-tls-subcerts [0].  We need to confirm this support on
> the list so please let the list know whether you support adoption of
> the draft and are willing to review/comment on the draft before
> 20170429.  If you object to its adoption, please let us know why.

I support its adoption (for whatever it's worth I work for a
CDN) and would be happy to review the draft before the end of
the month.

Melinda

---

From: Russ Housley <[email-masked]>
Date: Wed, 12 Apr 2017 17:37:28 -0400

On Wed, Apr 12, 2017 at 12:31 PM, Sean Turner <[email-masked] <mailto:[email-masked]>> wrote:
All,

Cheers,

J&S

[0] https://datatracker.ietf.org/doc/html/draft-rescorla-tls-subcerts <https://datatracker.ietf.org/doc/html/draft-rescorla-tls-subcerts>

I want to see a solution to this problem, but I think we should look at RFC 3820, X.509 Proxy Certificate Profile.  I know that this was implemented, but I do not know if it is still in use.

Russ

---

From: Subodh Iyengar <[email-masked]>
Date: Thu, 13 Apr 2017 00:22:13 +0000

+1 for adoption

@Russ there's some discussion about comparison with proxy certs in the current draft.

Subodh

________________________________
From: TLS <[email-masked]> on behalf of Russ Housley <[email-masked]>
Sent: Wednesday, April 12, 2017 2:37:28 PM
To: IETF TLS; IETF LURK
Subject: Re: [TLS] [Lurk] WG Call for adoption of draft-rescorla-tls-subcerts

On Wed, Apr 12, 2017 at 12:31 PM, Sean Turner <[email-masked]<mailto:[email-masked]>> wrote:
All,

Cheers,

J&S

[0] https://datatracker.ietf.org/doc/html/draft-rescorla-tls-subcerts<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Drescorla-2Dtls-2Dsubcerts&d=DwMCAg&c=5VD0RTtNlTh3ycd41b3MUw&r=h3Ju9EBS7mHtwg-wAyN7fQ&m=osJAxjy_1uCu6fnGyX7xCq81BrisoC5B5ydK5vt3LCQ&s=GjhbUQ8zTz6yOY8b4PbBzUBVpAIbzU9Gi-fqPLvnPUc&e=>

Russ

---

From: Russ Housley <[email-masked]>
Date: Thu, 13 Apr 2017 10:23:17 -0400

> @Russ there's some discussion about comparison with proxy certs in the current draft. 

Yes, I saw the list of bullets in Section 5.  I think that a TLS-specific delegation is a good idea, but I do not agree with all of the points into bullets.  That said, we should not be having that discussion as part of the decision to adopt or not.

Russ

---

From: Peter Gutmann <[email-masked]>
Date: Fri, 14 Apr 2017 08:23:28 +0000

Russ Housley <[email-masked]> writes:

>I want to see a solution to this problem, but I think we should look at RFC
>3820, X.509 Proxy Certificate Profile.  I know that this was implemented, but
>I do not know if it is still in use.

It's fairly heavily used in grid computing.  It would probably be used outside
that environment as well if people knew it existed, meaning that I have on a
number of occasions encountered people who needed something like proxy certs
but were kludging around it in various ugly ways because they didn't know they
existed.

Peter.

---

From: Daniel Migault <[email-masked]>
Date: Wed, 19 Apr 2017 09:42:01 -0400

Hi,

I am in favor of adoption of the draft. This is an important issue we need
to address.

Yours,
Daniel

---

From: "Fossati, Thomas (Nokia - GB/Cambridge, UK)" <[email-masked]>
Date: Sat, 22 Apr 2017 20:45:47 +0000

I've read draft-rescorla-tls-subcerts-01 and have a few comments.

It's a well written document and the low-level mechanics look ok.  However,
I think I have a couple of issues with the overall design.

First: it is not self-sufficient.  The fact that clients must opt-in implies
that servers must have a backup plan.  Since keeping the high-value key
material in the same node as the delegate credentials contradicts the basic
security goal, the only realistic fallback is to have a key-server / LURK box
at hand?  But this has the known and already discussed limitations --
complicated setup and operations, scaling issues, single point of failure,
etc. -- which make it inapplicable to some key use cases (CDN).

Second, we need to change the stack at the endpoints.  This might be OK for
browsers, but it's a bit more problematic when the UA is an STB or a
residential gateway, as these things tend to have much slower release and
upgrade cycles.

With regards to WG adoption, I guess I'm neutral.  I think it doesn't hurt
to have something like this, but for the reasons stated above, I'm not sure
it provides a solution to the LURK problem.

Cheers, t

PS: It'd be nice if the document discussed the implication of the "unregulated"
delegation mechanism especially with regards to its auditability.

---

From: [email-masked]
Date: Tue, 25 Apr 2017 17:56:51 +0000

I have reviewed the draft and I support adoption of this draft. Agree that both the short-lived certificate and subcerts are addressing a similar issue and perhaps tradeoffs can be considered. 

Thanks
Sanjay

-----Original Message-----
From: Lurk [mailto:[email-masked]] On Behalf Of Sean Turner
Sent: Wednesday, April 12, 2017 3:31 PM
To: <[email-masked]>
Cc: [email-masked]
Subject: [E] [Lurk] WG Call for adoption of draft-rescorla-tls-subcerts

All,

Cheers,

J&S

[0] https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Drescorla-2Dtls-2Dsubcerts&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=9a_L6t5TdnDThojv7KBKmqsZzTGM6YylS2wfbAO9KK0&m=jR4l13smzl6mjhJNFZzBEcBkfCAl-bHE1ztPqmR8cSU&s=1-VoLJ98RM8Ke0Zyp2Qad4rw9aXhVeIkqqMVEhfGtuw&e= 
_______________________________________________
Lurk mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_lurk&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=9a_L6t5TdnDThojv7KBKmqsZzTGM6YylS2wfbAO9KK0&m=jR4l13smzl6mjhJNFZzBEcBkfCAl-bHE1ztPqmR8cSU&s=pquB3m1OmFta3X4qksEg1egdeKwrUVL4c5W4YFgkSu0&e=