Subject: [TLS] WG review of draft-ietf-tls-rfc4492bis

From: Sean Turner <[email-masked]>
Date: Tue, 11 Apr 2017 09:09:04 -0400

All,

draft-ietf-tls-rfc4492bis has been revised since it left the WG and we agree with Yoav’s statement at the mic in Chicago that the WG should review the changes before we ask Kathleen (our newly appointed AD) to continue progressing the draft.  Please review the differences from the -12 version that went through WGLC and the latest version [0] and let us know by 20170426 whether there is anything that would stop progression of the draft.

Thanks,

J&S

[0] https://www.ietf.org/rfcdiff?url1=draft-ietf-tls-rfc4492bis-12&url2=draft-ietf-tls-rfc4492bis-16

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Apr 2017 18:54:24 +1000

I have reviewed the changes. They look good.  I have some reservations
about section 7 (implementation status) given that I expect it to date
badly, but it isn't really doing any actual harm either.

On 11 Apr. 2017 11:09 pm, "Sean Turner" <[email-masked]> wrote:

> All,
>
> draft-ietf-tls-rfc4492bis has been revised since it left the WG and we
> agree with Yoav’s statement at the mic in Chicago that the WG should review
> the changes before we ask Kathleen (our newly appointed AD) to continue
> progressing the draft.  Please review the differences from the -12 version
> that went through WGLC and the latest version [0] and let us know by
> 20170426 whether there is anything that would stop progression of the draft.
>
> Thanks,
>
> J&S
>
> [0] https://www.ietf.org/rfcdiff?url1=draft-ietf-tls-
> rfc4492bis-12&url2=draft-ietf-tls-rfc4492bis-16
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 20 Apr 2017 16:41:25 -0500

I also reviewed the changes and have no objections.

I will just note that leaving the 'implicit' value in the
PublicValueEncoding but then removing the select() block that used it in
ClientECDiffieHellmanPublic looks a little weird at first glance, but is
probably okay (since implicit was only used for the fixed_ECDH methods
that are removed by this document).

-Ben

On 04/13/2017 03:54 AM, Martin Thomson wrote:
> On 11 Apr. 2017 11:09 pm, "Sean Turner" <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     All,
>
>     draft-ietf-tls-rfc4492bis has been revised since it left the WG
>     and we agree with Yoav’s statement at the mic in Chicago that the
>     WG should review the changes before we ask Kathleen (our newly
>     appointed AD) to continue progressing the draft.  Please review
>     the differences from the -12 version that went through WGLC and
>     the latest version [0] and let us know by 20170426 whether there
>     is anything that would stop progression of the draft.
>
>     Thanks,
>
>     J&S
>
>     [0]
>     https://www.ietf.org/rfcdiff?url1=draft-ietf-tls-rfc4492bis-12&url2=draft-ietf-tls-rfc4492bis-16
>     <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl1-3Ddraft-2Dietf-2Dtls-2Drfc4492bis-2D12-26url2-3Ddraft-2Dietf-2Dtls-2Drfc4492bis-2D16&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=sssDLkeEEBWNIXmTsdpw8TZ3tAJx-Job4p1unc7rOhM&m=j7NWbDnuLYFY4aLpEDDejngQYL6Fhh2HRdFyQpIaQ4E&s=HNgYXclC2RY5Gc5jxDQ1PYLCJLsAtGZkVHHHe_Dj3hM&e=>
>     [email-masked] <mailto:[email-masked]>
>     <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tls&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=sssDLkeEEBWNIXmTsdpw8TZ3tAJx-Job4p1unc7rOhM&m=j7NWbDnuLYFY4aLpEDDejngQYL6Fhh2HRdFyQpIaQ4E&s=LlJZwWVMZqNnQqGvXusM8WqLEOO-A2uvb7ln-TwSTYk&e=>
>
>
>

---

From: Sean Turner <[email-masked]>
Date: Fri, 28 Apr 2017 17:21:56 -0400

Thanks to MT and Ben for their reviews.  Joe and I have asked Kathleen to progress this draft towards the “approved” state.

spt

> On Apr 11, 2017, at 09:09, Sean Turner <[email-masked]> wrote:
> 
> All,
>