Subject: [TLS] TLS 1.3 (-18) at Apple

From: Chris Wood <[email-masked]>
Date: Wed, 14 Jun 2017 20:00:10 +0200

Hi folks,

Last week at WWDC 2017, we (Apple) announced support for TLS 1.3 (-18) in our platforms. It is not turned on by default. If you’re a member of the developer seed, you may enable it on iOS by downloading and installing the following profile:

    https://developer.apple.com/go/?id=tls13-mobile-profile

You may also enable support on macOS with the following defaults write:

    defaults write /Library/Preferences/com.apple.networkd tcp_connect_enable_tls13 1

Our goal is maximal coverage in apps and networks. We encourage everyone who’s a member to opt in and start testing your services. 

Note, we currently do not have 0-RTT data support.

Best,
Chris

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 14 Jun 2017 13:02:51 -0500

>     defaults write /Library/Preferences/com.apple.networkd tcp_connect_enable_tls13 1

Is the plan to stay on draft-18 until it's time to move to the final RFC
version?

> Note, we currently do not have 0-RTT data support.

Seems prudent, given how much it's still in flux (and the lack of
published application profiles for its use).

-Ben

---

From: Chris Wood <[email-masked]>
Date: Wed, 14 Jun 2017 20:09:01 +0200

> On Jun 14, 2017, at 8:02 PM, Benjamin Kaduk <[email-masked]> wrote:
> 
> Is the plan to stay on draft-18 until it's time to move to the final RFC version?

As of now, that is the most likely outcome. Though that may change if most other clients and servers move to a more recent version.

> Seems prudent, given how much it's still in flux (and the lack of published application profiles for its use).

Precisely. 

Best,
Chris