Subject: [TLS] certificate_request_context in TLS 1.3 Certificate handshake message

From: Xuelei Fan <[email-masked]>
Date: Tue, 25 Jul 2017 23:48:55 +0000

Hi,

The TLS 1.3 Certificate handshake message is defined as:

   struct {
       opaque certificate_request_context<0..2^8-1>;
       CertificateEntry certificate_list<0..2^24-1>;
   } Certificate;

   certificate_request_context  If this message is in response to a
      CertificateRequest, the value of certificate_request_context in
      that message.  Otherwise (in the case of server authentication),
      this field SHALL be zero length.

As the certificate_request_context and client delivered Certificate
handshake message are only in response to a CertificateRequest, the one
byte zero length of certificate_request_context field is redundant for
server delivered certificate handshake message. It may be more clear to use
the certificate_request_context field for client delivered Certificate
handshake message only, for example:

   struct {
       select (connection_end) {
            case client:
               opaque certificate_request_context<0..2^8-1>;
            case server:
               struct {};
       }
       CertificateEntry certificate_list<0..2^24-1>;
   } Certificate;

Regards,
Xuelei Fan

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 25 Jul 2017 16:57:31 -0700

Given that this document has been through 2 WGLCs, and this is basically an
aesthetic change, I don't think it gets over the barrier.

-Ekr

On Tue, Jul 25, 2017 at 4:48 PM, Xuelei Fan <[email-masked]> wrote:

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>
>

---

From: Xuelei Fan <[email-masked]>
Date: Wed, 26 Jul 2017 01:07:22 +0000

Agreed it is basically an aesthetic change.

Thanks,
Xuelei

On Tue, Jul 25, 2017 at 4:58 PM Eric Rescorla <[email-masked]> wrote:

> Given that this document has been through 2 WGLCs, and this is basically
> an aesthetic change, I don't think it gets over the barrier.
>
> -Ekr
>
>