Subject: [TLS] possible new work item: not breaking TLS

From: Stephen Farrell <[email-masked]>
Date: Thu, 13 Jul 2017 13:00:06 +0100

Hi again TLS WG chairs,

I've done a bit more work on the collection of arguments
against the latest break-TLS proposal. [1] I plan to keep
working on that so more input is welcome. (Corrections
where I've gotten stuff wrong are even more welcome.)

I'd like to again request some time on the agenda to
allow discussion of those points in a more structured
manner than will be possible during the mic-line scrum
that'll likely follow a sales-pitch for draft-green.

I'd also like to ask the WG if we think it'd be useful
to document the arguments against that and other "let's
break-tls" proposals we've seen in the past in an RFC.
If people think it would be useful, I'd be willing to
do work to edit such a draft, or help edit that.

Thanks,
S.

[1] https://github.com/sftcd/tinfoil

---

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Thu, 13 Jul 2017 15:52:31 +0000

I support allocating a time slot for the arguments against the draft-green (and similar/related approaches).

I also support documenting the above arguments, possibly in a TLS WG draft.
--
Regards,
Uri Blumenthal

On 7/13/17, 08:00, "TLS on behalf of Stephen Farrell" <[email-masked] on behalf of [email-masked]> wrote:

    Hi again TLS WG chairs,

    
    
    Thanks,
    S.

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Fri, 14 Jul 2017 16:19:00 +0000

I also support both time here and a "let's put all the bad breaking TLS
ideas in one draft".

On Thu, Jul 13, 2017 at 17:52 Blumenthal, Uri - 0553 - MITLL <[email-masked]>
wrote:

> On 7/13/17, 08:00, "TLS on behalf of Stephen Farrell" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>
>     Hi again TLS WG chairs,
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>
-- 
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked], p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 18 Jul 2017 16:23:26 +0100

Hiya,

Thanks to the chairs for allocating some agenda time for
discussion of this topic at tomorrow's session. I plan to
more or less present [1] instead of using slides, so if
folks have a chance to read it over before we get to that
agenda item tomorrow that should help speed things up a
bit.

I'm still happy to take corrections, comments and suggestions
however folks would like to provide those but plan to be at
the social event tonight so likely won't do more updates to
the text before tomorrow morning (semi-inebriated additions
being a bad plan, even if nowhere near as bad a plan as
draft-green:-)

Cheers,
S.