Subject: [TLS] NamedGroup 0

From: Martin Thomson <[email-masked]>
Date: Fri, 28 Jul 2017 21:59:08 +1000

Just doing some code review and noticed that we don't allocate a value
for a NamedGroup of 0.  Knowing the morass of code out there that does
TLS, this is probably used as a sentinel value of some sort somewhere
(the code I was reviewing did exactly that).

Can we reserve this value?

https://github.com/tlswg/draft-ietf-tls-iana-registry-updates/pull/26
https://github.com/tlswg/tls13-spec/pull/1069

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 28 Jul 2017 07:30:07 -0500

> https://github.com/tlswg/tls13-spec/pull/1069

Sounds like a good idea -- let's do it.

-Ben