Subject: Re: [TLS] I-D Action: draft-ietf-tls-tls13-vectors-01.txt

From: Martin Thomson <[email-masked]>
Date: Sun, 2 Jul 2017 14:01:30 +1000

Just a bump to -20. Not quite enough time to land a -21 version with the
changes to tickets. That might happen during the hackathon.

On 30 Jun. 2017 6:14 pm, <[email-masked]> wrote:

>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Transport Layer Security of the IETF.
>
>         Title           : Example Handshake Traces for TLS 1.3
>         Author          : Martin Thomson
>         Filename        : draft-ietf-tls-tls13-vectors-01.txt
>         Pages           : 36
>         Date            : 2017-06-30
>
> Abstract:
>    Examples of TLS 1.3 handshakes are shown.  Private keys and inputs
>    are provided so that these handshakes might be reproduced.
>    Intermediate values, including secrets, traffic keys and ivs are
>    shown so that implementations might be checked incrementally against
>    these values.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-tls-tls13-vectors/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-tls-tls13-vectors-01
> https://datatracker.ietf.org/doc/html/draft-ietf-tls-tls13-vectors-01
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-tls-tls13-vectors-01
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Martin Thomson <[email-masked]>
Date: Tue, 4 Jul 2017 15:23:57 +1000

One thing that we discovered is that NSS doesn't correctly pickle the
hash after HelloRetryRequest.  Obviously that makes the corresponding
example incorrect.