Subject: [TLS] TLS@IETF99 - Additional Session Added and Agenda Bash!

From: Sean Turner <[email-masked]>
Date: Fri, 14 Jul 2017 10:51:14 -0400

The chairs have requested an additional time on the IETF agenda for TLS.  The Secretariat has allocated us the Monday @ 13:30-15:30 slot.  Because the main point of the TLS WG are the TLS and DTLS drafts and the schedule was already announced, we want to leave those presentations on Wednesday.  What follows is a revised agenda; note that we’ve alloced 40 minutes for further about draft-green-tls-static-dh-in-tls13.  Please let us know your thoughts.

Monday @ 1330-1530 CET:

- Administrivia (5min)
- Document Status (5min)
- A DANE Record and DNSSEC Authentication Chain Extension for TLS (20min)
  https://datatracker.ietf.org/doc/draft-ietf-tls-dnssec-chain-extension/
- Record Size Limit Extension for TLS (15min)
  https://datatracker.ietf.org/doc/draft-thomson-tls-record-limit/
- SNI Encryption (25min)
  https://datatracker.ietf.org/doc/draft-huitema-tls-sni-encryption/

Wednesday @ 0930-1200 CET:

- Administrivia (5min)
- TLS1.3 (20min)
  https://datatracker.ietf.org/doc/draft-ietf-tls-tls13/
- DTLS1.3 (45min)
  https://datatracker.ietf.org/doc/draft-ietf-tls-dtls13/
- Data Center use of Static DH (30 min)
  https://datatracker.ietf.org/doc/draft-green-tls-static-dh-in-tls13/
- National Cybersecurity Center of Excellence (NCCOE) project for
  visibility within the datacenter with TLS 1.3 (10min)
  aka implementing draft-green-tls-static-dh-in-tls13
- Discussion about the previous topic (40min)

J&S

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 14 Jul 2017 16:09:45 +0100

Hiya,

On 14/07/17 15:51, Sean Turner wrote:
>  Please let us know your thoughts.

80 minutes for wiretapping is too much. Zero would
be better. But if not...

I'd suggest: 10 minutes for draft-green, 10 minutes
to describe issues with that (i.e. the slot for which
I continue to ask) and then 10 minutes discussion. If
we assume the folks in the room have read the list and
the draft that should be plenty.

If we assume they haven't read the list, then it's more
important that the counter-arguments be given sufficient
time.

So your draft agenda seems to get that backwards to me,
in that it allocates 40 minutes for a sales-pitch and
then 40 minutes where we bitch about that at the mic
interspersed with proponents repeating bits of the sales
pitch. That might be more amusing for us all, but seems
like a worse use of time to me.

Cheers,
S.

---

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Fri, 14 Jul 2017 15:13:04 +0000

+1

Current agenda does look backwards. IMHO, do as Stephen suggested.

Regards,
Uri

Sent from my iPhone

> On Jul 14, 2017, at 11:10, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Ted Lemon <[email-masked]>
Date: Fri, 14 Jul 2017 19:10:47 +0200

I have two working groups already in the monday slot.   I doubt I'm unique
in this.   It seems like you should put the important business in the slot
that was previously scheduled, and the overflow into the Monday slot.
It's hard to imagine how a discussion of the wiretapping thing could be
anything other than a dance at the mic, full of sound and fury, signifying
nothing.

---

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Fri, 14 Jul 2017 17:22:41 +0000

I will be perfectly happy not allocating any time at all for the wiretapping presentation.

I would not call the discussed draft "the important business" - for me it's anything but that. 

Regards,
Uri

Sent from my iPhone

> On Jul 14, 2017, at 13:11, Ted Lemon <[email-masked]> wrote:
> 
> I have two working groups already in the monday slot.   I doubt I'm unique in this.   It seems like you should put the important business in the slot that was previously scheduled, and the overflow into the Monday slot.   It's hard to imagine how a discussion of the wiretapping thing could be anything other than a dance at the mic, full of sound and fury, signifying nothing.
> 
>> On Fri, Jul 14, 2017 at 5:13 PM, Blumenthal, Uri - 0553 - MITLL <[email-masked]> wrote:
>> +1
>>

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Fri, 14 Jul 2017 20:01:03 +0200

On Fri 2017-07-14 10:51:14 -0400, Sean Turner wrote:
> The Secretariat has allocated us the Monday @ 13:30-15:30 slot.

hm, that's disappointing for those of us who had other things we'd
planned on going to already in that slot. :/  But it's not on the agenda
yet, so maybe it has been changed already?

    https://datatracker.ietf.org/meeting/99/agenda.html

> Because the main point of the TLS WG are the TLS and DTLS drafts and
> the schedule was already announced, we want to leave those
> presentations on Wednesday.  What follows is a revised agenda; note
> that we’ve alloced 40 minutes for further about
> draft-green-tls-static-dh-in-tls13.  Please let us know your thoughts.

As Stephen points out, it looks like we've allocated 80 minutes to the
topic of how to remove the forward secrecy guarantees that we've
struggled for over a year to introduce.  That's more than we've
allocated for the "main point of the TLS WG", which are only 65 minutes
combined.

    --dkg

---

From: Andrei Popov <[email-masked]>
Date: Fri, 14 Jul 2017 18:31:12 +0000

> As Stephen points out, it looks like we've allocated 80 minutes to the topic of how to remove the forward secrecy guarantees that we've struggled for over a year to introduce.  That's more than we've allocated for the "main point of the TLS WG", which are only 65 minutes combined.

+1. Restating the same positions over and over again for 80 minutes might get repetitive... It seems that all we need is a quick summary from each side, perhaps some Q&A and a hum.

Cheers,

Andrei

---

From: Nico Williams <[email-masked]>
Date: Fri, 14 Jul 2017 13:55:19 -0500

+1

At some point decisions have to be made though, and someone will end up
on the rough side of consensus in the WG.  There could be (will be!)
appeals.  Lastly, the IESG could also decline to allow such a WG item to
get published.  This would all be much easier if the authors would just
go the ISE Informational route.  Then only the IESG needs to decide
anything -- either way the IESG will be the last stop for this train.

Better skip the Q/A at the WG meeting -- it makes no difference as to
determining consensus, and no one needs the other side screaming bloody
murder and judging one a moron or evil.  It won't be worthy of popcorn.
Just boring, oh so boring.

Nico
--

---

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Fri, 14 Jul 2017 15:25:26 -0400

> ... the IESG could also decline to allow such a WG item to
> get published.  

That’s what I’d expect and hope for.

> determining consensus,

+1

> and no one needs the other side screaming bloody
> murder and judging one a moron or evil.  

I thought the judgment has already been made? ;-)

P.S. I assume the “or” above is an “inclusive or”? ;-)

---

From: Sean Turner <[email-masked]>
Date: Fri, 14 Jul 2017 15:51:35 -0400

And by the important business I was referring to the TLS and DTLS drafts.

spt

> On Jul 14, 2017, at 13:22, Blumenthal, Uri - 0553 - MITLL <[email-masked]> wrote:
>

---

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Fri, 14 Jul 2017 15:53:47 -0400

> And by the important business I was referring to the TLS and DTLS drafts.

My apology. We’re in agreement then.

---

From: Sean Turner <[email-masked]>
Date: Fri, 14 Jul 2017 16:08:29 -0400

> On Jul 14, 2017, at 15:53, Blumenthal, Uri - 0553 - MITLL <[email-masked]> wrote:
> 

No worries I should have been more explicit.

spt

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Fri, 14 Jul 2017 16:35:06 -0400

Sean, can you let us know what room the new session will be in when
you know? (Not on the agenda.)

-- 
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked], p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

---

From: Sean Turner <[email-masked]>
Date: Fri, 14 Jul 2017 17:31:13 -0400

The Secretariat is going to put out a revised IETF agenda tomorrow.  I suspect we’ll be in the room that was allocated to RTCweb.

spt

> On Jul 14, 2017, at 16:35, Joseph Lorenzo Hall <[email-masked]> wrote:
>

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 15 Jul 2017 13:46:47 +0000

I would *VERY VERY STRONGLY* like to see the static-dh draft be on Monday, and all the Monday topics moved to the main scheduled slot on Wednesday, even if it means taking 5 minutes of each of encrypting-SNI and DANE/DNSSEC

Those are technical topics, far more suited to the main event then the other one which has very little technical content at this stage.

---

From: Russ Housley <[email-masked]>
Date: Sat, 15 Jul 2017 09:51:19 -0400

Travel plans were made based on the published agenda, an Matt Green will not be on Prague on Monday.  We should not discuss draft-green- without him.

Russ

> On Jul 15, 2017, at 9:46 AM, Salz, Rich <[email-masked]> wrote:
>

---

From: Sean Turner <[email-masked]>
Date: Sat, 15 Jul 2017 10:01:27 -0400

> On Jul 15, 2017, at 09:46, Salz, Rich <[email-masked]> wrote:
> 
> encrypting-SNI and DANE/DNSSEC

draft-ietf-tls-dnssec-chain-extension is getting moved back to Monday because that’s the only time Melinda can make.

In Yokohama, I said encrypted SNI has occupied about 27 hours of WG time so this will make it 27.5/28.  The sessions are recorded and we’ll obviously be taking it to the list.

spt

---

From: Melinda Shore <[email-masked]>
Date: Sat, 15 Jul 2017 18:44:54 +0200

On 7/15/17 4:01 PM, Sean Turner wrote:
> draft-ietf-tls-dnssec-chain-extension is getting moved back to Monday
> because that’s the only time Melinda can make.

No, I'm afraid that I *cannot* make it Monday, and need to have
our slot stay on Wednesday.

Melinda

---

From: Sean Turner <[email-masked]>
Date: Mon, 17 Jul 2017 09:05:07 +0200

Chair slides are up:
https://www.ietf.org/proceedings/99/slides/slides-99-tls-sessb-chairs-slides-06.pdf

Further bash: I talked to Nick last night and since we have time on Monday he whipped up some slides on Exported Authenticators in TLS (aka https://datatracker.ietf.org/doc/draft-ietf-tls-exported-authenticator/).

spt

> On Jul 14, 2017, at 16:51, Sean Turner <[email-masked]> wrote:
>