Subject: [TLS] Looking for sample captures involving ChaCha20-Poly1305

From: Debapriyay Mukhopadhyay <[email-masked]>
Date: Mon, 7 Aug 2017 17:30:12 +0530

Hi,
   I am in need of a sample capture through which I can get to see the
packet exchanges involving CHACHA20_POLY1305 cipher suites. Can anyone
please point me to any such sample capture.
   That would be helpful.

   Thanks.

Regards
Debapriyay Mukhopadhyay

---

From: Peter Wu <[email-masked]>
Date: Fri, 11 Aug 2017 20:46:44 +0200

Hi Debapriyay,

> please point me to any such sample capture.

The Wireshark test suite has captures involving the ChaCha20-Poly1305
cipher suite. See
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=57b0527821b69dc8aa0786a3b5a425192795aff2

TLS 1.2:
test/captures/tls12-chacha20poly1305.pcap

TLS 1.3 (draft -20):
test/captures/tls13-20-chacha20poly1305.pcap
-- 
Kind regards,
Peter Wu
https://lekensteyn.nl