Subject: [TLS] WG adoption call: draft-thomson-tls-record-limit

From: Sean Turner <[email-masked]>
Date: Fri, 4 Aug 2017 08:50:31 -0400

At our IETF 99 session, there was support in the room to adopt draft-thomson-tls-record-limit [0].  We need to confirm this support on the list so please let the list know whether you support adoption of the draft and are willing to review/comment on the draft before 20170818.  If you object to its adoption, please let us know why.

Cheers,

J&S

[0] https://datatracker.ietf.org/doc/draft-thomson-tls-record-limit/

---

From: Ilari Liusvaara <[email-masked]>
Date: Fri, 4 Aug 2017 16:42:00 +0300

On Fri, Aug 04, 2017 at 08:50:31AM -0400, Sean Turner wrote:
> At our IETF 99 session, there was support in the room to adopt
> draft-thomson-tls-record-limit [0].  We need to confirm this
> support on the list so please let the list know whether you support
> adoption of the draft and are willing to review/comment on the draft
> before 20170818.  

Yeah, adopt.

I have experimentented with implementing extremely similar extension.

Reviewing the draft, one technical comment:

1) It is really the ciphertext size that needs to be limited, due to
in-place decryption being possible.

As proposed by PR #1 in the repository, One way to limit the ciphertext
is to give the record size limit as payload size and then apply minmax
limit to ciphertext size.

-Ilari

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 4 Aug 2017 15:07:08 -0500

It is currently before 20170818, and I support adoption of this draft
and am willing to review it as it progresses.

I do agree with Ilari that limiting the ciphertext size seems to make
more sense, but of course we can discuss that post adoption.

-Ben

On 08/04/2017 07:50 AM, Sean Turner wrote:
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Martin Thomson <[email-masked]>
Date: Sat, 5 Aug 2017 20:57:50 +1000

On 5 August 2017 at 06:07, Benjamin Kaduk <[email-masked]> wrote:
> It is currently before 20170818, and I support adoption of this draft and am
> willing to review it as it progresses.
>
> I do agree with Ilari that limiting the ciphertext size seems to make more
> sense, but of course we can discuss that post adoption.

FWIW, I hope to merge PR #1 that addresses this point.  It isn't
perfect, but it keeps the happy path - those who don't pad more than
the minimum - happy.  We should discuss pros and cons, of course, and
I'd prefer to do that as an official WG product.

---

From: "Short, Todd" <[email-masked]>
Date: Mon, 7 Aug 2017 14:15:58 +0000

I support adoption too.
--
-Todd Short
// [email-masked]<mailto:[email-masked]>
// "One if by land, two if by sea, three if by the Internet."

On Aug 5, 2017, at 6:57 AM, Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote:

On 5 August 2017 at 06:07, Benjamin Kaduk <[email-masked]<mailto:[email-masked]>> wrote:
It is currently before 20170818, and I support adoption of this draft and am
willing to review it as it progresses.

_______________________________________________
TLS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tls

---

From: Adam Langley <[email-masked]>
Date: Mon, 7 Aug 2017 08:10:17 -0700

On Fri, Aug 4, 2017 at 5:50 AM, Sean Turner <[email-masked]> wrote:

> draft-thomson-tls-record-limit [0].  We need to confirm this support on the
> list so please let the list know whether you support adoption of the draft
> and are willing to review/comment on the draft before 20170818.  If you
> object to its adoption, please let us know why.
>

I support adoption.

Cheers

AGL

-- 
Adam Langley [email-masked] https://www.imperialviolet.org

---

From: Martin Thomson <[email-masked]>
Date: Fri, 18 Aug 2017 14:33:52 +1000

> At our IETF 99 session, there was support in the room to adopt draft-thomson-tls-record-limit [0].  We need to confirm this support on the list so please let the list know whether you support adopt…

It is 20170818 now where I am, so I'm going to provide an update
before the chairs make their minds up.

I have a patch for NSS that implements this (including the assumptions
in PR #1).

TLS was easy.  For some structural reasons DTLS wasn't as simple
because you have to be aware of record size limits when fragmenting
handshake messages.  I ended up having to restructure a function or
two and break down some bad/previously-ok assumptions, but it wasn't
especially difficult.  As a bonus, we will now be marginally more
efficient with our DTLS handshake.

I ended up implementing for SSLv3 through to TLS 1.3.

Should anyone want to test, please contact me privately.  This will
eventually hit NSS trunk, but probably not until we sort out the TLS
1.3 deployment challenges.

---

From: Sean Turner <[email-masked]>
Date: Mon, 28 Aug 2017 10:03:34 -0400

It looks like we have consensus to adopt this draft as a working group item.  I’ve set up a GH repo in the TLSWG repo:https://github.com/tlswg/tls-record-limit.
Please submit the current draft as a working group item with the filename draft-ietf-tls-record-limit.    If you can hold off on merging PR#1 until it’s a WG item, that would be great (i.e., publish then merge).

Thanks,

J&S

> On Aug 4, 2017, at 08:50, Sean Turner <[email-masked]> wrote:
>

---

From: Martin Thomson <[email-masked]>
Date: Tue, 29 Aug 2017 09:01:47 +1000

All done, including the PR being merged into the editor's copy.