Subject: [Tools-arch] Recommendation 13: Baking in support for git etc

From: Jay Daley <[email-masked]>
Date: Fri, 9 Apr 2021 13:15:45 +1200

=  Recommendation

Recommendation 13:  A conversation needs to start on whether our tools should be adapted to integrate with one or more collaboration platforms or whether collaboration is achieved by third party services and tools that work side-by-side the IETF tools.

=  Commentary

A document collaboration platform, such as GitHub, comprises a set of tools: version control, issue management, documentation, release management, build system, etc.  This is a rapidly developing area with much of the innovation taking place in non-standard ways (i.e. the git level is stable, but such things as roadmaps are changing fast).  Currently our tools do not support any collaboration platform and in doing so are not taking advantage of the services they provide.  

The question posed in this recommendation is should our tools be adapted to integrate with such collaboration platforms?  For example, should idnits be able to pull a document directly from GitHub and record the problems it finds as GitHub issues?

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 9 Apr 2021 14:44:07 +1000

My .02 - I don't think there's enough value here to justify the cost / ongoing maintenance / complexity.

> On 9 Apr 2021, at 11:15 am, Jay Daley <[email-masked]> wrote:
> 
> =  Recommendation
> 
> Tools-arch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-arch

--
Mark Nottingham   https://www.mnot.net/