Subject: [Tools-arch] Recommendation 11: Tools ease of use and quality

From: Jay Daley <[email-masked]>
Date: Fri, 9 Apr 2021 13:14:39 +1200

=  Recommendation

Recommendation 11:  Initiate a project to raise the overall ease of use and quality of authoring tools, probably involving a UX professional to create a consistent interaction model for all IETF-supported tools.  This is closely linked to recommendation 8 as the end-to-end support of tools is a key element of their ease of use. 

=  Commentary

For info, recommendation 8 is intended for RSOC: “An end-to-end analysis is carried out to ensure that v3 XML can be used effectively and seamlessly at all stages of the authoring process.”.

An application interaction model is a description of the actions someone can perform in an application and the objects they can perform those on, all expressed in a set of simple concepts and terminology, such that once someone understands those concepts and terminology, understanding how to interact with unfamiliar actions or objects becomes intuitive. 

This is recommending using a UX professional to develop such a model and document it in a style guide that is used for all IETF-commissioned work and recommended to third parties who voluntarily develop tools.   

To give an example, an interaction model may define the concept of ‘validator’ as follows:

	• A ‘validator’ is passed a document/fragment which it makes no changes to.  It returns a list of annotations and an overall status for the document/fragment.  Each annotation consists of […].  The list of statuses and their meanings is [...]. 

An interaction model would generally be developed before or as part of any standardisation of APIs as discussed under recommendation 6.

The TAS Team may feel this is more of an implementation issue and so best left to the Tools Team.

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 9 Apr 2021 14:43:29 +1000

> On 9 Apr 2021, at 11:14 am, Jay Daley <[email-masked]> wrote:
> 
> =  Recommendation
> 

I suspect we need an information architect before we need a UX designer. Many of the problems we face are do to the larger-scale organisation of our info/services and the mental models of them, rather than the detailed presentation / interface issues.

> For info, recommendation 8 is intended for RSOC: “An end-to-end analysis is carried out to ensure that v3 XML can be used effectively and seamlessly at all stages of the authoring process.”.

I don't think a UX designer would be helpful for those issues, if that's what's being suggested; this is language/format design, which is a different discipline.

> The TAS Team may feel this is more of an implementation issue and so best left to the Tools Team.

This feels very top-down architecture. I agree we need more rigour about tools' input and output, but I'm not convinced this is the way to do it.

--
Mark Nottingham   https://www.mnot.net/