Subject: Re: Fwd: [Tools-discuss] IETF Email problem - Loosing From: field contents

From: Brian E Carpenter <[email-masked]>
Date: Wed, 21 Sep 2005 09:49:43 +0200

Bob,

This looks like a possible bug in an operational mail
system. The Tools team isn't responsible for the secretariat's
operational systems.

If it's a bug, it needs to be reported to [email-masked],
like any other operational issue. That will generate
a ticket and the secretariat will follow up.

But it isn't at all clear to me below which From field
you mean and what it was altered from and to.  Since
the Nokia mail system is known to change the sender
of external senders to "ext XXXX", I suspect it is also
falling into the very old trap of using Return-Path
instead of From or Sender. Return-Path should never
be used if either of the other two is present, iirc.
So maybe the ticket should be sent to the Nokia help desk?

Thanks

      Brian

> ---------------------------------------------------
> 
>> Envelope-to: [email-masked]
>> X-Mailer: QUALCOMM Windows Eudora Version 6.2.1.2
>> Date: Mon, 19 Sep 2005 16:50:58 -0700
>> To: [email-masked]
>> From: Bob Hinden <[email-masked]>
>> X-OriginalArrivalTime: 19 Sep 2005 23:51:04.0196 (UTC)
>>         FILETIME=[FEFFCC40:01C5BD74]
>> X-Spam-Score: 0.0 (/)
>> X-Scan-Signature: 29dc808194f5fb921c09d0040806d6eb
>> X-Mailman-Approved-At: Tue, 20 Sep 2005 15:40:25 -0400
>> Cc: [email-masked], Bob Hinden <[email-masked]>
>> Subject: [Tools-discuss] IETF Email problem - Loosing From: field 
>> contents
>> X-BeenThere: [email-masked]
>> X-Mailman-Version: 2.1.5
>> List-Id: IETF Tools Discussion <tools-discuss.ietf.org>
>> List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/tools-discuss>,
>>         <mailto:[email-masked]?subject=unsubscribe>
>> List-Archive: <http://www1.ietf.org/pipermail/tools-discuss>
>> List-Post: <mailto:[email-masked]>
>> List-Help: <mailto:[email-masked]?subject=help>
>> List-Subscribe: <https://www1.ietf.org/mailman/listinfo/tools-discuss>,
>>         <mailto:[email-masked]?subject=subscribe>
>> Sender: [email-masked]
>> X-Spam-Score: 0.0 (/)
>> X-Scan-Signature: 3971661e40967acfc35f708dd5f33760
>>
>> Hi,
>>
>> We apparently have a problem where something in the IETF email 
>> infrastructure is changing the From: fields.  See example below.  From 
>> where the "new" From: field is in the email headers, it looks like it 
>> is happening at: ietf-mx.ietf.org (though be at the next hop).
>>
>> The reason I think it is very important to fix this, is that the email 
>> that it is impossible to see who sent an email.  This is in my view a 
>> big problem for an open standards group where it is important to know 
>> who made specific comments.
>>
>> I hope this can be fixed as soon as possible.
>>
>> Thanks,
>> Bob
>>
>> p.s. This is not a problem in the archive.  It must be getting put in 
>> the archive prior to the From: header rewriting.  I did note that the 
>> web archive is somewhat different from the ftp archive.  No clue....
>>
>>
>>
>>
>>> Received: from daebh101.NOE.Nokia.com ([10.241.35.111]) by 
>>> daebe102.NOE.Nokia.com with Microsoft SMTPSVC(6.0.3790.1830);
>>>         Mon, 19 Sep 2005 10:31:17 -0500
>>> Received: from esebh107.NOE.Nokia.com ([172.21.143.143]) by 
>>> daebh101.NOE.Nokia.com with Microsoft SMTPSVC(6.0.3790.1830);
>>>         Mon, 19 Sep 2005 10:31:16 -0500
>>> Received: from esdks004.ntc.nokia.com ([172.21.138.159]) by 
>>> esebh107.NOE.Nokia.com with Microsoft SMTPSVC(6.0.3790.1830);
>>>         Mon, 19 Sep 2005 18:31:13 +0300
>>> X-Scanned: Mon, 19 Sep 2005 18:30:34 +0300 Nokia Message Protector 
>>> V1.3.35 2005042208 - RELEASE
>>> Received: (from root@localhost)
>>>         by esdks004.ntc.nokia.com (8.12.9/8.12.9) id j8JFUXmT032285;
>>>         Mon, 19 Sep 2005 18:30:34 +0300
>>> Received: from mgw-ext02.nokia.com (131.228.20.94)
>>>         by esdks004.ntc.nokia.com 004VgA2Q; Mon, 19 Sep 2005 18:30:32 
>>> EEST
>>> Received: from megatron.ietf.org (megatron.ietf.org [132.151.6.71])
>>>         by mgw-ext02.nokia.com (Switch-3.1.7/Switch-3.1.7) with ESMTP 
>>> id j8JFUUXp002364;
>>>         Mon, 19 Sep 2005 18:30:31 +0300
>>> Received: from localhost.localdomain ([127.0.0.1] 
>>> helo=megatron.ietf.org)
>>>         by megatron.ietf.org with esmtp (Exim 4.32)
>>>         id 1EHNaq-0005Xq-FR; Mon, 19 Sep 2005 11:30:08 -0400
>>> Received: from odin.ietf.org ([132.151.1.176] helo=ietf.org)
>>>         by megatron.ietf.org with esmtp (Exim 4.32) id 1EHNap-0005Va-5j
>>>         for [email-masked]; Mon, 19 Sep 2005 11:30:07 -0400
>>> Received: from ietf-mx.ietf.org (ietf-mx [132.151.6.1])
>>>         by ietf.org (8.9.1a/8.9.1a) with ESMTP id LAA03165
>>>         for <[email-masked]>; Mon, 19 Sep 2005 11:30:04 -0400 (EDT)
>>> From: "ext [email-masked]" <[email-masked]>
>>> Received: from mailhub.lss.emc.com ([168.159.2.31])
>>>         by ietf-mx.ietf.org with esmtp (Exim 4.43) id 1EHNgS-0003kr-8D
>>>         for [email-masked]; Mon, 19 Sep 2005 11:35:57 -0400
>>> Received: from mxic2.corp.emc.com (mxic2.corp.emc.com [128.221.12.9])
>>>         by mailhub.lss.emc.com (Switch-3.1.6/Switch-3.1.6) with ESMTP id
>>>         j8JFTm1o002975; Mon, 19 Sep 2005 11:29:49 -0400 (EDT)
>>> Received: by mxic2.corp.emc.com with Internet Mail Service (5.5.2653.19)
>>>         id <RT50LMNX>; Mon, 19 Sep 2005 11:29:48 -0400
>>> Message-ID: 
>>> <[email-masked]>
>>> To: [email-masked], [email-masked]
>>> Date: Mon, 19 Sep 2005 11:29:41 -0400
>>> MIME-Version: 1.0
>>> X-Mailer: Internet Mail Service (5.5.2653.19)
>>> Content-Type: text/plain
>>> X-PMX-Version: 4.7.1.128075, Antispam-Engine: 2.1.0.0,
>>>         Antispam-Data: 2005.9.19.14
>>> X-PerlMx-Spam: Gauge=, SPAM=0%, Reasons='EMC_BODY_1+ -5, EMC_FROM_00+ 
>>> -0,
>>>         NO_REAL_NAME 0, __C230066_P5 0, __CT 0, __CT_TEXT_PLAIN 0,
>>>         __HAS_MSGID 0, __HAS_X_MAILER 0, __IMS_MSGID 0, __IMS_MUA 0,
>>>         __MIME_TEXT_ONLY 0, __MIME_VERSION 0, __SANE_MSGID 0,
>>>         __STOCK_CRUFT 0'
>>> X-Spam-Score: 0.3 (/)
>>> X-Scan-Signature: 4d87d2aa806f79fed918a62e834505ca
>>> Cc: [email-masked]
>>> Subject: Allocating RFC numbers at time of approval
>>> X-BeenThere: [email-masked]
>>> X-Mailman-Version: 2.1.5
>>> Precedence: list
>>> List-Id: Working Group Chairs <wgchairs.ietf.org>
>>> List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/wgchairs>,
>>>         <mailto:[email-masked]?subject=unsubscribe>
>>> List-Post: <mailto:[email-masked]>
>>> List-Help: <mailto:[email-masked]?subject=help>
>>> List-Subscribe: <https://www1.ietf.org/mailman/listinfo/wgchairs>,
>>>         <mailto:[email-masked]?subject=subscribe>
>>> Sender: [email-masked]
>>> Errors-To: [email-masked]
>>> Return-Path: [email-masked]
>>> X-OriginalArrivalTime: 19 Sep 2005 15:31:13.0477 (UTC) 
>>> FILETIME=[2B233F50:01C5BD2F]
>>>
>>> > If people want this to change, it means changing another long-time
>>> > practice by allocating RFC numbers at the time of approval.
>>>
>>> That might be a very good thing.  I have a number of interactions
>>> with another standards body in which speed of IETF publication of
>>> RFCs is an issue.  The crucial external requirement is a stable
>>> reference designator - having an RFC number prior to publication
>>> could be quite useful by taking the RFC Editor out of the critical
>>> path to that designator, thereby enabling publication of other
>>> standards that want to reference RFCs (to-be).
>>>
>>> Thanks,
>>> --David
>>> ----------------------------------------------------
>>> David L. Black, Senior Technologist
>>> EMC Corporation, 176 South St., Hopkinton, MA  01748
>>> +1 (508) 293-7953             FAX: +1 (508) 293-7786
>>> [email-masked]        Mobile: +1 (978) 394-7754
>>> ----------------------------------------------------
>>>
>>> > -----Original Message-----
>>> > From: [email-masked]
>>> > [mailto:[email-masked]] On Behalf Of Brian E Carpenter
>>> > Sent: Monday, September 19, 2005 4:26 AM
>>> > To: Scott Bradner
>>> > Cc: [email-masked]
>>> > Subject: Re: when does the RFC2026 advancement timer start?
>>> > IESG approval, or publication as an RFC?
>>> >
>>> > Scott Bradner wrote:
>>> > >>but when does the timer start?  with IESG approval, or at
>>> > publication as an RFC?
>>> > >
>>> > >
>>> > > a long-time question - the only date that shows up in the index and
>>> > > document is the publication date so there is no way to know
>>> > by looking
>>> > > at the RFC what the approval time was so in practice the publication
>>> > > date is the practical one to use
>>> >
>>> > If people want this to change, it means changing another long-time
>>> > practice by allocating RFC numbers at the time of approval.
>>> > That way the
>>> > RFC index could carry an "approved date" as well as a
>>> > publication date.
>>> >
>>> > That's a requirement the IETF would have to express very clearly
>>> > for it to happen.
>>> >
>>> >      Brian
>>> >
>>> >
>>
>>
>>
>>
>> _______________________________________________
>> Tools-discuss mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/tools-discuss
> 
> ------------------------------------------------
> Barbara B. Fuller
> Acting Executive Director
> Internet Engineering Task Force
> 
> Natick, Massachusetts Office:
> 
> Phone: +1-508-650-4020
> Fax:     +1-508-650-4639
> 
> Reston, Virginia Office:
> 
> Phone: +1-703-620-9053
> Fax:     +1-703-620-9071

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Bob Hinden <[email-masked]>
Date: Wed, 21 Sep 2005 11:51:43 -0700

Brian,

>a ticket and the secretariat will follow up.

OK, I will send it to them once I get some more data.

>So maybe the ticket should be sent to the Nokia help desk?

Well, I am not 100% sure that this isn't a problem with Nokia IM is 
doing.  I will subscribe using another email account and compare the 
two.  This should help understand what is going on.  It may be some 
combination of what ietf.org and Nokia is doing.

Thanks,
Bob